/[packages]/backports/4/ipython/current/SPECS/ipython.spec
ViewVC logotype

Annotation of /backports/4/ipython/current/SPECS/ipython.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 611437 - (hide annotations) (download)
Wed Apr 2 22:29:24 2014 UTC (9 years, 11 months ago) by philippem
Original Path: cauldron/ipython/current/SPECS/ipython.spec
File size: 6386 byte(s)
update to 2.0.0
1 philippem 604190 %define name ipython
2 philippem 611437 %define version 2.0.0
3     %define release %mkrel 1
4 saispo 65239
5 philippem 604190 Summary: An interactive computing environment for Python
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}
9     Source0: http://pypi.python.org/packages/source/i/ipython/%{name}-%{version}.tar.gz
10     License: BSD
11     Group: Development/Python
12     Url: http://ipython.org
13     BuildArch: noarch
14     Requires: python-pexpect >= 2.2
15     Requires: python-mglob
16     Requires: python-simplegeneric
17     Suggests: python-mpi4py
18     Suggests: wxPython, python-qt4, pyside >= 1.0.3
19     Suggests: python-pygments
20 philippem 611437 Suggests: python-pyzmq >= 2.1.11
21 malo 519210 #notebook requires tornado and jinja2
22 philippem 611437 Suggests: python-tornado >= 3.1
23 philippem 604190 Suggests: python-jinja2
24     Suggests: python-matplotlib
25     BuildRequires: python-devel
26     BuildRequires: python-simplegeneric
27     BuildRequires: python-setuptools
28 philippem 611437 BuildRequires: python-pygments
29     BuildRequires: python-sphinx
30     BuildRequires: python-jinja2
31     BuildRequires: python-pyzmq >= 2.1.11
32     BuildRequires: python-pexpect >= 2.2
33     BuildRequires: python-tornado >= 3.1
34     BuildRequires: python-matplotlib
35     BuildRequires: python-numpydoc
36 saispo 65239
37 philippem 604190 %package -n python3-ipython
38     Group: Development/Python
39     Summary: An enhanced interactive Python shell
40     BuildRequires: python3-devel
41     BuildRequires: python3-setuptools
42     BuildRequires: python3-simplegeneric
43 philippem 611437 BuildRequires: python3-pygments
44     BuildRequires: python3-sphinx
45     BuildRequires: python3-jinja2
46     BuildRequires: python3-pexpect
47     BuildRequires: python3-pyzmq
48     BuildRequires: python3-tornado
49 philippem 604190 Requires: python3-pexpect
50     Requires: python3-mglob
51     Requires: python3-simplegeneric
52     Suggests: python3-mpi4py
53     Suggests: python3-tornado
54     Suggests: python3-jinja2
55     Suggests: python3-matplotlib
56 philippem 611437 Suggests: python3-pyzmq
57 philippem 604190
58 saispo 65239 %description
59 lebedov 146101 The goal of IPython is to create a comprehensive environment for
60     interactive and exploratory computing. To support this goal, IPython
61     has two main components:
62 saispo 65239
63 lebedov 146101 * An enhanced interactive Python shell.
64     * An architecture for interactive parallel computing.
65 saispo 65239
66 lebedov 146101 The enhanced interactive Python shell has the following main features:
67 saispo 65239
68 lebedov 146101 * Comprehensive object introspection.
69     * Input history, persistent across sessions.
70     * Caching of output results during a session with automatically
71     generated references.
72     * Readline based name completion.
73     * Extensible system of 'magic' commands for controlling the
74     environment and performing many tasks related either to IPython or
75     the operating system.
76     * Configuration system with easy switching between different setups
77     (simpler than changing $PYTHONSTARTUP environment variables every
78     time).
79     * Session logging and reloading.
80     * Extensible syntax processing for special purpose situations.
81     * Access to the system shell with user-extensible alias system.
82     * Easily embeddable in other Python programs and wxPython GUIs.
83     * Integrated access to the pdb debugger and the Python profiler.
84 saispo 65239
85 lebedov 146101 The parallel computing architecture has the following main features:
86 saispo 65239
87 lebedov 146101 * Quickly parallelize Python code from an interactive Python/IPython
88     session.
89     * A flexible and dynamic process model that be deployed on anything
90     from multicore workstations to supercomputers.
91     * An architecture that supports many different styles of parallelism,
92     from message passing to task farming.
93     * Both blocking and fully asynchronous interfaces.
94     * High level APIs that enable many things to be parallelized in a few
95     lines of code.
96     * Share live parallel jobs with other users securely.
97     * Dynamically load balanced task farming system.
98     * Robust error handling in parallel code.
99    
100 philippem 604190 %description -n python3-ipython
101     IPython provides a replacement for the interactive Python interpreter with
102     extra functionality.
103    
104     Main features:
105     * Comprehensive object introspection.
106     * Input history, persistent across sessions.
107     * Caching of output results during a session with automatically generated\
108     references.
109     * Readline based name completion.
110     * Extensible system of 'magic' commands for controlling the environment and
111     performing many tasks related either to IPython or the operating system.
112     * Configuration system with easy switching between different setups (simpler
113     than changing $PYTHONSTARTUP environment variables every time).
114     * Session logging and reloading.
115     * Extensible syntax processing for special purpose situations.
116     * Access to the system shell with user-extensible alias system.
117     * Easily embeddable in other Python programs.
118     * Integrated access to the pdb debugger and the Python profiler.
119    
120 philippem 611437 %package doc
121     Summary: An Enhanced Interactive Python Shell documentation
122     Group: Development/Python
123    
124     %description doc
125     IPython provides a replacement for the interactive python (Python)
126     interpreter with extra functionality.
127    
128     This package contains comprehensive documentation for IPython in
129     html format, as well as examples of usage.
130    
131 saispo 65239 %prep
132 luigiwalser 468289 %setup -q
133 philippem 604190 # delete bundling libs
134     pushd IPython/external
135 saispo 65239
136 philippem 604190 # use decorators of numpy
137     rm decorators/_decorators.py
138    
139     # other packages exist in Mageia
140     rm simplegeneric/_simplegeneric.py
141     rm pexpect/_pexpect.py
142    
143     popd
144    
145 philippem 611437 # Get rid of library shebangs
146     find . -type f -name "*.py" -exec sed -i '/#!\/usr\/bin\/env/d' {} \;
147    
148 philippem 604190 cp -a . %{py3dir}
149    
150 saispo 65239 %build
151 philippem 604190 pushd %{py3dir}
152     %{__python3} setup.py build
153     popd
154 saispo 65239
155 philippem 604190 %{__python} setup.py build
156    
157 saispo 65239 %install
158 philippem 604190 pushd %{py3dir}
159     %{__python3} setup.py install -O1 --skip-build --root %{buildroot}
160 philippem 611437 rm %{buildroot}%{_bindir}/ipython
161     rm %{buildroot}%{_bindir}/ipcluster
162     rm %{buildroot}%{_bindir}/ipcontroller
163     rm %{buildroot}%{_bindir}/ipengine
164     rm %{buildroot}%{_bindir}/iptest
165    
166 philippem 604190 popd
167    
168     %{__python} setup.py install -O1 --skip-build --root %{buildroot}
169    
170 lebedov 146101 chmod 644 %{buildroot}%{_mandir}/man1/*.1*
171     find %{buildroot} -name .buildinfo -exec rm -f {} \;
172     find %{buildroot} -name .git_commit_info.ini -exec rm -rf {} \;
173 saispo 65239
174 philippem 611437 # make docs
175     pushd docs
176     PYTHONPATH=$PYTHONPATH:%{buildroot}%{python_sitelib} make html
177     rm build/html/.buildinfo
178     popd
179    
180 saispo 65239 %files
181 philippem 604190 %{_bindir}/ipython
182     %{_bindir}/ipcluster
183     %{_bindir}/ipcontroller
184     %{_bindir}/ipengine
185     %{_bindir}/iptest
186 philippem 611437 %{_bindir}/ipython2
187     %{_bindir}/ipcluster2
188     %{_bindir}/ipcontroller2
189     %{_bindir}/ipengine2
190     %{_bindir}/iptest2
191 philippem 604190
192     %{python_sitelib}/*
193 philippem 611437
194     %files doc
195     %doc examples docs/build/html
196 saispo 65239 %{_mandir}/man1/*
197 philippem 604190
198     %files -n python3-ipython
199     %{_bindir}/ipython3
200     %{_bindir}/ipcluster3
201     %{_bindir}/ipcontroller3
202     %{_bindir}/ipengine3
203     %{_bindir}/iptest3
204    
205     %{python3_sitelib}/*
206    

  ViewVC Help
Powered by ViewVC 1.1.30