/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 289281 - (hide annotations) (download)
Fri Sep 7 11:01:44 2012 UTC (11 years, 7 months ago) by blino
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23100 byte(s)
rediff undefined symbols patch
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 blino 289278 %define git 20120906
19     %define git_branch 9.0
20 mikala 112356 %define with_hardware 1
21    
22 tv 131211 %define relc 0
23 pterjan 5340 %define name mesa
24 blino 289278 %define version 9.0.0
25     %define rel 1
26 pterjan 5340
27     %define release %mkrel %{rel}
28     %define src_type tar.bz2
29 tv 173693 #define vsuffix %{expand:}
30     %define vsuffix %nil
31 pterjan 5340
32     %if %{relc}
33     %define release %mkrel 0.rc%{relc}.%{rel}
34     %define vsuffix -rc%{relc}
35     %define src_type tar.bz2
36     %endif
37    
38     %if %{git}
39     %if %{relc}
40 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
41 pterjan 5340 %else
42     %define release %mkrel 0.git%{git}.%{rel}
43     %endif
44     %endif
45    
46     %define makedepend %{_bindir}/gccmakedep
47    
48 blino 271501 %define dricorename dricore
49 pterjan 5340 %define eglname mesaegl
50     %define glname mesagl
51     %define gluname mesaglu
52     %define glwname mesaglw
53 tv 88442 %define glesv1name mesaglesv1
54     %define glesv2name mesaglesv2
55 tv 88445 %define openvgname mesaopenvg
56 mikala 112356 %define glapiname glapi
57 blino 215979 %define gbmname gbm
58     %define waylandeglname wayland-egl
59 tv 88442
60 blino 271501 %define dricoremajor 1
61 pterjan 5340 %define eglmajor 1
62     %define glmajor 1
63     %define glumajor 1
64     %define glwmajor 1
65 tv 88442 %define glesv1major 1
66     %define glesv2major 2
67 tv 88445 %define openvgmajor 1
68 mikala 112356 %define glapimajor 0
69 blino 215979 %define gbmmajor 1
70     %define waylandeglmajor 1
71 anssi 278008 %define osmesamajor 8
72 tv 88442
73 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
74 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
75     %define libglname %mklibname %{glname} %{glmajor}
76     %define libgluname %mklibname %{gluname} %{glumajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libgluname_virt lib%{gluname}
95     %define libglwname_virt lib%{glwname}
96 tv 88442 %define libglesv1name_virt lib%{glesv1name}
97     %define libglesv2name_virt lib%{glesv2name}
98 tv 88445 %define libopenvgname_virt lib%{openvgname}
99 mikala 112356 %define libglapiname_virt lib%{glapiname}
100 blino 215979 %define libgbmname_virt lib%{gbmname}
101     %define libwaylandeglname_virt lib%{waylandeglname}
102 pterjan 5340
103     %define oldlibglname %mklibname MesaGL 1
104     %define oldlibgluname %mklibname MesaGLU 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 18133 %define dri_drivers_arm "swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129     Summary: OpenGL 2.1 compatible 3D graphics library
130     Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 blino 278332 BuildRequires: llvm-devel
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 blino 289278 # (blino) snapshot of 9.0 branch
159     Source0: %{name}-%{git_branch}-%{git}.tar.bz2
160 pterjan 5340 %else
161     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
162     %endif
163     Source3: make-git-snapshot.sh
164    
165     # Instructions to setup your repository clone
166     # git://git.freedesktop.org/git/mesa/mesa
167     # git checkout mesa_7_5_branch
168     # git branch mdv-cherry-picks
169     # git am ../02??-*.patch
170     # git branch mdv-redhat
171     # git am ../03??-*.patch
172     # git branch mdv-patches
173     # git am ../09??-*.patch
174 blino 289281 Patch001: 0001-Fix-undefined-symbols-in-libOSMesa-and-libglapi.patch
175 anssi 278531
176 pterjan 5340 # In order to update to the branch via patches, issue this command:
177     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
178    
179     # Cherry picks
180     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
181     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
182 blino 289280 # (blino) should be pushed to 9.0 branch upstream
183     Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
184 pterjan 5340
185 tv 88247 # Patches "liberated" from Fedora:
186 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
187     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
188    
189 blino 278732 # Patches from ChromiumOS
190     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191    
192 blino 271493 # Mageia/Mandriva patches
193 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
195 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
196 pterjan 5340
197    
198 tv 88440 #------------------------------------------------------------------------------
199    
200     # package mesa
201 pterjan 5340 License: MIT
202     Requires: %{libglname} = %{version}-%{release}
203     Provides: hackMesa = %{version}
204     Obsoletes: hackMesa <= %{version}
205     Provides: Mesa = %{version}
206     Obsoletes: Mesa < %{version}
207    
208 blino 271501 %package -n %{libdricorename}
209     Summary: Shared library for DRI drivers
210     Group: System/Libraries
211     Provides: %{libdricorename_virt} = %{version}-%{release}
212    
213     %package -n %{libdricorename}-devel
214     Summary: Development files for DRI core
215     Group: Development/C
216     Requires: %{libdricorename} = %{version}-%{release}
217     Provides: lib%{dricorename}-devel = %{version}-%{release}
218     Provides: %{dricorename}-devel = %{version}-%{release}
219    
220 pterjan 5340 %package -n %{libglname}
221     Summary: Files for Mesa (GL and GLX libs)
222     Group: System/Libraries
223 tv 88247 Obsoletes: %{oldlibglname} < 6.4
224 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
225     Provides: %{libglname_virt} = %{version}-%{release}
226     Requires: %{dridrivers} >= %{version}-%{release}
227 tv 135172 %if %{build_plf}
228     Requires: %mklibname txc-dxtn
229     %endif
230 pterjan 5340
231     # (anssi) Forces the upgrade of x11-server-common to happen before
232     # alternatives removal, which allows x11-server-common to grab the symlink.
233     Conflicts: x11-server-common < 1.3.0.0-17
234    
235     %package -n %{dridrivers}
236     Summary: Mesa DRI drivers
237     Group: System/Libraries
238 blino 274132 # do not require exact release to avoid conflicts when having
239     # x86_64 dri drivers from tainted and i586 dri drivers from core
240     Requires: mesa = %{version}
241 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
242 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
243     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
244 pterjan 5340
245     %package -n %{libglname}-devel
246     Summary: Development files for Mesa (OpenGL compatible 3D lib)
247     Group: Development/C
248 tv 88237 Requires: %{libglname} = %{version}-%{release}
249 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
250     Provides: %{glname}-devel = %{version}-%{release}
251     Provides: GL-devel
252     Obsoletes: %{oldlibglname}-devel < 6.4
253     Provides: %{oldlibglname}-devel = %{version}-%{release}
254     Provides: libMesaGL-devel = %{version}-%{release}
255     Provides: MesaGL-devel = %{version}-%{release}
256 tv 88438 Provides: libgl-devel
257 pterjan 5340
258     %package -n %{libgluname}
259     Summary: Files for Mesa (GLU libs)
260     Group: System/Libraries
261     Obsoletes: %{oldlibgluname} < 6.4
262     Provides: %{oldlibgluname} = %{version}-%{release}
263     Provides: %{libgluname_virt} = %{version}-%{release}
264    
265     %package -n %{libgluname}-devel
266     Summary: Development files for GLU libs
267     Group: Development/C
268     Requires: %{libgluname} = %{version}-%{release}
269     Provides: lib%{gluname}-devel = %{version}-%{release}
270     Provides: %{gluname}-devel = %{version}-%{release}
271     Obsoletes: %{oldlibgluname}-devel < 6.4
272     Provides: %{oldlibgluname}-devel = %{version}-%{release}
273     Provides: libMesaGLU-devel = %{version}-%{release}
274 tv 88247 Provides: MesaGLU-devel = %{version}-%{release}
275 tv 88438 Provides: libglu-devel
276 tv 88436 # pkgconfig files moved from libgl-devel:
277     Conflicts: %{libglname}-devel < 7.10.2-4
278 pterjan 5340
279 tv 88433 %if %{enable_egl}
280     %package -n %{libeglname}
281     Summary: Files for Mesa (EGL libs)
282     Group: System/Libraries
283     Provides: %{libeglname_virt} = %{version}-%{release}
284    
285     %package -n %{libeglname}-devel
286     Summary: Development files for Mesa (EGL libs)
287     Group: Development/C
288 tv 88439 Requires: %{libeglname} = %{version}-%{release}
289 tv 88433 Provides: EGL-devel
290 tv 88438 Provides: lib%{eglname}-devel
291     Provides: %{eglname}-devel
292     Provides: libegl-devel
293 tv 88433 %endif
294    
295 anssi 278008 %package -n %{libosmesaname}
296     Summary: Mesa offscreen rendering library
297     Group: System/Libraries
298    
299     %package -n %{osmesadevel}
300     Summary: Development files for libosmesa
301     Group: Development/C
302     Requires: %{libosmesaname} = %{version}-%{release}
303     Provides: osmesa-devel = %{version}-%{release}
304     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
305    
306 mikala 112356 %package -n %{libglapiname}
307     Summary: Files for mesa (glapi libs)
308     Group: System/Libraries
309     Provides: %{libglapiname_virt} = %{version}-%{release}
310 tv 88442
311 mikala 112356 %package -n %{libglapiname}-devel
312     Summary: Development files for glapi libs
313     Group: Development/C
314     Requires: %{libglapiname_virt} = %{version}-%{release}
315     Provides: lib%{glapiname}-devel
316     Provides: %{libglapiname}-devel
317    
318 tv 88442 %package -n %{libglesv1name}
319     Summary: Files for Mesa (glesv1 libs)
320     Group: System/Libraries
321     Provides: %{libglesv1name_virt} = %{version}-%{release}
322    
323     %package -n %{libglesv1name}-devel
324     Summary: Development files for glesv1 libs
325     Group: Development/C
326     Requires: %{libglesv1name} = %{version}-%{release}
327     Provides: lib%{glesv1name}-devel
328     Provides: %{glesv1name}-devel
329     Provides: libglesv1-devel
330    
331     %package -n %{libglesv2name}
332     Summary: Files for Mesa (glesv2 libs)
333     Group: System/Libraries
334     Provides: %{libglesv2name_virt} = %{version}-%{release}
335    
336     %package -n %{libglesv2name}-devel
337     Summary: Development files for glesv2 libs
338     Group: Development/C
339     Requires: %{libglesv2name} = %{version}-%{release}
340 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
341 tv 88442 Provides: lib%{glesv2name}-devel
342     Provides: %{glesv2name}-devel
343     Provides: libglesv2-devel
344    
345 tv 88445 %package -n %{libopenvgname}
346     Summary: Files for MESA (OpenVG libs)
347     Group: System/Libraries
348     Provides: %{libopenvgname_virt} = %{version}-%{release}
349    
350     %package -n %{libopenvgname}-devel
351     Summary: Development files vor OpenVG libs
352     Group: Development/C
353     Requires: %{libopenvgname} = %{version}-%{release}
354     Provides: lib%{openvgname}-devel
355     Provides: %{openvgname}-devel
356     Provides: libopenvg-devel
357    
358 blino 215979 %if %{enable_wayland}
359     %package -n %{libgbmname}
360     Summary: Files for Mesa (gbm libs)
361     Group: System/Libraries
362     Provides: %{libgbmname_virt} = %{version}-%{release}
363    
364     %package -n %{libgbmname}-devel
365     Summary: Development files for Mesa (gbm libs)
366     Group: Development/C
367     Requires: %{libgbmname} = %{version}-%{release}
368     Provides: lib%{gbmname}-devel
369     Provides: %{gbmname}-devel
370    
371     %package -n %{libwaylandeglname}
372     Summary: Files for Mesa (Wayland EGL libs)
373     Group: System/Libraries
374     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
375    
376     %package -n %{libwaylandeglname}-devel
377     Summary: Development files for Mesa (Wayland EGL libs)
378     Group: Development/C
379     Requires: %{libwaylandeglname} = %{version}-%{release}
380     Provides: lib%{waylandeglname}-devel
381     Provides: %{waylandeglname}-devel
382     %endif
383    
384 blino 270761 %package -n vdpau-driver-nouveau
385     Summary: VDPAU plugin for nouveau driver
386 blino 279553 Group: Video
387 blino 270761
388     %package -n vdpau-driver-r300
389     Summary: VDPAU plugin for r300 driver
390 blino 279553 Group: Video
391 blino 270761
392     %package -n vdpau-driver-r600
393     Summary: VDPAU plugin for r600 driver
394 blino 279553 Group: Video
395 blino 270761
396     %package -n vdpau-driver-softpipe
397     Summary: VDPAU plugin for softpipe driver
398 blino 279553 Group: Video
399 blino 270761
400 pterjan 5340 %package common-devel
401     Summary: Meta package for mesa devel
402     Group: Development/C
403 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
404 pterjan 5340 Provides: hackMesa-common-devel = %{version}
405 tv 88247 Obsoletes: Mesa-common-devel < %{version}
406 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
407     Requires: %{libglname}-devel = %{version}
408     Requires: %{libgluname}-devel = %{version}
409 tv 135156 Requires: freeglut-devel
410 tv 88442 Requires: %{libeglname}-devel = %{version}
411     Requires: %{libglesv1name}-devel = %{version}
412     Requires: %{libglesv2name}-devel = %{version}
413 pterjan 5340
414 tv 88440 #------------------------------------------------------------------------------
415 pterjan 5340
416     %description
417     Mesa is an OpenGL 2.1 compatible 3D graphics library.
418 tv 135173 %if %{build_plf}
419 pterjan 5340
420 tv 135173 This package is in the "tainted" section because it enables some
421     OpenGL extentions that are covered by software patents.
422     %endif
423    
424 pterjan 5340 %description common-devel
425     Mesa common metapackage devel
426    
427     %if %{enable_egl}
428     %description -n %{libeglname}
429     Mesa is an OpenGL 2.1 compatible 3D graphics library.
430     EGL parts.
431    
432     %description -n %{libeglname}-devel
433     Mesa is an OpenGL 2.1 compatible 3D graphics library.
434     EGL development parts.
435     %endif
436    
437 blino 271501 %description -n %{libdricorename}
438     Mesa is an OpenGL 2.1 compatible 3D graphics library.
439     DRI core part.
440    
441 pterjan 5340 %description -n %{libglname}
442     Mesa is an OpenGL 2.1 compatible 3D graphics library.
443     GL and GLX parts.
444    
445 tv 135155 %if %{build_plf}
446     This package is in the "tainted" section because it enables some
447     OpenGL extentions that are covered by software patents.
448     %endif
449    
450 pterjan 5340 %description -n %{dridrivers}
451     Mesa is an OpenGL 2.1 compatible 3D graphics library.
452     DRI drivers.
453    
454 blino 271501 %description -n %{libdricorename}-devel
455     Mesa is an OpenGL 2.1 compatible 3D graphics library.
456    
457     This package contains the headers needed to compile DRI drivers.
458    
459 pterjan 5340 %description -n %{libglname}-devel
460     Mesa is an OpenGL 2.1 compatible 3D graphics library.
461    
462     This package contains the headers needed to compile Mesa programs.
463    
464     %description -n %{libgluname}
465     GLU is the OpenGL Utility Library.
466     It provides a number of functions upon the base OpenGL library to provide
467     higher-level drawing routines from the more primitive routines provided by
468     OpenGL.
469    
470     %description -n %{libgluname}-devel
471     This package contains the headers needed to compile programs with GLU.
472    
473 tv 88442 %description -n %{libglesv1name}
474     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
475     well-defined subset profiles of OpenGL.
476    
477     This package provides the OpenGL ES library version 1.
478    
479 anssi 278008 %description -n %{libosmesaname}
480     Mesa offscreen rendering libraries for rendering OpenGL into
481     application-allocated blocks of memory.
482    
483     %description -n %{osmesadevel}
484     This package contains the headers needed to compile programs against
485     the Mesa offscreen rendering library.
486    
487 mikala 112356 %description -n %{libglapiname}
488     This packages provides the glapi shared library used by gallium.
489    
490     %description -n %{libglapiname}-devel
491     This package contains the headers needed to compile programes against glapi shared library.
492    
493 tv 88442 %description -n %{libglesv1name}-devel
494     This package contains the headers needed to compile OpenGL ES 1 programs.
495    
496     %description -n %{libglesv2name}
497     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
498     well-defined subset profiles of OpenGL.
499    
500     This package provides the OpenGL ES library version 2.
501    
502     %description -n %{libglesv2name}-devel
503     This package contains the headers needed to compile OpenGL ES 2 programs.
504    
505 tv 88445 %description -n %{libopenvgname}
506     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
507     acceleration interface for vector graphics libraries such as Flash and SVG.
508    
509     %description -n %{libopenvgname}-devel
510     Development files for OpenVG library.
511    
512 blino 215979 %if %{enable_wayland}
513     %description -n %{libgbmname}
514     Mesa is an OpenGL 2.1 compatible 3D graphics library.
515     GBM (Graphics Buffer Manager) parts.
516    
517     %description -n %{libgbmname}-devel
518     Mesa is an OpenGL 2.1 compatible 3D graphics library.
519     GBM (Graphics Buffer Manager) development parts.
520    
521     %description -n %{libwaylandeglname}
522     Mesa is an OpenGL 2.1 compatible 3D graphics library.
523     Wayland EGL platform parts.
524    
525     %description -n %{libwaylandeglname}-devel
526     Mesa is an OpenGL 2.1 compatible 3D graphics library.
527     Wayland EGL platform development parts.
528     %endif
529    
530 blino 270761 %description -n vdpau-driver-nouveau
531     This packages provides a VPDAU plugin to enable video acceleration
532     with the nouveau driver.
533    
534     %description -n vdpau-driver-r300
535     This packages provides a VPDAU plugin to enable video acceleration
536     with the r300 driver.
537    
538     %description -n vdpau-driver-r600
539     This packages provides a VPDAU plugin to enable video acceleration
540     with the r600 driver.
541    
542     %description -n vdpau-driver-softpipe
543     This packages provides a VPDAU plugin to enable video acceleration
544     with the softpipe driver.
545    
546 tv 88440 #------------------------------------------------------------------------------
547    
548 pterjan 5340 %prep
549     %if %{git}
550 blino 289278 %setup -q -n mesa-%{git_branch}-%{git}
551 pterjan 5340 %else
552 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
553 pterjan 5340 %endif
554    
555 blino 278731 %apply_patches
556 pterjan 5340
557     %build
558     autoreconf -vfi
559 anssi 278008
560     # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
561     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
562     export LDFLAGS="-L%{_libdir}/llvm"
563    
564     %configure2_5x --enable-dri \
565     --enable-glx \
566 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
567     --with-dri-drivers="%{dri_drivers}" \
568 anssi 165988 --enable-shared-dricore \
569 pterjan 5340 %if %{enable_egl}
570     --enable-egl \
571     %else
572     --disable-egl \
573     %endif
574 blino 215979 %if %{enable_wayland}
575     --with-egl-platforms=x11,wayland,drm \
576     --enable-gbm \
577     --enable-shared-glapi \
578     %endif
579 tv 88442 --enable-gles1 \
580     --enable-gles2 \
581 tv 88445 --enable-openvg \
582 mikala 112356 --enable-gallium-egl \
583 blino 270761 --enable-gallium-g3dvl \
584 anssi 278008 --enable-osmesa \
585 blino 270761 --disable-xvmc \
586     --enable-vdpau \
587     --disable-va \
588 mikala 112356 %if %{with_hardware}
589 blino 278332 --with-gallium-drivers=r300,r600,nouveau,swrast \
590 mikala 112356 --enable-gallium-llvm \
591     %else
592     --disable-gallium-llvm \
593     --with-gallium-drivers=swrast \
594     %endif
595 tv 135155 %if %{build_plf}
596     --enable-texture-float \
597     %endif
598 blino 270723 # end of configure options
599 pterjan 5340
600 anssi 165988 %make
601 pterjan 5340
602     %install
603 tv 88249 %makeinstall_std
604 pterjan 5340
605 blino 216556 # FIXME: strip will likely break the hardlink
606 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
607     # to prevent proprietary driver installers from removing them
608     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
609     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
610     for l in ../libGL.so.*; do cp -a $l .; done
611     popd
612    
613     %ifarch %{x86_64}
614     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
615     %endif
616    
617 tv 88231 rm -f %{buildroot}/%{_includedir}/GL/glut.h
618     rm -f %{buildroot}/%{_includedir}/GL/glutf90.h
619    
620 blino 270761 # .so files are not needed by vdpau
621     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
622    
623 blino 271144 # .la files are not needed by mesa
624     find %{buildroot} -name '*.la' -exec rm {} \;
625    
626 anssi 181478 # use swrastg if built (Anssi 12/2011)
627     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
628    
629 tv 88440 #------------------------------------------------------------------------------
630    
631 pterjan 5340 %files
632     %defattr(-,root,root)
633 blino 271481 %doc docs/COPYING
634 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
635 pterjan 5340
636 blino 271501 %files -n %{libdricorename}
637     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
638     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
639    
640     %files -n %{libdricorename}-devel
641     %{_libdir}/libdricore%{version}.so
642    
643 pterjan 5340 %files -n %{dridrivers}
644     %defattr(-,root,root)
645     %doc docs/COPYING
646     %ifnarch ppc64
647     %dir %{_libdir}/dri
648 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
649     #%{_libdir}/dri/libglsl.so
650 pterjan 5340 %{_libdir}/dri/*_dri.so
651     %endif
652    
653 tv 88433 %files -n %{libglname}
654     %defattr(-,root,root)
655     %doc docs/COPYING
656     %{_libdir}/libGL.so.*
657     %dir %{_libdir}/mesa
658 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
659 tv 88433
660 tv 88437 %files -n %{libgluname}
661 tv 88433 %defattr(-,root,root)
662     %doc docs/COPYING
663 tv 88434 %{_libdir}/libGLU.so.%{glumajor}*
664 tv 88433
665     %if %{enable_egl}
666     %files -n %{libeglname}
667     %defattr(-,root,root)
668 tv 88442 %doc docs/COPYING
669 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
670 tv 88442 %dir %{_libdir}/egl
671 blino 215979 %if !%{enable_wayland}
672     # st_GL, built only when shared glapi is not enabled
673 mikala 112356 %{_libdir}/egl/st_GL.so
674 blino 215979 %endif
675 mikala 127466 %{_libdir}/egl/egl_gallium.so
676 tv 88441 %endif
677 tv 88433
678 anssi 278008 %files -n %{libosmesaname}
679     %defattr(-,root,root)
680     %{_libdir}/libOSMesa.so.%{osmesamajor}*
681    
682 mikala 112356 %files -n %{libglapiname}
683     %defattr(-,root,root)
684     %{_libdir}/libglapi.so.%{glapimajor}*
685    
686 tv 88442 %files -n %{libglesv1name}
687     %defattr(-,root,root)
688     %doc docs/COPYING
689     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
690    
691     %files -n %{libglesv2name}
692     %defattr(-,root,root)
693     %doc docs/COPYING
694     %{_libdir}/libGLESv2.so.%{glesv2major}*
695    
696 tv 88445 %files -n %{libopenvgname}
697     %defattr(-,root,root)
698     %doc docs/COPYING
699     %{_libdir}/libOpenVG.so.%{openvgmajor}*
700    
701 blino 215979 %if %{enable_wayland}
702     %files -n %{libgbmname}
703     %{_libdir}/libgbm.so.%{gbmmajor}
704 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
705 blino 215979 %{_libdir}/gbm/gbm_*.so
706     %{_libdir}/gbm/pipe_*.so
707 tv 88445
708 blino 215979 %files -n %{libwaylandeglname}
709     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
710 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
711 blino 215979 %endif
712    
713    
714 pterjan 5340 %files -n %{libglname}-devel
715     %defattr(-,root,root)
716     %doc docs/COPYING
717 anssi 278008 %dir %{_includedir}/GL
718 pterjan 5340 %{_includedir}/GL/gl.h
719     %{_includedir}/GL/glext.h
720     %{_includedir}/GL/gl_mangle.h
721     %{_includedir}/GL/wglext.h
722     %{_includedir}/GL/glx.h
723     %{_includedir}/GL/glxext.h
724     %{_includedir}/GL/glx_mangle.h
725     %{_libdir}/libGL.so
726 tv 88436 %{_libdir}/pkgconfig/gl.pc
727     %{_libdir}/pkgconfig/dri.pc
728 pterjan 5340
729     #FIXME: check those headers
730     %{_includedir}/GL/vms_x_fix.h
731     %{_includedir}/GL/wmesa.h
732     %dir %{_includedir}/GL/internal
733     %{_includedir}/GL/internal/dri_interface.h
734    
735     %files -n %{libgluname}-devel
736     %defattr(-,root,root)
737     %doc docs/COPYING
738 anssi 278008 %dir %{_includedir}/GL
739 pterjan 5340 %{_includedir}/GL/glu.h
740     %{_includedir}/GL/glu_mangle.h
741     %{_libdir}/libGLU.so
742 tv 88436 %{_libdir}/pkgconfig/glu.pc
743 pterjan 5340
744     %files common-devel
745     %defattr(-,root,root)
746    
747 tv 88441 %if %{enable_egl}
748 tv 88433 %files -n %{libeglname}-devel
749     %defattr(-,root,root)
750 tv 88442 %doc docs/COPYING
751     %{_includedir}/EGL
752     %{_includedir}/KHR
753 tv 88433 %{_libdir}/libEGL.so
754 tv 88436 %{_libdir}/pkgconfig/egl.pc
755 tv 88433 %endif
756 pterjan 5340
757 anssi 278008 %files -n %{osmesadevel}
758     %defattr(-,root,root)
759     %dir %{_includedir}/GL
760     %{_includedir}/GL/osmesa.h
761     %{_libdir}/libOSMesa.so
762     %{_libdir}/pkgconfig/osmesa.pc
763    
764 mikala 112356 %files -n %{libglapiname}-devel
765     %defattr(-,root,root)
766     %{_libdir}/libglapi.so
767 pterjan 5340
768 tv 88442 %files -n %{libglesv1name}-devel
769     %defattr(-,root,root)
770     %{_includedir}/GLES
771     %{_libdir}/libGLESv1_CM.so
772     %{_libdir}/pkgconfig/glesv1_cm.pc
773 tv 88433
774 tv 88442 %files -n %{libglesv2name}-devel
775     %defattr(-,root,root)
776     %{_includedir}/GLES2
777     %{_libdir}/libGLESv2.so
778     %{_libdir}/pkgconfig/glesv2.pc
779 tv 88445
780     %files -n %{libopenvgname}-devel
781     %defattr(-,root,root)
782     %{_includedir}/VG
783     %{_libdir}/libOpenVG.so
784     %{_libdir}/pkgconfig/vg.pc
785 blino 215979
786     %if %{enable_wayland}
787     %files -n %{libgbmname}-devel
788     %{_includedir}/gbm.h
789     %{_libdir}/libgbm.so
790     %{_libdir}/pkgconfig/gbm.pc
791    
792     %files -n %{libwaylandeglname}-devel
793     %{_libdir}/libwayland-egl.so
794     %{_libdir}/pkgconfig/wayland-egl.pc
795     %endif
796 blino 270761
797     %files -n vdpau-driver-nouveau
798     %{_libdir}/vdpau/libvdpau_nouveau.so.*
799    
800     %files -n vdpau-driver-r300
801     %{_libdir}/vdpau/libvdpau_r300.so.*
802    
803     %files -n vdpau-driver-r600
804     %{_libdir}/vdpau/libvdpau_r600.so.*
805    
806     %files -n vdpau-driver-softpipe
807     %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30