/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 293701 - (hide annotations) (download)
Thu Sep 13 20:31:37 2012 UTC (11 years, 7 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 21950 byte(s)
rebuild for new x11-server
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 blino 289616 %define git 20120907
19 blino 289278 %define git_branch 9.0
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 blino 289278 %define version 9.0.0
27 tv 293701 %define rel 2
28 pterjan 5340
29     %define release %mkrel %{rel}
30     %define src_type tar.bz2
31 tv 173693 #define vsuffix %{expand:}
32     %define vsuffix %nil
33 pterjan 5340
34     %if %{relc}
35     %define release %mkrel 0.rc%{relc}.%{rel}
36     %define vsuffix -rc%{relc}
37     %define src_type tar.bz2
38     %endif
39    
40     %if %{git}
41     %if %{relc}
42 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
43 pterjan 5340 %else
44     %define release %mkrel 0.git%{git}.%{rel}
45     %endif
46     %endif
47    
48     %define makedepend %{_bindir}/gccmakedep
49    
50 blino 271501 %define dricorename dricore
51 pterjan 5340 %define eglname mesaegl
52     %define glname mesagl
53     %define glwname mesaglw
54 tv 88442 %define glesv1name mesaglesv1
55     %define glesv2name mesaglesv2
56 tv 88445 %define openvgname mesaopenvg
57 mikala 112356 %define glapiname glapi
58 blino 215979 %define gbmname gbm
59     %define waylandeglname wayland-egl
60 tv 88442
61 blino 271501 %define dricoremajor 1
62 pterjan 5340 %define eglmajor 1
63     %define glmajor 1
64     %define glwmajor 1
65 tv 88442 %define glesv1major 1
66     %define glesv2major 2
67 tv 88445 %define openvgmajor 1
68 mikala 112356 %define glapimajor 0
69 blino 215979 %define gbmmajor 1
70     %define waylandeglmajor 1
71 blino 289617 %define osmesamajor 8
72 tv 88442
73 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
74 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
75     %define libglname %mklibname %{glname} %{glmajor}
76     %define libglwname %mklibname %{glwname} %{glwmajor}
77 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
78     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
79 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
80 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
81 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
82     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
83 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
84 pterjan 5340
85     %define dridrivers %mklibname dri-drivers
86    
87 anssi 278008 %define osmesadevel %mklibname osmesa -d
88    
89 pterjan 5340 # Architecture-independent Virtual provides:
90 blino 271501 %define libdricorename_virt lib%{dricorename}
91 pterjan 5340 %define libeglname_virt lib%{eglname}
92     %define libglname_virt lib%{glname}
93     %define libglwname_virt lib%{glwname}
94 tv 88442 %define libglesv1name_virt lib%{glesv1name}
95     %define libglesv2name_virt lib%{glesv2name}
96 tv 88445 %define libopenvgname_virt lib%{openvgname}
97 mikala 112356 %define libglapiname_virt lib%{glapiname}
98 blino 215979 %define libgbmname_virt lib%{gbmname}
99     %define libwaylandeglname_virt lib%{waylandeglname}
100 pterjan 5340
101     %define oldlibglname %mklibname MesaGL 1
102    
103     %define mesasrcdir %{_prefix}/src/Mesa/
104     %define driver_dir %{_libdir}/dri
105    
106 tv 88451 %define enable_egl 1
107 blino 215979 %define enable_wayland 1
108 pterjan 5340
109     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
110     #FIXME: (for >=i586) disable sse
111     # SSE seems to have problem on some apps (gtulpas) for probing.
112 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
113 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
114 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
115 pterjan 5340 %define dri_drivers_ppc64 ""
116 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
117     %define dri_drivers_alpha "r200,radeon,swrast"
118     %define dri_drivers_sparc "ffb,radeon,swrast"
119     %define dri_drivers_mipsel "r200,radeon,swrast"
120 rtp 18133 %define dri_drivers_arm "swrast"
121 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
122    
123     Name: %{name}
124     Version: %{version}
125     Release: %{release}
126 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
127 pterjan 5340 Group: System/Libraries
128    
129 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
130     BuildRequires: pkgconfig(xt) >= 1.0.5
131     BuildRequires: pkgconfig(xmu) >= 1.0.3
132     BuildRequires: pkgconfig(x11) >= 1.3.3
133     BuildRequires: pkgconfig(xdamage) >= 1.1.1
134 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
135     BuildRequires: gccmakedep
136     BuildRequires: x11-proto-devel >= 7.3
137 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
138 pterjan 5340
139 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
140     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
141     BuildRequires: pkgconfig(xi) >= 1.3
142     BuildRequires: pkgconfig(talloc)
143 tv 88443 BuildRequires: libxml2-python
144 tmb 35532 BuildRequires: makedepend
145 dmorgan 106004 BuildRequires: bison flex
146 blino 289282 BuildRequires: llvm-devel >= 3.1
147 mikala 127466 BuildRequires: pkgconfig(libudev)
148 blino 270761 BuildRequires: pkgconfig(vdpau)
149 blino 215979 %if %{enable_wayland}
150     BuildRequires: wayland-devel
151     %endif
152 pterjan 5340
153     URL: http://www.mesa3d.org
154     %if %{git}
155 blino 289278 # (blino) snapshot of 9.0 branch
156     Source0: %{name}-%{git_branch}-%{git}.tar.bz2
157 pterjan 5340 %else
158     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
159     %endif
160     Source3: make-git-snapshot.sh
161    
162     # Instructions to setup your repository clone
163     # git://git.freedesktop.org/git/mesa/mesa
164     # git checkout mesa_7_5_branch
165     # git branch mdv-cherry-picks
166     # git am ../02??-*.patch
167     # git branch mdv-redhat
168     # git am ../03??-*.patch
169     # git branch mdv-patches
170     # git am ../09??-*.patch
171 blino 289281 Patch001: 0001-Fix-undefined-symbols-in-libOSMesa-and-libglapi.patch
172 anssi 278531
173 pterjan 5340 # In order to update to the branch via patches, issue this command:
174     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
175    
176     # Cherry picks
177     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
178     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
179 blino 289280 # (blino) should be pushed to 9.0 branch upstream
180     Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
181 blino 289384 Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
182 pterjan 5340
183 tv 88247 # Patches "liberated" from Fedora:
184 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
185     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
186    
187 blino 278732 # Patches from ChromiumOS
188     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
189    
190 blino 271493 # Mageia/Mandriva patches
191 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
192 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
193 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
194 pterjan 5340
195    
196 tv 88440 #------------------------------------------------------------------------------
197    
198     # package mesa
199 pterjan 5340 License: MIT
200     Requires: %{libglname} = %{version}-%{release}
201     Provides: hackMesa = %{version}
202     Obsoletes: hackMesa <= %{version}
203     Provides: Mesa = %{version}
204     Obsoletes: Mesa < %{version}
205    
206 blino 271501 %package -n %{libdricorename}
207     Summary: Shared library for DRI drivers
208     Group: System/Libraries
209     Provides: %{libdricorename_virt} = %{version}-%{release}
210    
211     %package -n %{libdricorename}-devel
212     Summary: Development files for DRI core
213     Group: Development/C
214     Requires: %{libdricorename} = %{version}-%{release}
215     Provides: lib%{dricorename}-devel = %{version}-%{release}
216     Provides: %{dricorename}-devel = %{version}-%{release}
217    
218 pterjan 5340 %package -n %{libglname}
219     Summary: Files for Mesa (GL and GLX libs)
220     Group: System/Libraries
221 tv 88247 Obsoletes: %{oldlibglname} < 6.4
222 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
223     Provides: %{libglname_virt} = %{version}-%{release}
224     Requires: %{dridrivers} >= %{version}-%{release}
225 tv 135172 %if %{build_plf}
226     Requires: %mklibname txc-dxtn
227     %endif
228 pterjan 5340
229     # (anssi) Forces the upgrade of x11-server-common to happen before
230     # alternatives removal, which allows x11-server-common to grab the symlink.
231     Conflicts: x11-server-common < 1.3.0.0-17
232    
233     %package -n %{dridrivers}
234     Summary: Mesa DRI drivers
235     Group: System/Libraries
236 blino 274132 # do not require exact release to avoid conflicts when having
237     # x86_64 dri drivers from tainted and i586 dri drivers from core
238     Requires: mesa = %{version}
239 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
240 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
241     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
242 pterjan 5340
243     %package -n %{libglname}-devel
244     Summary: Development files for Mesa (OpenGL compatible 3D lib)
245     Group: Development/C
246 tv 88237 Requires: %{libglname} = %{version}-%{release}
247 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
248     Provides: %{glname}-devel = %{version}-%{release}
249     Provides: GL-devel
250     Obsoletes: %{oldlibglname}-devel < 6.4
251     Provides: %{oldlibglname}-devel = %{version}-%{release}
252     Provides: libMesaGL-devel = %{version}-%{release}
253     Provides: MesaGL-devel = %{version}-%{release}
254 tv 88438 Provides: libgl-devel
255 pterjan 5340
256 tv 88433 %if %{enable_egl}
257     %package -n %{libeglname}
258     Summary: Files for Mesa (EGL libs)
259     Group: System/Libraries
260     Provides: %{libeglname_virt} = %{version}-%{release}
261    
262     %package -n %{libeglname}-devel
263     Summary: Development files for Mesa (EGL libs)
264     Group: Development/C
265 tv 88439 Requires: %{libeglname} = %{version}-%{release}
266 tv 88433 Provides: EGL-devel
267 tv 88438 Provides: lib%{eglname}-devel
268     Provides: %{eglname}-devel
269     Provides: libegl-devel
270 tv 88433 %endif
271    
272 anssi 278008 %package -n %{libosmesaname}
273     Summary: Mesa offscreen rendering library
274     Group: System/Libraries
275    
276     %package -n %{osmesadevel}
277     Summary: Development files for libosmesa
278     Group: Development/C
279     Requires: %{libosmesaname} = %{version}-%{release}
280     Provides: osmesa-devel = %{version}-%{release}
281     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
282    
283 mikala 112356 %package -n %{libglapiname}
284     Summary: Files for mesa (glapi libs)
285     Group: System/Libraries
286     Provides: %{libglapiname_virt} = %{version}-%{release}
287 tv 88442
288 mikala 112356 %package -n %{libglapiname}-devel
289     Summary: Development files for glapi libs
290     Group: Development/C
291     Requires: %{libglapiname_virt} = %{version}-%{release}
292     Provides: lib%{glapiname}-devel
293     Provides: %{libglapiname}-devel
294    
295 tv 88442 %package -n %{libglesv1name}
296     Summary: Files for Mesa (glesv1 libs)
297     Group: System/Libraries
298     Provides: %{libglesv1name_virt} = %{version}-%{release}
299    
300     %package -n %{libglesv1name}-devel
301     Summary: Development files for glesv1 libs
302     Group: Development/C
303     Requires: %{libglesv1name} = %{version}-%{release}
304     Provides: lib%{glesv1name}-devel
305     Provides: %{glesv1name}-devel
306     Provides: libglesv1-devel
307    
308     %package -n %{libglesv2name}
309     Summary: Files for Mesa (glesv2 libs)
310     Group: System/Libraries
311     Provides: %{libglesv2name_virt} = %{version}-%{release}
312    
313     %package -n %{libglesv2name}-devel
314     Summary: Development files for glesv2 libs
315     Group: Development/C
316     Requires: %{libglesv2name} = %{version}-%{release}
317 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
318 tv 88442 Provides: lib%{glesv2name}-devel
319     Provides: %{glesv2name}-devel
320     Provides: libglesv2-devel
321    
322 tv 88445 %package -n %{libopenvgname}
323     Summary: Files for MESA (OpenVG libs)
324     Group: System/Libraries
325     Provides: %{libopenvgname_virt} = %{version}-%{release}
326    
327     %package -n %{libopenvgname}-devel
328     Summary: Development files vor OpenVG libs
329     Group: Development/C
330     Requires: %{libopenvgname} = %{version}-%{release}
331     Provides: lib%{openvgname}-devel
332     Provides: %{openvgname}-devel
333     Provides: libopenvg-devel
334    
335 blino 215979 %if %{enable_wayland}
336     %package -n %{libgbmname}
337     Summary: Files for Mesa (gbm libs)
338     Group: System/Libraries
339     Provides: %{libgbmname_virt} = %{version}-%{release}
340    
341     %package -n %{libgbmname}-devel
342     Summary: Development files for Mesa (gbm libs)
343     Group: Development/C
344     Requires: %{libgbmname} = %{version}-%{release}
345     Provides: lib%{gbmname}-devel
346     Provides: %{gbmname}-devel
347    
348     %package -n %{libwaylandeglname}
349     Summary: Files for Mesa (Wayland EGL libs)
350     Group: System/Libraries
351     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
352    
353     %package -n %{libwaylandeglname}-devel
354     Summary: Development files for Mesa (Wayland EGL libs)
355     Group: Development/C
356     Requires: %{libwaylandeglname} = %{version}-%{release}
357     Provides: lib%{waylandeglname}-devel
358     Provides: %{waylandeglname}-devel
359     %endif
360    
361 blino 270761 %package -n vdpau-driver-nouveau
362     Summary: VDPAU plugin for nouveau driver
363 blino 279553 Group: Video
364 blino 270761
365     %package -n vdpau-driver-r300
366     Summary: VDPAU plugin for r300 driver
367 blino 279553 Group: Video
368 blino 270761
369     %package -n vdpau-driver-r600
370     Summary: VDPAU plugin for r600 driver
371 blino 279553 Group: Video
372 blino 270761
373 blino 289282 %package -n vdpau-driver-radeonsi
374     Summary: VDPAU plugin for radeonsi driver
375     Group: System/Libraries
376    
377 blino 270761 %package -n vdpau-driver-softpipe
378     Summary: VDPAU plugin for softpipe driver
379 blino 279553 Group: Video
380 blino 270761
381 pterjan 5340 %package common-devel
382     Summary: Meta package for mesa devel
383     Group: Development/C
384 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
385 pterjan 5340 Provides: hackMesa-common-devel = %{version}
386 tv 88247 Obsoletes: Mesa-common-devel < %{version}
387 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
388     Requires: %{libglname}-devel = %{version}
389 blino 289355 Requires: mesaglu-devel
390 tv 135156 Requires: freeglut-devel
391 tv 88442 Requires: %{libeglname}-devel = %{version}
392     Requires: %{libglesv1name}-devel = %{version}
393     Requires: %{libglesv2name}-devel = %{version}
394 pterjan 5340
395 tv 88440 #------------------------------------------------------------------------------
396 pterjan 5340
397     %description
398 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
399 tv 135173 %if %{build_plf}
400 pterjan 5340
401 tv 135173 This package is in the "tainted" section because it enables some
402     OpenGL extentions that are covered by software patents.
403     %endif
404    
405 pterjan 5340 %description common-devel
406     Mesa common metapackage devel
407    
408     %if %{enable_egl}
409     %description -n %{libeglname}
410 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
411 pterjan 5340 EGL parts.
412    
413     %description -n %{libeglname}-devel
414 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
415 pterjan 5340 EGL development parts.
416     %endif
417    
418 blino 271501 %description -n %{libdricorename}
419 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 blino 271501 DRI core part.
421    
422 pterjan 5340 %description -n %{libglname}
423 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 pterjan 5340 GL and GLX parts.
425    
426 tv 135155 %if %{build_plf}
427     This package is in the "tainted" section because it enables some
428     OpenGL extentions that are covered by software patents.
429     %endif
430    
431 pterjan 5340 %description -n %{dridrivers}
432 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
433 pterjan 5340 DRI drivers.
434    
435 blino 271501 %description -n %{libdricorename}-devel
436 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
437 blino 271501
438     This package contains the headers needed to compile DRI drivers.
439    
440 pterjan 5340 %description -n %{libglname}-devel
441 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
442 pterjan 5340
443     This package contains the headers needed to compile Mesa programs.
444    
445 tv 88442 %description -n %{libglesv1name}
446     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
447     well-defined subset profiles of OpenGL.
448    
449     This package provides the OpenGL ES library version 1.
450    
451 anssi 278008 %description -n %{libosmesaname}
452     Mesa offscreen rendering libraries for rendering OpenGL into
453     application-allocated blocks of memory.
454    
455     %description -n %{osmesadevel}
456     This package contains the headers needed to compile programs against
457     the Mesa offscreen rendering library.
458    
459 mikala 112356 %description -n %{libglapiname}
460     This packages provides the glapi shared library used by gallium.
461    
462     %description -n %{libglapiname}-devel
463     This package contains the headers needed to compile programes against glapi shared library.
464    
465 tv 88442 %description -n %{libglesv1name}-devel
466     This package contains the headers needed to compile OpenGL ES 1 programs.
467    
468     %description -n %{libglesv2name}
469     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
470     well-defined subset profiles of OpenGL.
471    
472     This package provides the OpenGL ES library version 2.
473    
474     %description -n %{libglesv2name}-devel
475     This package contains the headers needed to compile OpenGL ES 2 programs.
476    
477 tv 88445 %description -n %{libopenvgname}
478     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
479     acceleration interface for vector graphics libraries such as Flash and SVG.
480    
481     %description -n %{libopenvgname}-devel
482     Development files for OpenVG library.
483    
484 blino 215979 %if %{enable_wayland}
485     %description -n %{libgbmname}
486 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
487 blino 215979 GBM (Graphics Buffer Manager) parts.
488    
489     %description -n %{libgbmname}-devel
490 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
491 blino 215979 GBM (Graphics Buffer Manager) development parts.
492    
493     %description -n %{libwaylandeglname}
494 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
495 blino 215979 Wayland EGL platform parts.
496    
497     %description -n %{libwaylandeglname}-devel
498 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
499 blino 215979 Wayland EGL platform development parts.
500     %endif
501    
502 blino 270761 %description -n vdpau-driver-nouveau
503     This packages provides a VPDAU plugin to enable video acceleration
504     with the nouveau driver.
505    
506     %description -n vdpau-driver-r300
507     This packages provides a VPDAU plugin to enable video acceleration
508     with the r300 driver.
509    
510     %description -n vdpau-driver-r600
511     This packages provides a VPDAU plugin to enable video acceleration
512     with the r600 driver.
513    
514 blino 289282 %description -n vdpau-driver-radeonsi
515     This packages provides a VPDAU plugin to enable video acceleration
516     with the radeonsi driver.
517    
518 blino 270761 %description -n vdpau-driver-softpipe
519     This packages provides a VPDAU plugin to enable video acceleration
520     with the softpipe driver.
521    
522 tv 88440 #------------------------------------------------------------------------------
523    
524 pterjan 5340 %prep
525     %if %{git}
526 blino 289278 %setup -q -n mesa-%{git_branch}-%{git}
527 pterjan 5340 %else
528 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
529 pterjan 5340 %endif
530    
531 blino 278731 %apply_patches
532 blino 289353 autoreconf -vfi
533 pterjan 5340
534     %build
535 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
536     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
537     export LDFLAGS="-L%{_libdir}/llvm"
538    
539     %configure2_5x --enable-dri \
540     --enable-glx \
541 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
542     --with-dri-drivers="%{dri_drivers}" \
543 anssi 165988 --enable-shared-dricore \
544 pterjan 5340 %if %{enable_egl}
545     --enable-egl \
546     %else
547     --disable-egl \
548     %endif
549 blino 215979 %if %{enable_wayland}
550     --with-egl-platforms=x11,wayland,drm \
551     --enable-gbm \
552     --enable-shared-glapi \
553     %endif
554 tv 88442 --enable-gles1 \
555     --enable-gles2 \
556 tv 88445 --enable-openvg \
557 mikala 112356 --enable-gallium-egl \
558 blino 270761 --enable-gallium-g3dvl \
559 anssi 278008 --enable-osmesa \
560 blino 270761 --disable-xvmc \
561     --enable-vdpau \
562     --disable-va \
563 mikala 112356 %if %{with_hardware}
564 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
565 mikala 112356 --enable-gallium-llvm \
566     %else
567     --disable-gallium-llvm \
568     --with-gallium-drivers=swrast \
569     %endif
570 tv 135155 %if %{build_plf}
571     --enable-texture-float \
572     %endif
573 blino 270723 # end of configure options
574 pterjan 5340
575 anssi 165988 %make
576 pterjan 5340
577     %install
578 tv 88249 %makeinstall_std
579 pterjan 5340
580 blino 216556 # FIXME: strip will likely break the hardlink
581 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
582     # to prevent proprietary driver installers from removing them
583     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
584     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
585     for l in ../libGL.so.*; do cp -a $l .; done
586     popd
587    
588     %ifarch %{x86_64}
589     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
590     %endif
591    
592 blino 270761 # .so files are not needed by vdpau
593     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
594    
595 blino 271144 # .la files are not needed by mesa
596     find %{buildroot} -name '*.la' -exec rm {} \;
597    
598 anssi 181478 # use swrastg if built (Anssi 12/2011)
599     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
600    
601 tv 88440 #------------------------------------------------------------------------------
602    
603 pterjan 5340 %files
604     %defattr(-,root,root)
605 blino 271481 %doc docs/COPYING
606 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
607 pterjan 5340
608 blino 271501 %files -n %{libdricorename}
609     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
610     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
611    
612     %files -n %{libdricorename}-devel
613     %{_libdir}/libdricore%{version}.so
614    
615 pterjan 5340 %files -n %{dridrivers}
616     %defattr(-,root,root)
617     %doc docs/COPYING
618     %ifnarch ppc64
619     %dir %{_libdir}/dri
620 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
621     #%{_libdir}/dri/libglsl.so
622 pterjan 5340 %{_libdir}/dri/*_dri.so
623     %endif
624    
625 tv 88433 %files -n %{libglname}
626     %defattr(-,root,root)
627     %doc docs/COPYING
628     %{_libdir}/libGL.so.*
629     %dir %{_libdir}/mesa
630 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
631 tv 88433
632     %if %{enable_egl}
633     %files -n %{libeglname}
634     %defattr(-,root,root)
635 tv 88442 %doc docs/COPYING
636 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
637 tv 88442 %dir %{_libdir}/egl
638 blino 215979 %if !%{enable_wayland}
639     # st_GL, built only when shared glapi is not enabled
640 mikala 112356 %{_libdir}/egl/st_GL.so
641 blino 215979 %endif
642 mikala 127466 %{_libdir}/egl/egl_gallium.so
643 tv 88441 %endif
644 tv 88433
645 anssi 278008 %files -n %{libosmesaname}
646     %defattr(-,root,root)
647     %{_libdir}/libOSMesa.so.%{osmesamajor}*
648    
649 mikala 112356 %files -n %{libglapiname}
650     %defattr(-,root,root)
651     %{_libdir}/libglapi.so.%{glapimajor}*
652    
653 tv 88442 %files -n %{libglesv1name}
654     %defattr(-,root,root)
655     %doc docs/COPYING
656     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
657    
658     %files -n %{libglesv2name}
659     %defattr(-,root,root)
660     %doc docs/COPYING
661     %{_libdir}/libGLESv2.so.%{glesv2major}*
662    
663 tv 88445 %files -n %{libopenvgname}
664     %defattr(-,root,root)
665     %doc docs/COPYING
666     %{_libdir}/libOpenVG.so.%{openvgmajor}*
667    
668 blino 215979 %if %{enable_wayland}
669     %files -n %{libgbmname}
670     %{_libdir}/libgbm.so.%{gbmmajor}
671 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
672 blino 215979 %{_libdir}/gbm/gbm_*.so
673     %{_libdir}/gbm/pipe_*.so
674 tv 88445
675 blino 215979 %files -n %{libwaylandeglname}
676     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
677 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
678 blino 215979 %endif
679    
680    
681 pterjan 5340 %files -n %{libglname}-devel
682     %defattr(-,root,root)
683     %doc docs/COPYING
684 anssi 278008 %dir %{_includedir}/GL
685 pterjan 5340 %{_includedir}/GL/gl.h
686     %{_includedir}/GL/glext.h
687     %{_includedir}/GL/gl_mangle.h
688     %{_includedir}/GL/wglext.h
689     %{_includedir}/GL/glx.h
690     %{_includedir}/GL/glxext.h
691     %{_includedir}/GL/glx_mangle.h
692     %{_libdir}/libGL.so
693 tv 88436 %{_libdir}/pkgconfig/gl.pc
694     %{_libdir}/pkgconfig/dri.pc
695 pterjan 5340
696     #FIXME: check those headers
697     %{_includedir}/GL/vms_x_fix.h
698     %{_includedir}/GL/wmesa.h
699     %dir %{_includedir}/GL/internal
700     %{_includedir}/GL/internal/dri_interface.h
701    
702     %files common-devel
703     %defattr(-,root,root)
704    
705 tv 88441 %if %{enable_egl}
706 tv 88433 %files -n %{libeglname}-devel
707     %defattr(-,root,root)
708 tv 88442 %doc docs/COPYING
709     %{_includedir}/EGL
710     %{_includedir}/KHR
711 tv 88433 %{_libdir}/libEGL.so
712 tv 88436 %{_libdir}/pkgconfig/egl.pc
713 tv 88433 %endif
714 pterjan 5340
715 anssi 278008 %files -n %{osmesadevel}
716     %defattr(-,root,root)
717     %dir %{_includedir}/GL
718     %{_includedir}/GL/osmesa.h
719     %{_libdir}/libOSMesa.so
720     %{_libdir}/pkgconfig/osmesa.pc
721    
722 mikala 112356 %files -n %{libglapiname}-devel
723     %defattr(-,root,root)
724     %{_libdir}/libglapi.so
725 pterjan 5340
726 tv 88442 %files -n %{libglesv1name}-devel
727     %defattr(-,root,root)
728     %{_includedir}/GLES
729     %{_libdir}/libGLESv1_CM.so
730     %{_libdir}/pkgconfig/glesv1_cm.pc
731 tv 88433
732 tv 88442 %files -n %{libglesv2name}-devel
733     %defattr(-,root,root)
734     %{_includedir}/GLES2
735     %{_libdir}/libGLESv2.so
736     %{_libdir}/pkgconfig/glesv2.pc
737 tv 88445
738     %files -n %{libopenvgname}-devel
739     %defattr(-,root,root)
740     %{_includedir}/VG
741     %{_libdir}/libOpenVG.so
742     %{_libdir}/pkgconfig/vg.pc
743 blino 215979
744     %if %{enable_wayland}
745     %files -n %{libgbmname}-devel
746     %{_includedir}/gbm.h
747     %{_libdir}/libgbm.so
748     %{_libdir}/pkgconfig/gbm.pc
749    
750     %files -n %{libwaylandeglname}-devel
751     %{_libdir}/libwayland-egl.so
752     %{_libdir}/pkgconfig/wayland-egl.pc
753     %endif
754 blino 270761
755     %files -n vdpau-driver-nouveau
756     %{_libdir}/vdpau/libvdpau_nouveau.so.*
757    
758     %files -n vdpau-driver-r300
759     %{_libdir}/vdpau/libvdpau_r300.so.*
760    
761     %files -n vdpau-driver-r600
762     %{_libdir}/vdpau/libvdpau_r600.so.*
763    
764 blino 289282 %files -n vdpau-driver-radeonsi
765     %{_libdir}/vdpau/libvdpau_radeonsi.so.*
766    
767 blino 270761 %files -n vdpau-driver-softpipe
768     %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30