/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 303796 - (hide annotations) (download)
Tue Oct 9 06:18:26 2012 UTC (11 years, 6 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 22319 byte(s)
- new release
- drop patch 101, 201, 202 (merged)
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 tv 303796 %define git 0
19 blino 289278 %define git_branch 9.0
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 303796 %define version 9.0
27     %define rel 1
28 pterjan 5340
29     %define release %mkrel %{rel}
30     %define src_type tar.bz2
31 tv 173693 #define vsuffix %{expand:}
32     %define vsuffix %nil
33 pterjan 5340
34     %if %{relc}
35     %define release %mkrel 0.rc%{relc}.%{rel}
36     %define vsuffix -rc%{relc}
37     %define src_type tar.bz2
38     %endif
39    
40     %if %{git}
41     %if %{relc}
42 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
43 pterjan 5340 %else
44     %define release %mkrel 0.git%{git}.%{rel}
45     %endif
46     %endif
47    
48     %define makedepend %{_bindir}/gccmakedep
49    
50 blino 271501 %define dricorename dricore
51 pterjan 5340 %define eglname mesaegl
52     %define glname mesagl
53     %define glwname mesaglw
54 tv 88442 %define glesv1name mesaglesv1
55     %define glesv2name mesaglesv2
56 tv 88445 %define openvgname mesaopenvg
57 mikala 112356 %define glapiname glapi
58 blino 215979 %define gbmname gbm
59     %define waylandeglname wayland-egl
60 tv 88442
61 blino 271501 %define dricoremajor 1
62 pterjan 5340 %define eglmajor 1
63     %define glmajor 1
64     %define glwmajor 1
65 tv 88442 %define glesv1major 1
66     %define glesv2major 2
67 tv 88445 %define openvgmajor 1
68 mikala 112356 %define glapimajor 0
69 blino 215979 %define gbmmajor 1
70     %define waylandeglmajor 1
71 blino 289617 %define osmesamajor 8
72 tv 88442
73 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
74 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
75     %define libglname %mklibname %{glname} %{glmajor}
76     %define libglwname %mklibname %{glwname} %{glwmajor}
77 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
78     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
79 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
80 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
81 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
82     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
83 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
84 pterjan 5340
85     %define dridrivers %mklibname dri-drivers
86    
87 anssi 278008 %define osmesadevel %mklibname osmesa -d
88    
89 pterjan 5340 # Architecture-independent Virtual provides:
90 blino 271501 %define libdricorename_virt lib%{dricorename}
91 pterjan 5340 %define libeglname_virt lib%{eglname}
92     %define libglname_virt lib%{glname}
93     %define libglwname_virt lib%{glwname}
94 tv 88442 %define libglesv1name_virt lib%{glesv1name}
95     %define libglesv2name_virt lib%{glesv2name}
96 tv 88445 %define libopenvgname_virt lib%{openvgname}
97 mikala 112356 %define libglapiname_virt lib%{glapiname}
98 blino 215979 %define libgbmname_virt lib%{gbmname}
99     %define libwaylandeglname_virt lib%{waylandeglname}
100 pterjan 5340
101     %define oldlibglname %mklibname MesaGL 1
102    
103     %define mesasrcdir %{_prefix}/src/Mesa/
104     %define driver_dir %{_libdir}/dri
105    
106 tv 88451 %define enable_egl 1
107 blino 215979 %define enable_wayland 1
108 pterjan 5340
109     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
110     #FIXME: (for >=i586) disable sse
111     # SSE seems to have problem on some apps (gtulpas) for probing.
112 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
113 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
114 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
115 pterjan 5340 %define dri_drivers_ppc64 ""
116 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
117     %define dri_drivers_alpha "r200,radeon,swrast"
118     %define dri_drivers_sparc "ffb,radeon,swrast"
119     %define dri_drivers_mipsel "r200,radeon,swrast"
120 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
121 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
122    
123     Name: %{name}
124     Version: %{version}
125     Release: %{release}
126 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
127 pterjan 5340 Group: System/Libraries
128    
129 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
130     BuildRequires: pkgconfig(xt) >= 1.0.5
131     BuildRequires: pkgconfig(xmu) >= 1.0.3
132     BuildRequires: pkgconfig(x11) >= 1.3.3
133     BuildRequires: pkgconfig(xdamage) >= 1.1.1
134 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
135     BuildRequires: gccmakedep
136     BuildRequires: x11-proto-devel >= 7.3
137 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
138 pterjan 5340
139 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
140     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
141     BuildRequires: pkgconfig(xi) >= 1.3
142     BuildRequires: pkgconfig(talloc)
143 tv 88443 BuildRequires: libxml2-python
144 tmb 35532 BuildRequires: makedepend
145 dmorgan 106004 BuildRequires: bison flex
146 blino 289282 BuildRequires: llvm-devel >= 3.1
147 mikala 127466 BuildRequires: pkgconfig(libudev)
148 blino 270761 BuildRequires: pkgconfig(vdpau)
149 blino 215979 %if %{enable_wayland}
150     BuildRequires: wayland-devel
151     %endif
152 pterjan 5340
153     URL: http://www.mesa3d.org
154     %if %{git}
155 blino 289278 # (blino) snapshot of 9.0 branch
156     Source0: %{name}-%{git_branch}-%{git}.tar.bz2
157 pterjan 5340 %else
158     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
159     %endif
160     Source3: make-git-snapshot.sh
161    
162     # Instructions to setup your repository clone
163     # git://git.freedesktop.org/git/mesa/mesa
164     # git checkout mesa_7_5_branch
165     # git branch mdv-cherry-picks
166     # git am ../02??-*.patch
167     # git branch mdv-redhat
168     # git am ../03??-*.patch
169     # git branch mdv-patches
170     # git am ../09??-*.patch
171 tv 303796 Source101: 0001-Fix-undefined-symbols-in-libOSMesa-and-libglapi.patch
172 anssi 278531
173 pterjan 5340 # In order to update to the branch via patches, issue this command:
174     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
175    
176     # Cherry picks
177     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
178     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
179 blino 289280 # (blino) should be pushed to 9.0 branch upstream
180 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
181     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
182 pterjan 5340
183 tv 88247 # Patches "liberated" from Fedora:
184 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
185     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
186    
187 blino 278732 # Patches from ChromiumOS
188     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
189    
190 blino 271493 # Mageia/Mandriva patches
191 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
192 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
193 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
194 pterjan 5340
195    
196 tv 88440 #------------------------------------------------------------------------------
197    
198     # package mesa
199 pterjan 5340 License: MIT
200     Requires: %{libglname} = %{version}-%{release}
201     Provides: hackMesa = %{version}
202     Obsoletes: hackMesa <= %{version}
203     Provides: Mesa = %{version}
204     Obsoletes: Mesa < %{version}
205    
206 blino 271501 %package -n %{libdricorename}
207     Summary: Shared library for DRI drivers
208     Group: System/Libraries
209     Provides: %{libdricorename_virt} = %{version}-%{release}
210    
211     %package -n %{libdricorename}-devel
212     Summary: Development files for DRI core
213     Group: Development/C
214     Requires: %{libdricorename} = %{version}-%{release}
215     Provides: lib%{dricorename}-devel = %{version}-%{release}
216     Provides: %{dricorename}-devel = %{version}-%{release}
217    
218 pterjan 5340 %package -n %{libglname}
219     Summary: Files for Mesa (GL and GLX libs)
220     Group: System/Libraries
221 tv 88247 Obsoletes: %{oldlibglname} < 6.4
222 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
223     Provides: %{libglname_virt} = %{version}-%{release}
224     Requires: %{dridrivers} >= %{version}-%{release}
225 tv 135172 %if %{build_plf}
226     Requires: %mklibname txc-dxtn
227     %endif
228 pterjan 5340
229     # (anssi) Forces the upgrade of x11-server-common to happen before
230     # alternatives removal, which allows x11-server-common to grab the symlink.
231     Conflicts: x11-server-common < 1.3.0.0-17
232    
233     %package -n %{dridrivers}
234     Summary: Mesa DRI drivers
235     Group: System/Libraries
236 blino 274132 # do not require exact release to avoid conflicts when having
237     # x86_64 dri drivers from tainted and i586 dri drivers from core
238     Requires: mesa = %{version}
239 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
240 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
241     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
242 pterjan 5340
243     %package -n %{libglname}-devel
244     Summary: Development files for Mesa (OpenGL compatible 3D lib)
245     Group: Development/C
246 tv 88237 Requires: %{libglname} = %{version}-%{release}
247 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
248     Provides: %{glname}-devel = %{version}-%{release}
249     Provides: GL-devel
250     Obsoletes: %{oldlibglname}-devel < 6.4
251     Provides: %{oldlibglname}-devel = %{version}-%{release}
252     Provides: libMesaGL-devel = %{version}-%{release}
253     Provides: MesaGL-devel = %{version}-%{release}
254 tv 88438 Provides: libgl-devel
255 pterjan 5340
256 tv 88433 %if %{enable_egl}
257     %package -n %{libeglname}
258     Summary: Files for Mesa (EGL libs)
259     Group: System/Libraries
260     Provides: %{libeglname_virt} = %{version}-%{release}
261    
262     %package -n %{libeglname}-devel
263     Summary: Development files for Mesa (EGL libs)
264     Group: Development/C
265 tv 88439 Requires: %{libeglname} = %{version}-%{release}
266 tv 88433 Provides: EGL-devel
267 tv 88438 Provides: lib%{eglname}-devel
268     Provides: %{eglname}-devel
269     Provides: libegl-devel
270 tv 88433 %endif
271    
272 anssi 278008 %package -n %{libosmesaname}
273     Summary: Mesa offscreen rendering library
274     Group: System/Libraries
275    
276     %package -n %{osmesadevel}
277     Summary: Development files for libosmesa
278     Group: Development/C
279     Requires: %{libosmesaname} = %{version}-%{release}
280     Provides: osmesa-devel = %{version}-%{release}
281     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
282    
283 mikala 112356 %package -n %{libglapiname}
284     Summary: Files for mesa (glapi libs)
285     Group: System/Libraries
286     Provides: %{libglapiname_virt} = %{version}-%{release}
287 tv 88442
288 mikala 112356 %package -n %{libglapiname}-devel
289     Summary: Development files for glapi libs
290     Group: Development/C
291     Requires: %{libglapiname_virt} = %{version}-%{release}
292     Provides: lib%{glapiname}-devel
293     Provides: %{libglapiname}-devel
294    
295 tv 88442 %package -n %{libglesv1name}
296     Summary: Files for Mesa (glesv1 libs)
297     Group: System/Libraries
298     Provides: %{libglesv1name_virt} = %{version}-%{release}
299    
300     %package -n %{libglesv1name}-devel
301     Summary: Development files for glesv1 libs
302     Group: Development/C
303     Requires: %{libglesv1name} = %{version}-%{release}
304     Provides: lib%{glesv1name}-devel
305     Provides: %{glesv1name}-devel
306     Provides: libglesv1-devel
307    
308     %package -n %{libglesv2name}
309     Summary: Files for Mesa (glesv2 libs)
310     Group: System/Libraries
311     Provides: %{libglesv2name_virt} = %{version}-%{release}
312    
313     %package -n %{libglesv2name}-devel
314     Summary: Development files for glesv2 libs
315     Group: Development/C
316     Requires: %{libglesv2name} = %{version}-%{release}
317 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
318 tv 88442 Provides: lib%{glesv2name}-devel
319     Provides: %{glesv2name}-devel
320     Provides: libglesv2-devel
321    
322 tv 88445 %package -n %{libopenvgname}
323     Summary: Files for MESA (OpenVG libs)
324     Group: System/Libraries
325     Provides: %{libopenvgname_virt} = %{version}-%{release}
326    
327     %package -n %{libopenvgname}-devel
328     Summary: Development files vor OpenVG libs
329     Group: Development/C
330     Requires: %{libopenvgname} = %{version}-%{release}
331     Provides: lib%{openvgname}-devel
332     Provides: %{openvgname}-devel
333     Provides: libopenvg-devel
334    
335 blino 215979 %if %{enable_wayland}
336     %package -n %{libgbmname}
337     Summary: Files for Mesa (gbm libs)
338     Group: System/Libraries
339     Provides: %{libgbmname_virt} = %{version}-%{release}
340    
341     %package -n %{libgbmname}-devel
342     Summary: Development files for Mesa (gbm libs)
343     Group: Development/C
344     Requires: %{libgbmname} = %{version}-%{release}
345     Provides: lib%{gbmname}-devel
346     Provides: %{gbmname}-devel
347    
348     %package -n %{libwaylandeglname}
349     Summary: Files for Mesa (Wayland EGL libs)
350     Group: System/Libraries
351     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
352    
353     %package -n %{libwaylandeglname}-devel
354     Summary: Development files for Mesa (Wayland EGL libs)
355     Group: Development/C
356     Requires: %{libwaylandeglname} = %{version}-%{release}
357     Provides: lib%{waylandeglname}-devel
358     Provides: %{waylandeglname}-devel
359     %endif
360    
361 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
362 blino 270761 Summary: VDPAU plugin for nouveau driver
363 blino 300616 Group: System/Libraries
364 tv 302568 # temporary:
365     %rename vdpau-driver-nouveau
366 blino 270761
367 tv 301233 %package -n %{_lib}vdpau-driver-r300
368 blino 270761 Summary: VDPAU plugin for r300 driver
369 blino 300616 Group: System/Libraries
370 tv 302568 # temporary:
371     %rename vdpau-driver-r300
372 blino 270761
373 tv 301233 %package -n %{_lib}vdpau-driver-r600
374 blino 270761 Summary: VDPAU plugin for r600 driver
375 blino 300616 Group: System/Libraries
376 tv 302568 # temporary:
377     %rename vdpau-driver-r600
378 blino 270761
379 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
380 blino 289282 Summary: VDPAU plugin for radeonsi driver
381     Group: System/Libraries
382 tv 302568 # temporary:
383     %rename vdpau-driver-radeonsi
384 blino 289282
385 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
386 blino 270761 Summary: VDPAU plugin for softpipe driver
387 blino 300616 Group: System/Libraries
388 tv 302568 # temporary:
389     %rename vdpau-driver-softpipe
390 blino 270761
391 pterjan 5340 %package common-devel
392     Summary: Meta package for mesa devel
393     Group: Development/C
394 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
395 pterjan 5340 Provides: hackMesa-common-devel = %{version}
396 tv 88247 Obsoletes: Mesa-common-devel < %{version}
397 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
398     Requires: %{libglname}-devel = %{version}
399 blino 289355 Requires: mesaglu-devel
400 tv 135156 Requires: freeglut-devel
401 tv 88442 Requires: %{libeglname}-devel = %{version}
402     Requires: %{libglesv1name}-devel = %{version}
403     Requires: %{libglesv2name}-devel = %{version}
404 pterjan 5340
405 tv 88440 #------------------------------------------------------------------------------
406 pterjan 5340
407     %description
408 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
409 tv 135173 %if %{build_plf}
410 pterjan 5340
411 tv 135173 This package is in the "tainted" section because it enables some
412     OpenGL extentions that are covered by software patents.
413     %endif
414    
415 pterjan 5340 %description common-devel
416     Mesa common metapackage devel
417    
418     %if %{enable_egl}
419     %description -n %{libeglname}
420 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
421 pterjan 5340 EGL parts.
422    
423     %description -n %{libeglname}-devel
424 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
425 pterjan 5340 EGL development parts.
426     %endif
427    
428 blino 271501 %description -n %{libdricorename}
429 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
430 blino 271501 DRI core part.
431    
432 pterjan 5340 %description -n %{libglname}
433 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
434 pterjan 5340 GL and GLX parts.
435    
436 tv 135155 %if %{build_plf}
437     This package is in the "tainted" section because it enables some
438     OpenGL extentions that are covered by software patents.
439     %endif
440    
441 pterjan 5340 %description -n %{dridrivers}
442 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
443 pterjan 5340 DRI drivers.
444    
445 blino 271501 %description -n %{libdricorename}-devel
446 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
447 blino 271501
448     This package contains the headers needed to compile DRI drivers.
449    
450 pterjan 5340 %description -n %{libglname}-devel
451 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
452 pterjan 5340
453     This package contains the headers needed to compile Mesa programs.
454    
455 tv 88442 %description -n %{libglesv1name}
456     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
457     well-defined subset profiles of OpenGL.
458    
459     This package provides the OpenGL ES library version 1.
460    
461 anssi 278008 %description -n %{libosmesaname}
462     Mesa offscreen rendering libraries for rendering OpenGL into
463     application-allocated blocks of memory.
464    
465     %description -n %{osmesadevel}
466     This package contains the headers needed to compile programs against
467     the Mesa offscreen rendering library.
468    
469 mikala 112356 %description -n %{libglapiname}
470     This packages provides the glapi shared library used by gallium.
471    
472     %description -n %{libglapiname}-devel
473     This package contains the headers needed to compile programes against glapi shared library.
474    
475 tv 88442 %description -n %{libglesv1name}-devel
476     This package contains the headers needed to compile OpenGL ES 1 programs.
477    
478     %description -n %{libglesv2name}
479     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
480     well-defined subset profiles of OpenGL.
481    
482     This package provides the OpenGL ES library version 2.
483    
484     %description -n %{libglesv2name}-devel
485     This package contains the headers needed to compile OpenGL ES 2 programs.
486    
487 tv 88445 %description -n %{libopenvgname}
488     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
489     acceleration interface for vector graphics libraries such as Flash and SVG.
490    
491     %description -n %{libopenvgname}-devel
492     Development files for OpenVG library.
493    
494 blino 215979 %if %{enable_wayland}
495     %description -n %{libgbmname}
496 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
497 blino 215979 GBM (Graphics Buffer Manager) parts.
498    
499     %description -n %{libgbmname}-devel
500 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
501 blino 215979 GBM (Graphics Buffer Manager) development parts.
502    
503     %description -n %{libwaylandeglname}
504 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
505 blino 215979 Wayland EGL platform parts.
506    
507     %description -n %{libwaylandeglname}-devel
508 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
509 blino 215979 Wayland EGL platform development parts.
510     %endif
511    
512 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
513 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
514     with the nouveau driver.
515    
516 tv 301233 %description -n %{_lib}vdpau-driver-r300
517 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
518     with the r300 driver.
519    
520 tv 301233 %description -n %{_lib}vdpau-driver-r600
521 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
522     with the r600 driver.
523    
524 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
525 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
526     with the radeonsi driver.
527    
528 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
529 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
530     with the softpipe driver.
531    
532 tv 88440 #------------------------------------------------------------------------------
533    
534 pterjan 5340 %prep
535     %if %{git}
536 blino 289278 %setup -q -n mesa-%{git_branch}-%{git}
537 pterjan 5340 %else
538 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
539 pterjan 5340 %endif
540    
541 blino 278731 %apply_patches
542 blino 289353 autoreconf -vfi
543 pterjan 5340
544     %build
545 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
546     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
547     export LDFLAGS="-L%{_libdir}/llvm"
548    
549     %configure2_5x --enable-dri \
550     --enable-glx \
551 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
552     --with-dri-drivers="%{dri_drivers}" \
553 anssi 165988 --enable-shared-dricore \
554 pterjan 5340 %if %{enable_egl}
555     --enable-egl \
556     %else
557     --disable-egl \
558     %endif
559 blino 215979 %if %{enable_wayland}
560     --with-egl-platforms=x11,wayland,drm \
561     --enable-gbm \
562     --enable-shared-glapi \
563     %endif
564 tv 88442 --enable-gles1 \
565     --enable-gles2 \
566 tv 88445 --enable-openvg \
567 mikala 112356 --enable-gallium-egl \
568 blino 270761 --enable-gallium-g3dvl \
569 anssi 278008 --enable-osmesa \
570 blino 270761 --disable-xvmc \
571     --enable-vdpau \
572     --disable-va \
573 mikala 112356 %if %{with_hardware}
574 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
575 mikala 112356 --enable-gallium-llvm \
576     %else
577     --disable-gallium-llvm \
578     --with-gallium-drivers=swrast \
579     %endif
580 tv 135155 %if %{build_plf}
581     --enable-texture-float \
582     %endif
583 blino 270723 # end of configure options
584 pterjan 5340
585 anssi 165988 %make
586 pterjan 5340
587     %install
588 tv 88249 %makeinstall_std
589 pterjan 5340
590 blino 216556 # FIXME: strip will likely break the hardlink
591 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
592     # to prevent proprietary driver installers from removing them
593     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
594     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
595     for l in ../libGL.so.*; do cp -a $l .; done
596     popd
597    
598     %ifarch %{x86_64}
599     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
600     %endif
601    
602 blino 270761 # .so files are not needed by vdpau
603     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
604    
605 blino 271144 # .la files are not needed by mesa
606     find %{buildroot} -name '*.la' -exec rm {} \;
607    
608 anssi 181478 # use swrastg if built (Anssi 12/2011)
609     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
610    
611 tv 88440 #------------------------------------------------------------------------------
612    
613 pterjan 5340 %files
614     %defattr(-,root,root)
615 blino 271481 %doc docs/COPYING
616 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
617 pterjan 5340
618 blino 271501 %files -n %{libdricorename}
619     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
620     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
621    
622     %files -n %{libdricorename}-devel
623     %{_libdir}/libdricore%{version}.so
624    
625 pterjan 5340 %files -n %{dridrivers}
626     %defattr(-,root,root)
627     %doc docs/COPYING
628     %ifnarch ppc64
629     %dir %{_libdir}/dri
630 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
631     #%{_libdir}/dri/libglsl.so
632 pterjan 5340 %{_libdir}/dri/*_dri.so
633     %endif
634    
635 tv 88433 %files -n %{libglname}
636     %defattr(-,root,root)
637     %doc docs/COPYING
638     %{_libdir}/libGL.so.*
639     %dir %{_libdir}/mesa
640 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
641 tv 88433
642     %if %{enable_egl}
643     %files -n %{libeglname}
644     %defattr(-,root,root)
645 tv 88442 %doc docs/COPYING
646 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
647 tv 88442 %dir %{_libdir}/egl
648 blino 215979 %if !%{enable_wayland}
649     # st_GL, built only when shared glapi is not enabled
650 mikala 112356 %{_libdir}/egl/st_GL.so
651 blino 215979 %endif
652 mikala 127466 %{_libdir}/egl/egl_gallium.so
653 tv 88441 %endif
654 tv 88433
655 anssi 278008 %files -n %{libosmesaname}
656     %defattr(-,root,root)
657     %{_libdir}/libOSMesa.so.%{osmesamajor}*
658    
659 mikala 112356 %files -n %{libglapiname}
660     %defattr(-,root,root)
661     %{_libdir}/libglapi.so.%{glapimajor}*
662    
663 tv 88442 %files -n %{libglesv1name}
664     %defattr(-,root,root)
665     %doc docs/COPYING
666     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
667    
668     %files -n %{libglesv2name}
669     %defattr(-,root,root)
670     %doc docs/COPYING
671     %{_libdir}/libGLESv2.so.%{glesv2major}*
672    
673 tv 88445 %files -n %{libopenvgname}
674     %defattr(-,root,root)
675     %doc docs/COPYING
676     %{_libdir}/libOpenVG.so.%{openvgmajor}*
677    
678 blino 215979 %if %{enable_wayland}
679     %files -n %{libgbmname}
680     %{_libdir}/libgbm.so.%{gbmmajor}
681 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
682 blino 215979 %{_libdir}/gbm/gbm_*.so
683     %{_libdir}/gbm/pipe_*.so
684 tv 88445
685 blino 215979 %files -n %{libwaylandeglname}
686     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
687 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
688 blino 215979 %endif
689    
690    
691 pterjan 5340 %files -n %{libglname}-devel
692     %defattr(-,root,root)
693     %doc docs/COPYING
694 anssi 278008 %dir %{_includedir}/GL
695 pterjan 5340 %{_includedir}/GL/gl.h
696     %{_includedir}/GL/glext.h
697     %{_includedir}/GL/gl_mangle.h
698     %{_includedir}/GL/wglext.h
699     %{_includedir}/GL/glx.h
700     %{_includedir}/GL/glxext.h
701     %{_includedir}/GL/glx_mangle.h
702     %{_libdir}/libGL.so
703 tv 88436 %{_libdir}/pkgconfig/gl.pc
704     %{_libdir}/pkgconfig/dri.pc
705 pterjan 5340
706     #FIXME: check those headers
707     %{_includedir}/GL/vms_x_fix.h
708     %{_includedir}/GL/wmesa.h
709     %dir %{_includedir}/GL/internal
710     %{_includedir}/GL/internal/dri_interface.h
711    
712     %files common-devel
713     %defattr(-,root,root)
714    
715 tv 88441 %if %{enable_egl}
716 tv 88433 %files -n %{libeglname}-devel
717     %defattr(-,root,root)
718 tv 88442 %doc docs/COPYING
719     %{_includedir}/EGL
720     %{_includedir}/KHR
721 tv 88433 %{_libdir}/libEGL.so
722 tv 88436 %{_libdir}/pkgconfig/egl.pc
723 tv 88433 %endif
724 pterjan 5340
725 anssi 278008 %files -n %{osmesadevel}
726     %defattr(-,root,root)
727     %dir %{_includedir}/GL
728     %{_includedir}/GL/osmesa.h
729     %{_libdir}/libOSMesa.so
730     %{_libdir}/pkgconfig/osmesa.pc
731    
732 mikala 112356 %files -n %{libglapiname}-devel
733     %defattr(-,root,root)
734     %{_libdir}/libglapi.so
735 pterjan 5340
736 tv 88442 %files -n %{libglesv1name}-devel
737     %defattr(-,root,root)
738     %{_includedir}/GLES
739     %{_libdir}/libGLESv1_CM.so
740     %{_libdir}/pkgconfig/glesv1_cm.pc
741 tv 88433
742 tv 88442 %files -n %{libglesv2name}-devel
743     %defattr(-,root,root)
744     %{_includedir}/GLES2
745     %{_libdir}/libGLESv2.so
746     %{_libdir}/pkgconfig/glesv2.pc
747 tv 88445
748     %files -n %{libopenvgname}-devel
749     %defattr(-,root,root)
750     %{_includedir}/VG
751     %{_libdir}/libOpenVG.so
752     %{_libdir}/pkgconfig/vg.pc
753 blino 215979
754     %if %{enable_wayland}
755     %files -n %{libgbmname}-devel
756     %{_includedir}/gbm.h
757     %{_libdir}/libgbm.so
758     %{_libdir}/pkgconfig/gbm.pc
759    
760     %files -n %{libwaylandeglname}-devel
761     %{_libdir}/libwayland-egl.so
762     %{_libdir}/pkgconfig/wayland-egl.pc
763     %endif
764 blino 270761
765 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
766 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
767    
768 tv 301233 %files -n %{_lib}vdpau-driver-r300
769 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
770    
771 tv 301233 %files -n %{_lib}vdpau-driver-r600
772 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
773    
774 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
775 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
776    
777 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
778 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30