/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 307643 - (hide annotations) (download)
Wed Oct 17 13:04:23 2012 UTC (11 years, 6 months ago) by fwang
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 22548 byte(s)
add krh patch to build with wayland 0.99
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 tv 303796 %define git 0
19 blino 289278 %define git_branch 9.0
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 303797 %define fversion 9.0
27     %define version 9.0.0
28 fwang 307417 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 tv 88442
74 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
75 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
76     %define libglname %mklibname %{glname} %{glmajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libglwname_virt lib%{glwname}
95 tv 88442 %define libglesv1name_virt lib%{glesv1name}
96     %define libglesv2name_virt lib%{glesv2name}
97 tv 88445 %define libopenvgname_virt lib%{openvgname}
98 mikala 112356 %define libglapiname_virt lib%{glapiname}
99 blino 215979 %define libgbmname_virt lib%{gbmname}
100     %define libwaylandeglname_virt lib%{waylandeglname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131     BuildRequires: pkgconfig(xt) >= 1.0.5
132     BuildRequires: pkgconfig(xmu) >= 1.0.3
133     BuildRequires: pkgconfig(x11) >= 1.3.3
134     BuildRequires: pkgconfig(xdamage) >= 1.1.1
135 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
136     BuildRequires: gccmakedep
137     BuildRequires: x11-proto-devel >= 7.3
138 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
139 pterjan 5340
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 dmorgan 106004 BuildRequires: bison flex
147 blino 289282 BuildRequires: llvm-devel >= 3.1
148 mikala 127466 BuildRequires: pkgconfig(libudev)
149 blino 270761 BuildRequires: pkgconfig(vdpau)
150 blino 215979 %if %{enable_wayland}
151     BuildRequires: wayland-devel
152     %endif
153 pterjan 5340
154     URL: http://www.mesa3d.org
155     %if %{git}
156 blino 289278 # (blino) snapshot of 9.0 branch
157     Source0: %{name}-%{git_branch}-%{git}.tar.bz2
158 pterjan 5340 %else
159 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
160 pterjan 5340 %endif
161     Source3: make-git-snapshot.sh
162    
163     # Instructions to setup your repository clone
164     # git://git.freedesktop.org/git/mesa/mesa
165     # git checkout mesa_7_5_branch
166     # git branch mdv-cherry-picks
167     # git am ../02??-*.patch
168     # git branch mdv-redhat
169     # git am ../03??-*.patch
170     # git branch mdv-patches
171     # git am ../09??-*.patch
172 tv 303796 Source101: 0001-Fix-undefined-symbols-in-libOSMesa-and-libglapi.patch
173 fwang 307643 # Patch to build with wayland 0.99 from here:
174     # http://cgit.freedesktop.org/~krh/mesa/commit/?h=wayland-0.99&id=04a515eddd44b6b49c7a212b95f81687ee6afe4f
175     Patch102: 0002-MesaLib-9.0-Wayland-0.99-api.patch
176 anssi 278531
177 pterjan 5340 # In order to update to the branch via patches, issue this command:
178     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
179    
180     # Cherry picks
181     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
182     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
183 blino 289280 # (blino) should be pushed to 9.0 branch upstream
184 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
185     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
186 pterjan 5340
187 tv 88247 # Patches "liberated" from Fedora:
188 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
189     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
190    
191 blino 278732 # Patches from ChromiumOS
192     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
193    
194 blino 271493 # Mageia/Mandriva patches
195 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
196 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
197 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
198 pterjan 5340
199    
200 tv 88440 #------------------------------------------------------------------------------
201    
202     # package mesa
203 pterjan 5340 License: MIT
204     Requires: %{libglname} = %{version}-%{release}
205     Provides: hackMesa = %{version}
206     Obsoletes: hackMesa <= %{version}
207     Provides: Mesa = %{version}
208     Obsoletes: Mesa < %{version}
209    
210 blino 271501 %package -n %{libdricorename}
211     Summary: Shared library for DRI drivers
212     Group: System/Libraries
213     Provides: %{libdricorename_virt} = %{version}-%{release}
214    
215     %package -n %{libdricorename}-devel
216     Summary: Development files for DRI core
217     Group: Development/C
218     Requires: %{libdricorename} = %{version}-%{release}
219     Provides: lib%{dricorename}-devel = %{version}-%{release}
220     Provides: %{dricorename}-devel = %{version}-%{release}
221    
222 pterjan 5340 %package -n %{libglname}
223     Summary: Files for Mesa (GL and GLX libs)
224     Group: System/Libraries
225 tv 88247 Obsoletes: %{oldlibglname} < 6.4
226 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
227     Provides: %{libglname_virt} = %{version}-%{release}
228     Requires: %{dridrivers} >= %{version}-%{release}
229 tv 135172 %if %{build_plf}
230     Requires: %mklibname txc-dxtn
231     %endif
232 pterjan 5340
233     # (anssi) Forces the upgrade of x11-server-common to happen before
234     # alternatives removal, which allows x11-server-common to grab the symlink.
235     Conflicts: x11-server-common < 1.3.0.0-17
236    
237     %package -n %{dridrivers}
238     Summary: Mesa DRI drivers
239     Group: System/Libraries
240 blino 274132 # do not require exact release to avoid conflicts when having
241     # x86_64 dri drivers from tainted and i586 dri drivers from core
242     Requires: mesa = %{version}
243 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
244 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
245     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
246 pterjan 5340
247     %package -n %{libglname}-devel
248     Summary: Development files for Mesa (OpenGL compatible 3D lib)
249     Group: Development/C
250 tv 88237 Requires: %{libglname} = %{version}-%{release}
251 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
252     Provides: %{glname}-devel = %{version}-%{release}
253     Provides: GL-devel
254     Obsoletes: %{oldlibglname}-devel < 6.4
255     Provides: %{oldlibglname}-devel = %{version}-%{release}
256     Provides: libMesaGL-devel = %{version}-%{release}
257     Provides: MesaGL-devel = %{version}-%{release}
258 tv 88438 Provides: libgl-devel
259 pterjan 5340
260 tv 88433 %if %{enable_egl}
261     %package -n %{libeglname}
262     Summary: Files for Mesa (EGL libs)
263     Group: System/Libraries
264     Provides: %{libeglname_virt} = %{version}-%{release}
265    
266     %package -n %{libeglname}-devel
267     Summary: Development files for Mesa (EGL libs)
268     Group: Development/C
269 tv 88439 Requires: %{libeglname} = %{version}-%{release}
270 tv 88433 Provides: EGL-devel
271 tv 88438 Provides: lib%{eglname}-devel
272     Provides: %{eglname}-devel
273     Provides: libegl-devel
274 tv 88433 %endif
275    
276 anssi 278008 %package -n %{libosmesaname}
277     Summary: Mesa offscreen rendering library
278     Group: System/Libraries
279    
280     %package -n %{osmesadevel}
281     Summary: Development files for libosmesa
282     Group: Development/C
283     Requires: %{libosmesaname} = %{version}-%{release}
284     Provides: osmesa-devel = %{version}-%{release}
285     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
286    
287 mikala 112356 %package -n %{libglapiname}
288     Summary: Files for mesa (glapi libs)
289     Group: System/Libraries
290     Provides: %{libglapiname_virt} = %{version}-%{release}
291 tv 88442
292 mikala 112356 %package -n %{libglapiname}-devel
293     Summary: Development files for glapi libs
294     Group: Development/C
295     Requires: %{libglapiname_virt} = %{version}-%{release}
296     Provides: lib%{glapiname}-devel
297     Provides: %{libglapiname}-devel
298    
299 tv 88442 %package -n %{libglesv1name}
300     Summary: Files for Mesa (glesv1 libs)
301     Group: System/Libraries
302     Provides: %{libglesv1name_virt} = %{version}-%{release}
303    
304     %package -n %{libglesv1name}-devel
305     Summary: Development files for glesv1 libs
306     Group: Development/C
307     Requires: %{libglesv1name} = %{version}-%{release}
308     Provides: lib%{glesv1name}-devel
309     Provides: %{glesv1name}-devel
310     Provides: libglesv1-devel
311    
312     %package -n %{libglesv2name}
313     Summary: Files for Mesa (glesv2 libs)
314     Group: System/Libraries
315     Provides: %{libglesv2name_virt} = %{version}-%{release}
316    
317     %package -n %{libglesv2name}-devel
318     Summary: Development files for glesv2 libs
319     Group: Development/C
320     Requires: %{libglesv2name} = %{version}-%{release}
321 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
322 tv 88442 Provides: lib%{glesv2name}-devel
323     Provides: %{glesv2name}-devel
324     Provides: libglesv2-devel
325    
326 tv 88445 %package -n %{libopenvgname}
327     Summary: Files for MESA (OpenVG libs)
328     Group: System/Libraries
329     Provides: %{libopenvgname_virt} = %{version}-%{release}
330    
331     %package -n %{libopenvgname}-devel
332     Summary: Development files vor OpenVG libs
333     Group: Development/C
334     Requires: %{libopenvgname} = %{version}-%{release}
335     Provides: lib%{openvgname}-devel
336     Provides: %{openvgname}-devel
337     Provides: libopenvg-devel
338    
339 blino 215979 %if %{enable_wayland}
340     %package -n %{libgbmname}
341     Summary: Files for Mesa (gbm libs)
342     Group: System/Libraries
343     Provides: %{libgbmname_virt} = %{version}-%{release}
344    
345     %package -n %{libgbmname}-devel
346     Summary: Development files for Mesa (gbm libs)
347     Group: Development/C
348     Requires: %{libgbmname} = %{version}-%{release}
349     Provides: lib%{gbmname}-devel
350     Provides: %{gbmname}-devel
351    
352     %package -n %{libwaylandeglname}
353     Summary: Files for Mesa (Wayland EGL libs)
354     Group: System/Libraries
355     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
356    
357     %package -n %{libwaylandeglname}-devel
358     Summary: Development files for Mesa (Wayland EGL libs)
359     Group: Development/C
360     Requires: %{libwaylandeglname} = %{version}-%{release}
361     Provides: lib%{waylandeglname}-devel
362     Provides: %{waylandeglname}-devel
363     %endif
364    
365 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
366 blino 270761 Summary: VDPAU plugin for nouveau driver
367 blino 300616 Group: System/Libraries
368 tv 302568 # temporary:
369     %rename vdpau-driver-nouveau
370 blino 270761
371 tv 301233 %package -n %{_lib}vdpau-driver-r300
372 blino 270761 Summary: VDPAU plugin for r300 driver
373 blino 300616 Group: System/Libraries
374 tv 302568 # temporary:
375     %rename vdpau-driver-r300
376 blino 270761
377 tv 301233 %package -n %{_lib}vdpau-driver-r600
378 blino 270761 Summary: VDPAU plugin for r600 driver
379 blino 300616 Group: System/Libraries
380 tv 302568 # temporary:
381     %rename vdpau-driver-r600
382 blino 270761
383 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
384 blino 289282 Summary: VDPAU plugin for radeonsi driver
385     Group: System/Libraries
386 tv 302568 # temporary:
387     %rename vdpau-driver-radeonsi
388 blino 289282
389 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
390 blino 270761 Summary: VDPAU plugin for softpipe driver
391 blino 300616 Group: System/Libraries
392 tv 302568 # temporary:
393     %rename vdpau-driver-softpipe
394 blino 270761
395 pterjan 5340 %package common-devel
396     Summary: Meta package for mesa devel
397     Group: Development/C
398 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
399 pterjan 5340 Provides: hackMesa-common-devel = %{version}
400 tv 88247 Obsoletes: Mesa-common-devel < %{version}
401 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
402     Requires: %{libglname}-devel = %{version}
403 blino 289355 Requires: mesaglu-devel
404 tv 135156 Requires: freeglut-devel
405 tv 88442 Requires: %{libeglname}-devel = %{version}
406     Requires: %{libglesv1name}-devel = %{version}
407     Requires: %{libglesv2name}-devel = %{version}
408 pterjan 5340
409 tv 88440 #------------------------------------------------------------------------------
410 pterjan 5340
411     %description
412 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
413 tv 135173 %if %{build_plf}
414 pterjan 5340
415 tv 135173 This package is in the "tainted" section because it enables some
416     OpenGL extentions that are covered by software patents.
417     %endif
418    
419 pterjan 5340 %description common-devel
420     Mesa common metapackage devel
421    
422     %if %{enable_egl}
423     %description -n %{libeglname}
424 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
425 pterjan 5340 EGL parts.
426    
427     %description -n %{libeglname}-devel
428 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
429 pterjan 5340 EGL development parts.
430     %endif
431    
432 blino 271501 %description -n %{libdricorename}
433 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
434 blino 271501 DRI core part.
435    
436 pterjan 5340 %description -n %{libglname}
437 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
438 pterjan 5340 GL and GLX parts.
439    
440 tv 135155 %if %{build_plf}
441     This package is in the "tainted" section because it enables some
442     OpenGL extentions that are covered by software patents.
443     %endif
444    
445 pterjan 5340 %description -n %{dridrivers}
446 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
447 pterjan 5340 DRI drivers.
448    
449 blino 271501 %description -n %{libdricorename}-devel
450 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
451 blino 271501
452     This package contains the headers needed to compile DRI drivers.
453    
454 pterjan 5340 %description -n %{libglname}-devel
455 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
456 pterjan 5340
457     This package contains the headers needed to compile Mesa programs.
458    
459 tv 88442 %description -n %{libglesv1name}
460     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
461     well-defined subset profiles of OpenGL.
462    
463     This package provides the OpenGL ES library version 1.
464    
465 anssi 278008 %description -n %{libosmesaname}
466     Mesa offscreen rendering libraries for rendering OpenGL into
467     application-allocated blocks of memory.
468    
469     %description -n %{osmesadevel}
470     This package contains the headers needed to compile programs against
471     the Mesa offscreen rendering library.
472    
473 mikala 112356 %description -n %{libglapiname}
474     This packages provides the glapi shared library used by gallium.
475    
476     %description -n %{libglapiname}-devel
477     This package contains the headers needed to compile programes against glapi shared library.
478    
479 tv 88442 %description -n %{libglesv1name}-devel
480     This package contains the headers needed to compile OpenGL ES 1 programs.
481    
482     %description -n %{libglesv2name}
483     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
484     well-defined subset profiles of OpenGL.
485    
486     This package provides the OpenGL ES library version 2.
487    
488     %description -n %{libglesv2name}-devel
489     This package contains the headers needed to compile OpenGL ES 2 programs.
490    
491 tv 88445 %description -n %{libopenvgname}
492     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
493     acceleration interface for vector graphics libraries such as Flash and SVG.
494    
495     %description -n %{libopenvgname}-devel
496     Development files for OpenVG library.
497    
498 blino 215979 %if %{enable_wayland}
499     %description -n %{libgbmname}
500 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
501 blino 215979 GBM (Graphics Buffer Manager) parts.
502    
503     %description -n %{libgbmname}-devel
504 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
505 blino 215979 GBM (Graphics Buffer Manager) development parts.
506    
507     %description -n %{libwaylandeglname}
508 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
509 blino 215979 Wayland EGL platform parts.
510    
511     %description -n %{libwaylandeglname}-devel
512 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
513 blino 215979 Wayland EGL platform development parts.
514     %endif
515    
516 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
517 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
518     with the nouveau driver.
519    
520 tv 301233 %description -n %{_lib}vdpau-driver-r300
521 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
522     with the r300 driver.
523    
524 tv 301233 %description -n %{_lib}vdpau-driver-r600
525 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
526     with the r600 driver.
527    
528 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
529 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
530     with the radeonsi driver.
531    
532 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
533 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
534     with the softpipe driver.
535    
536 tv 88440 #------------------------------------------------------------------------------
537    
538 pterjan 5340 %prep
539     %if %{git}
540 blino 289278 %setup -q -n mesa-%{git_branch}-%{git}
541 pterjan 5340 %else
542 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
543 pterjan 5340 %endif
544    
545 blino 278731 %apply_patches
546 blino 289353 autoreconf -vfi
547 pterjan 5340
548     %build
549 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
550     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
551     export LDFLAGS="-L%{_libdir}/llvm"
552    
553     %configure2_5x --enable-dri \
554     --enable-glx \
555 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
556     --with-dri-drivers="%{dri_drivers}" \
557 anssi 165988 --enable-shared-dricore \
558 pterjan 5340 %if %{enable_egl}
559     --enable-egl \
560     %else
561     --disable-egl \
562     %endif
563 blino 215979 %if %{enable_wayland}
564     --with-egl-platforms=x11,wayland,drm \
565     --enable-gbm \
566     --enable-shared-glapi \
567     %endif
568 tv 88442 --enable-gles1 \
569     --enable-gles2 \
570 tv 88445 --enable-openvg \
571 mikala 112356 --enable-gallium-egl \
572 blino 270761 --enable-gallium-g3dvl \
573 anssi 278008 --enable-osmesa \
574 blino 270761 --disable-xvmc \
575     --enable-vdpau \
576     --disable-va \
577 mikala 112356 %if %{with_hardware}
578 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
579 mikala 112356 --enable-gallium-llvm \
580     %else
581     --disable-gallium-llvm \
582     --with-gallium-drivers=swrast \
583     %endif
584 tv 135155 %if %{build_plf}
585     --enable-texture-float \
586     %endif
587 blino 270723 # end of configure options
588 pterjan 5340
589 anssi 165988 %make
590 pterjan 5340
591     %install
592 tv 88249 %makeinstall_std
593 pterjan 5340
594 blino 216556 # FIXME: strip will likely break the hardlink
595 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
596     # to prevent proprietary driver installers from removing them
597     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
598     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
599     for l in ../libGL.so.*; do cp -a $l .; done
600     popd
601    
602     %ifarch %{x86_64}
603     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
604     %endif
605    
606 blino 270761 # .so files are not needed by vdpau
607     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
608    
609 blino 271144 # .la files are not needed by mesa
610     find %{buildroot} -name '*.la' -exec rm {} \;
611    
612 anssi 181478 # use swrastg if built (Anssi 12/2011)
613     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
614    
615 tv 88440 #------------------------------------------------------------------------------
616    
617 pterjan 5340 %files
618     %defattr(-,root,root)
619 blino 271481 %doc docs/COPYING
620 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
621 pterjan 5340
622 blino 271501 %files -n %{libdricorename}
623     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
624     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
625    
626     %files -n %{libdricorename}-devel
627     %{_libdir}/libdricore%{version}.so
628    
629 pterjan 5340 %files -n %{dridrivers}
630     %defattr(-,root,root)
631     %doc docs/COPYING
632     %ifnarch ppc64
633     %dir %{_libdir}/dri
634 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
635     #%{_libdir}/dri/libglsl.so
636 pterjan 5340 %{_libdir}/dri/*_dri.so
637     %endif
638    
639 tv 88433 %files -n %{libglname}
640     %defattr(-,root,root)
641     %doc docs/COPYING
642     %{_libdir}/libGL.so.*
643     %dir %{_libdir}/mesa
644 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
645 tv 88433
646     %if %{enable_egl}
647     %files -n %{libeglname}
648     %defattr(-,root,root)
649 tv 88442 %doc docs/COPYING
650 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
651 tv 88442 %dir %{_libdir}/egl
652 blino 215979 %if !%{enable_wayland}
653     # st_GL, built only when shared glapi is not enabled
654 mikala 112356 %{_libdir}/egl/st_GL.so
655 blino 215979 %endif
656 mikala 127466 %{_libdir}/egl/egl_gallium.so
657 tv 88441 %endif
658 tv 88433
659 anssi 278008 %files -n %{libosmesaname}
660     %defattr(-,root,root)
661     %{_libdir}/libOSMesa.so.%{osmesamajor}*
662    
663 mikala 112356 %files -n %{libglapiname}
664     %defattr(-,root,root)
665     %{_libdir}/libglapi.so.%{glapimajor}*
666    
667 tv 88442 %files -n %{libglesv1name}
668     %defattr(-,root,root)
669     %doc docs/COPYING
670     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
671    
672     %files -n %{libglesv2name}
673     %defattr(-,root,root)
674     %doc docs/COPYING
675     %{_libdir}/libGLESv2.so.%{glesv2major}*
676    
677 tv 88445 %files -n %{libopenvgname}
678     %defattr(-,root,root)
679     %doc docs/COPYING
680     %{_libdir}/libOpenVG.so.%{openvgmajor}*
681    
682 blino 215979 %if %{enable_wayland}
683     %files -n %{libgbmname}
684     %{_libdir}/libgbm.so.%{gbmmajor}
685 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
686 blino 215979 %{_libdir}/gbm/gbm_*.so
687     %{_libdir}/gbm/pipe_*.so
688 tv 88445
689 blino 215979 %files -n %{libwaylandeglname}
690     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
691 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
692 blino 215979 %endif
693    
694    
695 pterjan 5340 %files -n %{libglname}-devel
696     %defattr(-,root,root)
697     %doc docs/COPYING
698 anssi 278008 %dir %{_includedir}/GL
699 pterjan 5340 %{_includedir}/GL/gl.h
700     %{_includedir}/GL/glext.h
701     %{_includedir}/GL/gl_mangle.h
702     %{_includedir}/GL/wglext.h
703     %{_includedir}/GL/glx.h
704     %{_includedir}/GL/glxext.h
705     %{_includedir}/GL/glx_mangle.h
706     %{_libdir}/libGL.so
707 tv 88436 %{_libdir}/pkgconfig/gl.pc
708     %{_libdir}/pkgconfig/dri.pc
709 pterjan 5340
710     #FIXME: check those headers
711     %{_includedir}/GL/vms_x_fix.h
712     %{_includedir}/GL/wmesa.h
713     %dir %{_includedir}/GL/internal
714     %{_includedir}/GL/internal/dri_interface.h
715    
716     %files common-devel
717     %defattr(-,root,root)
718    
719 tv 88441 %if %{enable_egl}
720 tv 88433 %files -n %{libeglname}-devel
721     %defattr(-,root,root)
722 tv 88442 %doc docs/COPYING
723     %{_includedir}/EGL
724     %{_includedir}/KHR
725 tv 88433 %{_libdir}/libEGL.so
726 tv 88436 %{_libdir}/pkgconfig/egl.pc
727 tv 88433 %endif
728 pterjan 5340
729 anssi 278008 %files -n %{osmesadevel}
730     %defattr(-,root,root)
731     %dir %{_includedir}/GL
732     %{_includedir}/GL/osmesa.h
733     %{_libdir}/libOSMesa.so
734     %{_libdir}/pkgconfig/osmesa.pc
735    
736 mikala 112356 %files -n %{libglapiname}-devel
737     %defattr(-,root,root)
738     %{_libdir}/libglapi.so
739 pterjan 5340
740 tv 88442 %files -n %{libglesv1name}-devel
741     %defattr(-,root,root)
742     %{_includedir}/GLES
743     %{_libdir}/libGLESv1_CM.so
744     %{_libdir}/pkgconfig/glesv1_cm.pc
745 tv 88433
746 tv 88442 %files -n %{libglesv2name}-devel
747     %defattr(-,root,root)
748     %{_includedir}/GLES2
749     %{_libdir}/libGLESv2.so
750     %{_libdir}/pkgconfig/glesv2.pc
751 tv 88445
752     %files -n %{libopenvgname}-devel
753     %defattr(-,root,root)
754     %{_includedir}/VG
755     %{_libdir}/libOpenVG.so
756     %{_libdir}/pkgconfig/vg.pc
757 blino 215979
758     %if %{enable_wayland}
759     %files -n %{libgbmname}-devel
760     %{_includedir}/gbm.h
761     %{_libdir}/libgbm.so
762     %{_libdir}/pkgconfig/gbm.pc
763    
764     %files -n %{libwaylandeglname}-devel
765     %{_libdir}/libwayland-egl.so
766     %{_libdir}/pkgconfig/wayland-egl.pc
767     %endif
768 blino 270761
769 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
770 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
771    
772 tv 301233 %files -n %{_lib}vdpau-driver-r300
773 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
774    
775 tv 301233 %files -n %{_lib}vdpau-driver-r600
776 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
777    
778 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
779 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
780    
781 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
782 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30