/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 336175 - (hide annotations) (download)
Sat Dec 29 18:58:23 2012 UTC (11 years, 3 months ago) by cjw
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23033 byte(s)
- 9.1 snapsnot from 20121228
- disable separate osmesa build since it fails to build, let's hope it is not needed anymore
- move autoreconf to build section where it belongs
- drop unrecognized configure options --enable-shared-dricore and --disable-va

1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 cjw 336175 %define git 20121228
19     %define git_branch 9.1
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 cjw 336175 %define fversion 9.1.0
27     %define version 9.1.0
28     %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 tv 88442
74 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
75 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
76     %define libglname %mklibname %{glname} %{glmajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libglwname_virt lib%{glwname}
95 tv 88442 %define libglesv1name_virt lib%{glesv1name}
96     %define libglesv2name_virt lib%{glesv2name}
97 tv 88445 %define libopenvgname_virt lib%{openvgname}
98 mikala 112356 %define libglapiname_virt lib%{glapiname}
99 blino 215979 %define libgbmname_virt lib%{gbmname}
100     %define libwaylandeglname_virt lib%{waylandeglname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131     BuildRequires: pkgconfig(xt) >= 1.0.5
132     BuildRequires: pkgconfig(xmu) >= 1.0.3
133     BuildRequires: pkgconfig(x11) >= 1.3.3
134     BuildRequires: pkgconfig(xdamage) >= 1.1.1
135 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
136     BuildRequires: gccmakedep
137     BuildRequires: x11-proto-devel >= 7.3
138 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
139 pterjan 5340
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 dmorgan 106004 BuildRequires: bison flex
147 cjw 336175 BuildRequires: llvm-devel > 3.2-1.mga3
148 mikala 127466 BuildRequires: pkgconfig(libudev)
149 blino 270761 BuildRequires: pkgconfig(vdpau)
150 blino 215979 %if %{enable_wayland}
151     BuildRequires: wayland-devel
152     %endif
153 pterjan 5340
154     URL: http://www.mesa3d.org
155     %if %{git}
156 cjw 336175 Source0: %{name}-%{git}.tar.bz2
157 blino 289278 # (blino) snapshot of 9.0 branch
158 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
159 pterjan 5340 %else
160 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
161 pterjan 5340 %endif
162     Source3: make-git-snapshot.sh
163    
164     # Instructions to setup your repository clone
165     # git://git.freedesktop.org/git/mesa/mesa
166     # git checkout mesa_7_5_branch
167     # git branch mdv-cherry-picks
168     # git am ../02??-*.patch
169     # git branch mdv-redhat
170     # git am ../03??-*.patch
171     # git branch mdv-patches
172     # git am ../09??-*.patch
173     # In order to update to the branch via patches, issue this command:
174     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
175    
176     # Cherry picks
177     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
178     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
179 blino 289280 # (blino) should be pushed to 9.0 branch upstream
180 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
181     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
182 pterjan 5340
183 tv 88247 # Patches "liberated" from Fedora:
184 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
185     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
186    
187 blino 278732 # Patches from ChromiumOS
188     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
189    
190 blino 271493 # Mageia/Mandriva patches
191 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
192 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
193 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
194 pterjan 5340
195 tv 88440 #------------------------------------------------------------------------------
196    
197     # package mesa
198 pterjan 5340 License: MIT
199     Requires: %{libglname} = %{version}-%{release}
200     Provides: hackMesa = %{version}
201     Obsoletes: hackMesa <= %{version}
202     Provides: Mesa = %{version}
203     Obsoletes: Mesa < %{version}
204    
205 blino 271501 %package -n %{libdricorename}
206     Summary: Shared library for DRI drivers
207     Group: System/Libraries
208     Provides: %{libdricorename_virt} = %{version}-%{release}
209    
210     %package -n %{libdricorename}-devel
211     Summary: Development files for DRI core
212     Group: Development/C
213     Requires: %{libdricorename} = %{version}-%{release}
214     Provides: lib%{dricorename}-devel = %{version}-%{release}
215     Provides: %{dricorename}-devel = %{version}-%{release}
216    
217 pterjan 5340 %package -n %{libglname}
218     Summary: Files for Mesa (GL and GLX libs)
219     Group: System/Libraries
220 tv 88247 Obsoletes: %{oldlibglname} < 6.4
221 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
222     Provides: %{libglname_virt} = %{version}-%{release}
223     Requires: %{dridrivers} >= %{version}-%{release}
224 tv 135172 %if %{build_plf}
225     Requires: %mklibname txc-dxtn
226     %endif
227 pterjan 5340
228     # (anssi) Forces the upgrade of x11-server-common to happen before
229     # alternatives removal, which allows x11-server-common to grab the symlink.
230     Conflicts: x11-server-common < 1.3.0.0-17
231    
232     %package -n %{dridrivers}
233     Summary: Mesa DRI drivers
234     Group: System/Libraries
235 blino 274132 # do not require exact release to avoid conflicts when having
236     # x86_64 dri drivers from tainted and i586 dri drivers from core
237     Requires: mesa = %{version}
238 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
239 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
240     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
241 pterjan 5340
242     %package -n %{libglname}-devel
243     Summary: Development files for Mesa (OpenGL compatible 3D lib)
244     Group: Development/C
245 tv 88237 Requires: %{libglname} = %{version}-%{release}
246 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
247     Provides: %{glname}-devel = %{version}-%{release}
248     Provides: GL-devel
249     Obsoletes: %{oldlibglname}-devel < 6.4
250     Provides: %{oldlibglname}-devel = %{version}-%{release}
251     Provides: libMesaGL-devel = %{version}-%{release}
252     Provides: MesaGL-devel = %{version}-%{release}
253 tv 88438 Provides: libgl-devel
254 pterjan 5340
255 tv 88433 %if %{enable_egl}
256     %package -n %{libeglname}
257     Summary: Files for Mesa (EGL libs)
258     Group: System/Libraries
259     Provides: %{libeglname_virt} = %{version}-%{release}
260    
261     %package -n %{libeglname}-devel
262     Summary: Development files for Mesa (EGL libs)
263     Group: Development/C
264 tv 88439 Requires: %{libeglname} = %{version}-%{release}
265 tv 88433 Provides: EGL-devel
266 tv 88438 Provides: lib%{eglname}-devel
267     Provides: %{eglname}-devel
268     Provides: libegl-devel
269 tv 88433 %endif
270    
271 anssi 278008 %package -n %{libosmesaname}
272     Summary: Mesa offscreen rendering library
273     Group: System/Libraries
274    
275     %package -n %{osmesadevel}
276     Summary: Development files for libosmesa
277     Group: Development/C
278     Requires: %{libosmesaname} = %{version}-%{release}
279     Provides: osmesa-devel = %{version}-%{release}
280     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
281    
282 mikala 112356 %package -n %{libglapiname}
283     Summary: Files for mesa (glapi libs)
284     Group: System/Libraries
285     Provides: %{libglapiname_virt} = %{version}-%{release}
286 tv 88442
287 mikala 112356 %package -n %{libglapiname}-devel
288     Summary: Development files for glapi libs
289     Group: Development/C
290     Requires: %{libglapiname_virt} = %{version}-%{release}
291     Provides: lib%{glapiname}-devel
292     Provides: %{libglapiname}-devel
293    
294 tv 88442 %package -n %{libglesv1name}
295     Summary: Files for Mesa (glesv1 libs)
296     Group: System/Libraries
297     Provides: %{libglesv1name_virt} = %{version}-%{release}
298    
299     %package -n %{libglesv1name}-devel
300     Summary: Development files for glesv1 libs
301     Group: Development/C
302     Requires: %{libglesv1name} = %{version}-%{release}
303     Provides: lib%{glesv1name}-devel
304     Provides: %{glesv1name}-devel
305     Provides: libglesv1-devel
306    
307     %package -n %{libglesv2name}
308     Summary: Files for Mesa (glesv2 libs)
309     Group: System/Libraries
310     Provides: %{libglesv2name_virt} = %{version}-%{release}
311    
312     %package -n %{libglesv2name}-devel
313     Summary: Development files for glesv2 libs
314     Group: Development/C
315     Requires: %{libglesv2name} = %{version}-%{release}
316 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
317 tv 88442 Provides: lib%{glesv2name}-devel
318     Provides: %{glesv2name}-devel
319     Provides: libglesv2-devel
320    
321 tv 88445 %package -n %{libopenvgname}
322     Summary: Files for MESA (OpenVG libs)
323     Group: System/Libraries
324     Provides: %{libopenvgname_virt} = %{version}-%{release}
325    
326     %package -n %{libopenvgname}-devel
327     Summary: Development files vor OpenVG libs
328     Group: Development/C
329     Requires: %{libopenvgname} = %{version}-%{release}
330     Provides: lib%{openvgname}-devel
331     Provides: %{openvgname}-devel
332     Provides: libopenvg-devel
333    
334 blino 215979 %if %{enable_wayland}
335     %package -n %{libgbmname}
336     Summary: Files for Mesa (gbm libs)
337     Group: System/Libraries
338     Provides: %{libgbmname_virt} = %{version}-%{release}
339    
340     %package -n %{libgbmname}-devel
341     Summary: Development files for Mesa (gbm libs)
342     Group: Development/C
343     Requires: %{libgbmname} = %{version}-%{release}
344     Provides: lib%{gbmname}-devel
345     Provides: %{gbmname}-devel
346    
347     %package -n %{libwaylandeglname}
348     Summary: Files for Mesa (Wayland EGL libs)
349     Group: System/Libraries
350     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
351    
352     %package -n %{libwaylandeglname}-devel
353     Summary: Development files for Mesa (Wayland EGL libs)
354     Group: Development/C
355     Requires: %{libwaylandeglname} = %{version}-%{release}
356     Provides: lib%{waylandeglname}-devel
357     Provides: %{waylandeglname}-devel
358     %endif
359    
360 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
361 blino 270761 Summary: VDPAU plugin for nouveau driver
362 blino 300616 Group: System/Libraries
363 tv 302568 # temporary:
364     %rename vdpau-driver-nouveau
365 blino 270761
366 tv 301233 %package -n %{_lib}vdpau-driver-r300
367 blino 270761 Summary: VDPAU plugin for r300 driver
368 blino 300616 Group: System/Libraries
369 tv 302568 # temporary:
370     %rename vdpau-driver-r300
371 blino 270761
372 tv 301233 %package -n %{_lib}vdpau-driver-r600
373 blino 270761 Summary: VDPAU plugin for r600 driver
374 blino 300616 Group: System/Libraries
375 tv 302568 # temporary:
376     %rename vdpau-driver-r600
377 blino 270761
378 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
379 blino 289282 Summary: VDPAU plugin for radeonsi driver
380     Group: System/Libraries
381 tv 302568 # temporary:
382     %rename vdpau-driver-radeonsi
383 blino 289282
384 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
385 blino 270761 Summary: VDPAU plugin for softpipe driver
386 blino 300616 Group: System/Libraries
387 tv 302568 # temporary:
388     %rename vdpau-driver-softpipe
389 blino 270761
390 pterjan 5340 %package common-devel
391     Summary: Meta package for mesa devel
392     Group: Development/C
393 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
394 pterjan 5340 Provides: hackMesa-common-devel = %{version}
395 tv 88247 Obsoletes: Mesa-common-devel < %{version}
396 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
397     Requires: %{libglname}-devel = %{version}
398 blino 289355 Requires: mesaglu-devel
399 tv 135156 Requires: freeglut-devel
400 tv 88442 Requires: %{libeglname}-devel = %{version}
401     Requires: %{libglesv1name}-devel = %{version}
402     Requires: %{libglesv2name}-devel = %{version}
403 pterjan 5340
404 tv 88440 #------------------------------------------------------------------------------
405 pterjan 5340
406     %description
407 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
408 tv 135173 %if %{build_plf}
409 pterjan 5340
410 tv 135173 This package is in the "tainted" section because it enables some
411     OpenGL extentions that are covered by software patents.
412     %endif
413    
414 pterjan 5340 %description common-devel
415     Mesa common metapackage devel
416    
417     %if %{enable_egl}
418     %description -n %{libeglname}
419 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 pterjan 5340 EGL parts.
421    
422     %description -n %{libeglname}-devel
423 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 pterjan 5340 EGL development parts.
425     %endif
426    
427 blino 271501 %description -n %{libdricorename}
428 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
429 blino 271501 DRI core part.
430    
431 pterjan 5340 %description -n %{libglname}
432 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
433 pterjan 5340 GL and GLX parts.
434    
435 tv 135155 %if %{build_plf}
436     This package is in the "tainted" section because it enables some
437     OpenGL extentions that are covered by software patents.
438     %endif
439    
440 pterjan 5340 %description -n %{dridrivers}
441 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
442 pterjan 5340 DRI drivers.
443    
444 blino 271501 %description -n %{libdricorename}-devel
445 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
446 blino 271501
447     This package contains the headers needed to compile DRI drivers.
448    
449 pterjan 5340 %description -n %{libglname}-devel
450 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
451 pterjan 5340
452     This package contains the headers needed to compile Mesa programs.
453    
454 tv 88442 %description -n %{libglesv1name}
455     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
456     well-defined subset profiles of OpenGL.
457    
458     This package provides the OpenGL ES library version 1.
459    
460 anssi 278008 %description -n %{libosmesaname}
461     Mesa offscreen rendering libraries for rendering OpenGL into
462     application-allocated blocks of memory.
463    
464     %description -n %{osmesadevel}
465     This package contains the headers needed to compile programs against
466     the Mesa offscreen rendering library.
467    
468 mikala 112356 %description -n %{libglapiname}
469     This packages provides the glapi shared library used by gallium.
470    
471     %description -n %{libglapiname}-devel
472     This package contains the headers needed to compile programes against glapi shared library.
473    
474 tv 88442 %description -n %{libglesv1name}-devel
475     This package contains the headers needed to compile OpenGL ES 1 programs.
476    
477     %description -n %{libglesv2name}
478     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
479     well-defined subset profiles of OpenGL.
480    
481     This package provides the OpenGL ES library version 2.
482    
483     %description -n %{libglesv2name}-devel
484     This package contains the headers needed to compile OpenGL ES 2 programs.
485    
486 tv 88445 %description -n %{libopenvgname}
487     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
488     acceleration interface for vector graphics libraries such as Flash and SVG.
489    
490     %description -n %{libopenvgname}-devel
491     Development files for OpenVG library.
492    
493 blino 215979 %if %{enable_wayland}
494     %description -n %{libgbmname}
495 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
496 blino 215979 GBM (Graphics Buffer Manager) parts.
497    
498     %description -n %{libgbmname}-devel
499 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
500 blino 215979 GBM (Graphics Buffer Manager) development parts.
501    
502     %description -n %{libwaylandeglname}
503 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
504 blino 215979 Wayland EGL platform parts.
505    
506     %description -n %{libwaylandeglname}-devel
507 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
508 blino 215979 Wayland EGL platform development parts.
509     %endif
510    
511 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
512 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
513     with the nouveau driver.
514    
515 tv 301233 %description -n %{_lib}vdpau-driver-r300
516 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
517     with the r300 driver.
518    
519 tv 301233 %description -n %{_lib}vdpau-driver-r600
520 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
521     with the r600 driver.
522    
523 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
524 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
525     with the radeonsi driver.
526    
527 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
528 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
529     with the softpipe driver.
530    
531 tv 88440 #------------------------------------------------------------------------------
532    
533 pterjan 5340 %prep
534     %if %{git}
535 cjw 336175 %setup -q -n mesa-%{git}
536     #setup -q -n mesa-%{git_branch}-%{git}
537 pterjan 5340 %else
538 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
539 pterjan 5340 %endif
540    
541 blino 278731 %apply_patches
542 pterjan 5340
543 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
544     # would break build. - Anssi 12/2012
545 cjw 336175 #all=$(ls)
546     #mkdir -p build-osmesa
547     #cp -a $all build-osmesa
548 anssi 332631
549 pterjan 5340 %build
550 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
551     autoreconf -vfi
552    
553 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
554     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
555     export LDFLAGS="-L%{_libdir}/llvm"
556    
557     %configure2_5x --enable-dri \
558     --enable-glx \
559 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
560     --with-dri-drivers="%{dri_drivers}" \
561     %if %{enable_egl}
562     --enable-egl \
563     %else
564     --disable-egl \
565     %endif
566 blino 215979 %if %{enable_wayland}
567     --with-egl-platforms=x11,wayland,drm \
568     --enable-gbm \
569     --enable-shared-glapi \
570     %endif
571 tv 88442 --enable-gles1 \
572     --enable-gles2 \
573 tv 88445 --enable-openvg \
574 mikala 112356 --enable-gallium-egl \
575 blino 270761 --enable-gallium-g3dvl \
576     --disable-xvmc \
577     --enable-vdpau \
578 cjw 336175 --enable-osmesa \
579 mikala 112356 %if %{with_hardware}
580 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
581 mikala 112356 --enable-gallium-llvm \
582     %else
583     --disable-gallium-llvm \
584     --with-gallium-drivers=swrast \
585     %endif
586 tv 135155 %if %{build_plf}
587     --enable-texture-float \
588     %endif
589 blino 270723 # end of configure options
590 pterjan 5340
591 anssi 332631
592     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
593     # since doing that causes OSMesa to miss the OpenGL symbols.
594     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
595     # -Anssi 12/2012
596    
597 cjw 336175 #pushd build-osmesa
598     #configure2_5x \
599     # --enable-osmesa \
600     # --disable-dri \
601     # --disable-glx \
602     # --disable-egl \
603     # --disable-shared-glapi \
604     # --without-gallium-drivers
605     #popd
606 anssi 332631
607 anssi 165988 %make
608 cjw 336175 #make -C build-osmesa
609 pterjan 5340
610     %install
611 cjw 336175 #makeinstall_std -C build-osmesa
612 tv 88249 %makeinstall_std
613 pterjan 5340
614 blino 216556 # FIXME: strip will likely break the hardlink
615 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
616     # to prevent proprietary driver installers from removing them
617     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
618     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
619     for l in ../libGL.so.*; do cp -a $l .; done
620     popd
621    
622     %ifarch %{x86_64}
623     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
624     %endif
625    
626 blino 270761 # .so files are not needed by vdpau
627     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
628    
629 blino 271144 # .la files are not needed by mesa
630     find %{buildroot} -name '*.la' -exec rm {} \;
631    
632 anssi 181478 # use swrastg if built (Anssi 12/2011)
633     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
634    
635 tv 88440 #------------------------------------------------------------------------------
636    
637 pterjan 5340 %files
638     %defattr(-,root,root)
639 blino 271481 %doc docs/COPYING
640 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
641 pterjan 5340
642 blino 271501 %files -n %{libdricorename}
643     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
644     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
645    
646     %files -n %{libdricorename}-devel
647     %{_libdir}/libdricore%{version}.so
648    
649 pterjan 5340 %files -n %{dridrivers}
650     %defattr(-,root,root)
651     %doc docs/COPYING
652     %ifnarch ppc64
653     %dir %{_libdir}/dri
654 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
655     #%{_libdir}/dri/libglsl.so
656 pterjan 5340 %{_libdir}/dri/*_dri.so
657     %endif
658    
659 tv 88433 %files -n %{libglname}
660     %defattr(-,root,root)
661     %doc docs/COPYING
662     %{_libdir}/libGL.so.*
663     %dir %{_libdir}/mesa
664 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
665 tv 88433
666     %if %{enable_egl}
667     %files -n %{libeglname}
668     %defattr(-,root,root)
669 tv 88442 %doc docs/COPYING
670 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
671 tv 88442 %dir %{_libdir}/egl
672 blino 215979 %if !%{enable_wayland}
673     # st_GL, built only when shared glapi is not enabled
674 mikala 112356 %{_libdir}/egl/st_GL.so
675 blino 215979 %endif
676 mikala 127466 %{_libdir}/egl/egl_gallium.so
677 tv 88441 %endif
678 tv 88433
679 anssi 278008 %files -n %{libosmesaname}
680     %defattr(-,root,root)
681     %{_libdir}/libOSMesa.so.%{osmesamajor}*
682    
683 mikala 112356 %files -n %{libglapiname}
684     %defattr(-,root,root)
685     %{_libdir}/libglapi.so.%{glapimajor}*
686    
687 tv 88442 %files -n %{libglesv1name}
688     %defattr(-,root,root)
689     %doc docs/COPYING
690     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
691    
692     %files -n %{libglesv2name}
693     %defattr(-,root,root)
694     %doc docs/COPYING
695     %{_libdir}/libGLESv2.so.%{glesv2major}*
696    
697 tv 88445 %files -n %{libopenvgname}
698     %defattr(-,root,root)
699     %doc docs/COPYING
700     %{_libdir}/libOpenVG.so.%{openvgmajor}*
701    
702 blino 215979 %if %{enable_wayland}
703     %files -n %{libgbmname}
704     %{_libdir}/libgbm.so.%{gbmmajor}
705 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
706 blino 215979 %{_libdir}/gbm/gbm_*.so
707     %{_libdir}/gbm/pipe_*.so
708 tv 88445
709 blino 215979 %files -n %{libwaylandeglname}
710     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
711 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
712 blino 215979 %endif
713    
714    
715 pterjan 5340 %files -n %{libglname}-devel
716     %defattr(-,root,root)
717     %doc docs/COPYING
718 anssi 278008 %dir %{_includedir}/GL
719 pterjan 5340 %{_includedir}/GL/gl.h
720     %{_includedir}/GL/glext.h
721     %{_includedir}/GL/gl_mangle.h
722     %{_includedir}/GL/wglext.h
723     %{_includedir}/GL/glx.h
724     %{_includedir}/GL/glxext.h
725     %{_includedir}/GL/glx_mangle.h
726     %{_libdir}/libGL.so
727 tv 88436 %{_libdir}/pkgconfig/gl.pc
728     %{_libdir}/pkgconfig/dri.pc
729 pterjan 5340
730     #FIXME: check those headers
731 cjw 336175 #{_includedir}/GL/vms_x_fix.h
732 pterjan 5340 %{_includedir}/GL/wmesa.h
733     %dir %{_includedir}/GL/internal
734     %{_includedir}/GL/internal/dri_interface.h
735    
736     %files common-devel
737     %defattr(-,root,root)
738    
739 tv 88441 %if %{enable_egl}
740 tv 88433 %files -n %{libeglname}-devel
741     %defattr(-,root,root)
742 tv 88442 %doc docs/COPYING
743     %{_includedir}/EGL
744     %{_includedir}/KHR
745 tv 88433 %{_libdir}/libEGL.so
746 tv 88436 %{_libdir}/pkgconfig/egl.pc
747 tv 88433 %endif
748 pterjan 5340
749 anssi 278008 %files -n %{osmesadevel}
750     %defattr(-,root,root)
751     %dir %{_includedir}/GL
752     %{_includedir}/GL/osmesa.h
753     %{_libdir}/libOSMesa.so
754     %{_libdir}/pkgconfig/osmesa.pc
755    
756 mikala 112356 %files -n %{libglapiname}-devel
757     %defattr(-,root,root)
758     %{_libdir}/libglapi.so
759 pterjan 5340
760 tv 88442 %files -n %{libglesv1name}-devel
761     %defattr(-,root,root)
762     %{_includedir}/GLES
763     %{_libdir}/libGLESv1_CM.so
764     %{_libdir}/pkgconfig/glesv1_cm.pc
765 tv 88433
766 tv 88442 %files -n %{libglesv2name}-devel
767     %defattr(-,root,root)
768     %{_includedir}/GLES2
769 cjw 336175 %{_includedir}/GLES3
770 tv 88442 %{_libdir}/libGLESv2.so
771     %{_libdir}/pkgconfig/glesv2.pc
772 tv 88445
773     %files -n %{libopenvgname}-devel
774     %defattr(-,root,root)
775     %{_includedir}/VG
776     %{_libdir}/libOpenVG.so
777     %{_libdir}/pkgconfig/vg.pc
778 blino 215979
779     %if %{enable_wayland}
780     %files -n %{libgbmname}-devel
781     %{_includedir}/gbm.h
782     %{_libdir}/libgbm.so
783     %{_libdir}/pkgconfig/gbm.pc
784    
785     %files -n %{libwaylandeglname}-devel
786     %{_libdir}/libwayland-egl.so
787     %{_libdir}/pkgconfig/wayland-egl.pc
788     %endif
789 blino 270761
790 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
791 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
792    
793 tv 301233 %files -n %{_lib}vdpau-driver-r300
794 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
795    
796 tv 301233 %files -n %{_lib}vdpau-driver-r600
797 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
798    
799 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
800 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
801    
802 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
803 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30