/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 404139 - (hide annotations) (download)
Wed Mar 20 10:15:58 2013 UTC (11 years ago) by fwang
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23565 byte(s)
update llvmradeonmajor
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 cjw 336175 %define git_branch 9.1
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 404126 %define fversion 9.1.1
27     %define version 9.1.1
28 cjw 388874 %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 fwang 404139 %define llvmradeonmajor %{version}
74 tv 88442
75 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
76 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
77     %define libglname %mklibname %{glname} %{glmajor}
78     %define libglwname %mklibname %{glwname} %{glwmajor}
79 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
80     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
81 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
82 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
83 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
84     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
85 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
86 cjw 388874 %define libllvmradeonname %mklibname llvmradeon %{llvmradeonmajor}
87 pterjan 5340
88     %define dridrivers %mklibname dri-drivers
89    
90 anssi 278008 %define osmesadevel %mklibname osmesa -d
91    
92 pterjan 5340 # Architecture-independent Virtual provides:
93 blino 271501 %define libdricorename_virt lib%{dricorename}
94 pterjan 5340 %define libeglname_virt lib%{eglname}
95     %define libglname_virt lib%{glname}
96     %define libglwname_virt lib%{glwname}
97 tv 88442 %define libglesv1name_virt lib%{glesv1name}
98     %define libglesv2name_virt lib%{glesv2name}
99 tv 88445 %define libopenvgname_virt lib%{openvgname}
100 mikala 112356 %define libglapiname_virt lib%{glapiname}
101 blino 215979 %define libgbmname_virt lib%{gbmname}
102     %define libwaylandeglname_virt lib%{waylandeglname}
103 pterjan 5340
104     %define oldlibglname %mklibname MesaGL 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
130 pterjan 5340 Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 cjw 336175 BuildRequires: llvm-devel > 3.2-1.mga3
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 cjw 336175 Source0: %{name}-%{git}.tar.bz2
159 blino 289278 # (blino) snapshot of 9.0 branch
160 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
161 pterjan 5340 %else
162 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
163 pterjan 5340 %endif
164     Source3: make-git-snapshot.sh
165    
166     # Instructions to setup your repository clone
167     # git://git.freedesktop.org/git/mesa/mesa
168     # git checkout mesa_7_5_branch
169     # git branch mdv-cherry-picks
170     # git am ../02??-*.patch
171     # git branch mdv-redhat
172     # git am ../03??-*.patch
173     # git branch mdv-patches
174     # git am ../09??-*.patch
175     # In order to update to the branch via patches, issue this command:
176     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
177    
178     # Cherry picks
179     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
180     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
181 blino 289280 # (blino) should be pushed to 9.0 branch upstream
182 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
183     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
184 pterjan 5340
185 tv 88247 # Patches "liberated" from Fedora:
186 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
187     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
188    
189 blino 278732 # Patches from ChromiumOS
190     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191    
192 blino 271493 # Mageia/Mandriva patches
193 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
195 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
196 pterjan 5340
197 tv 88440 #------------------------------------------------------------------------------
198    
199     # package mesa
200 pterjan 5340 License: MIT
201     Requires: %{libglname} = %{version}-%{release}
202     Provides: hackMesa = %{version}
203     Obsoletes: hackMesa <= %{version}
204     Provides: Mesa = %{version}
205     Obsoletes: Mesa < %{version}
206    
207 blino 271501 %package -n %{libdricorename}
208     Summary: Shared library for DRI drivers
209     Group: System/Libraries
210     Provides: %{libdricorename_virt} = %{version}-%{release}
211    
212     %package -n %{libdricorename}-devel
213     Summary: Development files for DRI core
214     Group: Development/C
215     Requires: %{libdricorename} = %{version}-%{release}
216     Provides: lib%{dricorename}-devel = %{version}-%{release}
217     Provides: %{dricorename}-devel = %{version}-%{release}
218    
219 pterjan 5340 %package -n %{libglname}
220     Summary: Files for Mesa (GL and GLX libs)
221     Group: System/Libraries
222 tv 88247 Obsoletes: %{oldlibglname} < 6.4
223 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
224     Provides: %{libglname_virt} = %{version}-%{release}
225     Requires: %{dridrivers} >= %{version}-%{release}
226 tv 135172 %if %{build_plf}
227     Requires: %mklibname txc-dxtn
228     %endif
229 pterjan 5340
230     # (anssi) Forces the upgrade of x11-server-common to happen before
231     # alternatives removal, which allows x11-server-common to grab the symlink.
232     Conflicts: x11-server-common < 1.3.0.0-17
233    
234     %package -n %{dridrivers}
235     Summary: Mesa DRI drivers
236     Group: System/Libraries
237 blino 274132 # do not require exact release to avoid conflicts when having
238     # x86_64 dri drivers from tainted and i586 dri drivers from core
239     Requires: mesa = %{version}
240 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
241 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
242     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
243 pterjan 5340
244     %package -n %{libglname}-devel
245     Summary: Development files for Mesa (OpenGL compatible 3D lib)
246     Group: Development/C
247 tv 88237 Requires: %{libglname} = %{version}-%{release}
248 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
249     Provides: %{glname}-devel = %{version}-%{release}
250     Provides: GL-devel
251     Obsoletes: %{oldlibglname}-devel < 6.4
252     Provides: %{oldlibglname}-devel = %{version}-%{release}
253     Provides: libMesaGL-devel = %{version}-%{release}
254     Provides: MesaGL-devel = %{version}-%{release}
255 tv 88438 Provides: libgl-devel
256 pterjan 5340
257 tv 88433 %if %{enable_egl}
258     %package -n %{libeglname}
259     Summary: Files for Mesa (EGL libs)
260     Group: System/Libraries
261     Provides: %{libeglname_virt} = %{version}-%{release}
262    
263     %package -n %{libeglname}-devel
264     Summary: Development files for Mesa (EGL libs)
265     Group: Development/C
266 tv 88439 Requires: %{libeglname} = %{version}-%{release}
267 tv 88433 Provides: EGL-devel
268 tv 88438 Provides: lib%{eglname}-devel
269     Provides: %{eglname}-devel
270     Provides: libegl-devel
271 tv 88433 %endif
272    
273 anssi 278008 %package -n %{libosmesaname}
274     Summary: Mesa offscreen rendering library
275     Group: System/Libraries
276    
277     %package -n %{osmesadevel}
278     Summary: Development files for libosmesa
279     Group: Development/C
280     Requires: %{libosmesaname} = %{version}-%{release}
281     Provides: osmesa-devel = %{version}-%{release}
282     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
283    
284 mikala 112356 %package -n %{libglapiname}
285     Summary: Files for mesa (glapi libs)
286     Group: System/Libraries
287     Provides: %{libglapiname_virt} = %{version}-%{release}
288 tv 88442
289 mikala 112356 %package -n %{libglapiname}-devel
290     Summary: Development files for glapi libs
291     Group: Development/C
292     Requires: %{libglapiname_virt} = %{version}-%{release}
293     Provides: lib%{glapiname}-devel
294     Provides: %{libglapiname}-devel
295    
296 tv 88442 %package -n %{libglesv1name}
297     Summary: Files for Mesa (glesv1 libs)
298     Group: System/Libraries
299     Provides: %{libglesv1name_virt} = %{version}-%{release}
300    
301     %package -n %{libglesv1name}-devel
302     Summary: Development files for glesv1 libs
303     Group: Development/C
304     Requires: %{libglesv1name} = %{version}-%{release}
305     Provides: lib%{glesv1name}-devel
306     Provides: %{glesv1name}-devel
307     Provides: libglesv1-devel
308    
309     %package -n %{libglesv2name}
310     Summary: Files for Mesa (glesv2 libs)
311     Group: System/Libraries
312     Provides: %{libglesv2name_virt} = %{version}-%{release}
313    
314     %package -n %{libglesv2name}-devel
315     Summary: Development files for glesv2 libs
316     Group: Development/C
317     Requires: %{libglesv2name} = %{version}-%{release}
318 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
319 tv 88442 Provides: lib%{glesv2name}-devel
320     Provides: %{glesv2name}-devel
321     Provides: libglesv2-devel
322    
323 tv 88445 %package -n %{libopenvgname}
324     Summary: Files for MESA (OpenVG libs)
325     Group: System/Libraries
326     Provides: %{libopenvgname_virt} = %{version}-%{release}
327    
328     %package -n %{libopenvgname}-devel
329     Summary: Development files vor OpenVG libs
330     Group: Development/C
331     Requires: %{libopenvgname} = %{version}-%{release}
332     Provides: lib%{openvgname}-devel
333     Provides: %{openvgname}-devel
334     Provides: libopenvg-devel
335    
336 cjw 388874 %package -n %{libllvmradeonname}
337     Summary: Files for MESA (LLVM radeon library)
338     Group: System/Libraries
339    
340 blino 215979 %if %{enable_wayland}
341     %package -n %{libgbmname}
342     Summary: Files for Mesa (gbm libs)
343     Group: System/Libraries
344     Provides: %{libgbmname_virt} = %{version}-%{release}
345    
346     %package -n %{libgbmname}-devel
347     Summary: Development files for Mesa (gbm libs)
348     Group: Development/C
349     Requires: %{libgbmname} = %{version}-%{release}
350     Provides: lib%{gbmname}-devel
351     Provides: %{gbmname}-devel
352    
353     %package -n %{libwaylandeglname}
354     Summary: Files for Mesa (Wayland EGL libs)
355     Group: System/Libraries
356     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
357    
358     %package -n %{libwaylandeglname}-devel
359     Summary: Development files for Mesa (Wayland EGL libs)
360     Group: Development/C
361     Requires: %{libwaylandeglname} = %{version}-%{release}
362     Provides: lib%{waylandeglname}-devel
363     Provides: %{waylandeglname}-devel
364     %endif
365    
366 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
367 blino 270761 Summary: VDPAU plugin for nouveau driver
368 blino 300616 Group: System/Libraries
369 tv 302568 # temporary:
370     %rename vdpau-driver-nouveau
371 blino 270761
372 tv 301233 %package -n %{_lib}vdpau-driver-r300
373 blino 270761 Summary: VDPAU plugin for r300 driver
374 blino 300616 Group: System/Libraries
375 tv 302568 # temporary:
376     %rename vdpau-driver-r300
377 blino 270761
378 tv 301233 %package -n %{_lib}vdpau-driver-r600
379 blino 270761 Summary: VDPAU plugin for r600 driver
380 blino 300616 Group: System/Libraries
381 tv 302568 # temporary:
382     %rename vdpau-driver-r600
383 blino 270761
384 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
385 blino 289282 Summary: VDPAU plugin for radeonsi driver
386     Group: System/Libraries
387 tv 302568 # temporary:
388     %rename vdpau-driver-radeonsi
389 blino 289282
390 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
391 blino 270761 Summary: VDPAU plugin for softpipe driver
392 blino 300616 Group: System/Libraries
393 tv 302568 # temporary:
394     %rename vdpau-driver-softpipe
395 blino 270761
396 pterjan 5340 %package common-devel
397     Summary: Meta package for mesa devel
398     Group: Development/C
399 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
400 pterjan 5340 Provides: hackMesa-common-devel = %{version}
401 tv 88247 Obsoletes: Mesa-common-devel < %{version}
402 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
403     Requires: %{libglname}-devel = %{version}
404 blino 289355 Requires: mesaglu-devel
405 tv 135156 Requires: freeglut-devel
406 tv 88442 Requires: %{libeglname}-devel = %{version}
407     Requires: %{libglesv1name}-devel = %{version}
408     Requires: %{libglesv2name}-devel = %{version}
409 pterjan 5340
410 tv 88440 #------------------------------------------------------------------------------
411 pterjan 5340
412     %description
413 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
414 tv 135173 %if %{build_plf}
415 pterjan 5340
416 tv 135173 This package is in the "tainted" section because it enables some
417     OpenGL extentions that are covered by software patents.
418     %endif
419    
420 pterjan 5340 %description common-devel
421     Mesa common metapackage devel
422    
423     %if %{enable_egl}
424     %description -n %{libeglname}
425 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
426 pterjan 5340 EGL parts.
427    
428     %description -n %{libeglname}-devel
429 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
430 pterjan 5340 EGL development parts.
431     %endif
432    
433 blino 271501 %description -n %{libdricorename}
434 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
435 blino 271501 DRI core part.
436    
437 pterjan 5340 %description -n %{libglname}
438 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
439 pterjan 5340 GL and GLX parts.
440    
441 tv 135155 %if %{build_plf}
442     This package is in the "tainted" section because it enables some
443     OpenGL extentions that are covered by software patents.
444     %endif
445    
446 pterjan 5340 %description -n %{dridrivers}
447 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
448 pterjan 5340 DRI drivers.
449    
450 blino 271501 %description -n %{libdricorename}-devel
451 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
452 blino 271501
453     This package contains the headers needed to compile DRI drivers.
454    
455 pterjan 5340 %description -n %{libglname}-devel
456 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
457 pterjan 5340
458     This package contains the headers needed to compile Mesa programs.
459    
460 tv 88442 %description -n %{libglesv1name}
461     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
462     well-defined subset profiles of OpenGL.
463    
464     This package provides the OpenGL ES library version 1.
465    
466 anssi 278008 %description -n %{libosmesaname}
467     Mesa offscreen rendering libraries for rendering OpenGL into
468     application-allocated blocks of memory.
469    
470     %description -n %{osmesadevel}
471     This package contains the headers needed to compile programs against
472     the Mesa offscreen rendering library.
473    
474 mikala 112356 %description -n %{libglapiname}
475     This packages provides the glapi shared library used by gallium.
476    
477     %description -n %{libglapiname}-devel
478     This package contains the headers needed to compile programes against glapi shared library.
479    
480 tv 88442 %description -n %{libglesv1name}-devel
481     This package contains the headers needed to compile OpenGL ES 1 programs.
482    
483     %description -n %{libglesv2name}
484     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
485     well-defined subset profiles of OpenGL.
486    
487     This package provides the OpenGL ES library version 2.
488    
489     %description -n %{libglesv2name}-devel
490     This package contains the headers needed to compile OpenGL ES 2 programs.
491    
492 tv 88445 %description -n %{libopenvgname}
493     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
494     acceleration interface for vector graphics libraries such as Flash and SVG.
495    
496     %description -n %{libopenvgname}-devel
497     Development files for OpenVG library.
498    
499 cjw 388874 %description -n %{libllvmradeonname}
500     Gallium LLVM Radeon driver.
501    
502 blino 215979 %if %{enable_wayland}
503     %description -n %{libgbmname}
504 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
505 blino 215979 GBM (Graphics Buffer Manager) parts.
506    
507     %description -n %{libgbmname}-devel
508 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
509 blino 215979 GBM (Graphics Buffer Manager) development parts.
510    
511     %description -n %{libwaylandeglname}
512 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
513 blino 215979 Wayland EGL platform parts.
514    
515     %description -n %{libwaylandeglname}-devel
516 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
517 blino 215979 Wayland EGL platform development parts.
518     %endif
519    
520 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
521 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
522     with the nouveau driver.
523    
524 tv 301233 %description -n %{_lib}vdpau-driver-r300
525 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
526     with the r300 driver.
527    
528 tv 301233 %description -n %{_lib}vdpau-driver-r600
529 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
530     with the r600 driver.
531    
532 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
533 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
534     with the radeonsi driver.
535    
536 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
537 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
538     with the softpipe driver.
539    
540 tv 88440 #------------------------------------------------------------------------------
541    
542 pterjan 5340 %prep
543     %if %{git}
544 cjw 336175 %setup -q -n mesa-%{git}
545     #setup -q -n mesa-%{git_branch}-%{git}
546 pterjan 5340 %else
547 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
548 pterjan 5340 %endif
549    
550 blino 278731 %apply_patches
551 pterjan 5340
552 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
553     # would break build. - Anssi 12/2012
554 cjw 336233 all=$(ls)
555     mkdir -p build-osmesa
556     cp -al $all build-osmesa
557 anssi 332631
558 pterjan 5340 %build
559 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
560     autoreconf -vfi
561    
562 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
563     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
564     export LDFLAGS="-L%{_libdir}/llvm"
565    
566     %configure2_5x --enable-dri \
567     --enable-glx \
568 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
569     --with-dri-drivers="%{dri_drivers}" \
570     %if %{enable_egl}
571     --enable-egl \
572     %else
573     --disable-egl \
574     %endif
575 blino 215979 %if %{enable_wayland}
576     --with-egl-platforms=x11,wayland,drm \
577     --enable-gbm \
578     --enable-shared-glapi \
579     %endif
580 tv 88442 --enable-gles1 \
581     --enable-gles2 \
582 tv 88445 --enable-openvg \
583 mikala 112356 --enable-gallium-egl \
584 blino 270761 --enable-gallium-g3dvl \
585     --disable-xvmc \
586     --enable-vdpau \
587 mikala 112356 %if %{with_hardware}
588 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
589 mikala 112356 --enable-gallium-llvm \
590     %else
591     --disable-gallium-llvm \
592     --with-gallium-drivers=swrast \
593     %endif
594 tv 135155 %if %{build_plf}
595     --enable-texture-float \
596     %endif
597 blino 270723 # end of configure options
598 pterjan 5340
599 anssi 332631
600     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
601     # since doing that causes OSMesa to miss the OpenGL symbols.
602     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
603     # -Anssi 12/2012
604    
605 cjw 336233 pushd build-osmesa
606     autoreconf -vfi
607     %configure2_5x \
608     --enable-osmesa \
609     --disable-dri \
610     --disable-glx \
611     --disable-egl \
612     --disable-shared-glapi \
613     --without-gallium-drivers
614     popd
615 anssi 332631
616 anssi 165988 %make
617 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
618 pterjan 5340
619     %install
620 cjw 336233 %makeinstall_std -C build-osmesa
621 tv 88249 %makeinstall_std
622 pterjan 5340
623 blino 216556 # FIXME: strip will likely break the hardlink
624 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
625     # to prevent proprietary driver installers from removing them
626     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
627     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
628     for l in ../libGL.so.*; do cp -a $l .; done
629     popd
630    
631     %ifarch %{x86_64}
632     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
633     %endif
634    
635 blino 270761 # .so files are not needed by vdpau
636     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
637    
638 blino 271144 # .la files are not needed by mesa
639     find %{buildroot} -name '*.la' -exec rm {} \;
640    
641 anssi 181478 # use swrastg if built (Anssi 12/2011)
642     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
643    
644 tv 88440 #------------------------------------------------------------------------------
645    
646 pterjan 5340 %files
647     %defattr(-,root,root)
648 blino 271481 %doc docs/COPYING
649 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
650 pterjan 5340
651 blino 271501 %files -n %{libdricorename}
652     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
653     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
654    
655     %files -n %{libdricorename}-devel
656     %{_libdir}/libdricore%{version}.so
657    
658 pterjan 5340 %files -n %{dridrivers}
659     %defattr(-,root,root)
660     %doc docs/COPYING
661     %ifnarch ppc64
662     %dir %{_libdir}/dri
663 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
664     #%{_libdir}/dri/libglsl.so
665 pterjan 5340 %{_libdir}/dri/*_dri.so
666     %endif
667    
668 tv 88433 %files -n %{libglname}
669     %defattr(-,root,root)
670     %doc docs/COPYING
671     %{_libdir}/libGL.so.*
672     %dir %{_libdir}/mesa
673 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
674 tv 88433
675     %if %{enable_egl}
676     %files -n %{libeglname}
677     %defattr(-,root,root)
678 tv 88442 %doc docs/COPYING
679 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
680 tv 88442 %dir %{_libdir}/egl
681 blino 215979 %if !%{enable_wayland}
682     # st_GL, built only when shared glapi is not enabled
683 mikala 112356 %{_libdir}/egl/st_GL.so
684 blino 215979 %endif
685 mikala 127466 %{_libdir}/egl/egl_gallium.so
686 tv 88441 %endif
687 tv 88433
688 anssi 278008 %files -n %{libosmesaname}
689     %defattr(-,root,root)
690     %{_libdir}/libOSMesa.so.%{osmesamajor}*
691    
692 mikala 112356 %files -n %{libglapiname}
693     %defattr(-,root,root)
694     %{_libdir}/libglapi.so.%{glapimajor}*
695    
696 tv 88442 %files -n %{libglesv1name}
697     %defattr(-,root,root)
698     %doc docs/COPYING
699     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
700    
701     %files -n %{libglesv2name}
702     %defattr(-,root,root)
703     %doc docs/COPYING
704     %{_libdir}/libGLESv2.so.%{glesv2major}*
705    
706 tv 88445 %files -n %{libopenvgname}
707     %defattr(-,root,root)
708     %doc docs/COPYING
709     %{_libdir}/libOpenVG.so.%{openvgmajor}*
710    
711 cjw 388874 %files -n %{libllvmradeonname}
712     %defattr(-,root,root)
713     %{_libdir}/libllvmradeon9.1.0.so
714    
715 blino 215979 %if %{enable_wayland}
716     %files -n %{libgbmname}
717     %{_libdir}/libgbm.so.%{gbmmajor}
718 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
719 blino 215979 %{_libdir}/gbm/gbm_*.so
720 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
721 tv 88445
722 blino 215979 %files -n %{libwaylandeglname}
723     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
724 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
725 blino 215979 %endif
726    
727    
728 pterjan 5340 %files -n %{libglname}-devel
729     %defattr(-,root,root)
730     %doc docs/COPYING
731 anssi 278008 %dir %{_includedir}/GL
732 pterjan 5340 %{_includedir}/GL/gl.h
733     %{_includedir}/GL/glext.h
734     %{_includedir}/GL/gl_mangle.h
735     %{_includedir}/GL/wglext.h
736     %{_includedir}/GL/glx.h
737     %{_includedir}/GL/glxext.h
738     %{_includedir}/GL/glx_mangle.h
739     %{_libdir}/libGL.so
740 tv 88436 %{_libdir}/pkgconfig/gl.pc
741     %{_libdir}/pkgconfig/dri.pc
742 pterjan 5340
743     #FIXME: check those headers
744 cjw 336175 #{_includedir}/GL/vms_x_fix.h
745 pterjan 5340 %{_includedir}/GL/wmesa.h
746     %dir %{_includedir}/GL/internal
747     %{_includedir}/GL/internal/dri_interface.h
748    
749     %files common-devel
750     %defattr(-,root,root)
751    
752 tv 88441 %if %{enable_egl}
753 tv 88433 %files -n %{libeglname}-devel
754     %defattr(-,root,root)
755 tv 88442 %doc docs/COPYING
756     %{_includedir}/EGL
757     %{_includedir}/KHR
758 tv 88433 %{_libdir}/libEGL.so
759 tv 88436 %{_libdir}/pkgconfig/egl.pc
760 tv 88433 %endif
761 pterjan 5340
762 anssi 278008 %files -n %{osmesadevel}
763     %defattr(-,root,root)
764     %dir %{_includedir}/GL
765     %{_includedir}/GL/osmesa.h
766     %{_libdir}/libOSMesa.so
767     %{_libdir}/pkgconfig/osmesa.pc
768    
769 mikala 112356 %files -n %{libglapiname}-devel
770     %defattr(-,root,root)
771     %{_libdir}/libglapi.so
772 pterjan 5340
773 tv 88442 %files -n %{libglesv1name}-devel
774     %defattr(-,root,root)
775     %{_includedir}/GLES
776     %{_libdir}/libGLESv1_CM.so
777     %{_libdir}/pkgconfig/glesv1_cm.pc
778 tv 88433
779 tv 88442 %files -n %{libglesv2name}-devel
780     %defattr(-,root,root)
781     %{_includedir}/GLES2
782 cjw 336175 %{_includedir}/GLES3
783 tv 88442 %{_libdir}/libGLESv2.so
784     %{_libdir}/pkgconfig/glesv2.pc
785 tv 88445
786     %files -n %{libopenvgname}-devel
787     %defattr(-,root,root)
788     %{_includedir}/VG
789     %{_libdir}/libOpenVG.so
790     %{_libdir}/pkgconfig/vg.pc
791 blino 215979
792     %if %{enable_wayland}
793     %files -n %{libgbmname}-devel
794     %{_includedir}/gbm.h
795     %{_libdir}/libgbm.so
796     %{_libdir}/pkgconfig/gbm.pc
797    
798     %files -n %{libwaylandeglname}-devel
799     %{_libdir}/libwayland-egl.so
800     %{_libdir}/pkgconfig/wayland-egl.pc
801     %endif
802 blino 270761
803 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
804 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
805    
806 tv 301233 %files -n %{_lib}vdpau-driver-r300
807 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
808    
809 tv 301233 %files -n %{_lib}vdpau-driver-r600
810 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
811    
812 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
813 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
814    
815 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
816 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30