/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 411326 - (hide annotations) (download)
Fri Apr 26 23:05:37 2013 UTC (10 years, 11 months ago) by tmb
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23655 byte(s)
- radeonsi: add new SI pci ids
- r600g: add new richland pci ids


1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 cjw 336175 %define git_branch 9.1
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 404126 %define fversion 9.1.1
27     %define version 9.1.1
28 tmb 411326 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 fwang 404139 %define llvmradeonmajor %{version}
74 tv 88442
75 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
76 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
77     %define libglname %mklibname %{glname} %{glmajor}
78     %define libglwname %mklibname %{glwname} %{glwmajor}
79 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
80     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
81 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
82 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
83 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
84     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
85 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
86 cjw 388874 %define libllvmradeonname %mklibname llvmradeon %{llvmradeonmajor}
87 pterjan 5340
88     %define dridrivers %mklibname dri-drivers
89    
90 anssi 278008 %define osmesadevel %mklibname osmesa -d
91    
92 pterjan 5340 # Architecture-independent Virtual provides:
93 blino 271501 %define libdricorename_virt lib%{dricorename}
94 pterjan 5340 %define libeglname_virt lib%{eglname}
95     %define libglname_virt lib%{glname}
96     %define libglwname_virt lib%{glwname}
97 tv 88442 %define libglesv1name_virt lib%{glesv1name}
98     %define libglesv2name_virt lib%{glesv2name}
99 tv 88445 %define libopenvgname_virt lib%{openvgname}
100 mikala 112356 %define libglapiname_virt lib%{glapiname}
101 blino 215979 %define libgbmname_virt lib%{gbmname}
102     %define libwaylandeglname_virt lib%{waylandeglname}
103 pterjan 5340
104     %define oldlibglname %mklibname MesaGL 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
130 pterjan 5340 Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 tmb 411326 BuildRequires: llvm-devel > 3.2-1
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 cjw 336175 Source0: %{name}-%{git}.tar.bz2
159 blino 289278 # (blino) snapshot of 9.0 branch
160 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
161 pterjan 5340 %else
162 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
163 pterjan 5340 %endif
164     Source3: make-git-snapshot.sh
165    
166     # Instructions to setup your repository clone
167     # git://git.freedesktop.org/git/mesa/mesa
168     # git checkout mesa_7_5_branch
169     # git branch mdv-cherry-picks
170     # git am ../02??-*.patch
171     # git branch mdv-redhat
172     # git am ../03??-*.patch
173     # git branch mdv-patches
174     # git am ../09??-*.patch
175     # In order to update to the branch via patches, issue this command:
176     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
177    
178     # Cherry picks
179     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
180     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
181 tmb 411326 Patch202: radeonsi-add-new-SI-pci-ids.patch
182     Patch203: r600g-add-new-richland-pci-ids.patch
183    
184 blino 289280 # (blino) should be pushed to 9.0 branch upstream
185 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
186     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
187 pterjan 5340
188 tv 88247 # Patches "liberated" from Fedora:
189 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
190     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
191    
192 blino 278732 # Patches from ChromiumOS
193     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
194    
195 blino 271493 # Mageia/Mandriva patches
196 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
197 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
198 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
199 pterjan 5340
200 tv 88440 #------------------------------------------------------------------------------
201    
202     # package mesa
203 pterjan 5340 License: MIT
204     Requires: %{libglname} = %{version}-%{release}
205     Provides: hackMesa = %{version}
206     Obsoletes: hackMesa <= %{version}
207     Provides: Mesa = %{version}
208     Obsoletes: Mesa < %{version}
209    
210 blino 271501 %package -n %{libdricorename}
211     Summary: Shared library for DRI drivers
212     Group: System/Libraries
213     Provides: %{libdricorename_virt} = %{version}-%{release}
214    
215     %package -n %{libdricorename}-devel
216     Summary: Development files for DRI core
217     Group: Development/C
218     Requires: %{libdricorename} = %{version}-%{release}
219     Provides: lib%{dricorename}-devel = %{version}-%{release}
220     Provides: %{dricorename}-devel = %{version}-%{release}
221    
222 pterjan 5340 %package -n %{libglname}
223     Summary: Files for Mesa (GL and GLX libs)
224     Group: System/Libraries
225 tv 88247 Obsoletes: %{oldlibglname} < 6.4
226 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
227     Provides: %{libglname_virt} = %{version}-%{release}
228     Requires: %{dridrivers} >= %{version}-%{release}
229 tv 135172 %if %{build_plf}
230     Requires: %mklibname txc-dxtn
231     %endif
232 pterjan 5340
233     # (anssi) Forces the upgrade of x11-server-common to happen before
234     # alternatives removal, which allows x11-server-common to grab the symlink.
235     Conflicts: x11-server-common < 1.3.0.0-17
236    
237     %package -n %{dridrivers}
238     Summary: Mesa DRI drivers
239     Group: System/Libraries
240 blino 274132 # do not require exact release to avoid conflicts when having
241     # x86_64 dri drivers from tainted and i586 dri drivers from core
242     Requires: mesa = %{version}
243 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
244 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
245     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
246 pterjan 5340
247     %package -n %{libglname}-devel
248     Summary: Development files for Mesa (OpenGL compatible 3D lib)
249     Group: Development/C
250 tv 88237 Requires: %{libglname} = %{version}-%{release}
251 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
252     Provides: %{glname}-devel = %{version}-%{release}
253     Provides: GL-devel
254     Obsoletes: %{oldlibglname}-devel < 6.4
255     Provides: %{oldlibglname}-devel = %{version}-%{release}
256     Provides: libMesaGL-devel = %{version}-%{release}
257     Provides: MesaGL-devel = %{version}-%{release}
258 tv 88438 Provides: libgl-devel
259 pterjan 5340
260 tv 88433 %if %{enable_egl}
261     %package -n %{libeglname}
262     Summary: Files for Mesa (EGL libs)
263     Group: System/Libraries
264     Provides: %{libeglname_virt} = %{version}-%{release}
265    
266     %package -n %{libeglname}-devel
267     Summary: Development files for Mesa (EGL libs)
268     Group: Development/C
269 tv 88439 Requires: %{libeglname} = %{version}-%{release}
270 tv 88433 Provides: EGL-devel
271 tv 88438 Provides: lib%{eglname}-devel
272     Provides: %{eglname}-devel
273     Provides: libegl-devel
274 tv 88433 %endif
275    
276 anssi 278008 %package -n %{libosmesaname}
277     Summary: Mesa offscreen rendering library
278     Group: System/Libraries
279    
280     %package -n %{osmesadevel}
281     Summary: Development files for libosmesa
282     Group: Development/C
283     Requires: %{libosmesaname} = %{version}-%{release}
284     Provides: osmesa-devel = %{version}-%{release}
285     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
286    
287 mikala 112356 %package -n %{libglapiname}
288     Summary: Files for mesa (glapi libs)
289     Group: System/Libraries
290     Provides: %{libglapiname_virt} = %{version}-%{release}
291 tv 88442
292 mikala 112356 %package -n %{libglapiname}-devel
293     Summary: Development files for glapi libs
294     Group: Development/C
295     Requires: %{libglapiname_virt} = %{version}-%{release}
296     Provides: lib%{glapiname}-devel
297     Provides: %{libglapiname}-devel
298    
299 tv 88442 %package -n %{libglesv1name}
300     Summary: Files for Mesa (glesv1 libs)
301     Group: System/Libraries
302     Provides: %{libglesv1name_virt} = %{version}-%{release}
303    
304     %package -n %{libglesv1name}-devel
305     Summary: Development files for glesv1 libs
306     Group: Development/C
307     Requires: %{libglesv1name} = %{version}-%{release}
308     Provides: lib%{glesv1name}-devel
309     Provides: %{glesv1name}-devel
310     Provides: libglesv1-devel
311    
312     %package -n %{libglesv2name}
313     Summary: Files for Mesa (glesv2 libs)
314     Group: System/Libraries
315     Provides: %{libglesv2name_virt} = %{version}-%{release}
316    
317     %package -n %{libglesv2name}-devel
318     Summary: Development files for glesv2 libs
319     Group: Development/C
320     Requires: %{libglesv2name} = %{version}-%{release}
321 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
322 tv 88442 Provides: lib%{glesv2name}-devel
323     Provides: %{glesv2name}-devel
324     Provides: libglesv2-devel
325    
326 tv 88445 %package -n %{libopenvgname}
327     Summary: Files for MESA (OpenVG libs)
328     Group: System/Libraries
329     Provides: %{libopenvgname_virt} = %{version}-%{release}
330    
331     %package -n %{libopenvgname}-devel
332     Summary: Development files vor OpenVG libs
333     Group: Development/C
334     Requires: %{libopenvgname} = %{version}-%{release}
335     Provides: lib%{openvgname}-devel
336     Provides: %{openvgname}-devel
337     Provides: libopenvg-devel
338    
339 cjw 388874 %package -n %{libllvmradeonname}
340     Summary: Files for MESA (LLVM radeon library)
341     Group: System/Libraries
342    
343 blino 215979 %if %{enable_wayland}
344     %package -n %{libgbmname}
345     Summary: Files for Mesa (gbm libs)
346     Group: System/Libraries
347     Provides: %{libgbmname_virt} = %{version}-%{release}
348    
349     %package -n %{libgbmname}-devel
350     Summary: Development files for Mesa (gbm libs)
351     Group: Development/C
352     Requires: %{libgbmname} = %{version}-%{release}
353     Provides: lib%{gbmname}-devel
354     Provides: %{gbmname}-devel
355    
356     %package -n %{libwaylandeglname}
357     Summary: Files for Mesa (Wayland EGL libs)
358     Group: System/Libraries
359     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
360    
361     %package -n %{libwaylandeglname}-devel
362     Summary: Development files for Mesa (Wayland EGL libs)
363     Group: Development/C
364     Requires: %{libwaylandeglname} = %{version}-%{release}
365     Provides: lib%{waylandeglname}-devel
366     Provides: %{waylandeglname}-devel
367     %endif
368    
369 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
370 blino 270761 Summary: VDPAU plugin for nouveau driver
371 blino 300616 Group: System/Libraries
372 tv 302568 # temporary:
373     %rename vdpau-driver-nouveau
374 blino 270761
375 tv 301233 %package -n %{_lib}vdpau-driver-r300
376 blino 270761 Summary: VDPAU plugin for r300 driver
377 blino 300616 Group: System/Libraries
378 tv 302568 # temporary:
379     %rename vdpau-driver-r300
380 blino 270761
381 tv 301233 %package -n %{_lib}vdpau-driver-r600
382 blino 270761 Summary: VDPAU plugin for r600 driver
383 blino 300616 Group: System/Libraries
384 tv 302568 # temporary:
385     %rename vdpau-driver-r600
386 blino 270761
387 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
388 blino 289282 Summary: VDPAU plugin for radeonsi driver
389     Group: System/Libraries
390 tv 302568 # temporary:
391     %rename vdpau-driver-radeonsi
392 blino 289282
393 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
394 blino 270761 Summary: VDPAU plugin for softpipe driver
395 blino 300616 Group: System/Libraries
396 tv 302568 # temporary:
397     %rename vdpau-driver-softpipe
398 blino 270761
399 pterjan 5340 %package common-devel
400     Summary: Meta package for mesa devel
401     Group: Development/C
402 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
403 pterjan 5340 Provides: hackMesa-common-devel = %{version}
404 tv 88247 Obsoletes: Mesa-common-devel < %{version}
405 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
406     Requires: %{libglname}-devel = %{version}
407 blino 289355 Requires: mesaglu-devel
408 tv 135156 Requires: freeglut-devel
409 tv 88442 Requires: %{libeglname}-devel = %{version}
410     Requires: %{libglesv1name}-devel = %{version}
411     Requires: %{libglesv2name}-devel = %{version}
412 pterjan 5340
413 tv 88440 #------------------------------------------------------------------------------
414 pterjan 5340
415     %description
416 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
417 tv 135173 %if %{build_plf}
418 pterjan 5340
419 tv 135173 This package is in the "tainted" section because it enables some
420     OpenGL extentions that are covered by software patents.
421     %endif
422    
423 pterjan 5340 %description common-devel
424     Mesa common metapackage devel
425    
426     %if %{enable_egl}
427     %description -n %{libeglname}
428 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
429 pterjan 5340 EGL parts.
430    
431     %description -n %{libeglname}-devel
432 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
433 pterjan 5340 EGL development parts.
434     %endif
435    
436 blino 271501 %description -n %{libdricorename}
437 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
438 blino 271501 DRI core part.
439    
440 pterjan 5340 %description -n %{libglname}
441 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
442 pterjan 5340 GL and GLX parts.
443    
444 tv 135155 %if %{build_plf}
445     This package is in the "tainted" section because it enables some
446     OpenGL extentions that are covered by software patents.
447     %endif
448    
449 pterjan 5340 %description -n %{dridrivers}
450 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
451 pterjan 5340 DRI drivers.
452    
453 blino 271501 %description -n %{libdricorename}-devel
454 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
455 blino 271501
456     This package contains the headers needed to compile DRI drivers.
457    
458 pterjan 5340 %description -n %{libglname}-devel
459 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
460 pterjan 5340
461     This package contains the headers needed to compile Mesa programs.
462    
463 tv 88442 %description -n %{libglesv1name}
464     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
465     well-defined subset profiles of OpenGL.
466    
467     This package provides the OpenGL ES library version 1.
468    
469 anssi 278008 %description -n %{libosmesaname}
470     Mesa offscreen rendering libraries for rendering OpenGL into
471     application-allocated blocks of memory.
472    
473     %description -n %{osmesadevel}
474     This package contains the headers needed to compile programs against
475     the Mesa offscreen rendering library.
476    
477 mikala 112356 %description -n %{libglapiname}
478     This packages provides the glapi shared library used by gallium.
479    
480     %description -n %{libglapiname}-devel
481     This package contains the headers needed to compile programes against glapi shared library.
482    
483 tv 88442 %description -n %{libglesv1name}-devel
484     This package contains the headers needed to compile OpenGL ES 1 programs.
485    
486     %description -n %{libglesv2name}
487     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
488     well-defined subset profiles of OpenGL.
489    
490     This package provides the OpenGL ES library version 2.
491    
492     %description -n %{libglesv2name}-devel
493     This package contains the headers needed to compile OpenGL ES 2 programs.
494    
495 tv 88445 %description -n %{libopenvgname}
496     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
497     acceleration interface for vector graphics libraries such as Flash and SVG.
498    
499     %description -n %{libopenvgname}-devel
500     Development files for OpenVG library.
501    
502 cjw 388874 %description -n %{libllvmradeonname}
503     Gallium LLVM Radeon driver.
504    
505 blino 215979 %if %{enable_wayland}
506     %description -n %{libgbmname}
507 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
508 blino 215979 GBM (Graphics Buffer Manager) parts.
509    
510     %description -n %{libgbmname}-devel
511 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
512 blino 215979 GBM (Graphics Buffer Manager) development parts.
513    
514     %description -n %{libwaylandeglname}
515 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
516 blino 215979 Wayland EGL platform parts.
517    
518     %description -n %{libwaylandeglname}-devel
519 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
520 blino 215979 Wayland EGL platform development parts.
521     %endif
522    
523 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
524 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
525     with the nouveau driver.
526    
527 tv 301233 %description -n %{_lib}vdpau-driver-r300
528 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
529     with the r300 driver.
530    
531 tv 301233 %description -n %{_lib}vdpau-driver-r600
532 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
533     with the r600 driver.
534    
535 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
536 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
537     with the radeonsi driver.
538    
539 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
540 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
541     with the softpipe driver.
542    
543 tv 88440 #------------------------------------------------------------------------------
544    
545 pterjan 5340 %prep
546     %if %{git}
547 cjw 336175 %setup -q -n mesa-%{git}
548     #setup -q -n mesa-%{git_branch}-%{git}
549 pterjan 5340 %else
550 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
551 pterjan 5340 %endif
552    
553 blino 278731 %apply_patches
554 pterjan 5340
555 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
556     # would break build. - Anssi 12/2012
557 cjw 336233 all=$(ls)
558     mkdir -p build-osmesa
559     cp -al $all build-osmesa
560 anssi 332631
561 pterjan 5340 %build
562 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
563     autoreconf -vfi
564    
565 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
566     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
567     export LDFLAGS="-L%{_libdir}/llvm"
568    
569     %configure2_5x --enable-dri \
570     --enable-glx \
571 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
572     --with-dri-drivers="%{dri_drivers}" \
573     %if %{enable_egl}
574     --enable-egl \
575     %else
576     --disable-egl \
577     %endif
578 blino 215979 %if %{enable_wayland}
579     --with-egl-platforms=x11,wayland,drm \
580     --enable-gbm \
581     --enable-shared-glapi \
582     %endif
583 tv 88442 --enable-gles1 \
584     --enable-gles2 \
585 tv 88445 --enable-openvg \
586 mikala 112356 --enable-gallium-egl \
587 blino 270761 --enable-gallium-g3dvl \
588     --disable-xvmc \
589     --enable-vdpau \
590 mikala 112356 %if %{with_hardware}
591 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
592 mikala 112356 --enable-gallium-llvm \
593     %else
594     --disable-gallium-llvm \
595     --with-gallium-drivers=swrast \
596     %endif
597 tv 135155 %if %{build_plf}
598     --enable-texture-float \
599     %endif
600 blino 270723 # end of configure options
601 pterjan 5340
602 anssi 332631
603     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
604     # since doing that causes OSMesa to miss the OpenGL symbols.
605     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
606     # -Anssi 12/2012
607    
608 cjw 336233 pushd build-osmesa
609     autoreconf -vfi
610     %configure2_5x \
611     --enable-osmesa \
612     --disable-dri \
613     --disable-glx \
614     --disable-egl \
615     --disable-shared-glapi \
616     --without-gallium-drivers
617     popd
618 anssi 332631
619 anssi 165988 %make
620 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
621 pterjan 5340
622     %install
623 cjw 336233 %makeinstall_std -C build-osmesa
624 tv 88249 %makeinstall_std
625 pterjan 5340
626 blino 216556 # FIXME: strip will likely break the hardlink
627 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
628     # to prevent proprietary driver installers from removing them
629     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
630     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
631     for l in ../libGL.so.*; do cp -a $l .; done
632     popd
633    
634     %ifarch %{x86_64}
635     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
636     %endif
637    
638 blino 270761 # .so files are not needed by vdpau
639     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
640    
641 blino 271144 # .la files are not needed by mesa
642     find %{buildroot} -name '*.la' -exec rm {} \;
643    
644 anssi 181478 # use swrastg if built (Anssi 12/2011)
645     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
646    
647 tv 88440 #------------------------------------------------------------------------------
648    
649 pterjan 5340 %files
650     %defattr(-,root,root)
651 blino 271481 %doc docs/COPYING
652 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
653 pterjan 5340
654 blino 271501 %files -n %{libdricorename}
655     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
656     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
657    
658     %files -n %{libdricorename}-devel
659     %{_libdir}/libdricore%{version}.so
660    
661 pterjan 5340 %files -n %{dridrivers}
662     %defattr(-,root,root)
663     %doc docs/COPYING
664     %ifnarch ppc64
665     %dir %{_libdir}/dri
666 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
667     #%{_libdir}/dri/libglsl.so
668 pterjan 5340 %{_libdir}/dri/*_dri.so
669     %endif
670    
671 tv 88433 %files -n %{libglname}
672     %defattr(-,root,root)
673     %doc docs/COPYING
674     %{_libdir}/libGL.so.*
675     %dir %{_libdir}/mesa
676 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
677 tv 88433
678     %if %{enable_egl}
679     %files -n %{libeglname}
680     %defattr(-,root,root)
681 tv 88442 %doc docs/COPYING
682 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
683 tv 88442 %dir %{_libdir}/egl
684 blino 215979 %if !%{enable_wayland}
685     # st_GL, built only when shared glapi is not enabled
686 mikala 112356 %{_libdir}/egl/st_GL.so
687 blino 215979 %endif
688 mikala 127466 %{_libdir}/egl/egl_gallium.so
689 tv 88441 %endif
690 tv 88433
691 anssi 278008 %files -n %{libosmesaname}
692     %defattr(-,root,root)
693     %{_libdir}/libOSMesa.so.%{osmesamajor}*
694    
695 mikala 112356 %files -n %{libglapiname}
696     %defattr(-,root,root)
697     %{_libdir}/libglapi.so.%{glapimajor}*
698    
699 tv 88442 %files -n %{libglesv1name}
700     %defattr(-,root,root)
701     %doc docs/COPYING
702     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
703    
704     %files -n %{libglesv2name}
705     %defattr(-,root,root)
706     %doc docs/COPYING
707     %{_libdir}/libGLESv2.so.%{glesv2major}*
708    
709 tv 88445 %files -n %{libopenvgname}
710     %defattr(-,root,root)
711     %doc docs/COPYING
712     %{_libdir}/libOpenVG.so.%{openvgmajor}*
713    
714 cjw 388874 %files -n %{libllvmradeonname}
715     %defattr(-,root,root)
716 tv 404192 %{_libdir}/libllvmradeon%version.so
717 cjw 388874
718 blino 215979 %if %{enable_wayland}
719     %files -n %{libgbmname}
720     %{_libdir}/libgbm.so.%{gbmmajor}
721 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
722 blino 215979 %{_libdir}/gbm/gbm_*.so
723 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
724 tv 88445
725 blino 215979 %files -n %{libwaylandeglname}
726     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
727 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
728 blino 215979 %endif
729    
730    
731 pterjan 5340 %files -n %{libglname}-devel
732     %defattr(-,root,root)
733     %doc docs/COPYING
734 anssi 278008 %dir %{_includedir}/GL
735 pterjan 5340 %{_includedir}/GL/gl.h
736     %{_includedir}/GL/glext.h
737     %{_includedir}/GL/gl_mangle.h
738     %{_includedir}/GL/wglext.h
739     %{_includedir}/GL/glx.h
740     %{_includedir}/GL/glxext.h
741     %{_includedir}/GL/glx_mangle.h
742     %{_libdir}/libGL.so
743 tv 88436 %{_libdir}/pkgconfig/gl.pc
744     %{_libdir}/pkgconfig/dri.pc
745 pterjan 5340
746     #FIXME: check those headers
747 cjw 336175 #{_includedir}/GL/vms_x_fix.h
748 pterjan 5340 %{_includedir}/GL/wmesa.h
749     %dir %{_includedir}/GL/internal
750     %{_includedir}/GL/internal/dri_interface.h
751    
752     %files common-devel
753     %defattr(-,root,root)
754    
755 tv 88441 %if %{enable_egl}
756 tv 88433 %files -n %{libeglname}-devel
757     %defattr(-,root,root)
758 tv 88442 %doc docs/COPYING
759     %{_includedir}/EGL
760     %{_includedir}/KHR
761 tv 88433 %{_libdir}/libEGL.so
762 tv 88436 %{_libdir}/pkgconfig/egl.pc
763 tv 88433 %endif
764 pterjan 5340
765 anssi 278008 %files -n %{osmesadevel}
766     %defattr(-,root,root)
767     %dir %{_includedir}/GL
768     %{_includedir}/GL/osmesa.h
769     %{_libdir}/libOSMesa.so
770     %{_libdir}/pkgconfig/osmesa.pc
771    
772 mikala 112356 %files -n %{libglapiname}-devel
773     %defattr(-,root,root)
774     %{_libdir}/libglapi.so
775 pterjan 5340
776 tv 88442 %files -n %{libglesv1name}-devel
777     %defattr(-,root,root)
778     %{_includedir}/GLES
779     %{_libdir}/libGLESv1_CM.so
780     %{_libdir}/pkgconfig/glesv1_cm.pc
781 tv 88433
782 tv 88442 %files -n %{libglesv2name}-devel
783     %defattr(-,root,root)
784     %{_includedir}/GLES2
785 cjw 336175 %{_includedir}/GLES3
786 tv 88442 %{_libdir}/libGLESv2.so
787     %{_libdir}/pkgconfig/glesv2.pc
788 tv 88445
789     %files -n %{libopenvgname}-devel
790     %defattr(-,root,root)
791     %{_includedir}/VG
792     %{_libdir}/libOpenVG.so
793     %{_libdir}/pkgconfig/vg.pc
794 blino 215979
795     %if %{enable_wayland}
796     %files -n %{libgbmname}-devel
797     %{_includedir}/gbm.h
798     %{_libdir}/libgbm.so
799     %{_libdir}/pkgconfig/gbm.pc
800    
801     %files -n %{libwaylandeglname}-devel
802     %{_libdir}/libwayland-egl.so
803     %{_libdir}/pkgconfig/wayland-egl.pc
804     %endif
805 blino 270761
806 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
807 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
808    
809 tv 301233 %files -n %{_lib}vdpau-driver-r300
810 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
811    
812 tv 301233 %files -n %{_lib}vdpau-driver-r600
813 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
814    
815 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
816 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
817    
818 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
819 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30