/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 465405 - (hide annotations) (download)
Sun Aug 11 10:05:29 2013 UTC (10 years, 7 months ago) by tmb
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23564 byte(s)
rebuild with new gcc
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 cjw 336175 %define git_branch 9.1
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 131211 %define relc 0
25 pterjan 5340 %define name mesa
26 fwang 462788 %define fversion 9.1.6
27     %define version 9.1.6
28 tmb 465405 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 fwang 404139 %define llvmradeonmajor %{version}
74 tv 88442
75 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
76 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
77     %define libglname %mklibname %{glname} %{glmajor}
78     %define libglwname %mklibname %{glwname} %{glwmajor}
79 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
80     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
81 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
82 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
83 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
84     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
85 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
86 cjw 388874 %define libllvmradeonname %mklibname llvmradeon %{llvmradeonmajor}
87 pterjan 5340
88     %define dridrivers %mklibname dri-drivers
89    
90 anssi 278008 %define osmesadevel %mklibname osmesa -d
91    
92 pterjan 5340 # Architecture-independent Virtual provides:
93 blino 271501 %define libdricorename_virt lib%{dricorename}
94 pterjan 5340 %define libeglname_virt lib%{eglname}
95     %define libglname_virt lib%{glname}
96     %define libglwname_virt lib%{glwname}
97 tv 88442 %define libglesv1name_virt lib%{glesv1name}
98     %define libglesv2name_virt lib%{glesv2name}
99 tv 88445 %define libopenvgname_virt lib%{openvgname}
100 mikala 112356 %define libglapiname_virt lib%{glapiname}
101 blino 215979 %define libgbmname_virt lib%{gbmname}
102     %define libwaylandeglname_virt lib%{waylandeglname}
103 pterjan 5340
104     %define oldlibglname %mklibname MesaGL 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
130 pterjan 5340 Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 tmb 411326 BuildRequires: llvm-devel > 3.2-1
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 cjw 336175 Source0: %{name}-%{git}.tar.bz2
159 blino 289278 # (blino) snapshot of 9.0 branch
160 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
161 pterjan 5340 %else
162 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
163 pterjan 5340 %endif
164     Source3: make-git-snapshot.sh
165    
166     # Instructions to setup your repository clone
167     # git://git.freedesktop.org/git/mesa/mesa
168     # git checkout mesa_7_5_branch
169     # git branch mdv-cherry-picks
170     # git am ../02??-*.patch
171     # git branch mdv-redhat
172     # git am ../03??-*.patch
173     # git branch mdv-patches
174     # git am ../09??-*.patch
175     # In order to update to the branch via patches, issue this command:
176     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
177    
178     # Cherry picks
179     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
180     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
181 tmb 411326
182 blino 289280 # (blino) should be pushed to 9.0 branch upstream
183 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
184     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
185 pterjan 5340
186 tv 88247 # Patches "liberated" from Fedora:
187 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
188     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
189    
190 blino 278732 # Patches from ChromiumOS
191     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
192    
193 blino 271493 # Mageia/Mandriva patches
194 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
195 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
196 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
197 pterjan 5340
198 tv 88440 #------------------------------------------------------------------------------
199    
200     # package mesa
201 pterjan 5340 License: MIT
202     Requires: %{libglname} = %{version}-%{release}
203     Provides: hackMesa = %{version}
204     Obsoletes: hackMesa <= %{version}
205     Provides: Mesa = %{version}
206     Obsoletes: Mesa < %{version}
207    
208 blino 271501 %package -n %{libdricorename}
209     Summary: Shared library for DRI drivers
210     Group: System/Libraries
211     Provides: %{libdricorename_virt} = %{version}-%{release}
212    
213     %package -n %{libdricorename}-devel
214     Summary: Development files for DRI core
215     Group: Development/C
216     Requires: %{libdricorename} = %{version}-%{release}
217     Provides: lib%{dricorename}-devel = %{version}-%{release}
218     Provides: %{dricorename}-devel = %{version}-%{release}
219    
220 pterjan 5340 %package -n %{libglname}
221     Summary: Files for Mesa (GL and GLX libs)
222     Group: System/Libraries
223 tv 88247 Obsoletes: %{oldlibglname} < 6.4
224 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
225     Provides: %{libglname_virt} = %{version}-%{release}
226     Requires: %{dridrivers} >= %{version}-%{release}
227 tv 135172 %if %{build_plf}
228     Requires: %mklibname txc-dxtn
229     %endif
230 pterjan 5340
231     # (anssi) Forces the upgrade of x11-server-common to happen before
232     # alternatives removal, which allows x11-server-common to grab the symlink.
233     Conflicts: x11-server-common < 1.3.0.0-17
234    
235     %package -n %{dridrivers}
236     Summary: Mesa DRI drivers
237     Group: System/Libraries
238 blino 274132 # do not require exact release to avoid conflicts when having
239     # x86_64 dri drivers from tainted and i586 dri drivers from core
240     Requires: mesa = %{version}
241 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
242 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
243     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
244 pterjan 5340
245     %package -n %{libglname}-devel
246     Summary: Development files for Mesa (OpenGL compatible 3D lib)
247     Group: Development/C
248 tv 88237 Requires: %{libglname} = %{version}-%{release}
249 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
250     Provides: %{glname}-devel = %{version}-%{release}
251     Provides: GL-devel
252     Obsoletes: %{oldlibglname}-devel < 6.4
253     Provides: %{oldlibglname}-devel = %{version}-%{release}
254     Provides: libMesaGL-devel = %{version}-%{release}
255     Provides: MesaGL-devel = %{version}-%{release}
256 tv 88438 Provides: libgl-devel
257 pterjan 5340
258 tv 88433 %if %{enable_egl}
259     %package -n %{libeglname}
260     Summary: Files for Mesa (EGL libs)
261     Group: System/Libraries
262     Provides: %{libeglname_virt} = %{version}-%{release}
263    
264     %package -n %{libeglname}-devel
265     Summary: Development files for Mesa (EGL libs)
266     Group: Development/C
267 tv 88439 Requires: %{libeglname} = %{version}-%{release}
268 tv 88433 Provides: EGL-devel
269 tv 88438 Provides: lib%{eglname}-devel
270     Provides: %{eglname}-devel
271     Provides: libegl-devel
272 tv 88433 %endif
273    
274 anssi 278008 %package -n %{libosmesaname}
275     Summary: Mesa offscreen rendering library
276     Group: System/Libraries
277    
278     %package -n %{osmesadevel}
279     Summary: Development files for libosmesa
280     Group: Development/C
281     Requires: %{libosmesaname} = %{version}-%{release}
282     Provides: osmesa-devel = %{version}-%{release}
283     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
284    
285 mikala 112356 %package -n %{libglapiname}
286     Summary: Files for mesa (glapi libs)
287     Group: System/Libraries
288     Provides: %{libglapiname_virt} = %{version}-%{release}
289 tv 88442
290 mikala 112356 %package -n %{libglapiname}-devel
291     Summary: Development files for glapi libs
292     Group: Development/C
293     Requires: %{libglapiname_virt} = %{version}-%{release}
294     Provides: lib%{glapiname}-devel
295     Provides: %{libglapiname}-devel
296    
297 tv 88442 %package -n %{libglesv1name}
298     Summary: Files for Mesa (glesv1 libs)
299     Group: System/Libraries
300     Provides: %{libglesv1name_virt} = %{version}-%{release}
301    
302     %package -n %{libglesv1name}-devel
303     Summary: Development files for glesv1 libs
304     Group: Development/C
305     Requires: %{libglesv1name} = %{version}-%{release}
306     Provides: lib%{glesv1name}-devel
307     Provides: %{glesv1name}-devel
308     Provides: libglesv1-devel
309    
310     %package -n %{libglesv2name}
311     Summary: Files for Mesa (glesv2 libs)
312     Group: System/Libraries
313     Provides: %{libglesv2name_virt} = %{version}-%{release}
314    
315     %package -n %{libglesv2name}-devel
316     Summary: Development files for glesv2 libs
317     Group: Development/C
318     Requires: %{libglesv2name} = %{version}-%{release}
319 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
320 tv 88442 Provides: lib%{glesv2name}-devel
321     Provides: %{glesv2name}-devel
322     Provides: libglesv2-devel
323    
324 tv 88445 %package -n %{libopenvgname}
325     Summary: Files for MESA (OpenVG libs)
326     Group: System/Libraries
327     Provides: %{libopenvgname_virt} = %{version}-%{release}
328    
329     %package -n %{libopenvgname}-devel
330     Summary: Development files vor OpenVG libs
331     Group: Development/C
332     Requires: %{libopenvgname} = %{version}-%{release}
333     Provides: lib%{openvgname}-devel
334     Provides: %{openvgname}-devel
335     Provides: libopenvg-devel
336    
337 cjw 388874 %package -n %{libllvmradeonname}
338     Summary: Files for MESA (LLVM radeon library)
339     Group: System/Libraries
340    
341 blino 215979 %if %{enable_wayland}
342     %package -n %{libgbmname}
343     Summary: Files for Mesa (gbm libs)
344     Group: System/Libraries
345     Provides: %{libgbmname_virt} = %{version}-%{release}
346    
347     %package -n %{libgbmname}-devel
348     Summary: Development files for Mesa (gbm libs)
349     Group: Development/C
350     Requires: %{libgbmname} = %{version}-%{release}
351     Provides: lib%{gbmname}-devel
352     Provides: %{gbmname}-devel
353    
354     %package -n %{libwaylandeglname}
355     Summary: Files for Mesa (Wayland EGL libs)
356     Group: System/Libraries
357     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
358    
359     %package -n %{libwaylandeglname}-devel
360     Summary: Development files for Mesa (Wayland EGL libs)
361     Group: Development/C
362     Requires: %{libwaylandeglname} = %{version}-%{release}
363     Provides: lib%{waylandeglname}-devel
364     Provides: %{waylandeglname}-devel
365     %endif
366    
367 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
368 blino 270761 Summary: VDPAU plugin for nouveau driver
369 blino 300616 Group: System/Libraries
370 tv 302568 # temporary:
371     %rename vdpau-driver-nouveau
372 blino 270761
373 tv 301233 %package -n %{_lib}vdpau-driver-r300
374 blino 270761 Summary: VDPAU plugin for r300 driver
375 blino 300616 Group: System/Libraries
376 tv 302568 # temporary:
377     %rename vdpau-driver-r300
378 blino 270761
379 tv 301233 %package -n %{_lib}vdpau-driver-r600
380 blino 270761 Summary: VDPAU plugin for r600 driver
381 blino 300616 Group: System/Libraries
382 tv 302568 # temporary:
383     %rename vdpau-driver-r600
384 blino 270761
385 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
386 blino 289282 Summary: VDPAU plugin for radeonsi driver
387     Group: System/Libraries
388 tv 302568 # temporary:
389     %rename vdpau-driver-radeonsi
390 blino 289282
391 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
392 blino 270761 Summary: VDPAU plugin for softpipe driver
393 blino 300616 Group: System/Libraries
394 tv 302568 # temporary:
395     %rename vdpau-driver-softpipe
396 blino 270761
397 pterjan 5340 %package common-devel
398     Summary: Meta package for mesa devel
399     Group: Development/C
400 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
401 pterjan 5340 Provides: hackMesa-common-devel = %{version}
402 tv 88247 Obsoletes: Mesa-common-devel < %{version}
403 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
404     Requires: %{libglname}-devel = %{version}
405 blino 289355 Requires: mesaglu-devel
406 tv 135156 Requires: freeglut-devel
407 tv 88442 Requires: %{libeglname}-devel = %{version}
408     Requires: %{libglesv1name}-devel = %{version}
409     Requires: %{libglesv2name}-devel = %{version}
410 pterjan 5340
411 tv 88440 #------------------------------------------------------------------------------
412 pterjan 5340
413     %description
414 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
415 tv 135173 %if %{build_plf}
416 pterjan 5340
417 tv 135173 This package is in the "tainted" section because it enables some
418     OpenGL extentions that are covered by software patents.
419     %endif
420    
421 pterjan 5340 %description common-devel
422     Mesa common metapackage devel
423    
424     %if %{enable_egl}
425     %description -n %{libeglname}
426 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
427 pterjan 5340 EGL parts.
428    
429     %description -n %{libeglname}-devel
430 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
431 pterjan 5340 EGL development parts.
432     %endif
433    
434 blino 271501 %description -n %{libdricorename}
435 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
436 blino 271501 DRI core part.
437    
438 pterjan 5340 %description -n %{libglname}
439 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
440 pterjan 5340 GL and GLX parts.
441    
442 tv 135155 %if %{build_plf}
443     This package is in the "tainted" section because it enables some
444     OpenGL extentions that are covered by software patents.
445     %endif
446    
447 pterjan 5340 %description -n %{dridrivers}
448 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
449 pterjan 5340 DRI drivers.
450    
451 blino 271501 %description -n %{libdricorename}-devel
452 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
453 blino 271501
454     This package contains the headers needed to compile DRI drivers.
455    
456 pterjan 5340 %description -n %{libglname}-devel
457 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
458 pterjan 5340
459     This package contains the headers needed to compile Mesa programs.
460    
461 tv 88442 %description -n %{libglesv1name}
462     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
463     well-defined subset profiles of OpenGL.
464    
465     This package provides the OpenGL ES library version 1.
466    
467 anssi 278008 %description -n %{libosmesaname}
468     Mesa offscreen rendering libraries for rendering OpenGL into
469     application-allocated blocks of memory.
470    
471     %description -n %{osmesadevel}
472     This package contains the headers needed to compile programs against
473     the Mesa offscreen rendering library.
474    
475 mikala 112356 %description -n %{libglapiname}
476     This packages provides the glapi shared library used by gallium.
477    
478     %description -n %{libglapiname}-devel
479     This package contains the headers needed to compile programes against glapi shared library.
480    
481 tv 88442 %description -n %{libglesv1name}-devel
482     This package contains the headers needed to compile OpenGL ES 1 programs.
483    
484     %description -n %{libglesv2name}
485     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
486     well-defined subset profiles of OpenGL.
487    
488     This package provides the OpenGL ES library version 2.
489    
490     %description -n %{libglesv2name}-devel
491     This package contains the headers needed to compile OpenGL ES 2 programs.
492    
493 tv 88445 %description -n %{libopenvgname}
494     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
495     acceleration interface for vector graphics libraries such as Flash and SVG.
496    
497     %description -n %{libopenvgname}-devel
498     Development files for OpenVG library.
499    
500 cjw 388874 %description -n %{libllvmradeonname}
501     Gallium LLVM Radeon driver.
502    
503 blino 215979 %if %{enable_wayland}
504     %description -n %{libgbmname}
505 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
506 blino 215979 GBM (Graphics Buffer Manager) parts.
507    
508     %description -n %{libgbmname}-devel
509 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
510 blino 215979 GBM (Graphics Buffer Manager) development parts.
511    
512     %description -n %{libwaylandeglname}
513 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
514 blino 215979 Wayland EGL platform parts.
515    
516     %description -n %{libwaylandeglname}-devel
517 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
518 blino 215979 Wayland EGL platform development parts.
519     %endif
520    
521 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
522 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
523     with the nouveau driver.
524    
525 tv 301233 %description -n %{_lib}vdpau-driver-r300
526 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
527     with the r300 driver.
528    
529 tv 301233 %description -n %{_lib}vdpau-driver-r600
530 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
531     with the r600 driver.
532    
533 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
534 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
535     with the radeonsi driver.
536    
537 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
538 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
539     with the softpipe driver.
540    
541 tv 88440 #------------------------------------------------------------------------------
542    
543 pterjan 5340 %prep
544     %if %{git}
545 cjw 336175 %setup -q -n mesa-%{git}
546     #setup -q -n mesa-%{git_branch}-%{git}
547 pterjan 5340 %else
548 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
549 pterjan 5340 %endif
550    
551 blino 278731 %apply_patches
552 pterjan 5340
553 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
554     # would break build. - Anssi 12/2012
555 cjw 336233 all=$(ls)
556     mkdir -p build-osmesa
557     cp -al $all build-osmesa
558 anssi 332631
559 pterjan 5340 %build
560 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
561     autoreconf -vfi
562    
563 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
564     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
565     export LDFLAGS="-L%{_libdir}/llvm"
566    
567     %configure2_5x --enable-dri \
568     --enable-glx \
569 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
570     --with-dri-drivers="%{dri_drivers}" \
571     %if %{enable_egl}
572     --enable-egl \
573     %else
574     --disable-egl \
575     %endif
576 blino 215979 %if %{enable_wayland}
577     --with-egl-platforms=x11,wayland,drm \
578     --enable-gbm \
579     --enable-shared-glapi \
580     %endif
581 tv 88442 --enable-gles1 \
582     --enable-gles2 \
583 tv 88445 --enable-openvg \
584 mikala 112356 --enable-gallium-egl \
585 blino 270761 --enable-gallium-g3dvl \
586     --disable-xvmc \
587     --enable-vdpau \
588 mikala 112356 %if %{with_hardware}
589 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
590 mikala 112356 --enable-gallium-llvm \
591     %else
592     --disable-gallium-llvm \
593     --with-gallium-drivers=swrast \
594     %endif
595 tv 135155 %if %{build_plf}
596     --enable-texture-float \
597     %endif
598 blino 270723 # end of configure options
599 pterjan 5340
600 anssi 332631
601     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
602     # since doing that causes OSMesa to miss the OpenGL symbols.
603     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
604     # -Anssi 12/2012
605    
606 cjw 336233 pushd build-osmesa
607     autoreconf -vfi
608     %configure2_5x \
609     --enable-osmesa \
610     --disable-dri \
611     --disable-glx \
612     --disable-egl \
613     --disable-shared-glapi \
614     --without-gallium-drivers
615     popd
616 anssi 332631
617 anssi 165988 %make
618 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
619 pterjan 5340
620     %install
621 cjw 336233 %makeinstall_std -C build-osmesa
622 tv 88249 %makeinstall_std
623 pterjan 5340
624 blino 216556 # FIXME: strip will likely break the hardlink
625 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
626     # to prevent proprietary driver installers from removing them
627     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
628     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
629     for l in ../libGL.so.*; do cp -a $l .; done
630     popd
631    
632     %ifarch %{x86_64}
633     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
634     %endif
635    
636 blino 270761 # .so files are not needed by vdpau
637     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
638    
639 blino 271144 # .la files are not needed by mesa
640     find %{buildroot} -name '*.la' -exec rm {} \;
641    
642 anssi 181478 # use swrastg if built (Anssi 12/2011)
643     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
644    
645 tv 88440 #------------------------------------------------------------------------------
646    
647 pterjan 5340 %files
648     %defattr(-,root,root)
649 blino 271481 %doc docs/COPYING
650 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
651 pterjan 5340
652 blino 271501 %files -n %{libdricorename}
653     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
654     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
655    
656     %files -n %{libdricorename}-devel
657     %{_libdir}/libdricore%{version}.so
658    
659 pterjan 5340 %files -n %{dridrivers}
660     %defattr(-,root,root)
661     %doc docs/COPYING
662     %ifnarch ppc64
663     %dir %{_libdir}/dri
664 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
665     #%{_libdir}/dri/libglsl.so
666 pterjan 5340 %{_libdir}/dri/*_dri.so
667     %endif
668    
669 tv 88433 %files -n %{libglname}
670     %defattr(-,root,root)
671     %doc docs/COPYING
672     %{_libdir}/libGL.so.*
673     %dir %{_libdir}/mesa
674 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
675 tv 88433
676     %if %{enable_egl}
677     %files -n %{libeglname}
678     %defattr(-,root,root)
679 tv 88442 %doc docs/COPYING
680 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
681 tv 88442 %dir %{_libdir}/egl
682 blino 215979 %if !%{enable_wayland}
683     # st_GL, built only when shared glapi is not enabled
684 mikala 112356 %{_libdir}/egl/st_GL.so
685 blino 215979 %endif
686 mikala 127466 %{_libdir}/egl/egl_gallium.so
687 tv 88441 %endif
688 tv 88433
689 anssi 278008 %files -n %{libosmesaname}
690     %defattr(-,root,root)
691     %{_libdir}/libOSMesa.so.%{osmesamajor}*
692    
693 mikala 112356 %files -n %{libglapiname}
694     %defattr(-,root,root)
695     %{_libdir}/libglapi.so.%{glapimajor}*
696    
697 tv 88442 %files -n %{libglesv1name}
698     %defattr(-,root,root)
699     %doc docs/COPYING
700     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
701    
702     %files -n %{libglesv2name}
703     %defattr(-,root,root)
704     %doc docs/COPYING
705     %{_libdir}/libGLESv2.so.%{glesv2major}*
706    
707 tv 88445 %files -n %{libopenvgname}
708     %defattr(-,root,root)
709     %doc docs/COPYING
710     %{_libdir}/libOpenVG.so.%{openvgmajor}*
711    
712 cjw 388874 %files -n %{libllvmradeonname}
713     %defattr(-,root,root)
714 tv 404192 %{_libdir}/libllvmradeon%version.so
715 cjw 388874
716 blino 215979 %if %{enable_wayland}
717     %files -n %{libgbmname}
718     %{_libdir}/libgbm.so.%{gbmmajor}
719 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
720 blino 215979 %{_libdir}/gbm/gbm_*.so
721 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
722 tv 88445
723 blino 215979 %files -n %{libwaylandeglname}
724     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
725 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
726 blino 215979 %endif
727    
728    
729 pterjan 5340 %files -n %{libglname}-devel
730     %defattr(-,root,root)
731     %doc docs/COPYING
732 anssi 278008 %dir %{_includedir}/GL
733 pterjan 5340 %{_includedir}/GL/gl.h
734     %{_includedir}/GL/glext.h
735     %{_includedir}/GL/gl_mangle.h
736     %{_includedir}/GL/wglext.h
737     %{_includedir}/GL/glx.h
738     %{_includedir}/GL/glxext.h
739     %{_includedir}/GL/glx_mangle.h
740     %{_libdir}/libGL.so
741 tv 88436 %{_libdir}/pkgconfig/gl.pc
742     %{_libdir}/pkgconfig/dri.pc
743 pterjan 5340
744     #FIXME: check those headers
745 cjw 336175 #{_includedir}/GL/vms_x_fix.h
746 pterjan 5340 %{_includedir}/GL/wmesa.h
747     %dir %{_includedir}/GL/internal
748     %{_includedir}/GL/internal/dri_interface.h
749    
750     %files common-devel
751     %defattr(-,root,root)
752    
753 tv 88441 %if %{enable_egl}
754 tv 88433 %files -n %{libeglname}-devel
755     %defattr(-,root,root)
756 tv 88442 %doc docs/COPYING
757     %{_includedir}/EGL
758     %{_includedir}/KHR
759 tv 88433 %{_libdir}/libEGL.so
760 tv 88436 %{_libdir}/pkgconfig/egl.pc
761 tv 88433 %endif
762 pterjan 5340
763 anssi 278008 %files -n %{osmesadevel}
764     %defattr(-,root,root)
765     %dir %{_includedir}/GL
766     %{_includedir}/GL/osmesa.h
767     %{_libdir}/libOSMesa.so
768     %{_libdir}/pkgconfig/osmesa.pc
769    
770 mikala 112356 %files -n %{libglapiname}-devel
771     %defattr(-,root,root)
772     %{_libdir}/libglapi.so
773 pterjan 5340
774 tv 88442 %files -n %{libglesv1name}-devel
775     %defattr(-,root,root)
776     %{_includedir}/GLES
777     %{_libdir}/libGLESv1_CM.so
778     %{_libdir}/pkgconfig/glesv1_cm.pc
779 tv 88433
780 tv 88442 %files -n %{libglesv2name}-devel
781     %defattr(-,root,root)
782     %{_includedir}/GLES2
783 cjw 336175 %{_includedir}/GLES3
784 tv 88442 %{_libdir}/libGLESv2.so
785     %{_libdir}/pkgconfig/glesv2.pc
786 tv 88445
787     %files -n %{libopenvgname}-devel
788     %defattr(-,root,root)
789     %{_includedir}/VG
790     %{_libdir}/libOpenVG.so
791     %{_libdir}/pkgconfig/vg.pc
792 blino 215979
793     %if %{enable_wayland}
794     %files -n %{libgbmname}-devel
795     %{_includedir}/gbm.h
796     %{_libdir}/libgbm.so
797     %{_libdir}/pkgconfig/gbm.pc
798    
799     %files -n %{libwaylandeglname}-devel
800     %{_libdir}/libwayland-egl.so
801     %{_libdir}/pkgconfig/wayland-egl.pc
802     %endif
803 blino 270761
804 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
805 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
806    
807 tv 301233 %files -n %{_lib}vdpau-driver-r300
808 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
809    
810 tv 301233 %files -n %{_lib}vdpau-driver-r600
811 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
812    
813 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
814 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
815    
816 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
817 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30