/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 469143 - (hide annotations) (download)
Wed Aug 21 20:18:26 2013 UTC (10 years, 7 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23593 byte(s)
BR libelf-devel
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 cjw 336175 %define git_branch 9.1
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 469080 %define relc 1
25 pterjan 5340 %define name mesa
26 tv 469080 %define fversion 9.2.0
27     %define version 9.2.0
28 tmb 465405 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 fwang 404139 %define llvmradeonmajor %{version}
74 tv 88442
75 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
76 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
77     %define libglname %mklibname %{glname} %{glmajor}
78     %define libglwname %mklibname %{glwname} %{glwmajor}
79 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
80     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
81 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
82 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
83 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
84     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
85 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
86 cjw 388874 %define libllvmradeonname %mklibname llvmradeon %{llvmradeonmajor}
87 pterjan 5340
88     %define dridrivers %mklibname dri-drivers
89    
90 anssi 278008 %define osmesadevel %mklibname osmesa -d
91    
92 pterjan 5340 # Architecture-independent Virtual provides:
93 blino 271501 %define libdricorename_virt lib%{dricorename}
94 pterjan 5340 %define libeglname_virt lib%{eglname}
95     %define libglname_virt lib%{glname}
96     %define libglwname_virt lib%{glwname}
97 tv 88442 %define libglesv1name_virt lib%{glesv1name}
98     %define libglesv2name_virt lib%{glesv2name}
99 tv 88445 %define libopenvgname_virt lib%{openvgname}
100 mikala 112356 %define libglapiname_virt lib%{glapiname}
101 blino 215979 %define libgbmname_virt lib%{gbmname}
102     %define libwaylandeglname_virt lib%{waylandeglname}
103 pterjan 5340
104     %define oldlibglname %mklibname MesaGL 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
130 pterjan 5340 Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 tv 469143 BuildRequires: libelf-devel
150 tv 469141 BuildRequires: llvm-devel > 3.3-1
151 mikala 127466 BuildRequires: pkgconfig(libudev)
152 blino 270761 BuildRequires: pkgconfig(vdpau)
153 blino 215979 %if %{enable_wayland}
154     BuildRequires: wayland-devel
155     %endif
156 pterjan 5340
157     URL: http://www.mesa3d.org
158     %if %{git}
159 cjw 336175 Source0: %{name}-%{git}.tar.bz2
160 blino 289278 # (blino) snapshot of 9.0 branch
161 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
162 pterjan 5340 %else
163 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
164 pterjan 5340 %endif
165     Source3: make-git-snapshot.sh
166    
167     # Instructions to setup your repository clone
168     # git://git.freedesktop.org/git/mesa/mesa
169     # git checkout mesa_7_5_branch
170     # git branch mdv-cherry-picks
171     # git am ../02??-*.patch
172     # git branch mdv-redhat
173     # git am ../03??-*.patch
174     # git branch mdv-patches
175     # git am ../09??-*.patch
176     # In order to update to the branch via patches, issue this command:
177     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
178    
179     # Cherry picks
180     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
181     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
182 tmb 411326
183 blino 289280 # (blino) should be pushed to 9.0 branch upstream
184 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
185     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
186 pterjan 5340
187 tv 88247 # Patches "liberated" from Fedora:
188 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
189     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
190    
191 blino 278732 # Patches from ChromiumOS
192     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
193    
194 blino 271493 # Mageia/Mandriva patches
195 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
196 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
197 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
198 pterjan 5340
199 tv 88440 #------------------------------------------------------------------------------
200    
201     # package mesa
202 pterjan 5340 License: MIT
203     Requires: %{libglname} = %{version}-%{release}
204     Provides: hackMesa = %{version}
205     Obsoletes: hackMesa <= %{version}
206     Provides: Mesa = %{version}
207     Obsoletes: Mesa < %{version}
208    
209 blino 271501 %package -n %{libdricorename}
210     Summary: Shared library for DRI drivers
211     Group: System/Libraries
212     Provides: %{libdricorename_virt} = %{version}-%{release}
213    
214     %package -n %{libdricorename}-devel
215     Summary: Development files for DRI core
216     Group: Development/C
217     Requires: %{libdricorename} = %{version}-%{release}
218     Provides: lib%{dricorename}-devel = %{version}-%{release}
219     Provides: %{dricorename}-devel = %{version}-%{release}
220    
221 pterjan 5340 %package -n %{libglname}
222     Summary: Files for Mesa (GL and GLX libs)
223     Group: System/Libraries
224 tv 88247 Obsoletes: %{oldlibglname} < 6.4
225 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
226     Provides: %{libglname_virt} = %{version}-%{release}
227     Requires: %{dridrivers} >= %{version}-%{release}
228 tv 135172 %if %{build_plf}
229     Requires: %mklibname txc-dxtn
230     %endif
231 pterjan 5340
232     # (anssi) Forces the upgrade of x11-server-common to happen before
233     # alternatives removal, which allows x11-server-common to grab the symlink.
234     Conflicts: x11-server-common < 1.3.0.0-17
235    
236     %package -n %{dridrivers}
237     Summary: Mesa DRI drivers
238     Group: System/Libraries
239 blino 274132 # do not require exact release to avoid conflicts when having
240     # x86_64 dri drivers from tainted and i586 dri drivers from core
241     Requires: mesa = %{version}
242 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
243 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
244     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
245 pterjan 5340
246     %package -n %{libglname}-devel
247     Summary: Development files for Mesa (OpenGL compatible 3D lib)
248     Group: Development/C
249 tv 88237 Requires: %{libglname} = %{version}-%{release}
250 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
251     Provides: %{glname}-devel = %{version}-%{release}
252     Provides: GL-devel
253     Obsoletes: %{oldlibglname}-devel < 6.4
254     Provides: %{oldlibglname}-devel = %{version}-%{release}
255     Provides: libMesaGL-devel = %{version}-%{release}
256     Provides: MesaGL-devel = %{version}-%{release}
257 tv 88438 Provides: libgl-devel
258 pterjan 5340
259 tv 88433 %if %{enable_egl}
260     %package -n %{libeglname}
261     Summary: Files for Mesa (EGL libs)
262     Group: System/Libraries
263     Provides: %{libeglname_virt} = %{version}-%{release}
264    
265     %package -n %{libeglname}-devel
266     Summary: Development files for Mesa (EGL libs)
267     Group: Development/C
268 tv 88439 Requires: %{libeglname} = %{version}-%{release}
269 tv 88433 Provides: EGL-devel
270 tv 88438 Provides: lib%{eglname}-devel
271     Provides: %{eglname}-devel
272     Provides: libegl-devel
273 tv 88433 %endif
274    
275 anssi 278008 %package -n %{libosmesaname}
276     Summary: Mesa offscreen rendering library
277     Group: System/Libraries
278    
279     %package -n %{osmesadevel}
280     Summary: Development files for libosmesa
281     Group: Development/C
282     Requires: %{libosmesaname} = %{version}-%{release}
283     Provides: osmesa-devel = %{version}-%{release}
284     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
285    
286 mikala 112356 %package -n %{libglapiname}
287     Summary: Files for mesa (glapi libs)
288     Group: System/Libraries
289     Provides: %{libglapiname_virt} = %{version}-%{release}
290 tv 88442
291 mikala 112356 %package -n %{libglapiname}-devel
292     Summary: Development files for glapi libs
293     Group: Development/C
294     Requires: %{libglapiname_virt} = %{version}-%{release}
295     Provides: lib%{glapiname}-devel
296     Provides: %{libglapiname}-devel
297    
298 tv 88442 %package -n %{libglesv1name}
299     Summary: Files for Mesa (glesv1 libs)
300     Group: System/Libraries
301     Provides: %{libglesv1name_virt} = %{version}-%{release}
302    
303     %package -n %{libglesv1name}-devel
304     Summary: Development files for glesv1 libs
305     Group: Development/C
306     Requires: %{libglesv1name} = %{version}-%{release}
307     Provides: lib%{glesv1name}-devel
308     Provides: %{glesv1name}-devel
309     Provides: libglesv1-devel
310    
311     %package -n %{libglesv2name}
312     Summary: Files for Mesa (glesv2 libs)
313     Group: System/Libraries
314     Provides: %{libglesv2name_virt} = %{version}-%{release}
315    
316     %package -n %{libglesv2name}-devel
317     Summary: Development files for glesv2 libs
318     Group: Development/C
319     Requires: %{libglesv2name} = %{version}-%{release}
320 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
321 tv 88442 Provides: lib%{glesv2name}-devel
322     Provides: %{glesv2name}-devel
323     Provides: libglesv2-devel
324    
325 tv 88445 %package -n %{libopenvgname}
326     Summary: Files for MESA (OpenVG libs)
327     Group: System/Libraries
328     Provides: %{libopenvgname_virt} = %{version}-%{release}
329    
330     %package -n %{libopenvgname}-devel
331     Summary: Development files vor OpenVG libs
332     Group: Development/C
333     Requires: %{libopenvgname} = %{version}-%{release}
334     Provides: lib%{openvgname}-devel
335     Provides: %{openvgname}-devel
336     Provides: libopenvg-devel
337    
338 cjw 388874 %package -n %{libllvmradeonname}
339     Summary: Files for MESA (LLVM radeon library)
340     Group: System/Libraries
341    
342 blino 215979 %if %{enable_wayland}
343     %package -n %{libgbmname}
344     Summary: Files for Mesa (gbm libs)
345     Group: System/Libraries
346     Provides: %{libgbmname_virt} = %{version}-%{release}
347    
348     %package -n %{libgbmname}-devel
349     Summary: Development files for Mesa (gbm libs)
350     Group: Development/C
351     Requires: %{libgbmname} = %{version}-%{release}
352     Provides: lib%{gbmname}-devel
353     Provides: %{gbmname}-devel
354    
355     %package -n %{libwaylandeglname}
356     Summary: Files for Mesa (Wayland EGL libs)
357     Group: System/Libraries
358     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
359    
360     %package -n %{libwaylandeglname}-devel
361     Summary: Development files for Mesa (Wayland EGL libs)
362     Group: Development/C
363     Requires: %{libwaylandeglname} = %{version}-%{release}
364     Provides: lib%{waylandeglname}-devel
365     Provides: %{waylandeglname}-devel
366     %endif
367    
368 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
369 blino 270761 Summary: VDPAU plugin for nouveau driver
370 blino 300616 Group: System/Libraries
371 tv 302568 # temporary:
372     %rename vdpau-driver-nouveau
373 blino 270761
374 tv 301233 %package -n %{_lib}vdpau-driver-r300
375 blino 270761 Summary: VDPAU plugin for r300 driver
376 blino 300616 Group: System/Libraries
377 tv 302568 # temporary:
378     %rename vdpau-driver-r300
379 blino 270761
380 tv 301233 %package -n %{_lib}vdpau-driver-r600
381 blino 270761 Summary: VDPAU plugin for r600 driver
382 blino 300616 Group: System/Libraries
383 tv 302568 # temporary:
384     %rename vdpau-driver-r600
385 blino 270761
386 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
387 blino 289282 Summary: VDPAU plugin for radeonsi driver
388     Group: System/Libraries
389 tv 302568 # temporary:
390     %rename vdpau-driver-radeonsi
391 blino 289282
392 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
393 blino 270761 Summary: VDPAU plugin for softpipe driver
394 blino 300616 Group: System/Libraries
395 tv 302568 # temporary:
396     %rename vdpau-driver-softpipe
397 blino 270761
398 pterjan 5340 %package common-devel
399     Summary: Meta package for mesa devel
400     Group: Development/C
401 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
402 pterjan 5340 Provides: hackMesa-common-devel = %{version}
403 tv 88247 Obsoletes: Mesa-common-devel < %{version}
404 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
405     Requires: %{libglname}-devel = %{version}
406 blino 289355 Requires: mesaglu-devel
407 tv 135156 Requires: freeglut-devel
408 tv 88442 Requires: %{libeglname}-devel = %{version}
409     Requires: %{libglesv1name}-devel = %{version}
410     Requires: %{libglesv2name}-devel = %{version}
411 pterjan 5340
412 tv 88440 #------------------------------------------------------------------------------
413 pterjan 5340
414     %description
415 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
416 tv 135173 %if %{build_plf}
417 pterjan 5340
418 tv 135173 This package is in the "tainted" section because it enables some
419     OpenGL extentions that are covered by software patents.
420     %endif
421    
422 pterjan 5340 %description common-devel
423     Mesa common metapackage devel
424    
425     %if %{enable_egl}
426     %description -n %{libeglname}
427 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
428 pterjan 5340 EGL parts.
429    
430     %description -n %{libeglname}-devel
431 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
432 pterjan 5340 EGL development parts.
433     %endif
434    
435 blino 271501 %description -n %{libdricorename}
436 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
437 blino 271501 DRI core part.
438    
439 pterjan 5340 %description -n %{libglname}
440 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
441 pterjan 5340 GL and GLX parts.
442    
443 tv 135155 %if %{build_plf}
444     This package is in the "tainted" section because it enables some
445     OpenGL extentions that are covered by software patents.
446     %endif
447    
448 pterjan 5340 %description -n %{dridrivers}
449 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
450 pterjan 5340 DRI drivers.
451    
452 blino 271501 %description -n %{libdricorename}-devel
453 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
454 blino 271501
455     This package contains the headers needed to compile DRI drivers.
456    
457 pterjan 5340 %description -n %{libglname}-devel
458 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
459 pterjan 5340
460     This package contains the headers needed to compile Mesa programs.
461    
462 tv 88442 %description -n %{libglesv1name}
463     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
464     well-defined subset profiles of OpenGL.
465    
466     This package provides the OpenGL ES library version 1.
467    
468 anssi 278008 %description -n %{libosmesaname}
469     Mesa offscreen rendering libraries for rendering OpenGL into
470     application-allocated blocks of memory.
471    
472     %description -n %{osmesadevel}
473     This package contains the headers needed to compile programs against
474     the Mesa offscreen rendering library.
475    
476 mikala 112356 %description -n %{libglapiname}
477     This packages provides the glapi shared library used by gallium.
478    
479     %description -n %{libglapiname}-devel
480     This package contains the headers needed to compile programes against glapi shared library.
481    
482 tv 88442 %description -n %{libglesv1name}-devel
483     This package contains the headers needed to compile OpenGL ES 1 programs.
484    
485     %description -n %{libglesv2name}
486     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
487     well-defined subset profiles of OpenGL.
488    
489     This package provides the OpenGL ES library version 2.
490    
491     %description -n %{libglesv2name}-devel
492     This package contains the headers needed to compile OpenGL ES 2 programs.
493    
494 tv 88445 %description -n %{libopenvgname}
495     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
496     acceleration interface for vector graphics libraries such as Flash and SVG.
497    
498     %description -n %{libopenvgname}-devel
499     Development files for OpenVG library.
500    
501 cjw 388874 %description -n %{libllvmradeonname}
502     Gallium LLVM Radeon driver.
503    
504 blino 215979 %if %{enable_wayland}
505     %description -n %{libgbmname}
506 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
507 blino 215979 GBM (Graphics Buffer Manager) parts.
508    
509     %description -n %{libgbmname}-devel
510 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
511 blino 215979 GBM (Graphics Buffer Manager) development parts.
512    
513     %description -n %{libwaylandeglname}
514 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
515 blino 215979 Wayland EGL platform parts.
516    
517     %description -n %{libwaylandeglname}-devel
518 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
519 blino 215979 Wayland EGL platform development parts.
520     %endif
521    
522 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
523 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
524     with the nouveau driver.
525    
526 tv 301233 %description -n %{_lib}vdpau-driver-r300
527 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
528     with the r300 driver.
529    
530 tv 301233 %description -n %{_lib}vdpau-driver-r600
531 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
532     with the r600 driver.
533    
534 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
535 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
536     with the radeonsi driver.
537    
538 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
539 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
540     with the softpipe driver.
541    
542 tv 88440 #------------------------------------------------------------------------------
543    
544 pterjan 5340 %prep
545     %if %{git}
546 cjw 336175 %setup -q -n mesa-%{git}
547     #setup -q -n mesa-%{git_branch}-%{git}
548 pterjan 5340 %else
549 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
550 pterjan 5340 %endif
551    
552 blino 278731 %apply_patches
553 pterjan 5340
554 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
555     # would break build. - Anssi 12/2012
556 cjw 336233 all=$(ls)
557     mkdir -p build-osmesa
558     cp -al $all build-osmesa
559 anssi 332631
560 pterjan 5340 %build
561 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
562     autoreconf -vfi
563    
564 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
565     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
566     export LDFLAGS="-L%{_libdir}/llvm"
567    
568     %configure2_5x --enable-dri \
569     --enable-glx \
570 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
571     --with-dri-drivers="%{dri_drivers}" \
572     %if %{enable_egl}
573     --enable-egl \
574     %else
575     --disable-egl \
576     %endif
577 blino 215979 %if %{enable_wayland}
578     --with-egl-platforms=x11,wayland,drm \
579     --enable-gbm \
580     --enable-shared-glapi \
581     %endif
582 tv 88442 --enable-gles1 \
583     --enable-gles2 \
584 tv 88445 --enable-openvg \
585 mikala 112356 --enable-gallium-egl \
586 blino 270761 --enable-gallium-g3dvl \
587     --disable-xvmc \
588     --enable-vdpau \
589 mikala 112356 %if %{with_hardware}
590 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
591 mikala 112356 --enable-gallium-llvm \
592     %else
593     --disable-gallium-llvm \
594     --with-gallium-drivers=swrast \
595     %endif
596 tv 135155 %if %{build_plf}
597     --enable-texture-float \
598     %endif
599 blino 270723 # end of configure options
600 pterjan 5340
601 anssi 332631
602     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
603     # since doing that causes OSMesa to miss the OpenGL symbols.
604     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
605     # -Anssi 12/2012
606    
607 cjw 336233 pushd build-osmesa
608     autoreconf -vfi
609     %configure2_5x \
610     --enable-osmesa \
611     --disable-dri \
612     --disable-glx \
613     --disable-egl \
614     --disable-shared-glapi \
615     --without-gallium-drivers
616     popd
617 anssi 332631
618 anssi 165988 %make
619 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
620 pterjan 5340
621     %install
622 cjw 336233 %makeinstall_std -C build-osmesa
623 tv 88249 %makeinstall_std
624 pterjan 5340
625 blino 216556 # FIXME: strip will likely break the hardlink
626 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
627     # to prevent proprietary driver installers from removing them
628     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
629     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
630     for l in ../libGL.so.*; do cp -a $l .; done
631     popd
632    
633     %ifarch %{x86_64}
634     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
635     %endif
636    
637 blino 270761 # .so files are not needed by vdpau
638     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
639    
640 blino 271144 # .la files are not needed by mesa
641     find %{buildroot} -name '*.la' -exec rm {} \;
642    
643 anssi 181478 # use swrastg if built (Anssi 12/2011)
644     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
645    
646 tv 88440 #------------------------------------------------------------------------------
647    
648 pterjan 5340 %files
649     %defattr(-,root,root)
650 blino 271481 %doc docs/COPYING
651 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
652 pterjan 5340
653 blino 271501 %files -n %{libdricorename}
654     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
655     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
656    
657     %files -n %{libdricorename}-devel
658     %{_libdir}/libdricore%{version}.so
659    
660 pterjan 5340 %files -n %{dridrivers}
661     %defattr(-,root,root)
662     %doc docs/COPYING
663     %ifnarch ppc64
664     %dir %{_libdir}/dri
665 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
666     #%{_libdir}/dri/libglsl.so
667 pterjan 5340 %{_libdir}/dri/*_dri.so
668     %endif
669    
670 tv 88433 %files -n %{libglname}
671     %defattr(-,root,root)
672     %doc docs/COPYING
673     %{_libdir}/libGL.so.*
674     %dir %{_libdir}/mesa
675 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
676 tv 88433
677     %if %{enable_egl}
678     %files -n %{libeglname}
679     %defattr(-,root,root)
680 tv 88442 %doc docs/COPYING
681 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
682 tv 88442 %dir %{_libdir}/egl
683 blino 215979 %if !%{enable_wayland}
684     # st_GL, built only when shared glapi is not enabled
685 mikala 112356 %{_libdir}/egl/st_GL.so
686 blino 215979 %endif
687 mikala 127466 %{_libdir}/egl/egl_gallium.so
688 tv 88441 %endif
689 tv 88433
690 anssi 278008 %files -n %{libosmesaname}
691     %defattr(-,root,root)
692     %{_libdir}/libOSMesa.so.%{osmesamajor}*
693    
694 mikala 112356 %files -n %{libglapiname}
695     %defattr(-,root,root)
696     %{_libdir}/libglapi.so.%{glapimajor}*
697    
698 tv 88442 %files -n %{libglesv1name}
699     %defattr(-,root,root)
700     %doc docs/COPYING
701     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
702    
703     %files -n %{libglesv2name}
704     %defattr(-,root,root)
705     %doc docs/COPYING
706     %{_libdir}/libGLESv2.so.%{glesv2major}*
707    
708 tv 88445 %files -n %{libopenvgname}
709     %defattr(-,root,root)
710     %doc docs/COPYING
711     %{_libdir}/libOpenVG.so.%{openvgmajor}*
712    
713 cjw 388874 %files -n %{libllvmradeonname}
714     %defattr(-,root,root)
715 tv 404192 %{_libdir}/libllvmradeon%version.so
716 cjw 388874
717 blino 215979 %if %{enable_wayland}
718     %files -n %{libgbmname}
719     %{_libdir}/libgbm.so.%{gbmmajor}
720 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
721 blino 215979 %{_libdir}/gbm/gbm_*.so
722 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
723 tv 88445
724 blino 215979 %files -n %{libwaylandeglname}
725     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
726 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
727 blino 215979 %endif
728    
729    
730 pterjan 5340 %files -n %{libglname}-devel
731     %defattr(-,root,root)
732     %doc docs/COPYING
733 anssi 278008 %dir %{_includedir}/GL
734 pterjan 5340 %{_includedir}/GL/gl.h
735     %{_includedir}/GL/glext.h
736     %{_includedir}/GL/gl_mangle.h
737     %{_includedir}/GL/wglext.h
738     %{_includedir}/GL/glx.h
739     %{_includedir}/GL/glxext.h
740     %{_includedir}/GL/glx_mangle.h
741     %{_libdir}/libGL.so
742 tv 88436 %{_libdir}/pkgconfig/gl.pc
743     %{_libdir}/pkgconfig/dri.pc
744 pterjan 5340
745     #FIXME: check those headers
746 cjw 336175 #{_includedir}/GL/vms_x_fix.h
747 pterjan 5340 %{_includedir}/GL/wmesa.h
748     %dir %{_includedir}/GL/internal
749     %{_includedir}/GL/internal/dri_interface.h
750    
751     %files common-devel
752     %defattr(-,root,root)
753    
754 tv 88441 %if %{enable_egl}
755 tv 88433 %files -n %{libeglname}-devel
756     %defattr(-,root,root)
757 tv 88442 %doc docs/COPYING
758     %{_includedir}/EGL
759     %{_includedir}/KHR
760 tv 88433 %{_libdir}/libEGL.so
761 tv 88436 %{_libdir}/pkgconfig/egl.pc
762 tv 88433 %endif
763 pterjan 5340
764 anssi 278008 %files -n %{osmesadevel}
765     %defattr(-,root,root)
766     %dir %{_includedir}/GL
767     %{_includedir}/GL/osmesa.h
768     %{_libdir}/libOSMesa.so
769     %{_libdir}/pkgconfig/osmesa.pc
770    
771 mikala 112356 %files -n %{libglapiname}-devel
772     %defattr(-,root,root)
773     %{_libdir}/libglapi.so
774 pterjan 5340
775 tv 88442 %files -n %{libglesv1name}-devel
776     %defattr(-,root,root)
777     %{_includedir}/GLES
778     %{_libdir}/libGLESv1_CM.so
779     %{_libdir}/pkgconfig/glesv1_cm.pc
780 tv 88433
781 tv 88442 %files -n %{libglesv2name}-devel
782     %defattr(-,root,root)
783     %{_includedir}/GLES2
784 cjw 336175 %{_includedir}/GLES3
785 tv 88442 %{_libdir}/libGLESv2.so
786     %{_libdir}/pkgconfig/glesv2.pc
787 tv 88445
788     %files -n %{libopenvgname}-devel
789     %defattr(-,root,root)
790     %{_includedir}/VG
791     %{_libdir}/libOpenVG.so
792     %{_libdir}/pkgconfig/vg.pc
793 blino 215979
794     %if %{enable_wayland}
795     %files -n %{libgbmname}-devel
796     %{_includedir}/gbm.h
797     %{_libdir}/libgbm.so
798     %{_libdir}/pkgconfig/gbm.pc
799    
800     %files -n %{libwaylandeglname}-devel
801     %{_libdir}/libwayland-egl.so
802     %{_libdir}/pkgconfig/wayland-egl.pc
803     %endif
804 blino 270761
805 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
806 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
807    
808 tv 301233 %files -n %{_lib}vdpau-driver-r300
809 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
810    
811 tv 301233 %files -n %{_lib}vdpau-driver-r600
812 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
813    
814 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
815 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
816    
817 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
818 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30