/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 469191 - (hide annotations) (download)
Wed Aug 21 22:05:13 2013 UTC (11 years ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23259 byte(s)
libllvmradeon is no more
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 469145 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 469080 %define relc 1
25 pterjan 5340 %define name mesa
26 tv 469080 %define fversion 9.2.0
27     %define version 9.2.0
28 tv 469145 %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 tv 88442
74 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
75 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
76     %define libglname %mklibname %{glname} %{glmajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libglwname_virt lib%{glwname}
95 tv 88442 %define libglesv1name_virt lib%{glesv1name}
96     %define libglesv2name_virt lib%{glesv2name}
97 tv 88445 %define libopenvgname_virt lib%{openvgname}
98 mikala 112356 %define libglapiname_virt lib%{glapiname}
99 blino 215979 %define libgbmname_virt lib%{gbmname}
100     %define libwaylandeglname_virt lib%{waylandeglname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131     BuildRequires: pkgconfig(xt) >= 1.0.5
132     BuildRequires: pkgconfig(xmu) >= 1.0.3
133     BuildRequires: pkgconfig(x11) >= 1.3.3
134     BuildRequires: pkgconfig(xdamage) >= 1.1.1
135 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
136     BuildRequires: gccmakedep
137     BuildRequires: x11-proto-devel >= 7.3
138 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
139 pterjan 5340
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 dmorgan 106004 BuildRequires: bison flex
147 tv 469143 BuildRequires: libelf-devel
148 tv 469141 BuildRequires: llvm-devel > 3.3-1
149 mikala 127466 BuildRequires: pkgconfig(libudev)
150 blino 270761 BuildRequires: pkgconfig(vdpau)
151 blino 215979 %if %{enable_wayland}
152     BuildRequires: wayland-devel
153     %endif
154 pterjan 5340
155     URL: http://www.mesa3d.org
156     %if %{git}
157 cjw 336175 Source0: %{name}-%{git}.tar.bz2
158 blino 289278 # (blino) snapshot of 9.0 branch
159 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
160 pterjan 5340 %else
161 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
162 pterjan 5340 %endif
163     Source3: make-git-snapshot.sh
164    
165     # Instructions to setup your repository clone
166     # git://git.freedesktop.org/git/mesa/mesa
167     # git checkout mesa_7_5_branch
168     # git branch mdv-cherry-picks
169     # git am ../02??-*.patch
170     # git branch mdv-redhat
171     # git am ../03??-*.patch
172     # git branch mdv-patches
173     # git am ../09??-*.patch
174     # In order to update to the branch via patches, issue this command:
175     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
176    
177     # Cherry picks
178     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
179     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
180 tmb 411326
181 blino 289280 # (blino) should be pushed to 9.0 branch upstream
182 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
183     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
184 pterjan 5340
185 tv 88247 # Patches "liberated" from Fedora:
186 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
187     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
188    
189 blino 278732 # Patches from ChromiumOS
190     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191    
192 blino 271493 # Mageia/Mandriva patches
193 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
195 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
196 pterjan 5340
197 tv 88440 #------------------------------------------------------------------------------
198    
199     # package mesa
200 pterjan 5340 License: MIT
201     Requires: %{libglname} = %{version}-%{release}
202     Provides: hackMesa = %{version}
203     Obsoletes: hackMesa <= %{version}
204     Provides: Mesa = %{version}
205     Obsoletes: Mesa < %{version}
206    
207 blino 271501 %package -n %{libdricorename}
208     Summary: Shared library for DRI drivers
209     Group: System/Libraries
210     Provides: %{libdricorename_virt} = %{version}-%{release}
211    
212     %package -n %{libdricorename}-devel
213     Summary: Development files for DRI core
214     Group: Development/C
215     Requires: %{libdricorename} = %{version}-%{release}
216     Provides: lib%{dricorename}-devel = %{version}-%{release}
217     Provides: %{dricorename}-devel = %{version}-%{release}
218    
219 pterjan 5340 %package -n %{libglname}
220     Summary: Files for Mesa (GL and GLX libs)
221     Group: System/Libraries
222 tv 88247 Obsoletes: %{oldlibglname} < 6.4
223 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
224     Provides: %{libglname_virt} = %{version}-%{release}
225     Requires: %{dridrivers} >= %{version}-%{release}
226 tv 135172 %if %{build_plf}
227     Requires: %mklibname txc-dxtn
228     %endif
229 pterjan 5340
230     # (anssi) Forces the upgrade of x11-server-common to happen before
231     # alternatives removal, which allows x11-server-common to grab the symlink.
232     Conflicts: x11-server-common < 1.3.0.0-17
233    
234     %package -n %{dridrivers}
235     Summary: Mesa DRI drivers
236     Group: System/Libraries
237 blino 274132 # do not require exact release to avoid conflicts when having
238     # x86_64 dri drivers from tainted and i586 dri drivers from core
239     Requires: mesa = %{version}
240 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
241 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
242     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
243 pterjan 5340
244     %package -n %{libglname}-devel
245     Summary: Development files for Mesa (OpenGL compatible 3D lib)
246     Group: Development/C
247 tv 88237 Requires: %{libglname} = %{version}-%{release}
248 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
249     Provides: %{glname}-devel = %{version}-%{release}
250     Provides: GL-devel
251     Obsoletes: %{oldlibglname}-devel < 6.4
252     Provides: %{oldlibglname}-devel = %{version}-%{release}
253     Provides: libMesaGL-devel = %{version}-%{release}
254     Provides: MesaGL-devel = %{version}-%{release}
255 tv 88438 Provides: libgl-devel
256 pterjan 5340
257 tv 88433 %if %{enable_egl}
258     %package -n %{libeglname}
259     Summary: Files for Mesa (EGL libs)
260     Group: System/Libraries
261     Provides: %{libeglname_virt} = %{version}-%{release}
262    
263     %package -n %{libeglname}-devel
264     Summary: Development files for Mesa (EGL libs)
265     Group: Development/C
266 tv 88439 Requires: %{libeglname} = %{version}-%{release}
267 tv 88433 Provides: EGL-devel
268 tv 88438 Provides: lib%{eglname}-devel
269     Provides: %{eglname}-devel
270     Provides: libegl-devel
271 tv 88433 %endif
272    
273 anssi 278008 %package -n %{libosmesaname}
274     Summary: Mesa offscreen rendering library
275     Group: System/Libraries
276    
277     %package -n %{osmesadevel}
278     Summary: Development files for libosmesa
279     Group: Development/C
280     Requires: %{libosmesaname} = %{version}-%{release}
281     Provides: osmesa-devel = %{version}-%{release}
282     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
283    
284 mikala 112356 %package -n %{libglapiname}
285     Summary: Files for mesa (glapi libs)
286     Group: System/Libraries
287     Provides: %{libglapiname_virt} = %{version}-%{release}
288 tv 88442
289 mikala 112356 %package -n %{libglapiname}-devel
290     Summary: Development files for glapi libs
291     Group: Development/C
292     Requires: %{libglapiname_virt} = %{version}-%{release}
293     Provides: lib%{glapiname}-devel
294     Provides: %{libglapiname}-devel
295    
296 tv 88442 %package -n %{libglesv1name}
297     Summary: Files for Mesa (glesv1 libs)
298     Group: System/Libraries
299     Provides: %{libglesv1name_virt} = %{version}-%{release}
300    
301     %package -n %{libglesv1name}-devel
302     Summary: Development files for glesv1 libs
303     Group: Development/C
304     Requires: %{libglesv1name} = %{version}-%{release}
305     Provides: lib%{glesv1name}-devel
306     Provides: %{glesv1name}-devel
307     Provides: libglesv1-devel
308    
309     %package -n %{libglesv2name}
310     Summary: Files for Mesa (glesv2 libs)
311     Group: System/Libraries
312     Provides: %{libglesv2name_virt} = %{version}-%{release}
313    
314     %package -n %{libglesv2name}-devel
315     Summary: Development files for glesv2 libs
316     Group: Development/C
317     Requires: %{libglesv2name} = %{version}-%{release}
318 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
319 tv 88442 Provides: lib%{glesv2name}-devel
320     Provides: %{glesv2name}-devel
321     Provides: libglesv2-devel
322    
323 tv 88445 %package -n %{libopenvgname}
324     Summary: Files for MESA (OpenVG libs)
325     Group: System/Libraries
326     Provides: %{libopenvgname_virt} = %{version}-%{release}
327    
328     %package -n %{libopenvgname}-devel
329     Summary: Development files vor OpenVG libs
330     Group: Development/C
331     Requires: %{libopenvgname} = %{version}-%{release}
332     Provides: lib%{openvgname}-devel
333     Provides: %{openvgname}-devel
334     Provides: libopenvg-devel
335    
336 blino 215979 %if %{enable_wayland}
337     %package -n %{libgbmname}
338     Summary: Files for Mesa (gbm libs)
339     Group: System/Libraries
340     Provides: %{libgbmname_virt} = %{version}-%{release}
341    
342     %package -n %{libgbmname}-devel
343     Summary: Development files for Mesa (gbm libs)
344     Group: Development/C
345     Requires: %{libgbmname} = %{version}-%{release}
346     Provides: lib%{gbmname}-devel
347     Provides: %{gbmname}-devel
348    
349     %package -n %{libwaylandeglname}
350     Summary: Files for Mesa (Wayland EGL libs)
351     Group: System/Libraries
352     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
353    
354     %package -n %{libwaylandeglname}-devel
355     Summary: Development files for Mesa (Wayland EGL libs)
356     Group: Development/C
357     Requires: %{libwaylandeglname} = %{version}-%{release}
358     Provides: lib%{waylandeglname}-devel
359     Provides: %{waylandeglname}-devel
360     %endif
361    
362 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
363 blino 270761 Summary: VDPAU plugin for nouveau driver
364 blino 300616 Group: System/Libraries
365 tv 302568 # temporary:
366     %rename vdpau-driver-nouveau
367 blino 270761
368 tv 301233 %package -n %{_lib}vdpau-driver-r300
369 blino 270761 Summary: VDPAU plugin for r300 driver
370 blino 300616 Group: System/Libraries
371 tv 302568 # temporary:
372     %rename vdpau-driver-r300
373 blino 270761
374 tv 301233 %package -n %{_lib}vdpau-driver-r600
375 blino 270761 Summary: VDPAU plugin for r600 driver
376 blino 300616 Group: System/Libraries
377 tv 302568 # temporary:
378     %rename vdpau-driver-r600
379 blino 270761
380 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
381 blino 289282 Summary: VDPAU plugin for radeonsi driver
382     Group: System/Libraries
383 tv 302568 # temporary:
384     %rename vdpau-driver-radeonsi
385 blino 289282
386 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
387 blino 270761 Summary: VDPAU plugin for softpipe driver
388 blino 300616 Group: System/Libraries
389 tv 302568 # temporary:
390     %rename vdpau-driver-softpipe
391 blino 270761
392 pterjan 5340 %package common-devel
393     Summary: Meta package for mesa devel
394     Group: Development/C
395 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
396 pterjan 5340 Provides: hackMesa-common-devel = %{version}
397 tv 88247 Obsoletes: Mesa-common-devel < %{version}
398 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
399     Requires: %{libglname}-devel = %{version}
400 blino 289355 Requires: mesaglu-devel
401 tv 135156 Requires: freeglut-devel
402 tv 88442 Requires: %{libeglname}-devel = %{version}
403     Requires: %{libglesv1name}-devel = %{version}
404     Requires: %{libglesv2name}-devel = %{version}
405 pterjan 5340
406 tv 88440 #------------------------------------------------------------------------------
407 pterjan 5340
408     %description
409 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
410 tv 135173 %if %{build_plf}
411 pterjan 5340
412 tv 135173 This package is in the "tainted" section because it enables some
413     OpenGL extentions that are covered by software patents.
414     %endif
415    
416 pterjan 5340 %description common-devel
417     Mesa common metapackage devel
418    
419     %if %{enable_egl}
420     %description -n %{libeglname}
421 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
422 pterjan 5340 EGL parts.
423    
424     %description -n %{libeglname}-devel
425 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
426 pterjan 5340 EGL development parts.
427     %endif
428    
429 blino 271501 %description -n %{libdricorename}
430 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
431 blino 271501 DRI core part.
432    
433 pterjan 5340 %description -n %{libglname}
434 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
435 pterjan 5340 GL and GLX parts.
436    
437 tv 135155 %if %{build_plf}
438     This package is in the "tainted" section because it enables some
439     OpenGL extentions that are covered by software patents.
440     %endif
441    
442 pterjan 5340 %description -n %{dridrivers}
443 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
444 pterjan 5340 DRI drivers.
445    
446 blino 271501 %description -n %{libdricorename}-devel
447 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
448 blino 271501
449     This package contains the headers needed to compile DRI drivers.
450    
451 pterjan 5340 %description -n %{libglname}-devel
452 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
453 pterjan 5340
454     This package contains the headers needed to compile Mesa programs.
455    
456 tv 88442 %description -n %{libglesv1name}
457     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
458     well-defined subset profiles of OpenGL.
459    
460     This package provides the OpenGL ES library version 1.
461    
462 anssi 278008 %description -n %{libosmesaname}
463     Mesa offscreen rendering libraries for rendering OpenGL into
464     application-allocated blocks of memory.
465    
466     %description -n %{osmesadevel}
467     This package contains the headers needed to compile programs against
468     the Mesa offscreen rendering library.
469    
470 mikala 112356 %description -n %{libglapiname}
471     This packages provides the glapi shared library used by gallium.
472    
473     %description -n %{libglapiname}-devel
474     This package contains the headers needed to compile programes against glapi shared library.
475    
476 tv 88442 %description -n %{libglesv1name}-devel
477     This package contains the headers needed to compile OpenGL ES 1 programs.
478    
479     %description -n %{libglesv2name}
480     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
481     well-defined subset profiles of OpenGL.
482    
483     This package provides the OpenGL ES library version 2.
484    
485     %description -n %{libglesv2name}-devel
486     This package contains the headers needed to compile OpenGL ES 2 programs.
487    
488 tv 88445 %description -n %{libopenvgname}
489     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
490     acceleration interface for vector graphics libraries such as Flash and SVG.
491    
492     %description -n %{libopenvgname}-devel
493     Development files for OpenVG library.
494    
495 blino 215979 %if %{enable_wayland}
496     %description -n %{libgbmname}
497 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
498 blino 215979 GBM (Graphics Buffer Manager) parts.
499    
500     %description -n %{libgbmname}-devel
501 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
502 blino 215979 GBM (Graphics Buffer Manager) development parts.
503    
504     %description -n %{libwaylandeglname}
505 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
506 blino 215979 Wayland EGL platform parts.
507    
508     %description -n %{libwaylandeglname}-devel
509 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
510 blino 215979 Wayland EGL platform development parts.
511     %endif
512    
513 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
514 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
515     with the nouveau driver.
516    
517 tv 301233 %description -n %{_lib}vdpau-driver-r300
518 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
519     with the r300 driver.
520    
521 tv 301233 %description -n %{_lib}vdpau-driver-r600
522 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
523     with the r600 driver.
524    
525 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
526 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
527     with the radeonsi driver.
528    
529 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
530 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
531     with the softpipe driver.
532    
533 tv 88440 #------------------------------------------------------------------------------
534    
535 pterjan 5340 %prep
536     %if %{git}
537 cjw 336175 %setup -q -n mesa-%{git}
538     #setup -q -n mesa-%{git_branch}-%{git}
539 pterjan 5340 %else
540 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
541 pterjan 5340 %endif
542    
543 blino 278731 %apply_patches
544 pterjan 5340
545 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
546     # would break build. - Anssi 12/2012
547 cjw 336233 all=$(ls)
548     mkdir -p build-osmesa
549     cp -al $all build-osmesa
550 anssi 332631
551 pterjan 5340 %build
552 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
553     autoreconf -vfi
554    
555 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
556     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
557     export LDFLAGS="-L%{_libdir}/llvm"
558    
559     %configure2_5x --enable-dri \
560     --enable-glx \
561 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
562     --with-dri-drivers="%{dri_drivers}" \
563     %if %{enable_egl}
564     --enable-egl \
565     %else
566     --disable-egl \
567     %endif
568 blino 215979 %if %{enable_wayland}
569     --with-egl-platforms=x11,wayland,drm \
570     --enable-gbm \
571     --enable-shared-glapi \
572     %endif
573 tv 88442 --enable-gles1 \
574     --enable-gles2 \
575 tv 88445 --enable-openvg \
576 mikala 112356 --enable-gallium-egl \
577 blino 270761 --enable-gallium-g3dvl \
578     --disable-xvmc \
579     --enable-vdpau \
580 mikala 112356 %if %{with_hardware}
581 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
582 mikala 112356 --enable-gallium-llvm \
583     %else
584     --disable-gallium-llvm \
585     --with-gallium-drivers=swrast \
586     %endif
587 tv 135155 %if %{build_plf}
588     --enable-texture-float \
589     %endif
590 blino 270723 # end of configure options
591 pterjan 5340
592 anssi 332631
593     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
594     # since doing that causes OSMesa to miss the OpenGL symbols.
595     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
596     # -Anssi 12/2012
597    
598 cjw 336233 pushd build-osmesa
599     autoreconf -vfi
600     %configure2_5x \
601     --enable-osmesa \
602     --disable-dri \
603     --disable-glx \
604     --disable-egl \
605     --disable-shared-glapi \
606     --without-gallium-drivers
607     popd
608 anssi 332631
609 anssi 165988 %make
610 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
611 pterjan 5340
612     %install
613 cjw 336233 %makeinstall_std -C build-osmesa
614 tv 88249 %makeinstall_std
615 pterjan 5340
616 blino 216556 # FIXME: strip will likely break the hardlink
617 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
618     # to prevent proprietary driver installers from removing them
619     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
620     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
621     for l in ../libGL.so.*; do cp -a $l .; done
622     popd
623    
624     %ifarch %{x86_64}
625     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
626     %endif
627    
628 blino 270761 # .so files are not needed by vdpau
629     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
630    
631 blino 271144 # .la files are not needed by mesa
632     find %{buildroot} -name '*.la' -exec rm {} \;
633    
634 anssi 181478 # use swrastg if built (Anssi 12/2011)
635     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
636    
637 tv 88440 #------------------------------------------------------------------------------
638    
639 pterjan 5340 %files
640     %defattr(-,root,root)
641 blino 271481 %doc docs/COPYING
642 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
643 pterjan 5340
644 blino 271501 %files -n %{libdricorename}
645 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}
646     %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}.*
647 blino 271501
648     %files -n %{libdricorename}-devel
649 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so
650 blino 271501
651 pterjan 5340 %files -n %{dridrivers}
652     %defattr(-,root,root)
653     %doc docs/COPYING
654     %ifnarch ppc64
655     %dir %{_libdir}/dri
656 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
657     #%{_libdir}/dri/libglsl.so
658 pterjan 5340 %{_libdir}/dri/*_dri.so
659     %endif
660    
661 tv 88433 %files -n %{libglname}
662     %defattr(-,root,root)
663     %doc docs/COPYING
664     %{_libdir}/libGL.so.*
665     %dir %{_libdir}/mesa
666 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
667 tv 88433
668     %if %{enable_egl}
669     %files -n %{libeglname}
670     %defattr(-,root,root)
671 tv 88442 %doc docs/COPYING
672 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
673 tv 88442 %dir %{_libdir}/egl
674 blino 215979 %if !%{enable_wayland}
675     # st_GL, built only when shared glapi is not enabled
676 mikala 112356 %{_libdir}/egl/st_GL.so
677 blino 215979 %endif
678 mikala 127466 %{_libdir}/egl/egl_gallium.so
679 tv 88441 %endif
680 tv 88433
681 anssi 278008 %files -n %{libosmesaname}
682     %defattr(-,root,root)
683     %{_libdir}/libOSMesa.so.%{osmesamajor}*
684    
685 mikala 112356 %files -n %{libglapiname}
686     %defattr(-,root,root)
687     %{_libdir}/libglapi.so.%{glapimajor}*
688    
689 tv 88442 %files -n %{libglesv1name}
690     %defattr(-,root,root)
691     %doc docs/COPYING
692     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
693    
694     %files -n %{libglesv2name}
695     %defattr(-,root,root)
696     %doc docs/COPYING
697     %{_libdir}/libGLESv2.so.%{glesv2major}*
698    
699 tv 88445 %files -n %{libopenvgname}
700     %defattr(-,root,root)
701     %doc docs/COPYING
702     %{_libdir}/libOpenVG.so.%{openvgmajor}*
703    
704 blino 215979 %if %{enable_wayland}
705     %files -n %{libgbmname}
706     %{_libdir}/libgbm.so.%{gbmmajor}
707 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
708 blino 215979 %{_libdir}/gbm/gbm_*.so
709 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
710 tv 88445
711 blino 215979 %files -n %{libwaylandeglname}
712     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
713 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
714 blino 215979 %endif
715    
716    
717 pterjan 5340 %files -n %{libglname}-devel
718     %defattr(-,root,root)
719     %doc docs/COPYING
720 anssi 278008 %dir %{_includedir}/GL
721 pterjan 5340 %{_includedir}/GL/gl.h
722     %{_includedir}/GL/glext.h
723     %{_includedir}/GL/gl_mangle.h
724     %{_includedir}/GL/wglext.h
725     %{_includedir}/GL/glx.h
726     %{_includedir}/GL/glxext.h
727     %{_includedir}/GL/glx_mangle.h
728     %{_libdir}/libGL.so
729 tv 88436 %{_libdir}/pkgconfig/gl.pc
730     %{_libdir}/pkgconfig/dri.pc
731 pterjan 5340
732     #FIXME: check those headers
733 cjw 336175 #{_includedir}/GL/vms_x_fix.h
734 pterjan 5340 %{_includedir}/GL/wmesa.h
735     %dir %{_includedir}/GL/internal
736     %{_includedir}/GL/internal/dri_interface.h
737    
738     %files common-devel
739     %defattr(-,root,root)
740    
741 tv 88441 %if %{enable_egl}
742 tv 88433 %files -n %{libeglname}-devel
743     %defattr(-,root,root)
744 tv 88442 %doc docs/COPYING
745     %{_includedir}/EGL
746     %{_includedir}/KHR
747 tv 88433 %{_libdir}/libEGL.so
748 tv 88436 %{_libdir}/pkgconfig/egl.pc
749 tv 88433 %endif
750 pterjan 5340
751 anssi 278008 %files -n %{osmesadevel}
752     %defattr(-,root,root)
753     %dir %{_includedir}/GL
754     %{_includedir}/GL/osmesa.h
755     %{_libdir}/libOSMesa.so
756     %{_libdir}/pkgconfig/osmesa.pc
757    
758 mikala 112356 %files -n %{libglapiname}-devel
759     %defattr(-,root,root)
760     %{_libdir}/libglapi.so
761 pterjan 5340
762 tv 88442 %files -n %{libglesv1name}-devel
763     %defattr(-,root,root)
764     %{_includedir}/GLES
765     %{_libdir}/libGLESv1_CM.so
766     %{_libdir}/pkgconfig/glesv1_cm.pc
767 tv 88433
768 tv 88442 %files -n %{libglesv2name}-devel
769     %defattr(-,root,root)
770     %{_includedir}/GLES2
771 cjw 336175 %{_includedir}/GLES3
772 tv 88442 %{_libdir}/libGLESv2.so
773     %{_libdir}/pkgconfig/glesv2.pc
774 tv 88445
775     %files -n %{libopenvgname}-devel
776     %defattr(-,root,root)
777     %{_includedir}/VG
778     %{_libdir}/libOpenVG.so
779     %{_libdir}/pkgconfig/vg.pc
780 blino 215979
781     %if %{enable_wayland}
782     %files -n %{libgbmname}-devel
783     %{_includedir}/gbm.h
784     %{_libdir}/libgbm.so
785     %{_libdir}/pkgconfig/gbm.pc
786    
787     %files -n %{libwaylandeglname}-devel
788     %{_libdir}/libwayland-egl.so
789     %{_libdir}/pkgconfig/wayland-egl.pc
790     %endif
791 blino 270761
792 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
793 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
794    
795 tv 301233 %files -n %{_lib}vdpau-driver-r300
796 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
797    
798 tv 301233 %files -n %{_lib}vdpau-driver-r600
799 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
800    
801 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
802 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
803    
804 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
805 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30