/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 472610 - (hide annotations) (download)
Wed Aug 28 12:11:52 2013 UTC (10 years, 7 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23306 byte(s)
new release
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 469145 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 472610 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 469080 %define fversion 9.2.0
27     %define version 9.2.0
28 tv 469145 %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 tv 88442
74 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
75 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
76     %define libglname %mklibname %{glname} %{glmajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libglwname_virt lib%{glwname}
95 tv 88442 %define libglesv1name_virt lib%{glesv1name}
96     %define libglesv2name_virt lib%{glesv2name}
97 tv 88445 %define libopenvgname_virt lib%{openvgname}
98 mikala 112356 %define libglapiname_virt lib%{glapiname}
99 blino 215979 %define libgbmname_virt lib%{gbmname}
100     %define libwaylandeglname_virt lib%{waylandeglname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131     BuildRequires: pkgconfig(xt) >= 1.0.5
132     BuildRequires: pkgconfig(xmu) >= 1.0.3
133     BuildRequires: pkgconfig(x11) >= 1.3.3
134     BuildRequires: pkgconfig(xdamage) >= 1.1.1
135 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
136     BuildRequires: gccmakedep
137     BuildRequires: x11-proto-devel >= 7.3
138 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
139 pterjan 5340
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 dmorgan 106004 BuildRequires: bison flex
147 tv 469143 BuildRequires: libelf-devel
148 tv 469141 BuildRequires: llvm-devel > 3.3-1
149 mikala 127466 BuildRequires: pkgconfig(libudev)
150 blino 270761 BuildRequires: pkgconfig(vdpau)
151 blino 215979 %if %{enable_wayland}
152     BuildRequires: wayland-devel
153     %endif
154 pterjan 5340
155     URL: http://www.mesa3d.org
156     %if %{git}
157 cjw 336175 Source0: %{name}-%{git}.tar.bz2
158 blino 289278 # (blino) snapshot of 9.0 branch
159 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
160 pterjan 5340 %else
161 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
162 pterjan 5340 %endif
163     Source3: make-git-snapshot.sh
164 fwang 469263 Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
165 pterjan 5340
166     # Instructions to setup your repository clone
167     # git://git.freedesktop.org/git/mesa/mesa
168     # git checkout mesa_7_5_branch
169     # git branch mdv-cherry-picks
170     # git am ../02??-*.patch
171     # git branch mdv-redhat
172     # git am ../03??-*.patch
173     # git branch mdv-patches
174     # git am ../09??-*.patch
175     # In order to update to the branch via patches, issue this command:
176     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
177    
178     # Cherry picks
179     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
180     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
181 tmb 411326
182 blino 289280 # (blino) should be pushed to 9.0 branch upstream
183 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
184     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
185 pterjan 5340
186 tv 88247 # Patches "liberated" from Fedora:
187 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
188     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
189    
190 blino 278732 # Patches from ChromiumOS
191     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
192    
193 blino 271493 # Mageia/Mandriva patches
194 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
195 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
196 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
197 pterjan 5340
198 tv 88440 #------------------------------------------------------------------------------
199    
200     # package mesa
201 pterjan 5340 License: MIT
202     Requires: %{libglname} = %{version}-%{release}
203     Provides: hackMesa = %{version}
204     Obsoletes: hackMesa <= %{version}
205     Provides: Mesa = %{version}
206     Obsoletes: Mesa < %{version}
207    
208 blino 271501 %package -n %{libdricorename}
209     Summary: Shared library for DRI drivers
210     Group: System/Libraries
211     Provides: %{libdricorename_virt} = %{version}-%{release}
212    
213     %package -n %{libdricorename}-devel
214     Summary: Development files for DRI core
215     Group: Development/C
216     Requires: %{libdricorename} = %{version}-%{release}
217     Provides: lib%{dricorename}-devel = %{version}-%{release}
218     Provides: %{dricorename}-devel = %{version}-%{release}
219    
220 pterjan 5340 %package -n %{libglname}
221     Summary: Files for Mesa (GL and GLX libs)
222     Group: System/Libraries
223 tv 88247 Obsoletes: %{oldlibglname} < 6.4
224 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
225     Provides: %{libglname_virt} = %{version}-%{release}
226     Requires: %{dridrivers} >= %{version}-%{release}
227 tv 135172 %if %{build_plf}
228     Requires: %mklibname txc-dxtn
229     %endif
230 pterjan 5340
231     # (anssi) Forces the upgrade of x11-server-common to happen before
232     # alternatives removal, which allows x11-server-common to grab the symlink.
233     Conflicts: x11-server-common < 1.3.0.0-17
234    
235     %package -n %{dridrivers}
236     Summary: Mesa DRI drivers
237     Group: System/Libraries
238 blino 274132 # do not require exact release to avoid conflicts when having
239     # x86_64 dri drivers from tainted and i586 dri drivers from core
240     Requires: mesa = %{version}
241 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
242 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
243     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
244 pterjan 5340
245     %package -n %{libglname}-devel
246     Summary: Development files for Mesa (OpenGL compatible 3D lib)
247     Group: Development/C
248 tv 88237 Requires: %{libglname} = %{version}-%{release}
249 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
250     Provides: %{glname}-devel = %{version}-%{release}
251     Provides: GL-devel
252     Obsoletes: %{oldlibglname}-devel < 6.4
253     Provides: %{oldlibglname}-devel = %{version}-%{release}
254     Provides: libMesaGL-devel = %{version}-%{release}
255     Provides: MesaGL-devel = %{version}-%{release}
256 tv 88438 Provides: libgl-devel
257 pterjan 5340
258 tv 88433 %if %{enable_egl}
259     %package -n %{libeglname}
260     Summary: Files for Mesa (EGL libs)
261     Group: System/Libraries
262     Provides: %{libeglname_virt} = %{version}-%{release}
263    
264     %package -n %{libeglname}-devel
265     Summary: Development files for Mesa (EGL libs)
266     Group: Development/C
267 tv 88439 Requires: %{libeglname} = %{version}-%{release}
268 tv 88433 Provides: EGL-devel
269 tv 88438 Provides: lib%{eglname}-devel
270     Provides: %{eglname}-devel
271     Provides: libegl-devel
272 tv 88433 %endif
273    
274 anssi 278008 %package -n %{libosmesaname}
275     Summary: Mesa offscreen rendering library
276     Group: System/Libraries
277    
278     %package -n %{osmesadevel}
279     Summary: Development files for libosmesa
280     Group: Development/C
281     Requires: %{libosmesaname} = %{version}-%{release}
282     Provides: osmesa-devel = %{version}-%{release}
283     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
284    
285 mikala 112356 %package -n %{libglapiname}
286     Summary: Files for mesa (glapi libs)
287     Group: System/Libraries
288     Provides: %{libglapiname_virt} = %{version}-%{release}
289 tv 88442
290 mikala 112356 %package -n %{libglapiname}-devel
291     Summary: Development files for glapi libs
292     Group: Development/C
293     Requires: %{libglapiname_virt} = %{version}-%{release}
294     Provides: lib%{glapiname}-devel
295     Provides: %{libglapiname}-devel
296    
297 tv 88442 %package -n %{libglesv1name}
298     Summary: Files for Mesa (glesv1 libs)
299     Group: System/Libraries
300     Provides: %{libglesv1name_virt} = %{version}-%{release}
301    
302     %package -n %{libglesv1name}-devel
303     Summary: Development files for glesv1 libs
304     Group: Development/C
305     Requires: %{libglesv1name} = %{version}-%{release}
306     Provides: lib%{glesv1name}-devel
307     Provides: %{glesv1name}-devel
308     Provides: libglesv1-devel
309    
310     %package -n %{libglesv2name}
311     Summary: Files for Mesa (glesv2 libs)
312     Group: System/Libraries
313     Provides: %{libglesv2name_virt} = %{version}-%{release}
314    
315     %package -n %{libglesv2name}-devel
316     Summary: Development files for glesv2 libs
317     Group: Development/C
318     Requires: %{libglesv2name} = %{version}-%{release}
319 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
320 tv 88442 Provides: lib%{glesv2name}-devel
321     Provides: %{glesv2name}-devel
322     Provides: libglesv2-devel
323    
324 tv 88445 %package -n %{libopenvgname}
325     Summary: Files for MESA (OpenVG libs)
326     Group: System/Libraries
327     Provides: %{libopenvgname_virt} = %{version}-%{release}
328    
329     %package -n %{libopenvgname}-devel
330     Summary: Development files vor OpenVG libs
331     Group: Development/C
332     Requires: %{libopenvgname} = %{version}-%{release}
333     Provides: lib%{openvgname}-devel
334     Provides: %{openvgname}-devel
335     Provides: libopenvg-devel
336    
337 blino 215979 %if %{enable_wayland}
338     %package -n %{libgbmname}
339     Summary: Files for Mesa (gbm libs)
340     Group: System/Libraries
341     Provides: %{libgbmname_virt} = %{version}-%{release}
342    
343     %package -n %{libgbmname}-devel
344     Summary: Development files for Mesa (gbm libs)
345     Group: Development/C
346     Requires: %{libgbmname} = %{version}-%{release}
347     Provides: lib%{gbmname}-devel
348     Provides: %{gbmname}-devel
349    
350     %package -n %{libwaylandeglname}
351     Summary: Files for Mesa (Wayland EGL libs)
352     Group: System/Libraries
353     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
354    
355     %package -n %{libwaylandeglname}-devel
356     Summary: Development files for Mesa (Wayland EGL libs)
357     Group: Development/C
358     Requires: %{libwaylandeglname} = %{version}-%{release}
359     Provides: lib%{waylandeglname}-devel
360     Provides: %{waylandeglname}-devel
361     %endif
362    
363 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
364 blino 270761 Summary: VDPAU plugin for nouveau driver
365 blino 300616 Group: System/Libraries
366 tv 302568 # temporary:
367     %rename vdpau-driver-nouveau
368 blino 270761
369 tv 301233 %package -n %{_lib}vdpau-driver-r300
370 blino 270761 Summary: VDPAU plugin for r300 driver
371 blino 300616 Group: System/Libraries
372 tv 302568 # temporary:
373     %rename vdpau-driver-r300
374 blino 270761
375 tv 301233 %package -n %{_lib}vdpau-driver-r600
376 blino 270761 Summary: VDPAU plugin for r600 driver
377 blino 300616 Group: System/Libraries
378 tv 302568 # temporary:
379     %rename vdpau-driver-r600
380 blino 270761
381 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
382 blino 289282 Summary: VDPAU plugin for radeonsi driver
383     Group: System/Libraries
384 tv 302568 # temporary:
385     %rename vdpau-driver-radeonsi
386 blino 289282
387 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
388 blino 270761 Summary: VDPAU plugin for softpipe driver
389 blino 300616 Group: System/Libraries
390 tv 302568 # temporary:
391     %rename vdpau-driver-softpipe
392 blino 270761
393 pterjan 5340 %package common-devel
394     Summary: Meta package for mesa devel
395     Group: Development/C
396 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
397 pterjan 5340 Provides: hackMesa-common-devel = %{version}
398 tv 88247 Obsoletes: Mesa-common-devel < %{version}
399 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
400     Requires: %{libglname}-devel = %{version}
401 blino 289355 Requires: mesaglu-devel
402 tv 135156 Requires: freeglut-devel
403 tv 88442 Requires: %{libeglname}-devel = %{version}
404     Requires: %{libglesv1name}-devel = %{version}
405     Requires: %{libglesv2name}-devel = %{version}
406 pterjan 5340
407 tv 88440 #------------------------------------------------------------------------------
408 pterjan 5340
409     %description
410 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
411 tv 135173 %if %{build_plf}
412 pterjan 5340
413 tv 135173 This package is in the "tainted" section because it enables some
414     OpenGL extentions that are covered by software patents.
415     %endif
416    
417 pterjan 5340 %description common-devel
418     Mesa common metapackage devel
419    
420     %if %{enable_egl}
421     %description -n %{libeglname}
422 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
423 pterjan 5340 EGL parts.
424    
425     %description -n %{libeglname}-devel
426 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
427 pterjan 5340 EGL development parts.
428     %endif
429    
430 blino 271501 %description -n %{libdricorename}
431 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
432 blino 271501 DRI core part.
433    
434 pterjan 5340 %description -n %{libglname}
435 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
436 pterjan 5340 GL and GLX parts.
437    
438 tv 135155 %if %{build_plf}
439     This package is in the "tainted" section because it enables some
440     OpenGL extentions that are covered by software patents.
441     %endif
442    
443 pterjan 5340 %description -n %{dridrivers}
444 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
445 pterjan 5340 DRI drivers.
446    
447 blino 271501 %description -n %{libdricorename}-devel
448 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
449 blino 271501
450     This package contains the headers needed to compile DRI drivers.
451    
452 pterjan 5340 %description -n %{libglname}-devel
453 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
454 pterjan 5340
455     This package contains the headers needed to compile Mesa programs.
456    
457 tv 88442 %description -n %{libglesv1name}
458     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
459     well-defined subset profiles of OpenGL.
460    
461     This package provides the OpenGL ES library version 1.
462    
463 anssi 278008 %description -n %{libosmesaname}
464     Mesa offscreen rendering libraries for rendering OpenGL into
465     application-allocated blocks of memory.
466    
467     %description -n %{osmesadevel}
468     This package contains the headers needed to compile programs against
469     the Mesa offscreen rendering library.
470    
471 mikala 112356 %description -n %{libglapiname}
472     This packages provides the glapi shared library used by gallium.
473    
474     %description -n %{libglapiname}-devel
475     This package contains the headers needed to compile programes against glapi shared library.
476    
477 tv 88442 %description -n %{libglesv1name}-devel
478     This package contains the headers needed to compile OpenGL ES 1 programs.
479    
480     %description -n %{libglesv2name}
481     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
482     well-defined subset profiles of OpenGL.
483    
484     This package provides the OpenGL ES library version 2.
485    
486     %description -n %{libglesv2name}-devel
487     This package contains the headers needed to compile OpenGL ES 2 programs.
488    
489 tv 88445 %description -n %{libopenvgname}
490     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
491     acceleration interface for vector graphics libraries such as Flash and SVG.
492    
493     %description -n %{libopenvgname}-devel
494     Development files for OpenVG library.
495    
496 blino 215979 %if %{enable_wayland}
497     %description -n %{libgbmname}
498 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
499 blino 215979 GBM (Graphics Buffer Manager) parts.
500    
501     %description -n %{libgbmname}-devel
502 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
503 blino 215979 GBM (Graphics Buffer Manager) development parts.
504    
505     %description -n %{libwaylandeglname}
506 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
507 blino 215979 Wayland EGL platform parts.
508    
509     %description -n %{libwaylandeglname}-devel
510 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
511 blino 215979 Wayland EGL platform development parts.
512     %endif
513    
514 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
515 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
516     with the nouveau driver.
517    
518 tv 301233 %description -n %{_lib}vdpau-driver-r300
519 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
520     with the r300 driver.
521    
522 tv 301233 %description -n %{_lib}vdpau-driver-r600
523 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
524     with the r600 driver.
525    
526 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
527 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
528     with the radeonsi driver.
529    
530 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
531 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
532     with the softpipe driver.
533    
534 tv 88440 #------------------------------------------------------------------------------
535    
536 pterjan 5340 %prep
537     %if %{git}
538 cjw 336175 %setup -q -n mesa-%{git}
539     #setup -q -n mesa-%{git_branch}-%{git}
540 pterjan 5340 %else
541 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
542 pterjan 5340 %endif
543    
544 blino 278731 %apply_patches
545 pterjan 5340
546 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
547     # would break build. - Anssi 12/2012
548 cjw 336233 all=$(ls)
549     mkdir -p build-osmesa
550     cp -al $all build-osmesa
551 anssi 332631
552 pterjan 5340 %build
553 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
554     autoreconf -vfi
555    
556 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
557     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
558     export LDFLAGS="-L%{_libdir}/llvm"
559    
560     %configure2_5x --enable-dri \
561     --enable-glx \
562 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
563     --with-dri-drivers="%{dri_drivers}" \
564     %if %{enable_egl}
565     --enable-egl \
566     %else
567     --disable-egl \
568     %endif
569 blino 215979 %if %{enable_wayland}
570     --with-egl-platforms=x11,wayland,drm \
571     --enable-gbm \
572     --enable-shared-glapi \
573     %endif
574 tv 88442 --enable-gles1 \
575     --enable-gles2 \
576 tv 88445 --enable-openvg \
577 mikala 112356 --enable-gallium-egl \
578 blino 270761 --enable-gallium-g3dvl \
579     --disable-xvmc \
580     --enable-vdpau \
581 mikala 112356 %if %{with_hardware}
582 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
583 mikala 112356 --enable-gallium-llvm \
584     %else
585     --disable-gallium-llvm \
586     --with-gallium-drivers=swrast \
587     %endif
588 tv 135155 %if %{build_plf}
589     --enable-texture-float \
590     %endif
591 blino 270723 # end of configure options
592 pterjan 5340
593 anssi 332631
594     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
595     # since doing that causes OSMesa to miss the OpenGL symbols.
596     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
597     # -Anssi 12/2012
598    
599 cjw 336233 pushd build-osmesa
600     autoreconf -vfi
601     %configure2_5x \
602     --enable-osmesa \
603     --disable-dri \
604     --disable-glx \
605     --disable-egl \
606     --disable-shared-glapi \
607     --without-gallium-drivers
608     popd
609 anssi 332631
610 anssi 165988 %make
611 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
612 pterjan 5340
613     %install
614 cjw 336233 %makeinstall_std -C build-osmesa
615 tv 88249 %makeinstall_std
616 pterjan 5340
617 blino 216556 # FIXME: strip will likely break the hardlink
618 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
619     # to prevent proprietary driver installers from removing them
620     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
621     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
622     for l in ../libGL.so.*; do cp -a $l .; done
623     popd
624    
625     %ifarch %{x86_64}
626     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
627     %endif
628    
629 blino 270761 # .so files are not needed by vdpau
630     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
631    
632 blino 271144 # .la files are not needed by mesa
633     find %{buildroot} -name '*.la' -exec rm {} \;
634    
635 anssi 181478 # use swrastg if built (Anssi 12/2011)
636     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
637    
638 tv 88440 #------------------------------------------------------------------------------
639    
640 pterjan 5340 %files
641     %defattr(-,root,root)
642 blino 271481 %doc docs/COPYING
643 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
644 pterjan 5340
645 blino 271501 %files -n %{libdricorename}
646 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}
647     %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}.*
648 blino 271501
649     %files -n %{libdricorename}-devel
650 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so
651 blino 271501
652 pterjan 5340 %files -n %{dridrivers}
653     %defattr(-,root,root)
654     %doc docs/COPYING
655     %ifnarch ppc64
656     %dir %{_libdir}/dri
657 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
658     #%{_libdir}/dri/libglsl.so
659 pterjan 5340 %{_libdir}/dri/*_dri.so
660     %endif
661    
662 tv 88433 %files -n %{libglname}
663     %defattr(-,root,root)
664     %doc docs/COPYING
665     %{_libdir}/libGL.so.*
666     %dir %{_libdir}/mesa
667 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
668 tv 88433
669     %if %{enable_egl}
670     %files -n %{libeglname}
671     %defattr(-,root,root)
672 tv 88442 %doc docs/COPYING
673 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
674 tv 88442 %dir %{_libdir}/egl
675 blino 215979 %if !%{enable_wayland}
676     # st_GL, built only when shared glapi is not enabled
677 mikala 112356 %{_libdir}/egl/st_GL.so
678 blino 215979 %endif
679 mikala 127466 %{_libdir}/egl/egl_gallium.so
680 tv 88441 %endif
681 tv 88433
682 anssi 278008 %files -n %{libosmesaname}
683     %defattr(-,root,root)
684     %{_libdir}/libOSMesa.so.%{osmesamajor}*
685    
686 mikala 112356 %files -n %{libglapiname}
687     %defattr(-,root,root)
688     %{_libdir}/libglapi.so.%{glapimajor}*
689    
690 tv 88442 %files -n %{libglesv1name}
691     %defattr(-,root,root)
692     %doc docs/COPYING
693     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
694    
695     %files -n %{libglesv2name}
696     %defattr(-,root,root)
697     %doc docs/COPYING
698     %{_libdir}/libGLESv2.so.%{glesv2major}*
699    
700 tv 88445 %files -n %{libopenvgname}
701     %defattr(-,root,root)
702     %doc docs/COPYING
703     %{_libdir}/libOpenVG.so.%{openvgmajor}*
704    
705 blino 215979 %if %{enable_wayland}
706     %files -n %{libgbmname}
707     %{_libdir}/libgbm.so.%{gbmmajor}
708 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
709 blino 215979 %{_libdir}/gbm/gbm_*.so
710 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
711 tv 88445
712 blino 215979 %files -n %{libwaylandeglname}
713     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
714 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
715 blino 215979 %endif
716    
717    
718 pterjan 5340 %files -n %{libglname}-devel
719     %defattr(-,root,root)
720     %doc docs/COPYING
721 anssi 278008 %dir %{_includedir}/GL
722 pterjan 5340 %{_includedir}/GL/gl.h
723     %{_includedir}/GL/glext.h
724     %{_includedir}/GL/gl_mangle.h
725     %{_includedir}/GL/wglext.h
726     %{_includedir}/GL/glx.h
727     %{_includedir}/GL/glxext.h
728     %{_includedir}/GL/glx_mangle.h
729     %{_libdir}/libGL.so
730 tv 88436 %{_libdir}/pkgconfig/gl.pc
731     %{_libdir}/pkgconfig/dri.pc
732 pterjan 5340
733     #FIXME: check those headers
734 cjw 336175 #{_includedir}/GL/vms_x_fix.h
735 pterjan 5340 %{_includedir}/GL/wmesa.h
736     %dir %{_includedir}/GL/internal
737     %{_includedir}/GL/internal/dri_interface.h
738    
739     %files common-devel
740     %defattr(-,root,root)
741    
742 tv 88441 %if %{enable_egl}
743 tv 88433 %files -n %{libeglname}-devel
744     %defattr(-,root,root)
745 tv 88442 %doc docs/COPYING
746     %{_includedir}/EGL
747     %{_includedir}/KHR
748 tv 88433 %{_libdir}/libEGL.so
749 tv 88436 %{_libdir}/pkgconfig/egl.pc
750 tv 88433 %endif
751 pterjan 5340
752 anssi 278008 %files -n %{osmesadevel}
753     %defattr(-,root,root)
754     %dir %{_includedir}/GL
755     %{_includedir}/GL/osmesa.h
756     %{_libdir}/libOSMesa.so
757     %{_libdir}/pkgconfig/osmesa.pc
758    
759 mikala 112356 %files -n %{libglapiname}-devel
760     %defattr(-,root,root)
761     %{_libdir}/libglapi.so
762 pterjan 5340
763 tv 88442 %files -n %{libglesv1name}-devel
764     %defattr(-,root,root)
765     %{_includedir}/GLES
766     %{_libdir}/libGLESv1_CM.so
767     %{_libdir}/pkgconfig/glesv1_cm.pc
768 tv 88433
769 tv 88442 %files -n %{libglesv2name}-devel
770     %defattr(-,root,root)
771     %{_includedir}/GLES2
772 cjw 336175 %{_includedir}/GLES3
773 tv 88442 %{_libdir}/libGLESv2.so
774     %{_libdir}/pkgconfig/glesv2.pc
775 tv 88445
776     %files -n %{libopenvgname}-devel
777     %defattr(-,root,root)
778     %{_includedir}/VG
779     %{_libdir}/libOpenVG.so
780     %{_libdir}/pkgconfig/vg.pc
781 blino 215979
782     %if %{enable_wayland}
783     %files -n %{libgbmname}-devel
784     %{_includedir}/gbm.h
785     %{_libdir}/libgbm.so
786     %{_libdir}/pkgconfig/gbm.pc
787    
788     %files -n %{libwaylandeglname}-devel
789     %{_libdir}/libwayland-egl.so
790     %{_libdir}/pkgconfig/wayland-egl.pc
791     %endif
792 blino 270761
793 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
794 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
795    
796 tv 301233 %files -n %{_lib}vdpau-driver-r300
797 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
798    
799 tv 301233 %files -n %{_lib}vdpau-driver-r600
800 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
801    
802 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
803 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
804    
805 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
806 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30