/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 539306 - (hide annotations) (download)
Mon Oct 21 14:48:40 2013 UTC (10 years, 5 months ago) by umeabot
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 23366 byte(s)
Mageia 4 Mass Rebuild
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 469145 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 472610 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 491676 %define fversion 9.2.1
27     %define version 9.2.1
28 umeabot 539306 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51 blino 271501 %define dricorename dricore
52 pterjan 5340 %define eglname mesaegl
53     %define glname mesagl
54     %define glwname mesaglw
55 tv 88442 %define glesv1name mesaglesv1
56     %define glesv2name mesaglesv2
57 tv 88445 %define openvgname mesaopenvg
58 mikala 112356 %define glapiname glapi
59 blino 215979 %define gbmname gbm
60     %define waylandeglname wayland-egl
61 tv 88442
62 blino 271501 %define dricoremajor 1
63 pterjan 5340 %define eglmajor 1
64     %define glmajor 1
65     %define glwmajor 1
66 tv 88442 %define glesv1major 1
67     %define glesv2major 2
68 tv 88445 %define openvgmajor 1
69 mikala 112356 %define glapimajor 0
70 blino 215979 %define gbmmajor 1
71     %define waylandeglmajor 1
72 blino 289617 %define osmesamajor 8
73 tv 88442
74 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
75 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
76     %define libglname %mklibname %{glname} %{glmajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libglwname_virt lib%{glwname}
95 tv 88442 %define libglesv1name_virt lib%{glesv1name}
96     %define libglesv2name_virt lib%{glesv2name}
97 tv 88445 %define libopenvgname_virt lib%{openvgname}
98 mikala 112356 %define libglapiname_virt lib%{glapiname}
99 blino 215979 %define libgbmname_virt lib%{gbmname}
100     %define libwaylandeglname_virt lib%{waylandeglname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131     BuildRequires: pkgconfig(xt) >= 1.0.5
132     BuildRequires: pkgconfig(xmu) >= 1.0.3
133     BuildRequires: pkgconfig(x11) >= 1.3.3
134     BuildRequires: pkgconfig(xdamage) >= 1.1.1
135 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
136     BuildRequires: gccmakedep
137     BuildRequires: x11-proto-devel >= 7.3
138 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
139 pterjan 5340
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 dmorgan 106004 BuildRequires: bison flex
147 tv 469143 BuildRequires: libelf-devel
148 tv 469141 BuildRequires: llvm-devel > 3.3-1
149 mikala 127466 BuildRequires: pkgconfig(libudev)
150 blino 270761 BuildRequires: pkgconfig(vdpau)
151 blino 215979 %if %{enable_wayland}
152     BuildRequires: wayland-devel
153     %endif
154 pterjan 5340
155     URL: http://www.mesa3d.org
156     %if %{git}
157 cjw 336175 Source0: %{name}-%{git}.tar.bz2
158 blino 289278 # (blino) snapshot of 9.0 branch
159 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
160 pterjan 5340 %else
161 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
162 pterjan 5340 %endif
163     Source3: make-git-snapshot.sh
164 tmb 491931 # (tmb) disable as it breaks the build
165     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
166 pterjan 5340
167     # Instructions to setup your repository clone
168     # git://git.freedesktop.org/git/mesa/mesa
169     # git checkout mesa_7_5_branch
170     # git branch mdv-cherry-picks
171     # git am ../02??-*.patch
172     # git branch mdv-redhat
173     # git am ../03??-*.patch
174     # git branch mdv-patches
175     # git am ../09??-*.patch
176     # In order to update to the branch via patches, issue this command:
177     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
178    
179     # Cherry picks
180     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
181     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
182 tmb 411326
183 blino 289280 # (blino) should be pushed to 9.0 branch upstream
184 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
185     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
186 pterjan 5340
187 tv 88247 # Patches "liberated" from Fedora:
188 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
189     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
190    
191 blino 278732 # Patches from ChromiumOS
192     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
193    
194 blino 271493 # Mageia/Mandriva patches
195 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
196 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
197 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
198 pterjan 5340
199 tv 88440 #------------------------------------------------------------------------------
200    
201     # package mesa
202 pterjan 5340 License: MIT
203     Requires: %{libglname} = %{version}-%{release}
204     Provides: hackMesa = %{version}
205     Obsoletes: hackMesa <= %{version}
206     Provides: Mesa = %{version}
207     Obsoletes: Mesa < %{version}
208    
209 blino 271501 %package -n %{libdricorename}
210     Summary: Shared library for DRI drivers
211     Group: System/Libraries
212     Provides: %{libdricorename_virt} = %{version}-%{release}
213    
214     %package -n %{libdricorename}-devel
215     Summary: Development files for DRI core
216     Group: Development/C
217     Requires: %{libdricorename} = %{version}-%{release}
218     Provides: lib%{dricorename}-devel = %{version}-%{release}
219     Provides: %{dricorename}-devel = %{version}-%{release}
220    
221 pterjan 5340 %package -n %{libglname}
222     Summary: Files for Mesa (GL and GLX libs)
223     Group: System/Libraries
224 tv 88247 Obsoletes: %{oldlibglname} < 6.4
225 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
226     Provides: %{libglname_virt} = %{version}-%{release}
227     Requires: %{dridrivers} >= %{version}-%{release}
228 tv 135172 %if %{build_plf}
229     Requires: %mklibname txc-dxtn
230     %endif
231 pterjan 5340
232     # (anssi) Forces the upgrade of x11-server-common to happen before
233     # alternatives removal, which allows x11-server-common to grab the symlink.
234     Conflicts: x11-server-common < 1.3.0.0-17
235    
236     %package -n %{dridrivers}
237     Summary: Mesa DRI drivers
238     Group: System/Libraries
239 blino 274132 # do not require exact release to avoid conflicts when having
240     # x86_64 dri drivers from tainted and i586 dri drivers from core
241     Requires: mesa = %{version}
242 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
243 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
244     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
245 pterjan 5340
246     %package -n %{libglname}-devel
247     Summary: Development files for Mesa (OpenGL compatible 3D lib)
248     Group: Development/C
249 tv 88237 Requires: %{libglname} = %{version}-%{release}
250 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
251     Provides: %{glname}-devel = %{version}-%{release}
252     Provides: GL-devel
253     Obsoletes: %{oldlibglname}-devel < 6.4
254     Provides: %{oldlibglname}-devel = %{version}-%{release}
255     Provides: libMesaGL-devel = %{version}-%{release}
256     Provides: MesaGL-devel = %{version}-%{release}
257 tv 88438 Provides: libgl-devel
258 pterjan 5340
259 tv 88433 %if %{enable_egl}
260     %package -n %{libeglname}
261     Summary: Files for Mesa (EGL libs)
262     Group: System/Libraries
263     Provides: %{libeglname_virt} = %{version}-%{release}
264    
265     %package -n %{libeglname}-devel
266     Summary: Development files for Mesa (EGL libs)
267     Group: Development/C
268 tv 88439 Requires: %{libeglname} = %{version}-%{release}
269 tv 88433 Provides: EGL-devel
270 tv 88438 Provides: lib%{eglname}-devel
271     Provides: %{eglname}-devel
272     Provides: libegl-devel
273 tv 88433 %endif
274    
275 anssi 278008 %package -n %{libosmesaname}
276     Summary: Mesa offscreen rendering library
277     Group: System/Libraries
278    
279     %package -n %{osmesadevel}
280     Summary: Development files for libosmesa
281     Group: Development/C
282     Requires: %{libosmesaname} = %{version}-%{release}
283     Provides: osmesa-devel = %{version}-%{release}
284     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
285    
286 mikala 112356 %package -n %{libglapiname}
287     Summary: Files for mesa (glapi libs)
288     Group: System/Libraries
289     Provides: %{libglapiname_virt} = %{version}-%{release}
290 tv 88442
291 mikala 112356 %package -n %{libglapiname}-devel
292     Summary: Development files for glapi libs
293     Group: Development/C
294     Requires: %{libglapiname_virt} = %{version}-%{release}
295     Provides: lib%{glapiname}-devel
296     Provides: %{libglapiname}-devel
297    
298 tv 88442 %package -n %{libglesv1name}
299     Summary: Files for Mesa (glesv1 libs)
300     Group: System/Libraries
301     Provides: %{libglesv1name_virt} = %{version}-%{release}
302    
303     %package -n %{libglesv1name}-devel
304     Summary: Development files for glesv1 libs
305     Group: Development/C
306     Requires: %{libglesv1name} = %{version}-%{release}
307     Provides: lib%{glesv1name}-devel
308     Provides: %{glesv1name}-devel
309     Provides: libglesv1-devel
310    
311     %package -n %{libglesv2name}
312     Summary: Files for Mesa (glesv2 libs)
313     Group: System/Libraries
314     Provides: %{libglesv2name_virt} = %{version}-%{release}
315    
316     %package -n %{libglesv2name}-devel
317     Summary: Development files for glesv2 libs
318     Group: Development/C
319     Requires: %{libglesv2name} = %{version}-%{release}
320 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
321 tv 88442 Provides: lib%{glesv2name}-devel
322     Provides: %{glesv2name}-devel
323     Provides: libglesv2-devel
324    
325 tv 88445 %package -n %{libopenvgname}
326     Summary: Files for MESA (OpenVG libs)
327     Group: System/Libraries
328     Provides: %{libopenvgname_virt} = %{version}-%{release}
329    
330     %package -n %{libopenvgname}-devel
331     Summary: Development files vor OpenVG libs
332     Group: Development/C
333     Requires: %{libopenvgname} = %{version}-%{release}
334     Provides: lib%{openvgname}-devel
335     Provides: %{openvgname}-devel
336     Provides: libopenvg-devel
337    
338 blino 215979 %if %{enable_wayland}
339     %package -n %{libgbmname}
340     Summary: Files for Mesa (gbm libs)
341     Group: System/Libraries
342     Provides: %{libgbmname_virt} = %{version}-%{release}
343    
344     %package -n %{libgbmname}-devel
345     Summary: Development files for Mesa (gbm libs)
346     Group: Development/C
347     Requires: %{libgbmname} = %{version}-%{release}
348     Provides: lib%{gbmname}-devel
349     Provides: %{gbmname}-devel
350    
351     %package -n %{libwaylandeglname}
352     Summary: Files for Mesa (Wayland EGL libs)
353     Group: System/Libraries
354     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
355    
356     %package -n %{libwaylandeglname}-devel
357     Summary: Development files for Mesa (Wayland EGL libs)
358     Group: Development/C
359     Requires: %{libwaylandeglname} = %{version}-%{release}
360     Provides: lib%{waylandeglname}-devel
361     Provides: %{waylandeglname}-devel
362     %endif
363    
364 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
365 blino 270761 Summary: VDPAU plugin for nouveau driver
366 blino 300616 Group: System/Libraries
367 tv 302568 # temporary:
368     %rename vdpau-driver-nouveau
369 blino 270761
370 tv 301233 %package -n %{_lib}vdpau-driver-r300
371 blino 270761 Summary: VDPAU plugin for r300 driver
372 blino 300616 Group: System/Libraries
373 tv 302568 # temporary:
374     %rename vdpau-driver-r300
375 blino 270761
376 tv 301233 %package -n %{_lib}vdpau-driver-r600
377 blino 270761 Summary: VDPAU plugin for r600 driver
378 blino 300616 Group: System/Libraries
379 tv 302568 # temporary:
380     %rename vdpau-driver-r600
381 blino 270761
382 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
383 blino 289282 Summary: VDPAU plugin for radeonsi driver
384     Group: System/Libraries
385 tv 302568 # temporary:
386     %rename vdpau-driver-radeonsi
387 blino 289282
388 tv 301233 %package -n %{_lib}vdpau-driver-softpipe
389 blino 270761 Summary: VDPAU plugin for softpipe driver
390 blino 300616 Group: System/Libraries
391 tv 302568 # temporary:
392     %rename vdpau-driver-softpipe
393 blino 270761
394 pterjan 5340 %package common-devel
395     Summary: Meta package for mesa devel
396     Group: Development/C
397 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
398 pterjan 5340 Provides: hackMesa-common-devel = %{version}
399 tv 88247 Obsoletes: Mesa-common-devel < %{version}
400 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
401     Requires: %{libglname}-devel = %{version}
402 blino 289355 Requires: mesaglu-devel
403 tv 135156 Requires: freeglut-devel
404 tv 88442 Requires: %{libeglname}-devel = %{version}
405     Requires: %{libglesv1name}-devel = %{version}
406     Requires: %{libglesv2name}-devel = %{version}
407 pterjan 5340
408 tv 88440 #------------------------------------------------------------------------------
409 pterjan 5340
410     %description
411 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
412 tv 135173 %if %{build_plf}
413 pterjan 5340
414 tv 135173 This package is in the "tainted" section because it enables some
415     OpenGL extentions that are covered by software patents.
416     %endif
417    
418 pterjan 5340 %description common-devel
419     Mesa common metapackage devel
420    
421     %if %{enable_egl}
422     %description -n %{libeglname}
423 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 pterjan 5340 EGL parts.
425    
426     %description -n %{libeglname}-devel
427 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
428 pterjan 5340 EGL development parts.
429     %endif
430    
431 blino 271501 %description -n %{libdricorename}
432 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
433 blino 271501 DRI core part.
434    
435 pterjan 5340 %description -n %{libglname}
436 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
437 pterjan 5340 GL and GLX parts.
438    
439 tv 135155 %if %{build_plf}
440     This package is in the "tainted" section because it enables some
441     OpenGL extentions that are covered by software patents.
442     %endif
443    
444 pterjan 5340 %description -n %{dridrivers}
445 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
446 pterjan 5340 DRI drivers.
447    
448 blino 271501 %description -n %{libdricorename}-devel
449 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
450 blino 271501
451     This package contains the headers needed to compile DRI drivers.
452    
453 pterjan 5340 %description -n %{libglname}-devel
454 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
455 pterjan 5340
456     This package contains the headers needed to compile Mesa programs.
457    
458 tv 88442 %description -n %{libglesv1name}
459     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
460     well-defined subset profiles of OpenGL.
461    
462     This package provides the OpenGL ES library version 1.
463    
464 anssi 278008 %description -n %{libosmesaname}
465     Mesa offscreen rendering libraries for rendering OpenGL into
466     application-allocated blocks of memory.
467    
468     %description -n %{osmesadevel}
469     This package contains the headers needed to compile programs against
470     the Mesa offscreen rendering library.
471    
472 mikala 112356 %description -n %{libglapiname}
473     This packages provides the glapi shared library used by gallium.
474    
475     %description -n %{libglapiname}-devel
476     This package contains the headers needed to compile programes against glapi shared library.
477    
478 tv 88442 %description -n %{libglesv1name}-devel
479     This package contains the headers needed to compile OpenGL ES 1 programs.
480    
481     %description -n %{libglesv2name}
482     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
483     well-defined subset profiles of OpenGL.
484    
485     This package provides the OpenGL ES library version 2.
486    
487     %description -n %{libglesv2name}-devel
488     This package contains the headers needed to compile OpenGL ES 2 programs.
489    
490 tv 88445 %description -n %{libopenvgname}
491     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
492     acceleration interface for vector graphics libraries such as Flash and SVG.
493    
494     %description -n %{libopenvgname}-devel
495     Development files for OpenVG library.
496    
497 blino 215979 %if %{enable_wayland}
498     %description -n %{libgbmname}
499 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
500 blino 215979 GBM (Graphics Buffer Manager) parts.
501    
502     %description -n %{libgbmname}-devel
503 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
504 blino 215979 GBM (Graphics Buffer Manager) development parts.
505    
506     %description -n %{libwaylandeglname}
507 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
508 blino 215979 Wayland EGL platform parts.
509    
510     %description -n %{libwaylandeglname}-devel
511 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
512 blino 215979 Wayland EGL platform development parts.
513     %endif
514    
515 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
516 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
517     with the nouveau driver.
518    
519 tv 301233 %description -n %{_lib}vdpau-driver-r300
520 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
521     with the r300 driver.
522    
523 tv 301233 %description -n %{_lib}vdpau-driver-r600
524 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
525     with the r600 driver.
526    
527 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
528 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
529     with the radeonsi driver.
530    
531 tv 301233 %description -n %{_lib}vdpau-driver-softpipe
532 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
533     with the softpipe driver.
534    
535 tv 88440 #------------------------------------------------------------------------------
536    
537 pterjan 5340 %prep
538     %if %{git}
539 cjw 336175 %setup -q -n mesa-%{git}
540     #setup -q -n mesa-%{git_branch}-%{git}
541 pterjan 5340 %else
542 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
543 pterjan 5340 %endif
544    
545 blino 278731 %apply_patches
546 pterjan 5340
547 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
548     # would break build. - Anssi 12/2012
549 cjw 336233 all=$(ls)
550     mkdir -p build-osmesa
551     cp -al $all build-osmesa
552 anssi 332631
553 pterjan 5340 %build
554 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
555     autoreconf -vfi
556    
557 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
558     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
559     export LDFLAGS="-L%{_libdir}/llvm"
560    
561     %configure2_5x --enable-dri \
562     --enable-glx \
563 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
564     --with-dri-drivers="%{dri_drivers}" \
565     %if %{enable_egl}
566     --enable-egl \
567     %else
568     --disable-egl \
569     %endif
570 blino 215979 %if %{enable_wayland}
571     --with-egl-platforms=x11,wayland,drm \
572     --enable-gbm \
573     --enable-shared-glapi \
574     %endif
575 tv 88442 --enable-gles1 \
576     --enable-gles2 \
577 tv 88445 --enable-openvg \
578 mikala 112356 --enable-gallium-egl \
579 blino 270761 --disable-xvmc \
580     --enable-vdpau \
581 mikala 112356 %if %{with_hardware}
582 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
583 mikala 112356 --enable-gallium-llvm \
584     %else
585     --disable-gallium-llvm \
586     --with-gallium-drivers=swrast \
587     %endif
588 tv 135155 %if %{build_plf}
589     --enable-texture-float \
590     %endif
591 blino 270723 # end of configure options
592 pterjan 5340
593 tv 491683 # for bin/test-driver:
594     automake --add-missing
595 anssi 332631
596 tv 491683
597 anssi 332631 # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
598     # since doing that causes OSMesa to miss the OpenGL symbols.
599     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
600     # -Anssi 12/2012
601    
602 cjw 336233 pushd build-osmesa
603     autoreconf -vfi
604     %configure2_5x \
605     --enable-osmesa \
606     --disable-dri \
607     --disable-glx \
608     --disable-egl \
609     --disable-shared-glapi \
610     --without-gallium-drivers
611     popd
612 anssi 332631
613 anssi 165988 %make
614 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
615 pterjan 5340
616     %install
617 cjw 336233 %makeinstall_std -C build-osmesa
618 tv 88249 %makeinstall_std
619 pterjan 5340
620 blino 216556 # FIXME: strip will likely break the hardlink
621 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
622     # to prevent proprietary driver installers from removing them
623     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
624     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
625     for l in ../libGL.so.*; do cp -a $l .; done
626     popd
627    
628     %ifarch %{x86_64}
629     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
630     %endif
631    
632 blino 270761 # .so files are not needed by vdpau
633     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
634    
635 blino 271144 # .la files are not needed by mesa
636     find %{buildroot} -name '*.la' -exec rm {} \;
637    
638 anssi 181478 # use swrastg if built (Anssi 12/2011)
639     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
640    
641 tv 88440 #------------------------------------------------------------------------------
642    
643 pterjan 5340 %files
644     %defattr(-,root,root)
645 blino 271481 %doc docs/COPYING
646 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
647 pterjan 5340
648 blino 271501 %files -n %{libdricorename}
649 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}
650     %{_libdir}/libdricore%{version}%{vsuffix}.so.%{dricoremajor}.*
651 blino 271501
652     %files -n %{libdricorename}-devel
653 tv 469155 %{_libdir}/libdricore%{version}%{vsuffix}.so
654 blino 271501
655 pterjan 5340 %files -n %{dridrivers}
656     %defattr(-,root,root)
657     %doc docs/COPYING
658     %ifnarch ppc64
659     %dir %{_libdir}/dri
660 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
661     #%{_libdir}/dri/libglsl.so
662 pterjan 5340 %{_libdir}/dri/*_dri.so
663     %endif
664    
665 tv 88433 %files -n %{libglname}
666     %defattr(-,root,root)
667     %doc docs/COPYING
668     %{_libdir}/libGL.so.*
669     %dir %{_libdir}/mesa
670 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
671 tv 88433
672     %if %{enable_egl}
673     %files -n %{libeglname}
674     %defattr(-,root,root)
675 tv 88442 %doc docs/COPYING
676 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
677 tv 88442 %dir %{_libdir}/egl
678 blino 215979 %if !%{enable_wayland}
679     # st_GL, built only when shared glapi is not enabled
680 mikala 112356 %{_libdir}/egl/st_GL.so
681 blino 215979 %endif
682 mikala 127466 %{_libdir}/egl/egl_gallium.so
683 tv 88441 %endif
684 tv 88433
685 anssi 278008 %files -n %{libosmesaname}
686     %defattr(-,root,root)
687     %{_libdir}/libOSMesa.so.%{osmesamajor}*
688    
689 mikala 112356 %files -n %{libglapiname}
690     %defattr(-,root,root)
691     %{_libdir}/libglapi.so.%{glapimajor}*
692    
693 tv 88442 %files -n %{libglesv1name}
694     %defattr(-,root,root)
695     %doc docs/COPYING
696     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
697    
698     %files -n %{libglesv2name}
699     %defattr(-,root,root)
700     %doc docs/COPYING
701     %{_libdir}/libGLESv2.so.%{glesv2major}*
702    
703 tv 88445 %files -n %{libopenvgname}
704     %defattr(-,root,root)
705     %doc docs/COPYING
706     %{_libdir}/libOpenVG.so.%{openvgmajor}*
707    
708 blino 215979 %if %{enable_wayland}
709     %files -n %{libgbmname}
710     %{_libdir}/libgbm.so.%{gbmmajor}
711 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
712 blino 215979 %{_libdir}/gbm/gbm_*.so
713 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
714 tv 88445
715 blino 215979 %files -n %{libwaylandeglname}
716     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
717 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
718 blino 215979 %endif
719    
720    
721 pterjan 5340 %files -n %{libglname}-devel
722     %defattr(-,root,root)
723     %doc docs/COPYING
724 anssi 278008 %dir %{_includedir}/GL
725 pterjan 5340 %{_includedir}/GL/gl.h
726     %{_includedir}/GL/glext.h
727     %{_includedir}/GL/gl_mangle.h
728     %{_includedir}/GL/wglext.h
729     %{_includedir}/GL/glx.h
730     %{_includedir}/GL/glxext.h
731     %{_includedir}/GL/glx_mangle.h
732     %{_libdir}/libGL.so
733 tv 88436 %{_libdir}/pkgconfig/gl.pc
734     %{_libdir}/pkgconfig/dri.pc
735 pterjan 5340
736     #FIXME: check those headers
737 cjw 336175 #{_includedir}/GL/vms_x_fix.h
738 pterjan 5340 %{_includedir}/GL/wmesa.h
739     %dir %{_includedir}/GL/internal
740     %{_includedir}/GL/internal/dri_interface.h
741    
742     %files common-devel
743     %defattr(-,root,root)
744    
745 tv 88441 %if %{enable_egl}
746 tv 88433 %files -n %{libeglname}-devel
747     %defattr(-,root,root)
748 tv 88442 %doc docs/COPYING
749     %{_includedir}/EGL
750     %{_includedir}/KHR
751 tv 88433 %{_libdir}/libEGL.so
752 tv 88436 %{_libdir}/pkgconfig/egl.pc
753 tv 88433 %endif
754 pterjan 5340
755 anssi 278008 %files -n %{osmesadevel}
756     %defattr(-,root,root)
757     %dir %{_includedir}/GL
758     %{_includedir}/GL/osmesa.h
759     %{_libdir}/libOSMesa.so
760     %{_libdir}/pkgconfig/osmesa.pc
761    
762 mikala 112356 %files -n %{libglapiname}-devel
763     %defattr(-,root,root)
764     %{_libdir}/libglapi.so
765 pterjan 5340
766 tv 88442 %files -n %{libglesv1name}-devel
767     %defattr(-,root,root)
768     %{_includedir}/GLES
769     %{_libdir}/libGLESv1_CM.so
770     %{_libdir}/pkgconfig/glesv1_cm.pc
771 tv 88433
772 tv 88442 %files -n %{libglesv2name}-devel
773     %defattr(-,root,root)
774     %{_includedir}/GLES2
775 cjw 336175 %{_includedir}/GLES3
776 tv 88442 %{_libdir}/libGLESv2.so
777     %{_libdir}/pkgconfig/glesv2.pc
778 tv 88445
779     %files -n %{libopenvgname}-devel
780     %defattr(-,root,root)
781     %{_includedir}/VG
782     %{_libdir}/libOpenVG.so
783     %{_libdir}/pkgconfig/vg.pc
784 blino 215979
785     %if %{enable_wayland}
786     %files -n %{libgbmname}-devel
787     %{_includedir}/gbm.h
788     %{_libdir}/libgbm.so
789     %{_libdir}/pkgconfig/gbm.pc
790    
791     %files -n %{libwaylandeglname}-devel
792     %{_libdir}/libwayland-egl.so
793     %{_libdir}/pkgconfig/wayland-egl.pc
794     %endif
795 blino 270761
796 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
797 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
798    
799 tv 301233 %files -n %{_lib}vdpau-driver-r300
800 blino 270761 %{_libdir}/vdpau/libvdpau_r300.so.*
801    
802 tv 301233 %files -n %{_lib}vdpau-driver-r600
803 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
804    
805 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
806 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
807    
808 tv 301233 %files -n %{_lib}vdpau-driver-softpipe
809 blino 270761 %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30