/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 566012 - (hide annotations) (download)
Thu Jan 9 21:42:16 2014 UTC (10 years, 2 months ago) by tmb
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 21563 byte(s)
drop merged patces
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 469145 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 472610 %define relc 0
25 pterjan 5340 %define name mesa
26 tmb 566007 %define fversion 10.0.2
27     %define version 10.0.2
28     %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51     %define eglname mesaegl
52     %define glname mesagl
53     %define glwname mesaglw
54 tv 88442 %define glesv1name mesaglesv1
55     %define glesv2name mesaglesv2
56 tv 88445 %define openvgname mesaopenvg
57 mikala 112356 %define glapiname glapi
58 blino 215979 %define gbmname gbm
59     %define waylandeglname wayland-egl
60 tv 88442
61 pterjan 5340 %define eglmajor 1
62     %define glmajor 1
63     %define glwmajor 1
64 tv 88442 %define glesv1major 1
65     %define glesv2major 2
66 tv 88445 %define openvgmajor 1
67 mikala 112356 %define glapimajor 0
68 blino 215979 %define gbmmajor 1
69     %define waylandeglmajor 1
70 blino 289617 %define osmesamajor 8
71 tv 88442
72 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
73     %define libglname %mklibname %{glname} %{glmajor}
74     %define libglwname %mklibname %{glwname} %{glwmajor}
75 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
76     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
77 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
78 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
79 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
80     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
81 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
82 pterjan 5340
83     %define dridrivers %mklibname dri-drivers
84    
85 anssi 278008 %define osmesadevel %mklibname osmesa -d
86    
87 pterjan 5340 # Architecture-independent Virtual provides:
88     %define libeglname_virt lib%{eglname}
89     %define libglname_virt lib%{glname}
90     %define libglwname_virt lib%{glwname}
91 tv 88442 %define libglesv1name_virt lib%{glesv1name}
92     %define libglesv2name_virt lib%{glesv2name}
93 tv 88445 %define libopenvgname_virt lib%{openvgname}
94 mikala 112356 %define libglapiname_virt lib%{glapiname}
95 blino 215979 %define libgbmname_virt lib%{gbmname}
96     %define libwaylandeglname_virt lib%{waylandeglname}
97 pterjan 5340
98     %define oldlibglname %mklibname MesaGL 1
99    
100     %define mesasrcdir %{_prefix}/src/Mesa/
101     %define driver_dir %{_libdir}/dri
102    
103 tv 88451 %define enable_egl 1
104 blino 215979 %define enable_wayland 1
105 pterjan 5340
106     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
107     #FIXME: (for >=i586) disable sse
108     # SSE seems to have problem on some apps (gtulpas) for probing.
109 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
110 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
111 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
112 pterjan 5340 %define dri_drivers_ppc64 ""
113 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
114     %define dri_drivers_alpha "r200,radeon,swrast"
115     %define dri_drivers_sparc "ffb,radeon,swrast"
116     %define dri_drivers_mipsel "r200,radeon,swrast"
117 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
119    
120     Name: %{name}
121     Version: %{version}
122     Release: %{release}
123 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
124 pterjan 5340 Group: System/Libraries
125    
126 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
127     BuildRequires: pkgconfig(xt) >= 1.0.5
128     BuildRequires: pkgconfig(xmu) >= 1.0.3
129     BuildRequires: pkgconfig(x11) >= 1.3.3
130     BuildRequires: pkgconfig(xdamage) >= 1.1.1
131 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
132     BuildRequires: gccmakedep
133     BuildRequires: x11-proto-devel >= 7.3
134 tv 554634 BuildRequires: pkgconfig(libdrm) >= 2.4.49
135 pterjan 5340
136 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
137     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
138     BuildRequires: pkgconfig(xi) >= 1.3
139     BuildRequires: pkgconfig(talloc)
140 tv 88443 BuildRequires: libxml2-python
141 tmb 35532 BuildRequires: makedepend
142 dmorgan 106004 BuildRequires: bison flex
143 tv 469143 BuildRequires: libelf-devel
144 tv 469141 BuildRequires: llvm-devel > 3.3-1
145 mikala 127466 BuildRequires: pkgconfig(libudev)
146 blino 270761 BuildRequires: pkgconfig(vdpau)
147 blino 215979 %if %{enable_wayland}
148     BuildRequires: wayland-devel
149     %endif
150 pterjan 5340
151     URL: http://www.mesa3d.org
152     %if %{git}
153 cjw 336175 Source0: %{name}-%{git}.tar.bz2
154 blino 289278 # (blino) snapshot of 9.0 branch
155 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
156 pterjan 5340 %else
157 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
158 pterjan 5340 %endif
159     Source3: make-git-snapshot.sh
160 tmb 491931 # (tmb) disable as it breaks the build
161     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
162 pterjan 5340
163     # Instructions to setup your repository clone
164     # git://git.freedesktop.org/git/mesa/mesa
165     # git checkout mesa_7_5_branch
166     # git branch mdv-cherry-picks
167     # git am ../02??-*.patch
168     # git branch mdv-redhat
169     # git am ../03??-*.patch
170     # git branch mdv-patches
171     # git am ../09??-*.patch
172     # In order to update to the branch via patches, issue this command:
173     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
174    
175 tmb 564877 # Upstream git
176    
177 pterjan 5340 # Cherry picks
178     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
179     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
180 tmb 411326
181 blino 289280 # (blino) should be pushed to 9.0 branch upstream
182 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
183     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
184 pterjan 5340
185 tv 88247 # Patches "liberated" from Fedora:
186 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
187     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
188    
189 blino 278732 # Patches from ChromiumOS
190     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191    
192 blino 271493 # Mageia/Mandriva patches
193 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
195 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
196 pterjan 5340
197 tv 88440 #------------------------------------------------------------------------------
198    
199     # package mesa
200 pterjan 5340 License: MIT
201     Requires: %{libglname} = %{version}-%{release}
202     Provides: hackMesa = %{version}
203     Obsoletes: hackMesa <= %{version}
204     Provides: Mesa = %{version}
205     Obsoletes: Mesa < %{version}
206    
207     %package -n %{libglname}
208     Summary: Files for Mesa (GL and GLX libs)
209     Group: System/Libraries
210 tv 88247 Obsoletes: %{oldlibglname} < 6.4
211 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
212     Provides: %{libglname_virt} = %{version}-%{release}
213     Requires: %{dridrivers} >= %{version}-%{release}
214 tv 135172 %if %{build_plf}
215     Requires: %mklibname txc-dxtn
216     %endif
217 pterjan 5340
218     # (anssi) Forces the upgrade of x11-server-common to happen before
219     # alternatives removal, which allows x11-server-common to grab the symlink.
220     Conflicts: x11-server-common < 1.3.0.0-17
221    
222     %package -n %{dridrivers}
223     Summary: Mesa DRI drivers
224     Group: System/Libraries
225 blino 274132 # do not require exact release to avoid conflicts when having
226     # x86_64 dri drivers from tainted and i586 dri drivers from core
227     Requires: mesa = %{version}
228 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
229 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
230     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
231 pterjan 5340
232     %package -n %{libglname}-devel
233     Summary: Development files for Mesa (OpenGL compatible 3D lib)
234     Group: Development/C
235 tv 88237 Requires: %{libglname} = %{version}-%{release}
236 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
237     Provides: %{glname}-devel = %{version}-%{release}
238     Provides: GL-devel
239     Obsoletes: %{oldlibglname}-devel < 6.4
240     Provides: %{oldlibglname}-devel = %{version}-%{release}
241     Provides: libMesaGL-devel = %{version}-%{release}
242     Provides: MesaGL-devel = %{version}-%{release}
243 tv 88438 Provides: libgl-devel
244 pterjan 5340
245 tv 88433 %if %{enable_egl}
246     %package -n %{libeglname}
247     Summary: Files for Mesa (EGL libs)
248     Group: System/Libraries
249     Provides: %{libeglname_virt} = %{version}-%{release}
250    
251     %package -n %{libeglname}-devel
252     Summary: Development files for Mesa (EGL libs)
253     Group: Development/C
254 tv 88439 Requires: %{libeglname} = %{version}-%{release}
255 tv 88433 Provides: EGL-devel
256 tv 88438 Provides: lib%{eglname}-devel
257     Provides: %{eglname}-devel
258     Provides: libegl-devel
259 tv 88433 %endif
260    
261 anssi 278008 %package -n %{libosmesaname}
262     Summary: Mesa offscreen rendering library
263     Group: System/Libraries
264    
265     %package -n %{osmesadevel}
266     Summary: Development files for libosmesa
267     Group: Development/C
268     Requires: %{libosmesaname} = %{version}-%{release}
269     Provides: osmesa-devel = %{version}-%{release}
270     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
271    
272 mikala 112356 %package -n %{libglapiname}
273     Summary: Files for mesa (glapi libs)
274     Group: System/Libraries
275     Provides: %{libglapiname_virt} = %{version}-%{release}
276 tv 88442
277 mikala 112356 %package -n %{libglapiname}-devel
278     Summary: Development files for glapi libs
279     Group: Development/C
280     Requires: %{libglapiname_virt} = %{version}-%{release}
281     Provides: lib%{glapiname}-devel
282     Provides: %{libglapiname}-devel
283    
284 tv 88442 %package -n %{libglesv1name}
285     Summary: Files for Mesa (glesv1 libs)
286     Group: System/Libraries
287     Provides: %{libglesv1name_virt} = %{version}-%{release}
288    
289     %package -n %{libglesv1name}-devel
290     Summary: Development files for glesv1 libs
291     Group: Development/C
292     Requires: %{libglesv1name} = %{version}-%{release}
293     Provides: lib%{glesv1name}-devel
294     Provides: %{glesv1name}-devel
295     Provides: libglesv1-devel
296    
297     %package -n %{libglesv2name}
298     Summary: Files for Mesa (glesv2 libs)
299     Group: System/Libraries
300     Provides: %{libglesv2name_virt} = %{version}-%{release}
301    
302     %package -n %{libglesv2name}-devel
303     Summary: Development files for glesv2 libs
304     Group: Development/C
305     Requires: %{libglesv2name} = %{version}-%{release}
306 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
307 tv 88442 Provides: lib%{glesv2name}-devel
308     Provides: %{glesv2name}-devel
309     Provides: libglesv2-devel
310    
311 tv 88445 %package -n %{libopenvgname}
312     Summary: Files for MESA (OpenVG libs)
313     Group: System/Libraries
314     Provides: %{libopenvgname_virt} = %{version}-%{release}
315    
316     %package -n %{libopenvgname}-devel
317     Summary: Development files vor OpenVG libs
318     Group: Development/C
319     Requires: %{libopenvgname} = %{version}-%{release}
320     Provides: lib%{openvgname}-devel
321     Provides: %{openvgname}-devel
322     Provides: libopenvg-devel
323    
324 blino 215979 %if %{enable_wayland}
325     %package -n %{libgbmname}
326     Summary: Files for Mesa (gbm libs)
327     Group: System/Libraries
328     Provides: %{libgbmname_virt} = %{version}-%{release}
329    
330     %package -n %{libgbmname}-devel
331     Summary: Development files for Mesa (gbm libs)
332     Group: Development/C
333     Requires: %{libgbmname} = %{version}-%{release}
334     Provides: lib%{gbmname}-devel
335     Provides: %{gbmname}-devel
336    
337     %package -n %{libwaylandeglname}
338     Summary: Files for Mesa (Wayland EGL libs)
339     Group: System/Libraries
340     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
341    
342     %package -n %{libwaylandeglname}-devel
343     Summary: Development files for Mesa (Wayland EGL libs)
344     Group: Development/C
345     Requires: %{libwaylandeglname} = %{version}-%{release}
346     Provides: lib%{waylandeglname}-devel
347     Provides: %{waylandeglname}-devel
348     %endif
349    
350 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
351 blino 270761 Summary: VDPAU plugin for nouveau driver
352 blino 300616 Group: System/Libraries
353 tv 302568 # temporary:
354     %rename vdpau-driver-nouveau
355 blino 270761
356 tv 301233 %package -n %{_lib}vdpau-driver-r600
357 blino 270761 Summary: VDPAU plugin for r600 driver
358 blino 300616 Group: System/Libraries
359 tv 302568 # temporary:
360     %rename vdpau-driver-r600
361 blino 270761
362 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
363 blino 289282 Summary: VDPAU plugin for radeonsi driver
364     Group: System/Libraries
365 tv 302568 # temporary:
366     %rename vdpau-driver-radeonsi
367 blino 289282
368 pterjan 5340 %package common-devel
369     Summary: Meta package for mesa devel
370     Group: Development/C
371 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
372 pterjan 5340 Provides: hackMesa-common-devel = %{version}
373 tv 88247 Obsoletes: Mesa-common-devel < %{version}
374 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
375     Requires: %{libglname}-devel = %{version}
376 blino 289355 Requires: mesaglu-devel
377 tv 135156 Requires: freeglut-devel
378 tv 88442 Requires: %{libeglname}-devel = %{version}
379     Requires: %{libglesv1name}-devel = %{version}
380     Requires: %{libglesv2name}-devel = %{version}
381 pterjan 5340
382 tv 88440 #------------------------------------------------------------------------------
383 pterjan 5340
384     %description
385 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
386 tv 135173 %if %{build_plf}
387 pterjan 5340
388 tv 135173 This package is in the "tainted" section because it enables some
389     OpenGL extentions that are covered by software patents.
390     %endif
391    
392 pterjan 5340 %description common-devel
393     Mesa common metapackage devel
394    
395     %if %{enable_egl}
396     %description -n %{libeglname}
397 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
398 pterjan 5340 EGL parts.
399    
400     %description -n %{libeglname}-devel
401 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
402 pterjan 5340 EGL development parts.
403     %endif
404    
405     %description -n %{libglname}
406 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
407 pterjan 5340 GL and GLX parts.
408    
409 tv 135155 %if %{build_plf}
410     This package is in the "tainted" section because it enables some
411     OpenGL extentions that are covered by software patents.
412     %endif
413    
414 pterjan 5340 %description -n %{dridrivers}
415 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
416 pterjan 5340 DRI drivers.
417    
418     %description -n %{libglname}-devel
419 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 pterjan 5340
421     This package contains the headers needed to compile Mesa programs.
422    
423 tv 88442 %description -n %{libglesv1name}
424     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
425     well-defined subset profiles of OpenGL.
426    
427     This package provides the OpenGL ES library version 1.
428    
429 anssi 278008 %description -n %{libosmesaname}
430     Mesa offscreen rendering libraries for rendering OpenGL into
431     application-allocated blocks of memory.
432    
433     %description -n %{osmesadevel}
434     This package contains the headers needed to compile programs against
435     the Mesa offscreen rendering library.
436    
437 mikala 112356 %description -n %{libglapiname}
438     This packages provides the glapi shared library used by gallium.
439    
440     %description -n %{libglapiname}-devel
441     This package contains the headers needed to compile programes against glapi shared library.
442    
443 tv 88442 %description -n %{libglesv1name}-devel
444     This package contains the headers needed to compile OpenGL ES 1 programs.
445    
446     %description -n %{libglesv2name}
447     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
448     well-defined subset profiles of OpenGL.
449    
450     This package provides the OpenGL ES library version 2.
451    
452     %description -n %{libglesv2name}-devel
453     This package contains the headers needed to compile OpenGL ES 2 programs.
454    
455 tv 88445 %description -n %{libopenvgname}
456     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
457     acceleration interface for vector graphics libraries such as Flash and SVG.
458    
459     %description -n %{libopenvgname}-devel
460     Development files for OpenVG library.
461    
462 blino 215979 %if %{enable_wayland}
463     %description -n %{libgbmname}
464 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
465 blino 215979 GBM (Graphics Buffer Manager) parts.
466    
467     %description -n %{libgbmname}-devel
468 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
469 blino 215979 GBM (Graphics Buffer Manager) development parts.
470    
471     %description -n %{libwaylandeglname}
472 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
473 blino 215979 Wayland EGL platform parts.
474    
475     %description -n %{libwaylandeglname}-devel
476 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
477 blino 215979 Wayland EGL platform development parts.
478     %endif
479    
480 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
481 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
482     with the nouveau driver.
483    
484 tv 301233 %description -n %{_lib}vdpau-driver-r600
485 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
486     with the r600 driver.
487    
488 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
489 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
490     with the radeonsi driver.
491    
492 tv 88440 #------------------------------------------------------------------------------
493    
494 pterjan 5340 %prep
495     %if %{git}
496 cjw 336175 %setup -q -n mesa-%{git}
497     #setup -q -n mesa-%{git_branch}-%{git}
498 pterjan 5340 %else
499 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
500 pterjan 5340 %endif
501    
502 blino 278731 %apply_patches
503 pterjan 5340
504 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
505     # would break build. - Anssi 12/2012
506 cjw 336233 all=$(ls)
507     mkdir -p build-osmesa
508     cp -al $all build-osmesa
509 anssi 332631
510 pterjan 5340 %build
511 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
512     autoreconf -vfi
513    
514 tv 551068 # for bin/test-driver:
515     automake --add-missing
516    
517 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
518     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
519     export LDFLAGS="-L%{_libdir}/llvm"
520    
521     %configure2_5x --enable-dri \
522     --enable-glx \
523 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
524     --with-dri-drivers="%{dri_drivers}" \
525     %if %{enable_egl}
526     --enable-egl \
527     %else
528     --disable-egl \
529     %endif
530 blino 215979 %if %{enable_wayland}
531     --with-egl-platforms=x11,wayland,drm \
532     --enable-gbm \
533     --enable-shared-glapi \
534     %endif
535 tv 88442 --enable-gles1 \
536     --enable-gles2 \
537 tv 88445 --enable-openvg \
538 mikala 112356 --enable-gallium-egl \
539 blino 270761 --disable-xvmc \
540     --enable-vdpau \
541 mikala 112356 %if %{with_hardware}
542 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
543 mikala 112356 --enable-gallium-llvm \
544     %else
545     --disable-gallium-llvm \
546     --with-gallium-drivers=swrast \
547     %endif
548 tv 135155 %if %{build_plf}
549     --enable-texture-float \
550     %endif
551 blino 270723 # end of configure options
552 pterjan 5340
553 anssi 332631
554     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
555     # since doing that causes OSMesa to miss the OpenGL symbols.
556     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
557     # -Anssi 12/2012
558    
559 cjw 336233 pushd build-osmesa
560     autoreconf -vfi
561     %configure2_5x \
562     --enable-osmesa \
563     --disable-dri \
564     --disable-glx \
565     --disable-egl \
566     --disable-shared-glapi \
567     --without-gallium-drivers
568     popd
569 anssi 332631
570 anssi 165988 %make
571 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
572 pterjan 5340
573     %install
574 cjw 336233 %makeinstall_std -C build-osmesa
575 tv 88249 %makeinstall_std
576 pterjan 5340
577 blino 216556 # FIXME: strip will likely break the hardlink
578 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
579     # to prevent proprietary driver installers from removing them
580     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
581     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
582     for l in ../libGL.so.*; do cp -a $l .; done
583     popd
584    
585     %ifarch %{x86_64}
586     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
587     %endif
588    
589 blino 270761 # .so files are not needed by vdpau
590     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
591    
592 blino 271144 # .la files are not needed by mesa
593     find %{buildroot} -name '*.la' -exec rm {} \;
594    
595 anssi 181478 # use swrastg if built (Anssi 12/2011)
596     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
597    
598 tv 88440 #------------------------------------------------------------------------------
599    
600 pterjan 5340 %files
601     %defattr(-,root,root)
602 blino 271481 %doc docs/COPYING
603 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
604 pterjan 5340
605     %files -n %{dridrivers}
606     %defattr(-,root,root)
607     %doc docs/COPYING
608     %ifnarch ppc64
609     %dir %{_libdir}/dri
610 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
611     #%{_libdir}/dri/libglsl.so
612 pterjan 5340 %{_libdir}/dri/*_dri.so
613     %endif
614    
615 tv 88433 %files -n %{libglname}
616     %defattr(-,root,root)
617     %doc docs/COPYING
618     %{_libdir}/libGL.so.*
619     %dir %{_libdir}/mesa
620 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
621 tv 88433
622     %if %{enable_egl}
623     %files -n %{libeglname}
624     %defattr(-,root,root)
625 tv 88442 %doc docs/COPYING
626 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
627 tv 88442 %dir %{_libdir}/egl
628 blino 215979 %if !%{enable_wayland}
629     # st_GL, built only when shared glapi is not enabled
630 mikala 112356 %{_libdir}/egl/st_GL.so
631 blino 215979 %endif
632 mikala 127466 %{_libdir}/egl/egl_gallium.so
633 tv 88441 %endif
634 tv 88433
635 anssi 278008 %files -n %{libosmesaname}
636     %defattr(-,root,root)
637     %{_libdir}/libOSMesa.so.%{osmesamajor}*
638    
639 mikala 112356 %files -n %{libglapiname}
640     %defattr(-,root,root)
641     %{_libdir}/libglapi.so.%{glapimajor}*
642    
643 tv 88442 %files -n %{libglesv1name}
644     %defattr(-,root,root)
645     %doc docs/COPYING
646     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
647    
648     %files -n %{libglesv2name}
649     %defattr(-,root,root)
650     %doc docs/COPYING
651     %{_libdir}/libGLESv2.so.%{glesv2major}*
652    
653 tv 88445 %files -n %{libopenvgname}
654     %defattr(-,root,root)
655     %doc docs/COPYING
656     %{_libdir}/libOpenVG.so.%{openvgmajor}*
657    
658 blino 215979 %if %{enable_wayland}
659     %files -n %{libgbmname}
660     %{_libdir}/libgbm.so.%{gbmmajor}
661 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
662 blino 215979 %{_libdir}/gbm/gbm_*.so
663 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
664 tv 88445
665 blino 215979 %files -n %{libwaylandeglname}
666     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
667 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
668 blino 215979 %endif
669    
670    
671 pterjan 5340 %files -n %{libglname}-devel
672     %defattr(-,root,root)
673     %doc docs/COPYING
674 anssi 278008 %dir %{_includedir}/GL
675 pterjan 5340 %{_includedir}/GL/gl.h
676     %{_includedir}/GL/glext.h
677     %{_includedir}/GL/gl_mangle.h
678     %{_includedir}/GL/wglext.h
679     %{_includedir}/GL/glx.h
680     %{_includedir}/GL/glxext.h
681     %{_includedir}/GL/glx_mangle.h
682     %{_libdir}/libGL.so
683 tv 88436 %{_libdir}/pkgconfig/gl.pc
684     %{_libdir}/pkgconfig/dri.pc
685 pterjan 5340
686     #FIXME: check those headers
687 cjw 336175 #{_includedir}/GL/vms_x_fix.h
688 pterjan 5340 %{_includedir}/GL/wmesa.h
689     %dir %{_includedir}/GL/internal
690     %{_includedir}/GL/internal/dri_interface.h
691    
692     %files common-devel
693     %defattr(-,root,root)
694    
695 tv 88441 %if %{enable_egl}
696 tv 88433 %files -n %{libeglname}-devel
697     %defattr(-,root,root)
698 tv 88442 %doc docs/COPYING
699     %{_includedir}/EGL
700     %{_includedir}/KHR
701 tv 88433 %{_libdir}/libEGL.so
702 tv 88436 %{_libdir}/pkgconfig/egl.pc
703 tv 88433 %endif
704 pterjan 5340
705 anssi 278008 %files -n %{osmesadevel}
706     %defattr(-,root,root)
707     %dir %{_includedir}/GL
708     %{_includedir}/GL/osmesa.h
709     %{_libdir}/libOSMesa.so
710     %{_libdir}/pkgconfig/osmesa.pc
711    
712 mikala 112356 %files -n %{libglapiname}-devel
713     %defattr(-,root,root)
714     %{_libdir}/libglapi.so
715 pterjan 5340
716 tv 88442 %files -n %{libglesv1name}-devel
717     %defattr(-,root,root)
718     %{_includedir}/GLES
719     %{_libdir}/libGLESv1_CM.so
720     %{_libdir}/pkgconfig/glesv1_cm.pc
721 tv 88433
722 tv 88442 %files -n %{libglesv2name}-devel
723     %defattr(-,root,root)
724     %{_includedir}/GLES2
725 cjw 336175 %{_includedir}/GLES3
726 tv 88442 %{_libdir}/libGLESv2.so
727     %{_libdir}/pkgconfig/glesv2.pc
728 tv 88445
729     %files -n %{libopenvgname}-devel
730     %defattr(-,root,root)
731     %{_includedir}/VG
732     %{_libdir}/libOpenVG.so
733     %{_libdir}/pkgconfig/vg.pc
734 blino 215979
735     %if %{enable_wayland}
736     %files -n %{libgbmname}-devel
737     %{_includedir}/gbm.h
738     %{_libdir}/libgbm.so
739     %{_libdir}/pkgconfig/gbm.pc
740    
741     %files -n %{libwaylandeglname}-devel
742     %{_libdir}/libwayland-egl.so
743     %{_libdir}/pkgconfig/wayland-egl.pc
744     %endif
745 blino 270761
746 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
747 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
748    
749 tv 301233 %files -n %{_lib}vdpau-driver-r600
750 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
751    
752 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
753 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
754    

  ViewVC Help
Powered by ViewVC 1.1.30