/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 585816 - (hide annotations) (download)
Sat Feb 8 07:42:54 2014 UTC (10 years, 2 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 21599 byte(s)
- new release
- BR xshmfence
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 469145 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 585816 %define relc 1
25 pterjan 5340 %define name mesa
26 tv 585816 %define fversion 10.1.0
27     %define version 10.1.0
28     %define rel 1
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51     %define eglname mesaegl
52     %define glname mesagl
53     %define glwname mesaglw
54 tv 88442 %define glesv1name mesaglesv1
55     %define glesv2name mesaglesv2
56 tv 88445 %define openvgname mesaopenvg
57 mikala 112356 %define glapiname glapi
58 blino 215979 %define gbmname gbm
59     %define waylandeglname wayland-egl
60 tv 88442
61 pterjan 5340 %define eglmajor 1
62     %define glmajor 1
63     %define glwmajor 1
64 tv 88442 %define glesv1major 1
65     %define glesv2major 2
66 tv 88445 %define openvgmajor 1
67 mikala 112356 %define glapimajor 0
68 blino 215979 %define gbmmajor 1
69     %define waylandeglmajor 1
70 blino 289617 %define osmesamajor 8
71 tv 88442
72 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
73     %define libglname %mklibname %{glname} %{glmajor}
74     %define libglwname %mklibname %{glwname} %{glwmajor}
75 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
76     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
77 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
78 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
79 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
80     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
81 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
82 pterjan 5340
83     %define dridrivers %mklibname dri-drivers
84    
85 anssi 278008 %define osmesadevel %mklibname osmesa -d
86    
87 pterjan 5340 # Architecture-independent Virtual provides:
88     %define libeglname_virt lib%{eglname}
89     %define libglname_virt lib%{glname}
90     %define libglwname_virt lib%{glwname}
91 tv 88442 %define libglesv1name_virt lib%{glesv1name}
92     %define libglesv2name_virt lib%{glesv2name}
93 tv 88445 %define libopenvgname_virt lib%{openvgname}
94 mikala 112356 %define libglapiname_virt lib%{glapiname}
95 blino 215979 %define libgbmname_virt lib%{gbmname}
96     %define libwaylandeglname_virt lib%{waylandeglname}
97 pterjan 5340
98     %define oldlibglname %mklibname MesaGL 1
99    
100     %define mesasrcdir %{_prefix}/src/Mesa/
101     %define driver_dir %{_libdir}/dri
102    
103 tv 88451 %define enable_egl 1
104 blino 215979 %define enable_wayland 1
105 pterjan 5340
106     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
107     #FIXME: (for >=i586) disable sse
108     # SSE seems to have problem on some apps (gtulpas) for probing.
109 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
110 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
111 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
112 pterjan 5340 %define dri_drivers_ppc64 ""
113 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
114     %define dri_drivers_alpha "r200,radeon,swrast"
115     %define dri_drivers_sparc "ffb,radeon,swrast"
116     %define dri_drivers_mipsel "r200,radeon,swrast"
117 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
119    
120     Name: %{name}
121     Version: %{version}
122     Release: %{release}
123 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
124 pterjan 5340 Group: System/Libraries
125    
126 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
127 tv 585816 BuildRequires: pkgconfig(xshmfence)
128 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
129     BuildRequires: pkgconfig(xmu) >= 1.0.3
130     BuildRequires: pkgconfig(x11) >= 1.3.3
131     BuildRequires: pkgconfig(xdamage) >= 1.1.1
132 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
133     BuildRequires: gccmakedep
134     BuildRequires: x11-proto-devel >= 7.3
135 tv 554634 BuildRequires: pkgconfig(libdrm) >= 2.4.49
136 pterjan 5340
137 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
138     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
139     BuildRequires: pkgconfig(xi) >= 1.3
140     BuildRequires: pkgconfig(talloc)
141 tv 88443 BuildRequires: libxml2-python
142 tmb 35532 BuildRequires: makedepend
143 dmorgan 106004 BuildRequires: bison flex
144 tv 469143 BuildRequires: libelf-devel
145 tv 469141 BuildRequires: llvm-devel > 3.3-1
146 mikala 127466 BuildRequires: pkgconfig(libudev)
147 blino 270761 BuildRequires: pkgconfig(vdpau)
148 blino 215979 %if %{enable_wayland}
149     BuildRequires: wayland-devel
150     %endif
151 pterjan 5340
152     URL: http://www.mesa3d.org
153     %if %{git}
154 cjw 336175 Source0: %{name}-%{git}.tar.bz2
155 blino 289278 # (blino) snapshot of 9.0 branch
156 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
157 pterjan 5340 %else
158 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
159 pterjan 5340 %endif
160     Source3: make-git-snapshot.sh
161 tmb 491931 # (tmb) disable as it breaks the build
162     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
163 pterjan 5340
164     # Instructions to setup your repository clone
165     # git://git.freedesktop.org/git/mesa/mesa
166     # git checkout mesa_7_5_branch
167     # git branch mdv-cherry-picks
168     # git am ../02??-*.patch
169     # git branch mdv-redhat
170     # git am ../03??-*.patch
171     # git branch mdv-patches
172     # git am ../09??-*.patch
173     # In order to update to the branch via patches, issue this command:
174     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
175    
176 tmb 564877 # Upstream git
177    
178 pterjan 5340 # Cherry picks
179     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
180     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
181 tmb 411326
182 blino 289280 # (blino) should be pushed to 9.0 branch upstream
183 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
184     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
185 pterjan 5340
186 tv 88247 # Patches "liberated" from Fedora:
187 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
188     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
189    
190 blino 278732 # Patches from ChromiumOS
191     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
192    
193 blino 271493 # Mageia/Mandriva patches
194 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
195 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
196 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
197 pterjan 5340
198 tv 88440 #------------------------------------------------------------------------------
199    
200     # package mesa
201 pterjan 5340 License: MIT
202     Requires: %{libglname} = %{version}-%{release}
203     Provides: hackMesa = %{version}
204     Obsoletes: hackMesa <= %{version}
205     Provides: Mesa = %{version}
206     Obsoletes: Mesa < %{version}
207    
208     %package -n %{libglname}
209     Summary: Files for Mesa (GL and GLX libs)
210     Group: System/Libraries
211 tv 88247 Obsoletes: %{oldlibglname} < 6.4
212 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
213     Provides: %{libglname_virt} = %{version}-%{release}
214     Requires: %{dridrivers} >= %{version}-%{release}
215 tv 135172 %if %{build_plf}
216     Requires: %mklibname txc-dxtn
217     %endif
218 pterjan 5340
219     # (anssi) Forces the upgrade of x11-server-common to happen before
220     # alternatives removal, which allows x11-server-common to grab the symlink.
221     Conflicts: x11-server-common < 1.3.0.0-17
222    
223     %package -n %{dridrivers}
224     Summary: Mesa DRI drivers
225     Group: System/Libraries
226 blino 274132 # do not require exact release to avoid conflicts when having
227     # x86_64 dri drivers from tainted and i586 dri drivers from core
228     Requires: mesa = %{version}
229 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
230 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
231     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
232 pterjan 5340
233     %package -n %{libglname}-devel
234     Summary: Development files for Mesa (OpenGL compatible 3D lib)
235     Group: Development/C
236 tv 88237 Requires: %{libglname} = %{version}-%{release}
237 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
238     Provides: %{glname}-devel = %{version}-%{release}
239     Provides: GL-devel
240     Obsoletes: %{oldlibglname}-devel < 6.4
241     Provides: %{oldlibglname}-devel = %{version}-%{release}
242     Provides: libMesaGL-devel = %{version}-%{release}
243     Provides: MesaGL-devel = %{version}-%{release}
244 tv 88438 Provides: libgl-devel
245 pterjan 5340
246 tv 88433 %if %{enable_egl}
247     %package -n %{libeglname}
248     Summary: Files for Mesa (EGL libs)
249     Group: System/Libraries
250     Provides: %{libeglname_virt} = %{version}-%{release}
251    
252     %package -n %{libeglname}-devel
253     Summary: Development files for Mesa (EGL libs)
254     Group: Development/C
255 tv 88439 Requires: %{libeglname} = %{version}-%{release}
256 tv 88433 Provides: EGL-devel
257 tv 88438 Provides: lib%{eglname}-devel
258     Provides: %{eglname}-devel
259     Provides: libegl-devel
260 tv 88433 %endif
261    
262 anssi 278008 %package -n %{libosmesaname}
263     Summary: Mesa offscreen rendering library
264     Group: System/Libraries
265    
266     %package -n %{osmesadevel}
267     Summary: Development files for libosmesa
268     Group: Development/C
269     Requires: %{libosmesaname} = %{version}-%{release}
270     Provides: osmesa-devel = %{version}-%{release}
271     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
272    
273 mikala 112356 %package -n %{libglapiname}
274     Summary: Files for mesa (glapi libs)
275     Group: System/Libraries
276     Provides: %{libglapiname_virt} = %{version}-%{release}
277 tv 88442
278 mikala 112356 %package -n %{libglapiname}-devel
279     Summary: Development files for glapi libs
280     Group: Development/C
281     Requires: %{libglapiname_virt} = %{version}-%{release}
282     Provides: lib%{glapiname}-devel
283     Provides: %{libglapiname}-devel
284    
285 tv 88442 %package -n %{libglesv1name}
286     Summary: Files for Mesa (glesv1 libs)
287     Group: System/Libraries
288     Provides: %{libglesv1name_virt} = %{version}-%{release}
289    
290     %package -n %{libglesv1name}-devel
291     Summary: Development files for glesv1 libs
292     Group: Development/C
293     Requires: %{libglesv1name} = %{version}-%{release}
294     Provides: lib%{glesv1name}-devel
295     Provides: %{glesv1name}-devel
296     Provides: libglesv1-devel
297    
298     %package -n %{libglesv2name}
299     Summary: Files for Mesa (glesv2 libs)
300     Group: System/Libraries
301     Provides: %{libglesv2name_virt} = %{version}-%{release}
302    
303     %package -n %{libglesv2name}-devel
304     Summary: Development files for glesv2 libs
305     Group: Development/C
306     Requires: %{libglesv2name} = %{version}-%{release}
307 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
308 tv 88442 Provides: lib%{glesv2name}-devel
309     Provides: %{glesv2name}-devel
310     Provides: libglesv2-devel
311    
312 tv 88445 %package -n %{libopenvgname}
313     Summary: Files for MESA (OpenVG libs)
314     Group: System/Libraries
315     Provides: %{libopenvgname_virt} = %{version}-%{release}
316    
317     %package -n %{libopenvgname}-devel
318     Summary: Development files vor OpenVG libs
319     Group: Development/C
320     Requires: %{libopenvgname} = %{version}-%{release}
321     Provides: lib%{openvgname}-devel
322     Provides: %{openvgname}-devel
323     Provides: libopenvg-devel
324    
325 blino 215979 %if %{enable_wayland}
326     %package -n %{libgbmname}
327     Summary: Files for Mesa (gbm libs)
328     Group: System/Libraries
329     Provides: %{libgbmname_virt} = %{version}-%{release}
330    
331     %package -n %{libgbmname}-devel
332     Summary: Development files for Mesa (gbm libs)
333     Group: Development/C
334     Requires: %{libgbmname} = %{version}-%{release}
335     Provides: lib%{gbmname}-devel
336     Provides: %{gbmname}-devel
337    
338     %package -n %{libwaylandeglname}
339     Summary: Files for Mesa (Wayland EGL libs)
340     Group: System/Libraries
341     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
342    
343     %package -n %{libwaylandeglname}-devel
344     Summary: Development files for Mesa (Wayland EGL libs)
345     Group: Development/C
346     Requires: %{libwaylandeglname} = %{version}-%{release}
347     Provides: lib%{waylandeglname}-devel
348     Provides: %{waylandeglname}-devel
349     %endif
350    
351 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
352 blino 270761 Summary: VDPAU plugin for nouveau driver
353 blino 300616 Group: System/Libraries
354 tv 302568 # temporary:
355     %rename vdpau-driver-nouveau
356 blino 270761
357 tv 301233 %package -n %{_lib}vdpau-driver-r600
358 blino 270761 Summary: VDPAU plugin for r600 driver
359 blino 300616 Group: System/Libraries
360 tv 302568 # temporary:
361     %rename vdpau-driver-r600
362 blino 270761
363 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
364 blino 289282 Summary: VDPAU plugin for radeonsi driver
365     Group: System/Libraries
366 tv 302568 # temporary:
367     %rename vdpau-driver-radeonsi
368 blino 289282
369 pterjan 5340 %package common-devel
370     Summary: Meta package for mesa devel
371     Group: Development/C
372 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
373 pterjan 5340 Provides: hackMesa-common-devel = %{version}
374 tv 88247 Obsoletes: Mesa-common-devel < %{version}
375 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
376     Requires: %{libglname}-devel = %{version}
377 blino 289355 Requires: mesaglu-devel
378 tv 135156 Requires: freeglut-devel
379 tv 88442 Requires: %{libeglname}-devel = %{version}
380     Requires: %{libglesv1name}-devel = %{version}
381     Requires: %{libglesv2name}-devel = %{version}
382 pterjan 5340
383 tv 88440 #------------------------------------------------------------------------------
384 pterjan 5340
385     %description
386 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
387 tv 135173 %if %{build_plf}
388 pterjan 5340
389 tv 135173 This package is in the "tainted" section because it enables some
390     OpenGL extentions that are covered by software patents.
391     %endif
392    
393 pterjan 5340 %description common-devel
394     Mesa common metapackage devel
395    
396     %if %{enable_egl}
397     %description -n %{libeglname}
398 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
399 pterjan 5340 EGL parts.
400    
401     %description -n %{libeglname}-devel
402 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
403 pterjan 5340 EGL development parts.
404     %endif
405    
406     %description -n %{libglname}
407 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
408 pterjan 5340 GL and GLX parts.
409    
410 tv 135155 %if %{build_plf}
411     This package is in the "tainted" section because it enables some
412     OpenGL extentions that are covered by software patents.
413     %endif
414    
415 pterjan 5340 %description -n %{dridrivers}
416 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
417 pterjan 5340 DRI drivers.
418    
419     %description -n %{libglname}-devel
420 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
421 pterjan 5340
422     This package contains the headers needed to compile Mesa programs.
423    
424 tv 88442 %description -n %{libglesv1name}
425     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
426     well-defined subset profiles of OpenGL.
427    
428     This package provides the OpenGL ES library version 1.
429    
430 anssi 278008 %description -n %{libosmesaname}
431     Mesa offscreen rendering libraries for rendering OpenGL into
432     application-allocated blocks of memory.
433    
434     %description -n %{osmesadevel}
435     This package contains the headers needed to compile programs against
436     the Mesa offscreen rendering library.
437    
438 mikala 112356 %description -n %{libglapiname}
439     This packages provides the glapi shared library used by gallium.
440    
441     %description -n %{libglapiname}-devel
442     This package contains the headers needed to compile programes against glapi shared library.
443    
444 tv 88442 %description -n %{libglesv1name}-devel
445     This package contains the headers needed to compile OpenGL ES 1 programs.
446    
447     %description -n %{libglesv2name}
448     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
449     well-defined subset profiles of OpenGL.
450    
451     This package provides the OpenGL ES library version 2.
452    
453     %description -n %{libglesv2name}-devel
454     This package contains the headers needed to compile OpenGL ES 2 programs.
455    
456 tv 88445 %description -n %{libopenvgname}
457     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
458     acceleration interface for vector graphics libraries such as Flash and SVG.
459    
460     %description -n %{libopenvgname}-devel
461     Development files for OpenVG library.
462    
463 blino 215979 %if %{enable_wayland}
464     %description -n %{libgbmname}
465 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
466 blino 215979 GBM (Graphics Buffer Manager) parts.
467    
468     %description -n %{libgbmname}-devel
469 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
470 blino 215979 GBM (Graphics Buffer Manager) development parts.
471    
472     %description -n %{libwaylandeglname}
473 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
474 blino 215979 Wayland EGL platform parts.
475    
476     %description -n %{libwaylandeglname}-devel
477 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
478 blino 215979 Wayland EGL platform development parts.
479     %endif
480    
481 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
482 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
483     with the nouveau driver.
484    
485 tv 301233 %description -n %{_lib}vdpau-driver-r600
486 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
487     with the r600 driver.
488    
489 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
490 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
491     with the radeonsi driver.
492    
493 tv 88440 #------------------------------------------------------------------------------
494    
495 pterjan 5340 %prep
496     %if %{git}
497 cjw 336175 %setup -q -n mesa-%{git}
498     #setup -q -n mesa-%{git_branch}-%{git}
499 pterjan 5340 %else
500 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
501 pterjan 5340 %endif
502    
503 blino 278731 %apply_patches
504 pterjan 5340
505 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
506     # would break build. - Anssi 12/2012
507 cjw 336233 all=$(ls)
508     mkdir -p build-osmesa
509     cp -al $all build-osmesa
510 anssi 332631
511 pterjan 5340 %build
512 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
513     autoreconf -vfi
514    
515 tv 551068 # for bin/test-driver:
516     automake --add-missing
517    
518 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
519     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
520     export LDFLAGS="-L%{_libdir}/llvm"
521    
522     %configure2_5x --enable-dri \
523     --enable-glx \
524 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
525     --with-dri-drivers="%{dri_drivers}" \
526     %if %{enable_egl}
527     --enable-egl \
528     %else
529     --disable-egl \
530     %endif
531 blino 215979 %if %{enable_wayland}
532     --with-egl-platforms=x11,wayland,drm \
533     --enable-gbm \
534     --enable-shared-glapi \
535     %endif
536 tv 88442 --enable-gles1 \
537     --enable-gles2 \
538 tv 88445 --enable-openvg \
539 mikala 112356 --enable-gallium-egl \
540 blino 270761 --disable-xvmc \
541     --enable-vdpau \
542 mikala 112356 %if %{with_hardware}
543 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
544 mikala 112356 --enable-gallium-llvm \
545     %else
546     --disable-gallium-llvm \
547     --with-gallium-drivers=swrast \
548     %endif
549 tv 135155 %if %{build_plf}
550     --enable-texture-float \
551     %endif
552 blino 270723 # end of configure options
553 pterjan 5340
554 anssi 332631
555     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
556     # since doing that causes OSMesa to miss the OpenGL symbols.
557     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
558     # -Anssi 12/2012
559    
560 cjw 336233 pushd build-osmesa
561     autoreconf -vfi
562     %configure2_5x \
563     --enable-osmesa \
564     --disable-dri \
565     --disable-glx \
566     --disable-egl \
567     --disable-shared-glapi \
568     --without-gallium-drivers
569     popd
570 anssi 332631
571 anssi 165988 %make
572 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
573 pterjan 5340
574     %install
575 cjw 336233 %makeinstall_std -C build-osmesa
576 tv 88249 %makeinstall_std
577 pterjan 5340
578 blino 216556 # FIXME: strip will likely break the hardlink
579 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
580     # to prevent proprietary driver installers from removing them
581     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
582     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
583     for l in ../libGL.so.*; do cp -a $l .; done
584     popd
585    
586     %ifarch %{x86_64}
587     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
588     %endif
589    
590 blino 270761 # .so files are not needed by vdpau
591     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
592    
593 blino 271144 # .la files are not needed by mesa
594     find %{buildroot} -name '*.la' -exec rm {} \;
595    
596 anssi 181478 # use swrastg if built (Anssi 12/2011)
597     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
598    
599 tv 88440 #------------------------------------------------------------------------------
600    
601 pterjan 5340 %files
602     %defattr(-,root,root)
603 blino 271481 %doc docs/COPYING
604 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
605 pterjan 5340
606     %files -n %{dridrivers}
607     %defattr(-,root,root)
608     %doc docs/COPYING
609     %ifnarch ppc64
610     %dir %{_libdir}/dri
611 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
612     #%{_libdir}/dri/libglsl.so
613 pterjan 5340 %{_libdir}/dri/*_dri.so
614     %endif
615    
616 tv 88433 %files -n %{libglname}
617     %defattr(-,root,root)
618     %doc docs/COPYING
619     %{_libdir}/libGL.so.*
620     %dir %{_libdir}/mesa
621 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
622 tv 88433
623     %if %{enable_egl}
624     %files -n %{libeglname}
625     %defattr(-,root,root)
626 tv 88442 %doc docs/COPYING
627 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
628 tv 88442 %dir %{_libdir}/egl
629 blino 215979 %if !%{enable_wayland}
630     # st_GL, built only when shared glapi is not enabled
631 mikala 112356 %{_libdir}/egl/st_GL.so
632 blino 215979 %endif
633 mikala 127466 %{_libdir}/egl/egl_gallium.so
634 tv 88441 %endif
635 tv 88433
636 anssi 278008 %files -n %{libosmesaname}
637     %defattr(-,root,root)
638     %{_libdir}/libOSMesa.so.%{osmesamajor}*
639    
640 mikala 112356 %files -n %{libglapiname}
641     %defattr(-,root,root)
642     %{_libdir}/libglapi.so.%{glapimajor}*
643    
644 tv 88442 %files -n %{libglesv1name}
645     %defattr(-,root,root)
646     %doc docs/COPYING
647     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
648    
649     %files -n %{libglesv2name}
650     %defattr(-,root,root)
651     %doc docs/COPYING
652     %{_libdir}/libGLESv2.so.%{glesv2major}*
653    
654 tv 88445 %files -n %{libopenvgname}
655     %defattr(-,root,root)
656     %doc docs/COPYING
657     %{_libdir}/libOpenVG.so.%{openvgmajor}*
658    
659 blino 215979 %if %{enable_wayland}
660     %files -n %{libgbmname}
661     %{_libdir}/libgbm.so.%{gbmmajor}
662 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
663 blino 215979 %{_libdir}/gbm/gbm_*.so
664 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
665 tv 88445
666 blino 215979 %files -n %{libwaylandeglname}
667     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
668 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
669 blino 215979 %endif
670    
671    
672 pterjan 5340 %files -n %{libglname}-devel
673     %defattr(-,root,root)
674     %doc docs/COPYING
675 anssi 278008 %dir %{_includedir}/GL
676 pterjan 5340 %{_includedir}/GL/gl.h
677     %{_includedir}/GL/glext.h
678     %{_includedir}/GL/gl_mangle.h
679     %{_includedir}/GL/wglext.h
680     %{_includedir}/GL/glx.h
681     %{_includedir}/GL/glxext.h
682     %{_includedir}/GL/glx_mangle.h
683     %{_libdir}/libGL.so
684 tv 88436 %{_libdir}/pkgconfig/gl.pc
685     %{_libdir}/pkgconfig/dri.pc
686 pterjan 5340
687     #FIXME: check those headers
688 cjw 336175 #{_includedir}/GL/vms_x_fix.h
689 pterjan 5340 %{_includedir}/GL/wmesa.h
690     %dir %{_includedir}/GL/internal
691     %{_includedir}/GL/internal/dri_interface.h
692    
693     %files common-devel
694     %defattr(-,root,root)
695    
696 tv 88441 %if %{enable_egl}
697 tv 88433 %files -n %{libeglname}-devel
698     %defattr(-,root,root)
699 tv 88442 %doc docs/COPYING
700     %{_includedir}/EGL
701     %{_includedir}/KHR
702 tv 88433 %{_libdir}/libEGL.so
703 tv 88436 %{_libdir}/pkgconfig/egl.pc
704 tv 88433 %endif
705 pterjan 5340
706 anssi 278008 %files -n %{osmesadevel}
707     %defattr(-,root,root)
708     %dir %{_includedir}/GL
709     %{_includedir}/GL/osmesa.h
710     %{_libdir}/libOSMesa.so
711     %{_libdir}/pkgconfig/osmesa.pc
712    
713 mikala 112356 %files -n %{libglapiname}-devel
714     %defattr(-,root,root)
715     %{_libdir}/libglapi.so
716 pterjan 5340
717 tv 88442 %files -n %{libglesv1name}-devel
718     %defattr(-,root,root)
719     %{_includedir}/GLES
720     %{_libdir}/libGLESv1_CM.so
721     %{_libdir}/pkgconfig/glesv1_cm.pc
722 tv 88433
723 tv 88442 %files -n %{libglesv2name}-devel
724     %defattr(-,root,root)
725     %{_includedir}/GLES2
726 cjw 336175 %{_includedir}/GLES3
727 tv 88442 %{_libdir}/libGLESv2.so
728     %{_libdir}/pkgconfig/glesv2.pc
729 tv 88445
730     %files -n %{libopenvgname}-devel
731     %defattr(-,root,root)
732     %{_includedir}/VG
733     %{_libdir}/libOpenVG.so
734     %{_libdir}/pkgconfig/vg.pc
735 blino 215979
736     %if %{enable_wayland}
737     %files -n %{libgbmname}-devel
738     %{_includedir}/gbm.h
739     %{_libdir}/libgbm.so
740     %{_libdir}/pkgconfig/gbm.pc
741    
742     %files -n %{libwaylandeglname}-devel
743     %{_libdir}/libwayland-egl.so
744     %{_libdir}/pkgconfig/wayland-egl.pc
745     %endif
746 blino 270761
747 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
748 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
749    
750 tv 301233 %files -n %{_lib}vdpau-driver-r600
751 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
752    
753 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
754 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
755    

  ViewVC Help
Powered by ViewVC 1.1.30