/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 634695 - (hide annotations) (download)
Sun Jun 8 00:02:34 2014 UTC (9 years, 10 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 22675 byte(s)
enable vmwgfx/svga driver for vmware
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 634669 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 634652 %define relc 0
25 pterjan 5340 %define name mesa
26 tv 634652 %define fversion 10.2.1
27     %define version 10.2.1
28 tv 634695 %define rel 2
29 pterjan 5340
30     %define release %mkrel %{rel}
31     %define src_type tar.bz2
32 tv 173693 #define vsuffix %{expand:}
33     %define vsuffix %nil
34 pterjan 5340
35     %if %{relc}
36     %define release %mkrel 0.rc%{relc}.%{rel}
37     %define vsuffix -rc%{relc}
38     %define src_type tar.bz2
39     %endif
40    
41     %if %{git}
42     %if %{relc}
43 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
44 pterjan 5340 %else
45     %define release %mkrel 0.git%{git}.%{rel}
46     %endif
47     %endif
48    
49     %define makedepend %{_bindir}/gccmakedep
50    
51     %define eglname mesaegl
52     %define glname mesagl
53     %define glwname mesaglw
54 tv 88442 %define glesv1name mesaglesv1
55     %define glesv2name mesaglesv2
56 tv 88445 %define openvgname mesaopenvg
57 mikala 112356 %define glapiname glapi
58 blino 215979 %define gbmname gbm
59     %define waylandeglname wayland-egl
60 tv 634669 %define xaname xatracker
61 tv 88442
62 pterjan 5340 %define eglmajor 1
63     %define glmajor 1
64     %define glwmajor 1
65 tv 88442 %define glesv1major 1
66     %define glesv2major 2
67 tv 88445 %define openvgmajor 1
68 mikala 112356 %define glapimajor 0
69 blino 215979 %define gbmmajor 1
70     %define waylandeglmajor 1
71 blino 289617 %define osmesamajor 8
72 tv 634669 %define xamajor 2
73 tv 88442
74 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
75     %define libglname %mklibname %{glname} %{glmajor}
76     %define libglwname %mklibname %{glwname} %{glwmajor}
77 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
78     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
79 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
80 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
81 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
82     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
83 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
84 tv 634669 %define libxaname %mklibname %{xaname} %{xamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91     %define libeglname_virt lib%{eglname}
92     %define libglname_virt lib%{glname}
93     %define libglwname_virt lib%{glwname}
94 tv 88442 %define libglesv1name_virt lib%{glesv1name}
95     %define libglesv2name_virt lib%{glesv2name}
96 tv 88445 %define libopenvgname_virt lib%{openvgname}
97 mikala 112356 %define libglapiname_virt lib%{glapiname}
98 blino 215979 %define libgbmname_virt lib%{gbmname}
99     %define libwaylandeglname_virt lib%{waylandeglname}
100 tv 634669 %define libxaname_virt lib%{xaname}
101 pterjan 5340
102     %define oldlibglname %mklibname MesaGL 1
103    
104     %define mesasrcdir %{_prefix}/src/Mesa/
105     %define driver_dir %{_libdir}/dri
106    
107 tv 88451 %define enable_egl 1
108 blino 215979 %define enable_wayland 1
109 pterjan 5340
110     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
111     #FIXME: (for >=i586) disable sse
112     # SSE seems to have problem on some apps (gtulpas) for probing.
113 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
115 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_ppc64 ""
117 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
118     %define dri_drivers_alpha "r200,radeon,swrast"
119     %define dri_drivers_sparc "ffb,radeon,swrast"
120     %define dri_drivers_mipsel "r200,radeon,swrast"
121 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
122 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
123    
124     Name: %{name}
125     Version: %{version}
126     Release: %{release}
127 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
128 pterjan 5340 Group: System/Libraries
129    
130 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
131 tv 585816 BuildRequires: pkgconfig(xshmfence)
132 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
133     BuildRequires: pkgconfig(xmu) >= 1.0.3
134     BuildRequires: pkgconfig(x11) >= 1.3.3
135     BuildRequires: pkgconfig(xdamage) >= 1.1.1
136 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
137     BuildRequires: gccmakedep
138     BuildRequires: x11-proto-devel >= 7.3
139 tv 585820 BuildRequires: pkgconfig(libdrm) >= 2.4.52
140 pterjan 5340
141 tv 585825 BuildRequires: pkgconfig(xcb-dri3)
142     BuildRequires: pkgconfig(xcb-present)
143 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
144     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
145     BuildRequires: pkgconfig(xi) >= 1.3
146     BuildRequires: pkgconfig(talloc)
147 tv 88443 BuildRequires: libxml2-python
148 tmb 35532 BuildRequires: makedepend
149 dmorgan 106004 BuildRequires: bison flex
150 tv 469143 BuildRequires: libelf-devel
151 tv 586838 BuildRequires: llvm-devel > 3.4-1
152 mikala 127466 BuildRequires: pkgconfig(libudev)
153 blino 270761 BuildRequires: pkgconfig(vdpau)
154 blino 215979 %if %{enable_wayland}
155     BuildRequires: wayland-devel
156     %endif
157 pterjan 5340
158     URL: http://www.mesa3d.org
159     %if %{git}
160 cjw 336175 Source0: %{name}-%{git}.tar.bz2
161 blino 289278 # (blino) snapshot of 9.0 branch
162 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
163 pterjan 5340 %else
164 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
165 pterjan 5340 %endif
166     Source3: make-git-snapshot.sh
167 tmb 491931 # (tmb) disable as it breaks the build
168     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
169 pterjan 5340
170     # Instructions to setup your repository clone
171     # git://git.freedesktop.org/git/mesa/mesa
172     # git checkout mesa_7_5_branch
173     # git branch mdv-cherry-picks
174     # git am ../02??-*.patch
175     # git branch mdv-redhat
176     # git am ../03??-*.patch
177     # git branch mdv-patches
178     # git am ../09??-*.patch
179     # In order to update to the branch via patches, issue this command:
180     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
181    
182 tmb 564877 # Upstream git
183    
184 pterjan 5340 # Cherry picks
185     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
186     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
187 tmb 411326
188 blino 289280 # (blino) should be pushed to 9.0 branch upstream
189 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
190     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
191 pterjan 5340
192 tv 88247 # Patches "liberated" from Fedora:
193 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
194     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
195    
196 blino 278732 # Patches from ChromiumOS
197     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
198    
199 blino 271493 # Mageia/Mandriva patches
200 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
201 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
202 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
203 pterjan 5340
204 tv 88440 #------------------------------------------------------------------------------
205    
206     # package mesa
207 pterjan 5340 License: MIT
208     Requires: %{libglname} = %{version}-%{release}
209     Provides: hackMesa = %{version}
210     Obsoletes: hackMesa <= %{version}
211     Provides: Mesa = %{version}
212     Obsoletes: Mesa < %{version}
213    
214     %package -n %{libglname}
215     Summary: Files for Mesa (GL and GLX libs)
216     Group: System/Libraries
217 tv 88247 Obsoletes: %{oldlibglname} < 6.4
218 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
219     Provides: %{libglname_virt} = %{version}-%{release}
220     Requires: %{dridrivers} >= %{version}-%{release}
221 tv 135172 %if %{build_plf}
222     Requires: %mklibname txc-dxtn
223     %endif
224 pterjan 5340
225     # (anssi) Forces the upgrade of x11-server-common to happen before
226     # alternatives removal, which allows x11-server-common to grab the symlink.
227     Conflicts: x11-server-common < 1.3.0.0-17
228    
229     %package -n %{dridrivers}
230     Summary: Mesa DRI drivers
231     Group: System/Libraries
232 blino 274132 # do not require exact release to avoid conflicts when having
233     # x86_64 dri drivers from tainted and i586 dri drivers from core
234     Requires: mesa = %{version}
235 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
236 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
237     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
238 pterjan 5340
239     %package -n %{libglname}-devel
240     Summary: Development files for Mesa (OpenGL compatible 3D lib)
241     Group: Development/C
242 tv 88237 Requires: %{libglname} = %{version}-%{release}
243 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
244     Provides: %{glname}-devel = %{version}-%{release}
245     Provides: GL-devel
246     Obsoletes: %{oldlibglname}-devel < 6.4
247     Provides: %{oldlibglname}-devel = %{version}-%{release}
248     Provides: libMesaGL-devel = %{version}-%{release}
249     Provides: MesaGL-devel = %{version}-%{release}
250 tv 88438 Provides: libgl-devel
251 pterjan 5340
252 tv 88433 %if %{enable_egl}
253     %package -n %{libeglname}
254     Summary: Files for Mesa (EGL libs)
255     Group: System/Libraries
256     Provides: %{libeglname_virt} = %{version}-%{release}
257    
258     %package -n %{libeglname}-devel
259     Summary: Development files for Mesa (EGL libs)
260     Group: Development/C
261 tv 88439 Requires: %{libeglname} = %{version}-%{release}
262 tv 88433 Provides: EGL-devel
263 tv 88438 Provides: lib%{eglname}-devel
264     Provides: %{eglname}-devel
265     Provides: libegl-devel
266 tv 88433 %endif
267    
268 anssi 278008 %package -n %{libosmesaname}
269     Summary: Mesa offscreen rendering library
270     Group: System/Libraries
271    
272     %package -n %{osmesadevel}
273     Summary: Development files for libosmesa
274     Group: Development/C
275     Requires: %{libosmesaname} = %{version}-%{release}
276     Provides: osmesa-devel = %{version}-%{release}
277     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
278    
279 mikala 112356 %package -n %{libglapiname}
280     Summary: Files for mesa (glapi libs)
281     Group: System/Libraries
282     Provides: %{libglapiname_virt} = %{version}-%{release}
283 tv 88442
284 mikala 112356 %package -n %{libglapiname}-devel
285     Summary: Development files for glapi libs
286     Group: Development/C
287     Requires: %{libglapiname_virt} = %{version}-%{release}
288     Provides: lib%{glapiname}-devel
289     Provides: %{libglapiname}-devel
290    
291 tv 88442 %package -n %{libglesv1name}
292     Summary: Files for Mesa (glesv1 libs)
293     Group: System/Libraries
294     Provides: %{libglesv1name_virt} = %{version}-%{release}
295    
296     %package -n %{libglesv1name}-devel
297     Summary: Development files for glesv1 libs
298     Group: Development/C
299     Requires: %{libglesv1name} = %{version}-%{release}
300     Provides: lib%{glesv1name}-devel
301     Provides: %{glesv1name}-devel
302     Provides: libglesv1-devel
303    
304     %package -n %{libglesv2name}
305     Summary: Files for Mesa (glesv2 libs)
306     Group: System/Libraries
307     Provides: %{libglesv2name_virt} = %{version}-%{release}
308    
309     %package -n %{libglesv2name}-devel
310     Summary: Development files for glesv2 libs
311     Group: Development/C
312     Requires: %{libglesv2name} = %{version}-%{release}
313 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
314 tv 88442 Provides: lib%{glesv2name}-devel
315     Provides: %{glesv2name}-devel
316     Provides: libglesv2-devel
317    
318 tv 88445 %package -n %{libopenvgname}
319     Summary: Files for MESA (OpenVG libs)
320     Group: System/Libraries
321     Provides: %{libopenvgname_virt} = %{version}-%{release}
322    
323     %package -n %{libopenvgname}-devel
324     Summary: Development files vor OpenVG libs
325     Group: Development/C
326     Requires: %{libopenvgname} = %{version}-%{release}
327     Provides: lib%{openvgname}-devel
328     Provides: %{openvgname}-devel
329     Provides: libopenvg-devel
330    
331 blino 215979 %if %{enable_wayland}
332     %package -n %{libgbmname}
333     Summary: Files for Mesa (gbm libs)
334     Group: System/Libraries
335     Provides: %{libgbmname_virt} = %{version}-%{release}
336    
337     %package -n %{libgbmname}-devel
338     Summary: Development files for Mesa (gbm libs)
339     Group: Development/C
340     Requires: %{libgbmname} = %{version}-%{release}
341     Provides: lib%{gbmname}-devel
342     Provides: %{gbmname}-devel
343    
344     %package -n %{libwaylandeglname}
345     Summary: Files for Mesa (Wayland EGL libs)
346     Group: System/Libraries
347     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
348    
349     %package -n %{libwaylandeglname}-devel
350     Summary: Development files for Mesa (Wayland EGL libs)
351     Group: Development/C
352     Requires: %{libwaylandeglname} = %{version}-%{release}
353     Provides: lib%{waylandeglname}-devel
354     Provides: %{waylandeglname}-devel
355     %endif
356    
357 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
358 blino 270761 Summary: VDPAU plugin for nouveau driver
359 blino 300616 Group: System/Libraries
360 tv 302568 # temporary:
361     %rename vdpau-driver-nouveau
362 blino 270761
363 tv 301233 %package -n %{_lib}vdpau-driver-r600
364 blino 270761 Summary: VDPAU plugin for r600 driver
365 blino 300616 Group: System/Libraries
366 tv 302568 # temporary:
367     %rename vdpau-driver-r600
368 blino 270761
369 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
370 blino 289282 Summary: VDPAU plugin for radeonsi driver
371     Group: System/Libraries
372 tv 302568 # temporary:
373     %rename vdpau-driver-radeonsi
374 blino 289282
375 tv 634669 %package -n %{libxaname}
376     Summary: Files for Mesa XA state tracker
377     Group: System/Libraries
378     Provides: %{libxaname_virt} = %{version}-%{release}
379    
380     %package -n %{libxaname}-devel
381     Summary: Development files for XA libs
382     Group: Development/C
383     Requires: %{libxaname_virt} = %{version}-%{release}
384     Provides: lib%{xaname}-devel
385     Provides: %{libxaname}-devel
386    
387 pterjan 5340 %package common-devel
388     Summary: Meta package for mesa devel
389     Group: Development/C
390 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
391 pterjan 5340 Provides: hackMesa-common-devel = %{version}
392 tv 88247 Obsoletes: Mesa-common-devel < %{version}
393 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
394     Requires: %{libglname}-devel = %{version}
395 blino 289355 Requires: mesaglu-devel
396 tv 135156 Requires: freeglut-devel
397 tv 88442 Requires: %{libeglname}-devel = %{version}
398     Requires: %{libglesv1name}-devel = %{version}
399     Requires: %{libglesv2name}-devel = %{version}
400 pterjan 5340
401 tv 88440 #------------------------------------------------------------------------------
402 pterjan 5340
403     %description
404 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
405 tv 135173 %if %{build_plf}
406 pterjan 5340
407 tv 135173 This package is in the "tainted" section because it enables some
408     OpenGL extentions that are covered by software patents.
409     %endif
410    
411 pterjan 5340 %description common-devel
412     Mesa common metapackage devel
413    
414     %if %{enable_egl}
415     %description -n %{libeglname}
416 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
417 pterjan 5340 EGL parts.
418    
419     %description -n %{libeglname}-devel
420 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
421 pterjan 5340 EGL development parts.
422     %endif
423    
424     %description -n %{libglname}
425 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
426 pterjan 5340 GL and GLX parts.
427    
428 tv 135155 %if %{build_plf}
429     This package is in the "tainted" section because it enables some
430     OpenGL extentions that are covered by software patents.
431     %endif
432    
433 pterjan 5340 %description -n %{dridrivers}
434 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
435 pterjan 5340 DRI drivers.
436    
437     %description -n %{libglname}-devel
438 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
439 pterjan 5340
440     This package contains the headers needed to compile Mesa programs.
441    
442 tv 88442 %description -n %{libglesv1name}
443     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
444     well-defined subset profiles of OpenGL.
445    
446     This package provides the OpenGL ES library version 1.
447    
448 anssi 278008 %description -n %{libosmesaname}
449     Mesa offscreen rendering libraries for rendering OpenGL into
450     application-allocated blocks of memory.
451    
452     %description -n %{osmesadevel}
453     This package contains the headers needed to compile programs against
454     the Mesa offscreen rendering library.
455    
456 mikala 112356 %description -n %{libglapiname}
457     This packages provides the glapi shared library used by gallium.
458    
459     %description -n %{libglapiname}-devel
460     This package contains the headers needed to compile programes against glapi shared library.
461    
462 tv 88442 %description -n %{libglesv1name}-devel
463     This package contains the headers needed to compile OpenGL ES 1 programs.
464    
465     %description -n %{libglesv2name}
466     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
467     well-defined subset profiles of OpenGL.
468    
469     This package provides the OpenGL ES library version 2.
470    
471     %description -n %{libglesv2name}-devel
472     This package contains the headers needed to compile OpenGL ES 2 programs.
473    
474 tv 88445 %description -n %{libopenvgname}
475     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
476     acceleration interface for vector graphics libraries such as Flash and SVG.
477    
478     %description -n %{libopenvgname}-devel
479     Development files for OpenVG library.
480    
481 blino 215979 %if %{enable_wayland}
482     %description -n %{libgbmname}
483 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
484 blino 215979 GBM (Graphics Buffer Manager) parts.
485    
486     %description -n %{libgbmname}-devel
487 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
488 blino 215979 GBM (Graphics Buffer Manager) development parts.
489    
490     %description -n %{libwaylandeglname}
491 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
492 blino 215979 Wayland EGL platform parts.
493    
494     %description -n %{libwaylandeglname}-devel
495 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
496 blino 215979 Wayland EGL platform development parts.
497     %endif
498    
499 tv 634669 %description -n %{libxaname}
500     This packages provides the xa shared library used by gallium.
501    
502     %description -n %{libxaname}-devel
503     This package contains the headers needed to compile programes against xa shared library.
504    
505 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
506 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
507     with the nouveau driver.
508    
509 tv 301233 %description -n %{_lib}vdpau-driver-r600
510 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
511     with the r600 driver.
512    
513 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
514 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
515     with the radeonsi driver.
516    
517 tv 88440 #------------------------------------------------------------------------------
518    
519 pterjan 5340 %prep
520     %if %{git}
521 cjw 336175 %setup -q -n mesa-%{git}
522     #setup -q -n mesa-%{git_branch}-%{git}
523 pterjan 5340 %else
524 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
525 pterjan 5340 %endif
526    
527 blino 278731 %apply_patches
528 pterjan 5340
529 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
530     # would break build. - Anssi 12/2012
531 cjw 336233 all=$(ls)
532     mkdir -p build-osmesa
533     cp -al $all build-osmesa
534 anssi 332631
535 pterjan 5340 %build
536 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
537     autoreconf -vfi
538    
539 tv 551068 # for bin/test-driver:
540     automake --add-missing
541    
542 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
543     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
544     export LDFLAGS="-L%{_libdir}/llvm"
545    
546     %configure2_5x --enable-dri \
547     --enable-glx \
548 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
549     --with-dri-drivers="%{dri_drivers}" \
550     %if %{enable_egl}
551     --enable-egl \
552     %else
553     --disable-egl \
554     %endif
555 blino 215979 %if %{enable_wayland}
556     --with-egl-platforms=x11,wayland,drm \
557     --enable-gbm \
558     --enable-shared-glapi \
559     %endif
560 tv 88442 --enable-gles1 \
561     --enable-gles2 \
562 tv 88445 --enable-openvg \
563 mikala 112356 --enable-gallium-egl \
564 blino 270761 --disable-xvmc \
565     --enable-vdpau \
566 mikala 112356 %if %{with_hardware}
567 tv 634695 --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
568 mikala 112356 --enable-gallium-llvm \
569 tv 634669 --enable-xa \
570 mikala 112356 %else
571     --disable-gallium-llvm \
572     --with-gallium-drivers=swrast \
573     %endif
574 tv 135155 %if %{build_plf}
575     --enable-texture-float \
576     %endif
577 blino 270723 # end of configure options
578 pterjan 5340
579 anssi 332631
580     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
581     # since doing that causes OSMesa to miss the OpenGL symbols.
582     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
583     # -Anssi 12/2012
584    
585 cjw 336233 pushd build-osmesa
586     autoreconf -vfi
587     %configure2_5x \
588     --enable-osmesa \
589     --disable-dri \
590     --disable-glx \
591     --disable-egl \
592     --disable-shared-glapi \
593     --without-gallium-drivers
594     popd
595 anssi 332631
596 anssi 165988 %make
597 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
598 pterjan 5340
599     %install
600 cjw 336233 %makeinstall_std -C build-osmesa
601 tv 88249 %makeinstall_std
602 pterjan 5340
603 blino 216556 # FIXME: strip will likely break the hardlink
604 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
605     # to prevent proprietary driver installers from removing them
606     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
607     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
608     for l in ../libGL.so.*; do cp -a $l .; done
609     popd
610    
611     %ifarch %{x86_64}
612     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
613     %endif
614    
615 blino 270761 # .so files are not needed by vdpau
616     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
617    
618 blino 271144 # .la files are not needed by mesa
619     find %{buildroot} -name '*.la' -exec rm {} \;
620    
621 anssi 181478 # use swrastg if built (Anssi 12/2011)
622     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
623    
624 tv 88440 #------------------------------------------------------------------------------
625    
626 pterjan 5340 %files
627     %defattr(-,root,root)
628 blino 271481 %doc docs/COPYING
629 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
630 pterjan 5340
631     %files -n %{dridrivers}
632     %defattr(-,root,root)
633     %doc docs/COPYING
634     %ifnarch ppc64
635     %dir %{_libdir}/dri
636 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
637     #%{_libdir}/dri/libglsl.so
638 pterjan 5340 %{_libdir}/dri/*_dri.so
639     %endif
640    
641 tv 88433 %files -n %{libglname}
642     %defattr(-,root,root)
643     %doc docs/COPYING
644     %{_libdir}/libGL.so.*
645     %dir %{_libdir}/mesa
646 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
647 tv 88433
648     %if %{enable_egl}
649     %files -n %{libeglname}
650     %defattr(-,root,root)
651 tv 88442 %doc docs/COPYING
652 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
653 tv 88442 %dir %{_libdir}/egl
654 blino 215979 %if !%{enable_wayland}
655     # st_GL, built only when shared glapi is not enabled
656 mikala 112356 %{_libdir}/egl/st_GL.so
657 blino 215979 %endif
658 mikala 127466 %{_libdir}/egl/egl_gallium.so
659 tv 88441 %endif
660 tv 88433
661 anssi 278008 %files -n %{libosmesaname}
662     %defattr(-,root,root)
663     %{_libdir}/libOSMesa.so.%{osmesamajor}*
664    
665 mikala 112356 %files -n %{libglapiname}
666     %defattr(-,root,root)
667     %{_libdir}/libglapi.so.%{glapimajor}*
668    
669 tv 88442 %files -n %{libglesv1name}
670     %defattr(-,root,root)
671     %doc docs/COPYING
672     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
673    
674     %files -n %{libglesv2name}
675     %defattr(-,root,root)
676     %doc docs/COPYING
677     %{_libdir}/libGLESv2.so.%{glesv2major}*
678    
679 tv 88445 %files -n %{libopenvgname}
680     %defattr(-,root,root)
681     %doc docs/COPYING
682     %{_libdir}/libOpenVG.so.%{openvgmajor}*
683    
684 blino 215979 %if %{enable_wayland}
685     %files -n %{libgbmname}
686     %{_libdir}/libgbm.so.%{gbmmajor}
687 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
688 blino 215979 %{_libdir}/gbm/gbm_*.so
689 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
690 tv 88445
691 blino 215979 %files -n %{libwaylandeglname}
692     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
693 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
694 blino 215979 %endif
695    
696 tv 634669 %files -n %{libxaname}
697     %defattr(-,root,root)
698     %{_libdir}/libxatracker.so.%{xamajor}*
699 blino 215979
700 pterjan 5340 %files -n %{libglname}-devel
701     %defattr(-,root,root)
702     %doc docs/COPYING
703 anssi 278008 %dir %{_includedir}/GL
704 pterjan 5340 %{_includedir}/GL/gl.h
705     %{_includedir}/GL/glext.h
706     %{_includedir}/GL/gl_mangle.h
707     %{_includedir}/GL/wglext.h
708     %{_includedir}/GL/glx.h
709     %{_includedir}/GL/glxext.h
710     %{_includedir}/GL/glx_mangle.h
711     %{_libdir}/libGL.so
712 tv 88436 %{_libdir}/pkgconfig/gl.pc
713     %{_libdir}/pkgconfig/dri.pc
714 pterjan 5340
715     #FIXME: check those headers
716 cjw 336175 #{_includedir}/GL/vms_x_fix.h
717 pterjan 5340 %{_includedir}/GL/wmesa.h
718     %dir %{_includedir}/GL/internal
719     %{_includedir}/GL/internal/dri_interface.h
720    
721     %files common-devel
722     %defattr(-,root,root)
723    
724 tv 88441 %if %{enable_egl}
725 tv 88433 %files -n %{libeglname}-devel
726     %defattr(-,root,root)
727 tv 88442 %doc docs/COPYING
728     %{_includedir}/EGL
729     %{_includedir}/KHR
730 tv 88433 %{_libdir}/libEGL.so
731 tv 88436 %{_libdir}/pkgconfig/egl.pc
732 tv 88433 %endif
733 pterjan 5340
734 anssi 278008 %files -n %{osmesadevel}
735     %defattr(-,root,root)
736     %dir %{_includedir}/GL
737     %{_includedir}/GL/osmesa.h
738     %{_libdir}/libOSMesa.so
739     %{_libdir}/pkgconfig/osmesa.pc
740    
741 mikala 112356 %files -n %{libglapiname}-devel
742     %defattr(-,root,root)
743     %{_libdir}/libglapi.so
744 pterjan 5340
745 tv 88442 %files -n %{libglesv1name}-devel
746     %defattr(-,root,root)
747     %{_includedir}/GLES
748     %{_libdir}/libGLESv1_CM.so
749     %{_libdir}/pkgconfig/glesv1_cm.pc
750 tv 88433
751 tv 88442 %files -n %{libglesv2name}-devel
752     %defattr(-,root,root)
753     %{_includedir}/GLES2
754 cjw 336175 %{_includedir}/GLES3
755 tv 88442 %{_libdir}/libGLESv2.so
756     %{_libdir}/pkgconfig/glesv2.pc
757 tv 88445
758     %files -n %{libopenvgname}-devel
759     %defattr(-,root,root)
760     %{_includedir}/VG
761     %{_libdir}/libOpenVG.so
762     %{_libdir}/pkgconfig/vg.pc
763 blino 215979
764     %if %{enable_wayland}
765     %files -n %{libgbmname}-devel
766     %{_includedir}/gbm.h
767     %{_libdir}/libgbm.so
768     %{_libdir}/pkgconfig/gbm.pc
769    
770     %files -n %{libwaylandeglname}-devel
771     %{_libdir}/libwayland-egl.so
772     %{_libdir}/pkgconfig/wayland-egl.pc
773     %endif
774 blino 270761
775 tv 634669 %files -n %{libxaname}-devel
776     %defattr(-,root,root)
777     %{_libdir}/libxatracker.so
778     %{_includedir}/xa_tracker.h
779     %{_includedir}/xa_composite.h
780     %{_includedir}/xa_context.h
781     %{_libdir}/pkgconfig/xatracker.pc
782    
783 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
784 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
785    
786 tv 301233 %files -n %{_lib}vdpau-driver-r600
787 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
788    
789 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
790 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
791    

  ViewVC Help
Powered by ViewVC 1.1.30