/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 645737 - (hide annotations) (download)
Sun Jul 6 13:05:18 2014 UTC (9 years, 9 months ago) by ovitters
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 22224 byte(s)
- SILENT one line per buildrequirement
- SILENT remove defattr
- SILENT remove variable definition(s) name, version
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 634669 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 634652 %define relc 0
25 tv 639551 %define fversion 10.2.2
26     %define rel 1
27 pterjan 5340
28     %define release %mkrel %{rel}
29     %define src_type tar.bz2
30 tv 173693 #define vsuffix %{expand:}
31     %define vsuffix %nil
32 pterjan 5340
33     %if %{relc}
34     %define release %mkrel 0.rc%{relc}.%{rel}
35     %define vsuffix -rc%{relc}
36     %define src_type tar.bz2
37     %endif
38    
39     %if %{git}
40     %if %{relc}
41 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
42 pterjan 5340 %else
43     %define release %mkrel 0.git%{git}.%{rel}
44     %endif
45     %endif
46    
47     %define makedepend %{_bindir}/gccmakedep
48    
49     %define eglname mesaegl
50     %define glname mesagl
51     %define glwname mesaglw
52 tv 88442 %define glesv1name mesaglesv1
53     %define glesv2name mesaglesv2
54 tv 88445 %define openvgname mesaopenvg
55 mikala 112356 %define glapiname glapi
56 blino 215979 %define gbmname gbm
57     %define waylandeglname wayland-egl
58 tv 634669 %define xaname xatracker
59 tv 88442
60 pterjan 5340 %define eglmajor 1
61     %define glmajor 1
62     %define glwmajor 1
63 tv 88442 %define glesv1major 1
64     %define glesv2major 2
65 tv 88445 %define openvgmajor 1
66 mikala 112356 %define glapimajor 0
67 blino 215979 %define gbmmajor 1
68     %define waylandeglmajor 1
69 blino 289617 %define osmesamajor 8
70 tv 634669 %define xamajor 2
71 tv 88442
72 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
73     %define libglname %mklibname %{glname} %{glmajor}
74     %define libglwname %mklibname %{glwname} %{glwmajor}
75 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
76     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
77 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
78 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
79 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
80     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
81 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
82 tv 634669 %define libxaname %mklibname %{xaname} %{xamajor}
83 pterjan 5340
84     %define dridrivers %mklibname dri-drivers
85    
86 anssi 278008 %define osmesadevel %mklibname osmesa -d
87    
88 pterjan 5340 # Architecture-independent Virtual provides:
89     %define libeglname_virt lib%{eglname}
90     %define libglname_virt lib%{glname}
91     %define libglwname_virt lib%{glwname}
92 tv 88442 %define libglesv1name_virt lib%{glesv1name}
93     %define libglesv2name_virt lib%{glesv2name}
94 tv 88445 %define libopenvgname_virt lib%{openvgname}
95 mikala 112356 %define libglapiname_virt lib%{glapiname}
96 blino 215979 %define libgbmname_virt lib%{gbmname}
97     %define libwaylandeglname_virt lib%{waylandeglname}
98 tv 634669 %define libxaname_virt lib%{xaname}
99 pterjan 5340
100     %define oldlibglname %mklibname MesaGL 1
101    
102     %define mesasrcdir %{_prefix}/src/Mesa/
103     %define driver_dir %{_libdir}/dri
104    
105 tv 88451 %define enable_egl 1
106 blino 215979 %define enable_wayland 1
107 pterjan 5340
108     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
109     #FIXME: (for >=i586) disable sse
110     # SSE seems to have problem on some apps (gtulpas) for probing.
111 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
112 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
113 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
114 pterjan 5340 %define dri_drivers_ppc64 ""
115 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
116     %define dri_drivers_alpha "r200,radeon,swrast"
117     %define dri_drivers_sparc "ffb,radeon,swrast"
118     %define dri_drivers_mipsel "r200,radeon,swrast"
119 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
120 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
121    
122 ovitters 645737 Name: mesa
123     Version: 10.2.2
124 pterjan 5340 Release: %{release}
125 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
126 pterjan 5340 Group: System/Libraries
127    
128 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
129 tv 585816 BuildRequires: pkgconfig(xshmfence)
130 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
131     BuildRequires: pkgconfig(xmu) >= 1.0.3
132     BuildRequires: pkgconfig(x11) >= 1.3.3
133     BuildRequires: pkgconfig(xdamage) >= 1.1.1
134 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
135     BuildRequires: gccmakedep
136     BuildRequires: x11-proto-devel >= 7.3
137 tv 585820 BuildRequires: pkgconfig(libdrm) >= 2.4.52
138 pterjan 5340
139 tv 585825 BuildRequires: pkgconfig(xcb-dri3)
140     BuildRequires: pkgconfig(xcb-present)
141 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
142     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
143     BuildRequires: pkgconfig(xi) >= 1.3
144     BuildRequires: pkgconfig(talloc)
145 tv 88443 BuildRequires: libxml2-python
146 tmb 35532 BuildRequires: makedepend
147 ovitters 645737 BuildRequires: bison
148     BuildRequires: flex
149 tv 469143 BuildRequires: libelf-devel
150 tmb 637662 BuildRequires: llvm-devel >= 3.4.2-1
151 mikala 127466 BuildRequires: pkgconfig(libudev)
152 blino 270761 BuildRequires: pkgconfig(vdpau)
153 blino 215979 %if %{enable_wayland}
154     BuildRequires: wayland-devel
155     %endif
156 pterjan 5340
157     URL: http://www.mesa3d.org
158     %if %{git}
159 cjw 336175 Source0: %{name}-%{git}.tar.bz2
160 blino 289278 # (blino) snapshot of 9.0 branch
161 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
162 pterjan 5340 %else
163 tv 303797 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type}
164 pterjan 5340 %endif
165     Source3: make-git-snapshot.sh
166 tmb 491931 # (tmb) disable as it breaks the build
167     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
168 pterjan 5340
169     # Instructions to setup your repository clone
170     # git://git.freedesktop.org/git/mesa/mesa
171     # git checkout mesa_7_5_branch
172     # git branch mdv-cherry-picks
173     # git am ../02??-*.patch
174     # git branch mdv-redhat
175     # git am ../03??-*.patch
176     # git branch mdv-patches
177     # git am ../09??-*.patch
178     # In order to update to the branch via patches, issue this command:
179     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
180    
181 tmb 564877 # Upstream git
182    
183 pterjan 5340 # Cherry picks
184     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
185     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
186 tmb 411326
187 blino 289280 # (blino) should be pushed to 9.0 branch upstream
188 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
189     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
190 pterjan 5340
191 tv 88247 # Patches "liberated" from Fedora:
192 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
193     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
194    
195 blino 278732 # Patches from ChromiumOS
196     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
197    
198 blino 271493 # Mageia/Mandriva patches
199 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
200 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
201 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
202 pterjan 5340
203 tv 88440 #------------------------------------------------------------------------------
204    
205     # package mesa
206 pterjan 5340 License: MIT
207     Requires: %{libglname} = %{version}-%{release}
208     Provides: hackMesa = %{version}
209     Obsoletes: hackMesa <= %{version}
210     Provides: Mesa = %{version}
211     Obsoletes: Mesa < %{version}
212    
213     %package -n %{libglname}
214     Summary: Files for Mesa (GL and GLX libs)
215     Group: System/Libraries
216 tv 88247 Obsoletes: %{oldlibglname} < 6.4
217 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
218     Provides: %{libglname_virt} = %{version}-%{release}
219     Requires: %{dridrivers} >= %{version}-%{release}
220 tv 135172 %if %{build_plf}
221     Requires: %mklibname txc-dxtn
222     %endif
223 pterjan 5340
224     # (anssi) Forces the upgrade of x11-server-common to happen before
225     # alternatives removal, which allows x11-server-common to grab the symlink.
226     Conflicts: x11-server-common < 1.3.0.0-17
227    
228     %package -n %{dridrivers}
229     Summary: Mesa DRI drivers
230     Group: System/Libraries
231 blino 274132 # do not require exact release to avoid conflicts when having
232     # x86_64 dri drivers from tainted and i586 dri drivers from core
233     Requires: mesa = %{version}
234 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
235 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
236     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
237 pterjan 5340
238     %package -n %{libglname}-devel
239     Summary: Development files for Mesa (OpenGL compatible 3D lib)
240     Group: Development/C
241 tv 88237 Requires: %{libglname} = %{version}-%{release}
242 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
243     Provides: %{glname}-devel = %{version}-%{release}
244     Provides: GL-devel
245     Obsoletes: %{oldlibglname}-devel < 6.4
246     Provides: %{oldlibglname}-devel = %{version}-%{release}
247     Provides: libMesaGL-devel = %{version}-%{release}
248     Provides: MesaGL-devel = %{version}-%{release}
249 tv 88438 Provides: libgl-devel
250 pterjan 5340
251 tv 88433 %if %{enable_egl}
252     %package -n %{libeglname}
253     Summary: Files for Mesa (EGL libs)
254     Group: System/Libraries
255     Provides: %{libeglname_virt} = %{version}-%{release}
256    
257     %package -n %{libeglname}-devel
258     Summary: Development files for Mesa (EGL libs)
259     Group: Development/C
260 tv 88439 Requires: %{libeglname} = %{version}-%{release}
261 tv 88433 Provides: EGL-devel
262 tv 88438 Provides: lib%{eglname}-devel
263     Provides: %{eglname}-devel
264     Provides: libegl-devel
265 tv 88433 %endif
266    
267 anssi 278008 %package -n %{libosmesaname}
268     Summary: Mesa offscreen rendering library
269     Group: System/Libraries
270    
271     %package -n %{osmesadevel}
272     Summary: Development files for libosmesa
273     Group: Development/C
274     Requires: %{libosmesaname} = %{version}-%{release}
275     Provides: osmesa-devel = %{version}-%{release}
276     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
277    
278 mikala 112356 %package -n %{libglapiname}
279     Summary: Files for mesa (glapi libs)
280     Group: System/Libraries
281     Provides: %{libglapiname_virt} = %{version}-%{release}
282 tv 88442
283 mikala 112356 %package -n %{libglapiname}-devel
284     Summary: Development files for glapi libs
285     Group: Development/C
286     Requires: %{libglapiname_virt} = %{version}-%{release}
287     Provides: lib%{glapiname}-devel
288     Provides: %{libglapiname}-devel
289    
290 tv 88442 %package -n %{libglesv1name}
291     Summary: Files for Mesa (glesv1 libs)
292     Group: System/Libraries
293     Provides: %{libglesv1name_virt} = %{version}-%{release}
294    
295     %package -n %{libglesv1name}-devel
296     Summary: Development files for glesv1 libs
297     Group: Development/C
298     Requires: %{libglesv1name} = %{version}-%{release}
299     Provides: lib%{glesv1name}-devel
300     Provides: %{glesv1name}-devel
301     Provides: libglesv1-devel
302    
303     %package -n %{libglesv2name}
304     Summary: Files for Mesa (glesv2 libs)
305     Group: System/Libraries
306     Provides: %{libglesv2name_virt} = %{version}-%{release}
307    
308     %package -n %{libglesv2name}-devel
309     Summary: Development files for glesv2 libs
310     Group: Development/C
311     Requires: %{libglesv2name} = %{version}-%{release}
312 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
313 tv 88442 Provides: lib%{glesv2name}-devel
314     Provides: %{glesv2name}-devel
315     Provides: libglesv2-devel
316    
317 tv 88445 %package -n %{libopenvgname}
318     Summary: Files for MESA (OpenVG libs)
319     Group: System/Libraries
320     Provides: %{libopenvgname_virt} = %{version}-%{release}
321    
322     %package -n %{libopenvgname}-devel
323     Summary: Development files vor OpenVG libs
324     Group: Development/C
325     Requires: %{libopenvgname} = %{version}-%{release}
326     Provides: lib%{openvgname}-devel
327     Provides: %{openvgname}-devel
328     Provides: libopenvg-devel
329    
330 blino 215979 %if %{enable_wayland}
331     %package -n %{libgbmname}
332     Summary: Files for Mesa (gbm libs)
333     Group: System/Libraries
334     Provides: %{libgbmname_virt} = %{version}-%{release}
335    
336     %package -n %{libgbmname}-devel
337     Summary: Development files for Mesa (gbm libs)
338     Group: Development/C
339     Requires: %{libgbmname} = %{version}-%{release}
340     Provides: lib%{gbmname}-devel
341     Provides: %{gbmname}-devel
342    
343     %package -n %{libwaylandeglname}
344     Summary: Files for Mesa (Wayland EGL libs)
345     Group: System/Libraries
346     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
347    
348     %package -n %{libwaylandeglname}-devel
349     Summary: Development files for Mesa (Wayland EGL libs)
350     Group: Development/C
351     Requires: %{libwaylandeglname} = %{version}-%{release}
352     Provides: lib%{waylandeglname}-devel
353     Provides: %{waylandeglname}-devel
354     %endif
355    
356 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
357 blino 270761 Summary: VDPAU plugin for nouveau driver
358 blino 300616 Group: System/Libraries
359 tv 302568 # temporary:
360     %rename vdpau-driver-nouveau
361 blino 270761
362 tv 301233 %package -n %{_lib}vdpau-driver-r600
363 blino 270761 Summary: VDPAU plugin for r600 driver
364 blino 300616 Group: System/Libraries
365 tv 302568 # temporary:
366     %rename vdpau-driver-r600
367 blino 270761
368 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
369 blino 289282 Summary: VDPAU plugin for radeonsi driver
370     Group: System/Libraries
371 tv 302568 # temporary:
372     %rename vdpau-driver-radeonsi
373 blino 289282
374 tv 634669 %package -n %{libxaname}
375     Summary: Files for Mesa XA state tracker
376     Group: System/Libraries
377     Provides: %{libxaname_virt} = %{version}-%{release}
378    
379     %package -n %{libxaname}-devel
380     Summary: Development files for XA libs
381     Group: Development/C
382     Requires: %{libxaname_virt} = %{version}-%{release}
383     Provides: lib%{xaname}-devel
384     Provides: %{libxaname}-devel
385    
386 pterjan 5340 %package common-devel
387     Summary: Meta package for mesa devel
388     Group: Development/C
389 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
390 pterjan 5340 Provides: hackMesa-common-devel = %{version}
391 tv 88247 Obsoletes: Mesa-common-devel < %{version}
392 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
393     Requires: %{libglname}-devel = %{version}
394 blino 289355 Requires: mesaglu-devel
395 tv 135156 Requires: freeglut-devel
396 tv 88442 Requires: %{libeglname}-devel = %{version}
397     Requires: %{libglesv1name}-devel = %{version}
398     Requires: %{libglesv2name}-devel = %{version}
399 pterjan 5340
400 tv 88440 #------------------------------------------------------------------------------
401 pterjan 5340
402     %description
403 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
404 tv 135173 %if %{build_plf}
405 pterjan 5340
406 tv 135173 This package is in the "tainted" section because it enables some
407     OpenGL extentions that are covered by software patents.
408     %endif
409    
410 pterjan 5340 %description common-devel
411     Mesa common metapackage devel
412    
413     %if %{enable_egl}
414     %description -n %{libeglname}
415 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
416 pterjan 5340 EGL parts.
417    
418     %description -n %{libeglname}-devel
419 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 pterjan 5340 EGL development parts.
421     %endif
422    
423     %description -n %{libglname}
424 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
425 pterjan 5340 GL and GLX parts.
426    
427 tv 135155 %if %{build_plf}
428     This package is in the "tainted" section because it enables some
429     OpenGL extentions that are covered by software patents.
430     %endif
431    
432 pterjan 5340 %description -n %{dridrivers}
433 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
434 pterjan 5340 DRI drivers.
435    
436     %description -n %{libglname}-devel
437 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
438 pterjan 5340
439     This package contains the headers needed to compile Mesa programs.
440    
441 tv 88442 %description -n %{libglesv1name}
442     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
443     well-defined subset profiles of OpenGL.
444    
445     This package provides the OpenGL ES library version 1.
446    
447 anssi 278008 %description -n %{libosmesaname}
448     Mesa offscreen rendering libraries for rendering OpenGL into
449     application-allocated blocks of memory.
450    
451     %description -n %{osmesadevel}
452     This package contains the headers needed to compile programs against
453     the Mesa offscreen rendering library.
454    
455 mikala 112356 %description -n %{libglapiname}
456     This packages provides the glapi shared library used by gallium.
457    
458     %description -n %{libglapiname}-devel
459     This package contains the headers needed to compile programes against glapi shared library.
460    
461 tv 88442 %description -n %{libglesv1name}-devel
462     This package contains the headers needed to compile OpenGL ES 1 programs.
463    
464     %description -n %{libglesv2name}
465     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
466     well-defined subset profiles of OpenGL.
467    
468     This package provides the OpenGL ES library version 2.
469    
470     %description -n %{libglesv2name}-devel
471     This package contains the headers needed to compile OpenGL ES 2 programs.
472    
473 tv 88445 %description -n %{libopenvgname}
474     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
475     acceleration interface for vector graphics libraries such as Flash and SVG.
476    
477     %description -n %{libopenvgname}-devel
478     Development files for OpenVG library.
479    
480 blino 215979 %if %{enable_wayland}
481     %description -n %{libgbmname}
482 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
483 blino 215979 GBM (Graphics Buffer Manager) parts.
484    
485     %description -n %{libgbmname}-devel
486 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
487 blino 215979 GBM (Graphics Buffer Manager) development parts.
488    
489     %description -n %{libwaylandeglname}
490 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
491 blino 215979 Wayland EGL platform parts.
492    
493     %description -n %{libwaylandeglname}-devel
494 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
495 blino 215979 Wayland EGL platform development parts.
496     %endif
497    
498 tv 634669 %description -n %{libxaname}
499     This packages provides the xa shared library used by gallium.
500    
501     %description -n %{libxaname}-devel
502     This package contains the headers needed to compile programes against xa shared library.
503    
504 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
505 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
506     with the nouveau driver.
507    
508 tv 301233 %description -n %{_lib}vdpau-driver-r600
509 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
510     with the r600 driver.
511    
512 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
513 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
514     with the radeonsi driver.
515    
516 tv 88440 #------------------------------------------------------------------------------
517    
518 pterjan 5340 %prep
519     %if %{git}
520 cjw 336175 %setup -q -n mesa-%{git}
521     #setup -q -n mesa-%{git_branch}-%{git}
522 pterjan 5340 %else
523 tv 303797 %setup -q -n Mesa-%{fversion}%{vsuffix}
524 pterjan 5340 %endif
525    
526 blino 278731 %apply_patches
527 pterjan 5340
528 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
529     # would break build. - Anssi 12/2012
530 cjw 336233 all=$(ls)
531     mkdir -p build-osmesa
532     cp -al $all build-osmesa
533 anssi 332631
534 pterjan 5340 %build
535 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
536     autoreconf -vfi
537    
538 tv 551068 # for bin/test-driver:
539     automake --add-missing
540    
541 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
542     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
543     export LDFLAGS="-L%{_libdir}/llvm"
544    
545     %configure2_5x --enable-dri \
546     --enable-glx \
547 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
548     --with-dri-drivers="%{dri_drivers}" \
549     %if %{enable_egl}
550     --enable-egl \
551     %else
552     --disable-egl \
553     %endif
554 blino 215979 %if %{enable_wayland}
555     --with-egl-platforms=x11,wayland,drm \
556     --enable-gbm \
557     --enable-shared-glapi \
558     %endif
559 tv 88442 --enable-gles1 \
560     --enable-gles2 \
561 tv 88445 --enable-openvg \
562 mikala 112356 --enable-gallium-egl \
563 blino 270761 --disable-xvmc \
564     --enable-vdpau \
565 mikala 112356 %if %{with_hardware}
566 tv 634695 --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
567 mikala 112356 --enable-gallium-llvm \
568 tv 634669 --enable-xa \
569 mikala 112356 %else
570     --disable-gallium-llvm \
571     --with-gallium-drivers=swrast \
572     %endif
573 tv 135155 %if %{build_plf}
574     --enable-texture-float \
575     %endif
576 blino 270723 # end of configure options
577 pterjan 5340
578 anssi 332631
579     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
580     # since doing that causes OSMesa to miss the OpenGL symbols.
581     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
582     # -Anssi 12/2012
583    
584 cjw 336233 pushd build-osmesa
585     autoreconf -vfi
586     %configure2_5x \
587     --enable-osmesa \
588     --disable-dri \
589     --disable-glx \
590     --disable-egl \
591     --disable-shared-glapi \
592     --without-gallium-drivers
593     popd
594 anssi 332631
595 anssi 165988 %make
596 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
597 pterjan 5340
598     %install
599 cjw 336233 %makeinstall_std -C build-osmesa
600 tv 88249 %makeinstall_std
601 pterjan 5340
602 blino 216556 # FIXME: strip will likely break the hardlink
603 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
604     # to prevent proprietary driver installers from removing them
605     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
606     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
607     for l in ../libGL.so.*; do cp -a $l .; done
608     popd
609    
610     %ifarch %{x86_64}
611     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
612     %endif
613    
614 blino 270761 # .so files are not needed by vdpau
615     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
616    
617 blino 271144 # .la files are not needed by mesa
618     find %{buildroot} -name '*.la' -exec rm {} \;
619    
620 anssi 181478 # use swrastg if built (Anssi 12/2011)
621     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
622    
623 tv 88440 #------------------------------------------------------------------------------
624    
625 pterjan 5340 %files
626 blino 271481 %doc docs/COPYING
627 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
628 pterjan 5340
629     %files -n %{dridrivers}
630     %doc docs/COPYING
631     %ifnarch ppc64
632     %dir %{_libdir}/dri
633 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
634     #%{_libdir}/dri/libglsl.so
635 pterjan 5340 %{_libdir}/dri/*_dri.so
636     %endif
637    
638 tv 88433 %files -n %{libglname}
639     %doc docs/COPYING
640     %{_libdir}/libGL.so.*
641     %dir %{_libdir}/mesa
642 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
643 tv 88433
644     %if %{enable_egl}
645     %files -n %{libeglname}
646 tv 88442 %doc docs/COPYING
647 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
648 tv 88442 %dir %{_libdir}/egl
649 blino 215979 %if !%{enable_wayland}
650     # st_GL, built only when shared glapi is not enabled
651 mikala 112356 %{_libdir}/egl/st_GL.so
652 blino 215979 %endif
653 mikala 127466 %{_libdir}/egl/egl_gallium.so
654 tv 88441 %endif
655 tv 88433
656 anssi 278008 %files -n %{libosmesaname}
657     %{_libdir}/libOSMesa.so.%{osmesamajor}*
658    
659 mikala 112356 %files -n %{libglapiname}
660     %{_libdir}/libglapi.so.%{glapimajor}*
661    
662 tv 88442 %files -n %{libglesv1name}
663     %doc docs/COPYING
664     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
665    
666     %files -n %{libglesv2name}
667     %doc docs/COPYING
668     %{_libdir}/libGLESv2.so.%{glesv2major}*
669    
670 tv 88445 %files -n %{libopenvgname}
671     %doc docs/COPYING
672     %{_libdir}/libOpenVG.so.%{openvgmajor}*
673    
674 blino 215979 %if %{enable_wayland}
675     %files -n %{libgbmname}
676     %{_libdir}/libgbm.so.%{gbmmajor}
677 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
678 blino 215979 %{_libdir}/gbm/gbm_*.so
679 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
680 tv 88445
681 blino 215979 %files -n %{libwaylandeglname}
682     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
683 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
684 blino 215979 %endif
685    
686 tv 634669 %files -n %{libxaname}
687     %{_libdir}/libxatracker.so.%{xamajor}*
688 blino 215979
689 pterjan 5340 %files -n %{libglname}-devel
690     %doc docs/COPYING
691 anssi 278008 %dir %{_includedir}/GL
692 pterjan 5340 %{_includedir}/GL/gl.h
693     %{_includedir}/GL/glext.h
694     %{_includedir}/GL/gl_mangle.h
695     %{_includedir}/GL/wglext.h
696     %{_includedir}/GL/glx.h
697     %{_includedir}/GL/glxext.h
698     %{_includedir}/GL/glx_mangle.h
699     %{_libdir}/libGL.so
700 tv 88436 %{_libdir}/pkgconfig/gl.pc
701     %{_libdir}/pkgconfig/dri.pc
702 pterjan 5340
703     #FIXME: check those headers
704 cjw 336175 #{_includedir}/GL/vms_x_fix.h
705 pterjan 5340 %{_includedir}/GL/wmesa.h
706     %dir %{_includedir}/GL/internal
707     %{_includedir}/GL/internal/dri_interface.h
708    
709     %files common-devel
710 tv 88441 %if %{enable_egl}
711 tv 88433 %files -n %{libeglname}-devel
712 tv 88442 %doc docs/COPYING
713     %{_includedir}/EGL
714     %{_includedir}/KHR
715 tv 88433 %{_libdir}/libEGL.so
716 tv 88436 %{_libdir}/pkgconfig/egl.pc
717 tv 88433 %endif
718 pterjan 5340
719 anssi 278008 %files -n %{osmesadevel}
720     %dir %{_includedir}/GL
721     %{_includedir}/GL/osmesa.h
722     %{_libdir}/libOSMesa.so
723     %{_libdir}/pkgconfig/osmesa.pc
724    
725 mikala 112356 %files -n %{libglapiname}-devel
726     %{_libdir}/libglapi.so
727 pterjan 5340
728 tv 88442 %files -n %{libglesv1name}-devel
729     %{_includedir}/GLES
730     %{_libdir}/libGLESv1_CM.so
731     %{_libdir}/pkgconfig/glesv1_cm.pc
732 tv 88433
733 tv 88442 %files -n %{libglesv2name}-devel
734     %{_includedir}/GLES2
735 cjw 336175 %{_includedir}/GLES3
736 tv 88442 %{_libdir}/libGLESv2.so
737     %{_libdir}/pkgconfig/glesv2.pc
738 tv 88445
739     %files -n %{libopenvgname}-devel
740     %{_includedir}/VG
741     %{_libdir}/libOpenVG.so
742     %{_libdir}/pkgconfig/vg.pc
743 blino 215979
744     %if %{enable_wayland}
745     %files -n %{libgbmname}-devel
746     %{_includedir}/gbm.h
747     %{_libdir}/libgbm.so
748     %{_libdir}/pkgconfig/gbm.pc
749    
750     %files -n %{libwaylandeglname}-devel
751     %{_libdir}/libwayland-egl.so
752     %{_libdir}/pkgconfig/wayland-egl.pc
753     %endif
754 blino 270761
755 tv 634669 %files -n %{libxaname}-devel
756     %{_libdir}/libxatracker.so
757     %{_includedir}/xa_tracker.h
758     %{_includedir}/xa_composite.h
759     %{_includedir}/xa_context.h
760     %{_libdir}/pkgconfig/xatracker.pc
761    
762 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
763 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
764    
765 tv 301233 %files -n %{_lib}vdpau-driver-r600
766 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
767    
768 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
769 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
770    

  ViewVC Help
Powered by ViewVC 1.1.30