/[packages]/backports/4/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /backports/4/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 650618 - (hide annotations) (download)
Tue Jul 8 06:24:37 2014 UTC (9 years, 8 months ago) by tv
Original Path: cauldron/mesa/current/SPECS/mesa.spec
File size: 22216 byte(s)
- new release
- drop %%fversion definition (SILENT)
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 cjw 398478 # http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4
18 tmb 400079 %define git 0
19 tv 634669 %define git_branch 9.2
20 mikala 112356 %define with_hardware 1
21    
22 blino 289603 %define opengl_ver 3.0
23 blino 289598
24 tv 634652 %define relc 0
25 tv 639551 %define rel 1
26 pterjan 5340
27     %define release %mkrel %{rel}
28     %define src_type tar.bz2
29 tv 173693 #define vsuffix %{expand:}
30     %define vsuffix %nil
31 pterjan 5340
32     %if %{relc}
33     %define release %mkrel 0.rc%{relc}.%{rel}
34     %define vsuffix -rc%{relc}
35     %define src_type tar.bz2
36     %endif
37    
38     %if %{git}
39     %if %{relc}
40 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
41 pterjan 5340 %else
42     %define release %mkrel 0.git%{git}.%{rel}
43     %endif
44     %endif
45    
46     %define makedepend %{_bindir}/gccmakedep
47    
48     %define eglname mesaegl
49     %define glname mesagl
50     %define glwname mesaglw
51 tv 88442 %define glesv1name mesaglesv1
52     %define glesv2name mesaglesv2
53 tv 88445 %define openvgname mesaopenvg
54 mikala 112356 %define glapiname glapi
55 blino 215979 %define gbmname gbm
56     %define waylandeglname wayland-egl
57 tv 634669 %define xaname xatracker
58 tv 88442
59 pterjan 5340 %define eglmajor 1
60     %define glmajor 1
61     %define glwmajor 1
62 tv 88442 %define glesv1major 1
63     %define glesv2major 2
64 tv 88445 %define openvgmajor 1
65 mikala 112356 %define glapimajor 0
66 blino 215979 %define gbmmajor 1
67     %define waylandeglmajor 1
68 blino 289617 %define osmesamajor 8
69 tv 634669 %define xamajor 2
70 tv 88442
71 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
72     %define libglname %mklibname %{glname} %{glmajor}
73     %define libglwname %mklibname %{glwname} %{glwmajor}
74 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
75     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
76 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
77 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
78 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
79     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
80 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
81 tv 634669 %define libxaname %mklibname %{xaname} %{xamajor}
82 pterjan 5340
83     %define dridrivers %mklibname dri-drivers
84    
85 anssi 278008 %define osmesadevel %mklibname osmesa -d
86    
87 pterjan 5340 # Architecture-independent Virtual provides:
88     %define libeglname_virt lib%{eglname}
89     %define libglname_virt lib%{glname}
90     %define libglwname_virt lib%{glwname}
91 tv 88442 %define libglesv1name_virt lib%{glesv1name}
92     %define libglesv2name_virt lib%{glesv2name}
93 tv 88445 %define libopenvgname_virt lib%{openvgname}
94 mikala 112356 %define libglapiname_virt lib%{glapiname}
95 blino 215979 %define libgbmname_virt lib%{gbmname}
96     %define libwaylandeglname_virt lib%{waylandeglname}
97 tv 634669 %define libxaname_virt lib%{xaname}
98 pterjan 5340
99     %define oldlibglname %mklibname MesaGL 1
100    
101     %define mesasrcdir %{_prefix}/src/Mesa/
102     %define driver_dir %{_libdir}/dri
103    
104 tv 88451 %define enable_egl 1
105 blino 215979 %define enable_wayland 1
106 pterjan 5340
107     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
108     #FIXME: (for >=i586) disable sse
109     # SSE seems to have problem on some apps (gtulpas) for probing.
110 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
111 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
112 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
113 pterjan 5340 %define dri_drivers_ppc64 ""
114 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
115     %define dri_drivers_alpha "r200,radeon,swrast"
116     %define dri_drivers_sparc "ffb,radeon,swrast"
117     %define dri_drivers_mipsel "r200,radeon,swrast"
118 rtp 302732 %define dri_drivers_arm "nouveau,r200,radeon,swrast"
119 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
120    
121 ovitters 645737 Name: mesa
122 tv 650618 Version: 10.2.3
123 pterjan 5340 Release: %{release}
124 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
125 pterjan 5340 Group: System/Libraries
126    
127 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
128 tv 585816 BuildRequires: pkgconfig(xshmfence)
129 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
130     BuildRequires: pkgconfig(xmu) >= 1.0.3
131     BuildRequires: pkgconfig(x11) >= 1.3.3
132     BuildRequires: pkgconfig(xdamage) >= 1.1.1
133 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
134     BuildRequires: gccmakedep
135     BuildRequires: x11-proto-devel >= 7.3
136 tv 585820 BuildRequires: pkgconfig(libdrm) >= 2.4.52
137 pterjan 5340
138 tv 585825 BuildRequires: pkgconfig(xcb-dri3)
139     BuildRequires: pkgconfig(xcb-present)
140 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
141     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
142     BuildRequires: pkgconfig(xi) >= 1.3
143     BuildRequires: pkgconfig(talloc)
144 tv 88443 BuildRequires: libxml2-python
145 tmb 35532 BuildRequires: makedepend
146 ovitters 645737 BuildRequires: bison
147     BuildRequires: flex
148 tv 469143 BuildRequires: libelf-devel
149 luigiwalser 650314 BuildRequires: llvm-devel >= 3.3-1
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 cjw 336175 Source0: %{name}-%{git}.tar.bz2
159 blino 289278 # (blino) snapshot of 9.0 branch
160 cjw 336175 #Source0: %{name}-%{git_branch}-%{git}.tar.bz2
161 pterjan 5340 %else
162 tv 650618 Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
163 pterjan 5340 %endif
164     Source3: make-git-snapshot.sh
165 tmb 491931 # (tmb) disable as it breaks the build
166     #Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch
167 pterjan 5340
168     # Instructions to setup your repository clone
169     # git://git.freedesktop.org/git/mesa/mesa
170     # git checkout mesa_7_5_branch
171     # git branch mdv-cherry-picks
172     # git am ../02??-*.patch
173     # git branch mdv-redhat
174     # git am ../03??-*.patch
175     # git branch mdv-patches
176     # git am ../09??-*.patch
177     # In order to update to the branch via patches, issue this command:
178     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
179    
180 tmb 564877 # Upstream git
181    
182 pterjan 5340 # Cherry picks
183     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
184     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
185 tmb 411326
186 blino 289280 # (blino) should be pushed to 9.0 branch upstream
187 tv 303796 #Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
188     #Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch
189 pterjan 5340
190 tv 88247 # Patches "liberated" from Fedora:
191 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
192     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
193    
194 blino 278732 # Patches from ChromiumOS
195     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
196    
197 blino 271493 # Mageia/Mandriva patches
198 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
199 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
200 cjw 388874 #Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
201 pterjan 5340
202 tv 88440 #------------------------------------------------------------------------------
203    
204     # package mesa
205 pterjan 5340 License: MIT
206     Requires: %{libglname} = %{version}-%{release}
207     Provides: hackMesa = %{version}
208     Obsoletes: hackMesa <= %{version}
209     Provides: Mesa = %{version}
210     Obsoletes: Mesa < %{version}
211    
212     %package -n %{libglname}
213     Summary: Files for Mesa (GL and GLX libs)
214     Group: System/Libraries
215 tv 88247 Obsoletes: %{oldlibglname} < 6.4
216 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
217     Provides: %{libglname_virt} = %{version}-%{release}
218     Requires: %{dridrivers} >= %{version}-%{release}
219 tv 135172 %if %{build_plf}
220     Requires: %mklibname txc-dxtn
221     %endif
222 pterjan 5340
223     # (anssi) Forces the upgrade of x11-server-common to happen before
224     # alternatives removal, which allows x11-server-common to grab the symlink.
225     Conflicts: x11-server-common < 1.3.0.0-17
226    
227     %package -n %{dridrivers}
228     Summary: Mesa DRI drivers
229     Group: System/Libraries
230 blino 274132 # do not require exact release to avoid conflicts when having
231     # x86_64 dri drivers from tainted and i586 dri drivers from core
232     Requires: mesa = %{version}
233 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
234 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
235     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
236 pterjan 5340
237     %package -n %{libglname}-devel
238     Summary: Development files for Mesa (OpenGL compatible 3D lib)
239     Group: Development/C
240 tv 88237 Requires: %{libglname} = %{version}-%{release}
241 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
242     Provides: %{glname}-devel = %{version}-%{release}
243     Provides: GL-devel
244     Obsoletes: %{oldlibglname}-devel < 6.4
245     Provides: %{oldlibglname}-devel = %{version}-%{release}
246     Provides: libMesaGL-devel = %{version}-%{release}
247     Provides: MesaGL-devel = %{version}-%{release}
248 tv 88438 Provides: libgl-devel
249 pterjan 5340
250 tv 88433 %if %{enable_egl}
251     %package -n %{libeglname}
252     Summary: Files for Mesa (EGL libs)
253     Group: System/Libraries
254     Provides: %{libeglname_virt} = %{version}-%{release}
255    
256     %package -n %{libeglname}-devel
257     Summary: Development files for Mesa (EGL libs)
258     Group: Development/C
259 tv 88439 Requires: %{libeglname} = %{version}-%{release}
260 tv 88433 Provides: EGL-devel
261 tv 88438 Provides: lib%{eglname}-devel
262     Provides: %{eglname}-devel
263     Provides: libegl-devel
264 tv 88433 %endif
265    
266 anssi 278008 %package -n %{libosmesaname}
267     Summary: Mesa offscreen rendering library
268     Group: System/Libraries
269    
270     %package -n %{osmesadevel}
271     Summary: Development files for libosmesa
272     Group: Development/C
273     Requires: %{libosmesaname} = %{version}-%{release}
274     Provides: osmesa-devel = %{version}-%{release}
275     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
276    
277 mikala 112356 %package -n %{libglapiname}
278     Summary: Files for mesa (glapi libs)
279     Group: System/Libraries
280     Provides: %{libglapiname_virt} = %{version}-%{release}
281 tv 88442
282 mikala 112356 %package -n %{libglapiname}-devel
283     Summary: Development files for glapi libs
284     Group: Development/C
285     Requires: %{libglapiname_virt} = %{version}-%{release}
286     Provides: lib%{glapiname}-devel
287     Provides: %{libglapiname}-devel
288    
289 tv 88442 %package -n %{libglesv1name}
290     Summary: Files for Mesa (glesv1 libs)
291     Group: System/Libraries
292     Provides: %{libglesv1name_virt} = %{version}-%{release}
293    
294     %package -n %{libglesv1name}-devel
295     Summary: Development files for glesv1 libs
296     Group: Development/C
297     Requires: %{libglesv1name} = %{version}-%{release}
298     Provides: lib%{glesv1name}-devel
299     Provides: %{glesv1name}-devel
300     Provides: libglesv1-devel
301    
302     %package -n %{libglesv2name}
303     Summary: Files for Mesa (glesv2 libs)
304     Group: System/Libraries
305     Provides: %{libglesv2name_virt} = %{version}-%{release}
306    
307     %package -n %{libglesv2name}-devel
308     Summary: Development files for glesv2 libs
309     Group: Development/C
310     Requires: %{libglesv2name} = %{version}-%{release}
311 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
312 tv 88442 Provides: lib%{glesv2name}-devel
313     Provides: %{glesv2name}-devel
314     Provides: libglesv2-devel
315    
316 tv 88445 %package -n %{libopenvgname}
317     Summary: Files for MESA (OpenVG libs)
318     Group: System/Libraries
319     Provides: %{libopenvgname_virt} = %{version}-%{release}
320    
321     %package -n %{libopenvgname}-devel
322     Summary: Development files vor OpenVG libs
323     Group: Development/C
324     Requires: %{libopenvgname} = %{version}-%{release}
325     Provides: lib%{openvgname}-devel
326     Provides: %{openvgname}-devel
327     Provides: libopenvg-devel
328    
329 blino 215979 %if %{enable_wayland}
330     %package -n %{libgbmname}
331     Summary: Files for Mesa (gbm libs)
332     Group: System/Libraries
333     Provides: %{libgbmname_virt} = %{version}-%{release}
334    
335     %package -n %{libgbmname}-devel
336     Summary: Development files for Mesa (gbm libs)
337     Group: Development/C
338     Requires: %{libgbmname} = %{version}-%{release}
339     Provides: lib%{gbmname}-devel
340     Provides: %{gbmname}-devel
341    
342     %package -n %{libwaylandeglname}
343     Summary: Files for Mesa (Wayland EGL libs)
344     Group: System/Libraries
345     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
346    
347     %package -n %{libwaylandeglname}-devel
348     Summary: Development files for Mesa (Wayland EGL libs)
349     Group: Development/C
350     Requires: %{libwaylandeglname} = %{version}-%{release}
351     Provides: lib%{waylandeglname}-devel
352     Provides: %{waylandeglname}-devel
353     %endif
354    
355 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
356 blino 270761 Summary: VDPAU plugin for nouveau driver
357 blino 300616 Group: System/Libraries
358 tv 302568 # temporary:
359     %rename vdpau-driver-nouveau
360 blino 270761
361 tv 301233 %package -n %{_lib}vdpau-driver-r600
362 blino 270761 Summary: VDPAU plugin for r600 driver
363 blino 300616 Group: System/Libraries
364 tv 302568 # temporary:
365     %rename vdpau-driver-r600
366 blino 270761
367 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
368 blino 289282 Summary: VDPAU plugin for radeonsi driver
369     Group: System/Libraries
370 tv 302568 # temporary:
371     %rename vdpau-driver-radeonsi
372 blino 289282
373 tv 634669 %package -n %{libxaname}
374     Summary: Files for Mesa XA state tracker
375     Group: System/Libraries
376     Provides: %{libxaname_virt} = %{version}-%{release}
377    
378     %package -n %{libxaname}-devel
379     Summary: Development files for XA libs
380     Group: Development/C
381     Requires: %{libxaname_virt} = %{version}-%{release}
382     Provides: lib%{xaname}-devel
383     Provides: %{libxaname}-devel
384    
385 pterjan 5340 %package common-devel
386     Summary: Meta package for mesa devel
387     Group: Development/C
388 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
389 pterjan 5340 Provides: hackMesa-common-devel = %{version}
390 tv 88247 Obsoletes: Mesa-common-devel < %{version}
391 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
392     Requires: %{libglname}-devel = %{version}
393 blino 289355 Requires: mesaglu-devel
394 tv 135156 Requires: freeglut-devel
395 tv 88442 Requires: %{libeglname}-devel = %{version}
396     Requires: %{libglesv1name}-devel = %{version}
397     Requires: %{libglesv2name}-devel = %{version}
398 pterjan 5340
399 tv 88440 #------------------------------------------------------------------------------
400 pterjan 5340
401     %description
402 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
403 tv 135173 %if %{build_plf}
404 pterjan 5340
405 tv 135173 This package is in the "tainted" section because it enables some
406     OpenGL extentions that are covered by software patents.
407     %endif
408    
409 pterjan 5340 %description common-devel
410     Mesa common metapackage devel
411    
412     %if %{enable_egl}
413     %description -n %{libeglname}
414 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
415 pterjan 5340 EGL parts.
416    
417     %description -n %{libeglname}-devel
418 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
419 pterjan 5340 EGL development parts.
420     %endif
421    
422     %description -n %{libglname}
423 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 pterjan 5340 GL and GLX parts.
425    
426 tv 135155 %if %{build_plf}
427     This package is in the "tainted" section because it enables some
428     OpenGL extentions that are covered by software patents.
429     %endif
430    
431 pterjan 5340 %description -n %{dridrivers}
432 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
433 pterjan 5340 DRI drivers.
434    
435     %description -n %{libglname}-devel
436 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
437 pterjan 5340
438     This package contains the headers needed to compile Mesa programs.
439    
440 tv 88442 %description -n %{libglesv1name}
441     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
442     well-defined subset profiles of OpenGL.
443    
444     This package provides the OpenGL ES library version 1.
445    
446 anssi 278008 %description -n %{libosmesaname}
447     Mesa offscreen rendering libraries for rendering OpenGL into
448     application-allocated blocks of memory.
449    
450     %description -n %{osmesadevel}
451     This package contains the headers needed to compile programs against
452     the Mesa offscreen rendering library.
453    
454 mikala 112356 %description -n %{libglapiname}
455     This packages provides the glapi shared library used by gallium.
456    
457     %description -n %{libglapiname}-devel
458     This package contains the headers needed to compile programes against glapi shared library.
459    
460 tv 88442 %description -n %{libglesv1name}-devel
461     This package contains the headers needed to compile OpenGL ES 1 programs.
462    
463     %description -n %{libglesv2name}
464     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
465     well-defined subset profiles of OpenGL.
466    
467     This package provides the OpenGL ES library version 2.
468    
469     %description -n %{libglesv2name}-devel
470     This package contains the headers needed to compile OpenGL ES 2 programs.
471    
472 tv 88445 %description -n %{libopenvgname}
473     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
474     acceleration interface for vector graphics libraries such as Flash and SVG.
475    
476     %description -n %{libopenvgname}-devel
477     Development files for OpenVG library.
478    
479 blino 215979 %if %{enable_wayland}
480     %description -n %{libgbmname}
481 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
482 blino 215979 GBM (Graphics Buffer Manager) parts.
483    
484     %description -n %{libgbmname}-devel
485 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
486 blino 215979 GBM (Graphics Buffer Manager) development parts.
487    
488     %description -n %{libwaylandeglname}
489 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
490 blino 215979 Wayland EGL platform parts.
491    
492     %description -n %{libwaylandeglname}-devel
493 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
494 blino 215979 Wayland EGL platform development parts.
495     %endif
496    
497 tv 634669 %description -n %{libxaname}
498     This packages provides the xa shared library used by gallium.
499    
500     %description -n %{libxaname}-devel
501     This package contains the headers needed to compile programes against xa shared library.
502    
503 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
504 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
505     with the nouveau driver.
506    
507 tv 301233 %description -n %{_lib}vdpau-driver-r600
508 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
509     with the r600 driver.
510    
511 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
512 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
513     with the radeonsi driver.
514    
515 tv 88440 #------------------------------------------------------------------------------
516    
517 pterjan 5340 %prep
518     %if %{git}
519 cjw 336175 %setup -q -n mesa-%{git}
520     #setup -q -n mesa-%{git_branch}-%{git}
521 pterjan 5340 %else
522 tv 650618 %setup -q -n Mesa-%{version}%{vsuffix}
523 pterjan 5340 %endif
524    
525 blino 278731 %apply_patches
526 pterjan 5340
527 anssi 332631 # Duplicate source tree for OSMesa, since building both versions out-of-tree
528     # would break build. - Anssi 12/2012
529 cjw 336233 all=$(ls)
530     mkdir -p build-osmesa
531     cp -al $all build-osmesa
532 anssi 332631
533 pterjan 5340 %build
534 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
535     autoreconf -vfi
536    
537 tv 551068 # for bin/test-driver:
538     automake --add-missing
539    
540 anssi 278008 # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
541     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
542     export LDFLAGS="-L%{_libdir}/llvm"
543    
544     %configure2_5x --enable-dri \
545     --enable-glx \
546 luigiwalser 650314 --enable-glx-tls \
547 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
548     --with-dri-drivers="%{dri_drivers}" \
549     %if %{enable_egl}
550     --enable-egl \
551     %else
552     --disable-egl \
553     %endif
554 blino 215979 %if %{enable_wayland}
555     --with-egl-platforms=x11,wayland,drm \
556     --enable-gbm \
557     --enable-shared-glapi \
558     %endif
559 tv 88442 --enable-gles1 \
560     --enable-gles2 \
561 tv 88445 --enable-openvg \
562 mikala 112356 --enable-gallium-egl \
563 blino 270761 --disable-xvmc \
564     --enable-vdpau \
565 mikala 112356 %if %{with_hardware}
566 tv 634695 --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
567 mikala 112356 --enable-gallium-llvm \
568 tv 634669 --enable-xa \
569 mikala 112356 %else
570     --disable-gallium-llvm \
571     --with-gallium-drivers=swrast \
572     %endif
573 tv 135155 %if %{build_plf}
574     --enable-texture-float \
575     %endif
576 blino 270723 # end of configure options
577 pterjan 5340
578 anssi 332631
579     # Build OSMesa separately, since we want to build OSMesa without shared-glapi,
580     # since doing that causes OSMesa to miss the OpenGL symbols.
581     # See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599
582     # -Anssi 12/2012
583    
584 cjw 336233 pushd build-osmesa
585     autoreconf -vfi
586     %configure2_5x \
587     --enable-osmesa \
588     --disable-dri \
589     --disable-glx \
590     --disable-egl \
591     --disable-shared-glapi \
592     --without-gallium-drivers
593     popd
594 anssi 332631
595 anssi 165988 %make
596 cjw 388874 %make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa )
597 pterjan 5340
598     %install
599 cjw 336233 %makeinstall_std -C build-osmesa
600 tv 88249 %makeinstall_std
601 pterjan 5340
602 blino 216556 # FIXME: strip will likely break the hardlink
603 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
604     # to prevent proprietary driver installers from removing them
605     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
606     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
607     for l in ../libGL.so.*; do cp -a $l .; done
608     popd
609    
610     %ifarch %{x86_64}
611     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
612     %endif
613    
614 blino 270761 # .so files are not needed by vdpau
615     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
616    
617 blino 271144 # .la files are not needed by mesa
618     find %{buildroot} -name '*.la' -exec rm {} \;
619    
620 anssi 181478 # use swrastg if built (Anssi 12/2011)
621     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
622    
623 tv 88440 #------------------------------------------------------------------------------
624    
625 pterjan 5340 %files
626 blino 271481 %doc docs/COPYING
627 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
628 pterjan 5340
629     %files -n %{dridrivers}
630     %doc docs/COPYING
631     %ifnarch ppc64
632     %dir %{_libdir}/dri
633 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
634     #%{_libdir}/dri/libglsl.so
635 pterjan 5340 %{_libdir}/dri/*_dri.so
636     %endif
637    
638 tv 88433 %files -n %{libglname}
639     %doc docs/COPYING
640     %{_libdir}/libGL.so.*
641     %dir %{_libdir}/mesa
642 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
643 tv 88433
644     %if %{enable_egl}
645     %files -n %{libeglname}
646 tv 88442 %doc docs/COPYING
647 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
648 tv 88442 %dir %{_libdir}/egl
649 blino 215979 %if !%{enable_wayland}
650     # st_GL, built only when shared glapi is not enabled
651 mikala 112356 %{_libdir}/egl/st_GL.so
652 blino 215979 %endif
653 mikala 127466 %{_libdir}/egl/egl_gallium.so
654 tv 88441 %endif
655 tv 88433
656 anssi 278008 %files -n %{libosmesaname}
657     %{_libdir}/libOSMesa.so.%{osmesamajor}*
658    
659 mikala 112356 %files -n %{libglapiname}
660     %{_libdir}/libglapi.so.%{glapimajor}*
661    
662 tv 88442 %files -n %{libglesv1name}
663     %doc docs/COPYING
664     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
665    
666     %files -n %{libglesv2name}
667     %doc docs/COPYING
668     %{_libdir}/libGLESv2.so.%{glesv2major}*
669    
670 tv 88445 %files -n %{libopenvgname}
671     %doc docs/COPYING
672     %{_libdir}/libOpenVG.so.%{openvgmajor}*
673    
674 blino 215979 %if %{enable_wayland}
675     %files -n %{libgbmname}
676     %{_libdir}/libgbm.so.%{gbmmajor}
677 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
678 blino 215979 %{_libdir}/gbm/gbm_*.so
679 cjw 388874 %{_libdir}/gallium-pipe/pipe_*.so
680 tv 88445
681 blino 215979 %files -n %{libwaylandeglname}
682     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
683 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
684 blino 215979 %endif
685    
686 tv 634669 %files -n %{libxaname}
687     %{_libdir}/libxatracker.so.%{xamajor}*
688 blino 215979
689 pterjan 5340 %files -n %{libglname}-devel
690     %doc docs/COPYING
691 anssi 278008 %dir %{_includedir}/GL
692 pterjan 5340 %{_includedir}/GL/gl.h
693     %{_includedir}/GL/glext.h
694     %{_includedir}/GL/gl_mangle.h
695     %{_includedir}/GL/wglext.h
696     %{_includedir}/GL/glx.h
697     %{_includedir}/GL/glxext.h
698     %{_includedir}/GL/glx_mangle.h
699     %{_libdir}/libGL.so
700 tv 88436 %{_libdir}/pkgconfig/gl.pc
701     %{_libdir}/pkgconfig/dri.pc
702 pterjan 5340
703     #FIXME: check those headers
704 cjw 336175 #{_includedir}/GL/vms_x_fix.h
705 pterjan 5340 %{_includedir}/GL/wmesa.h
706     %dir %{_includedir}/GL/internal
707     %{_includedir}/GL/internal/dri_interface.h
708    
709     %files common-devel
710 tv 88441 %if %{enable_egl}
711 tv 88433 %files -n %{libeglname}-devel
712 tv 88442 %doc docs/COPYING
713     %{_includedir}/EGL
714     %{_includedir}/KHR
715 tv 88433 %{_libdir}/libEGL.so
716 tv 88436 %{_libdir}/pkgconfig/egl.pc
717 tv 88433 %endif
718 pterjan 5340
719 anssi 278008 %files -n %{osmesadevel}
720     %dir %{_includedir}/GL
721     %{_includedir}/GL/osmesa.h
722     %{_libdir}/libOSMesa.so
723     %{_libdir}/pkgconfig/osmesa.pc
724    
725 mikala 112356 %files -n %{libglapiname}-devel
726     %{_libdir}/libglapi.so
727 pterjan 5340
728 tv 88442 %files -n %{libglesv1name}-devel
729     %{_includedir}/GLES
730     %{_libdir}/libGLESv1_CM.so
731     %{_libdir}/pkgconfig/glesv1_cm.pc
732 tv 88433
733 tv 88442 %files -n %{libglesv2name}-devel
734     %{_includedir}/GLES2
735 cjw 336175 %{_includedir}/GLES3
736 tv 88442 %{_libdir}/libGLESv2.so
737     %{_libdir}/pkgconfig/glesv2.pc
738 tv 88445
739     %files -n %{libopenvgname}-devel
740     %{_includedir}/VG
741     %{_libdir}/libOpenVG.so
742     %{_libdir}/pkgconfig/vg.pc
743 blino 215979
744     %if %{enable_wayland}
745     %files -n %{libgbmname}-devel
746     %{_includedir}/gbm.h
747     %{_libdir}/libgbm.so
748     %{_libdir}/pkgconfig/gbm.pc
749    
750     %files -n %{libwaylandeglname}-devel
751     %{_libdir}/libwayland-egl.so
752     %{_libdir}/pkgconfig/wayland-egl.pc
753     %endif
754 blino 270761
755 tv 634669 %files -n %{libxaname}-devel
756     %{_libdir}/libxatracker.so
757     %{_includedir}/xa_tracker.h
758     %{_includedir}/xa_composite.h
759     %{_includedir}/xa_context.h
760     %{_libdir}/pkgconfig/xatracker.pc
761    
762 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
763 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
764    
765 tv 301233 %files -n %{_lib}vdpau-driver-r600
766 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
767    
768 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
769 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
770    

  ViewVC Help
Powered by ViewVC 1.1.30