/[packages]/backports/5/ccnet/current/SPECS/ccnet.spec
ViewVC logotype

Annotation of /backports/5/ccnet/current/SPECS/ccnet.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1009881 - (hide annotations) (download)
Fri May 6 14:58:13 2016 UTC (7 years, 11 months ago) by daviddavid
Original Path: cauldron/ccnet/current/SPECS/ccnet.spec
File size: 2522 byte(s)
initial package ccnet
1 daviddavid 1009881 %define major 0
2     %define libname %mklibname %{name} %{major}
3     %define develname %mklibname %{name} -d
4    
5     Name: ccnet
6     Version: 5.1.1
7     Release: %mkrel 1
8     Summary: Networking library for Seafile
9     License: GPLv3+
10     Group: Networking/File transfer
11     URL: https://github.com/haiwen/ccnet
12     Source0: https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz
13     BuildRequires: pkgconfig(glib-2.0)
14     BuildRequires: pkgconfig(jansson)
15     BuildRequires: pkgconfig(sqlite3)
16     BuildRequires: pkgconfig(openssl)
17     BuildRequires: pkgconfig(libevent)
18     BuildRequires: pkgconfig(uuid) >= 2.0
19     BuildRequires: pkgconfig(libsearpc)
20     BuildRequires: pkgconfig(python2)
21     BuildRequires: vala >= 0.26
22    
23     Requires: pythonegg(2)(ccnet) = %{version}-%{release}
24    
25     %description
26     Ccnet is a framework for writing networked applications in C.
27    
28     #----------------------------------------------------
29    
30     %package -n %{libname}
31     Summary: Library for %{name}
32     Group: System/Libraries
33    
34     %description -n %{libname}
35     Ccnet is a framework for writing networked applications in C.
36     This package contains library files for %{name}.
37    
38     #----------------------------------------------------
39    
40     %package -n %{develname}
41     Summary: Development files for %{name}
42     Group: Development/C
43     Requires: %{libname} = %{version}-%{release}
44     Provides: %{name}-devel = %{version}-%{release}
45     Provides: lib%{name}-devel = %{version}-%{release}
46    
47     %description -n %{develname}
48     The %{develname} package contains libraries and header files for
49     developing applications that use %{name}.
50    
51     #----------------------------------------------------
52    
53     %package -n python-%{name}
54     Summary: Python 2 bindings for %{name}
55     Group: Development/Python
56     BuildArch: noarch
57     Provides: pythonegg(2)(ccnet) = %{version}-%{release}
58    
59     %description -n python-%{name}
60     Ccnet is a framework for writing networked applications in C.
61     This package contains the python 2 bindings for %{name}.
62    
63     #----------------------------------------------------
64    
65     %prep
66     %setup -q
67    
68     sed -i -e /\(DESTDIR\)/d libccnet.pc.in
69    
70     NOCONFIGURE=1 ./autogen.sh
71    
72     %build
73     %configure2_5x \
74     --disable-static \
75     --disable-compile-demo
76     %make
77    
78     %install
79     %make_install
80    
81     # we don't want these
82     find %{buildroot} -name '*.la' -delete
83    
84     %files
85     %doc HACKING README.markdown
86     %license COPYRIGHT
87     %{_bindir}/%{name}*
88    
89     %files -n %{libname}
90     %{_libdir}/lib%{name}.so.%{major}{,.*}
91    
92     %files -n %{develname}
93     %doc HACKING README.markdown
94     %{_includedir}/*
95     %{_libdir}/lib%{name}.so
96     %{_libdir}/pkgconfig/lib%{name}.pc
97    
98     %files -n python-%{name}
99     %doc HACKING README.markdown
100     %{python2_sitearch}/%{name}/

  ViewVC Help
Powered by ViewVC 1.1.30