1 |
%define major 0 |
2 |
%define libname %mklibname %{name} %{major} |
3 |
%define develname %mklibname %{name} -d |
4 |
|
5 |
Name: ccnet |
6 |
Version: 5.1.3 |
7 |
Release: %mkrel 1 |
8 |
Summary: Networking library for Seafile |
9 |
License: GPLv3+ |
10 |
Group: Networking/File transfer |
11 |
URL: https://github.com/haiwen/ccnet |
12 |
Source0: https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz |
13 |
BuildRequires: pkgconfig(glib-2.0) |
14 |
BuildRequires: pkgconfig(jansson) |
15 |
BuildRequires: pkgconfig(sqlite3) |
16 |
BuildRequires: pkgconfig(openssl) |
17 |
BuildRequires: pkgconfig(libevent) |
18 |
BuildRequires: pkgconfig(uuid) >= 2.0 |
19 |
BuildRequires: pkgconfig(libsearpc) |
20 |
BuildRequires: pkgconfig(python2) |
21 |
BuildRequires: vala >= 0.26 |
22 |
# server requirements |
23 |
BuildRequires: pkgconfig(zdb) |
24 |
|
25 |
Requires: pythonegg(2)(ccnet) = %{version}-%{release} |
26 |
|
27 |
%description |
28 |
Ccnet is a framework for writing networked applications in C. |
29 |
|
30 |
#---------------------------------------------------- |
31 |
|
32 |
%package server |
33 |
Summary: Ccnet server |
34 |
Group: Networking/File transfer |
35 |
Requires: pythonegg(2)(ccnet) = %{version}-%{release} |
36 |
|
37 |
%description server |
38 |
Ccnet is a framework for writing networked applications in C. |
39 |
This package contains the server part for %{name}. |
40 |
|
41 |
#---------------------------------------------------- |
42 |
|
43 |
%package -n %{libname} |
44 |
Summary: Library for %{name} |
45 |
Group: System/Libraries |
46 |
|
47 |
%description -n %{libname} |
48 |
Ccnet is a framework for writing networked applications in C. |
49 |
This package contains library files for %{name}. |
50 |
|
51 |
#---------------------------------------------------- |
52 |
|
53 |
%package -n %{develname} |
54 |
Summary: Development files for %{name} |
55 |
Group: Development/C |
56 |
Requires: %{libname} = %{version}-%{release} |
57 |
Provides: %{name}-devel = %{version}-%{release} |
58 |
Provides: lib%{name}-devel = %{version}-%{release} |
59 |
|
60 |
%description -n %{develname} |
61 |
The %{develname} package contains libraries and header files for |
62 |
developing applications that use %{name}. |
63 |
|
64 |
#---------------------------------------------------- |
65 |
|
66 |
%package -n python-%{name} |
67 |
Summary: Python 2 bindings for %{name} |
68 |
Group: Development/Python |
69 |
BuildArch: noarch |
70 |
Provides: pythonegg(2)(ccnet) = %{version}-%{release} |
71 |
|
72 |
%description -n python-%{name} |
73 |
Ccnet is a framework for writing networked applications in C. |
74 |
This package contains the python 2 bindings for %{name}. |
75 |
|
76 |
#---------------------------------------------------- |
77 |
|
78 |
%prep |
79 |
%setup -q |
80 |
|
81 |
sed -i -e /\(DESTDIR\)/d libccnet.pc.in |
82 |
|
83 |
NOCONFIGURE=1 ./autogen.sh |
84 |
|
85 |
%build |
86 |
%configure2_5x \ |
87 |
--enable-server \ |
88 |
--disable-static \ |
89 |
--disable-compile-demo |
90 |
%make_build |
91 |
|
92 |
%install |
93 |
%make_install |
94 |
|
95 |
# we don't want these |
96 |
find %{buildroot} -name '*.la' -delete |
97 |
|
98 |
%files |
99 |
%doc HACKING README.markdown |
100 |
%license COPYRIGHT |
101 |
%{_bindir}/%{name} |
102 |
%{_bindir}/%{name}-init |
103 |
%{_bindir}/%{name}-tool |
104 |
|
105 |
%files server |
106 |
%doc HACKING README.markdown |
107 |
%license COPYRIGHT |
108 |
%{_bindir}/%{name}-server |
109 |
%{_bindir}/%{name}-servtool |
110 |
|
111 |
%files -n %{libname} |
112 |
%{_libdir}/lib%{name}.so.%{major} |
113 |
%{_libdir}/lib%{name}.so.%{major}.* |
114 |
|
115 |
%files -n %{develname} |
116 |
%doc HACKING README.markdown |
117 |
%{_includedir}/* |
118 |
%{_libdir}/lib%{name}.so |
119 |
%{_libdir}/pkgconfig/lib%{name}.pc |
120 |
|
121 |
%files -n python-%{name} |
122 |
%doc HACKING README.markdown |
123 |
%{python2_sitearch}/%{name}/ |