/[packages]/cauldron/AfterStep/current/SPECS/afterstep.spec
ViewVC logotype

Contents of /cauldron/AfterStep/current/SPECS/afterstep.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 202881 - (show annotations) (download)
Sun Jan 29 14:17:59 2012 UTC (12 years, 2 months ago) by remmy
File size: 6100 byte(s)
- Removed .xsession file, closing bug report mga#3650
- Removed xeyes from default Wharf configuration
- Added LibreOffice Writer and Clac as default Wharf options
- Added suggest on asclock

1 %define name afterstep
2 %define version 2.2.11
3 %define release %mkrel 7
4 %define major 0
5 %define libname %mklibname %{name} %{major}
6 %define libname_devel %mklibname %{name} -d
7 %define ltitle AfterStep Window Manager
8 %define casedname AfterStep
9
10 Summary: %{ltitle}
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Epoch: 4
15 License: GPLv2+
16 Group: Graphical desktop/Other
17 URL: http://www.afterstep.org/
18
19 Source: ftp://ftp.afterstep.org/stable/%{casedname}-%version.tar.bz2
20 Source1: %{casedname}-mdkconf.tar.bz2
21 Source3: %{casedname}.png
22 Source4: %{casedname}32.png
23 Source5: %{casedname}48.png
24 Patch2: %{casedname}-1.8.9-menuname.patch
25 Patch3: %{casedname}.MenuKey.patch
26 Patch4: %{name}-2.2.9-ldflags.patch
27 Patch5: %{casedname}-2.2.11-libpng15.patch
28 Patch6: %{name}-wharf.patch
29
30 %rename %{casedname}
31 Requires: desktop-common-data xli
32 Suggests: asclock
33 # Requires: %libname = %{epoch}:%{version}-%{release}
34 BuildRequires: libx11-devel
35 BuildRequires: libxext-devel
36 BuildRequires: libxinerama-devel
37 BuildRequires: dbus-devel
38 BuildRequires: freetype2-devel
39 BuildRequires: jpeg-devel
40 BuildRequires: librsvg-devel
41 BuildRequires: png-devel
42 BuildRequires: tiff-devel
43 BuildRequires: gtk2-devel
44
45 %description
46 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
47 look and feel, but which has been significantly altered according to the
48 requests of various users. Many adepts will tell you that NEXTSTEP is not
49 only the most visually pleasant interface, but also one of the most functional
50 and intuitive out there. AfterStep aims to incorporate the advantages of the
51 NEXTSTEP interface, and add additional useful features.
52
53 The developers of AfterStep have also worked very hard to ensure stability and
54 a small program footprint. Without giving up too many features, AfterStep still
55 works nicely in environments where memory is at a premium.
56
57 %package -n %libname
58 Summary: Libraries needed by AfterStep
59 Group: Graphical desktop/Other
60 Provides: lib%name = %version-%release
61 %rename lib%{casedname}
62
63 %description -n %libname
64 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
65 look and feel, but which has been significantly altered according to the
66 requests of various users. Many adepts will tell you that NEXTSTEP is not
67 only the most visually pleasant interface, but also one of the most functional
68 and intuitive out there. AfterStep aims to incorporate the advantages of the
69 NEXTSTEP interface, and add additional useful features.
70
71 The developers of AfterStep have also worked very hard to ensure stability and
72 a small program footprint. Without giving up too many features, AfterStep still
73 works nicely in environments where memory is at a premium.
74
75 This package contains libraries needed by AfterStep package.
76
77 %package -n %libname_devel
78 Summary: Devel files needed to build applications based on AfterStep
79 Group: Development/C
80 Provides: %name-devel lib%name-devel
81 Requires: %libname = %{epoch}:%version-%release
82 Obsoletes: %mklibname -d %name 0
83 %rename lib%{casedname}_devel
84
85 %description -n %libname_devel
86 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
87 look and feel, but which has been significantly altered according to the
88 requests of various users. Many adepts will tell you that NEXTSTEP is not
89 only the most visually pleasant interface, but also one of the most functional
90 and intuitive out there. AfterStep aims to incorporate the advantages of the
91 NEXTSTEP interface, and add additional useful features.
92
93 The developers of AfterStep have also worked very hard to ensure stability and
94 a small program footprint. Without giving up too many features, AfterStep still
95 works nicely in environments where memory is at a premium.
96
97 This package contains devel files needed to build applications based on
98 AfterStep.
99
100 %prep
101 %setup -q -n %{casedname}-%{version}
102
103 # LMDK patches
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p0 -b .link
107 %patch5 -p0 -b .libpng
108 %patch6 -p0
109
110 %build
111 rm -f config.status
112 export CFLAGS="%optflags"
113 export CCFLAGS="%optflags"
114
115 %configure2_5x \
116 --enable-sharedlibs \
117 --with-imageloader="xsetbg" \
118 --with-helpcommand="xterm -fn 9x15 -e man" \
119 --with-desktops=1 \
120 --with-deskgeometry=1x1 \
121 --enable-different-looknfeels \
122 --enable-i18n \
123 --enable-savewindows \
124 --enable-texture \
125 --enable-shade \
126 --enable-virtual \
127 --enable-saveunders \
128 --enable-windowlist \
129 --enable-availability \
130 --enable-shaping \
131 --enable-xinerama \
132 --enable-script \
133 --with-xpm \
134 --with-jpeg \
135 --with-png \
136 --with-ttf \
137 --with-tiff
138
139 # We're using make here instead of the built-in macro percent-make because the AfterStep
140 # build-system lacks some dependencies which makes it fail sometimes with parallel
141 # builds (-j).
142 make
143
144 if [ -x /usr/bin/sgml2html ]; then sgml2html doc/afterstep.sgml; fi
145
146
147 %install
148 rm -rf %{buildroot}
149 %makeinstall_std LDCONFIG=/bin/true
150
151 # LMDK icons
152 install -m644 %SOURCE4 -D %{buildroot}%{_iconsdir}/%{casedname}.png
153 install -m644 %SOURCE3 -D %{buildroot}%{_miconsdir}/%{casedname}.png
154 install -m644 %SOURCE5 -D %{buildroot}%{_liconsdir}/%{casedname}.png
155
156 # Not needed with Mageia menu
157 rm -rf %{buildroot}%{__datadir}/afterstep/start/Applications/
158 rm -rf %{buildroot}%{_datadir}/xsessions/AfterStep.desktop
159
160 install -d %{buildroot}%{_sysconfdir}/X11/wmsession.d
161 cat > %{buildroot}%{_sysconfdir}/X11/wmsession.d/15%{name} << EOF
162 NAME=%{casedname}
163 ICON=%{casedname}.png
164 EXEC=%{_bindir}/%{name}
165 DESC=A NeXt like Window-Manager
166 SCRIPT:
167 exec %{_bindir}/%{name}
168 EOF
169
170 %files
171 %defattr(-,root,root)
172 %config(noreplace) %{_sysconfdir}/X11/wmsession.d/15%{name}
173 %doc COPYRIGHT ChangeLog NEW README TEAM UPGRADE doc/languages doc/licences
174 %{_iconsdir}/%{casedname}.png
175 %{_miconsdir}/%{casedname}.png
176 %{_liconsdir}/%{casedname}.png
177 %{_bindir}/*
178 %{_mandir}/man1/*
179 %{_mandir}/man3/*
180 %dir %{_datadir}/%{name}
181 %{_datadir}/%{name}/*
182
183 %files -n %libname
184 %defattr(-,root,root,-)
185 %{_libdir}/*.so.%major
186 %{_libdir}/*.so.%major.*
187
188 %files -n %libname_devel
189 %defattr(-,root,root,-)
190 %{_libdir}/*.so
191 %{_libdir}/*.a
192 %_includedir/*

  ViewVC Help
Powered by ViewVC 1.1.30