1 |
daviddavid |
1337935 |
Name: aalto-xml |
2 |
|
|
Version: 1.0.0 |
3 |
daviddavid |
1337937 |
Release: %mkrel 1 |
4 |
|
|
Group: Development/Java |
5 |
daviddavid |
1337935 |
Summary: Ultra-high performance non-blocking XML processor (Stax/Stax2, SAX/SAX2) |
6 |
|
|
# Source files without license headers https://github.com/FasterXML/aalto-xml/issues/38 |
7 |
|
|
# See https://github.com/FasterXML/jackson-modules-base/issues/18, from main developer: |
8 |
|
|
# "To whoever it concerns: policy of the Jackson project is to only include licensing information as project |
9 |
|
|
# level metadata (in repo, pom.xml, artifact within source and binary jars), and not as headers in source files. |
10 |
|
|
# Licensing is Apache License 2.0, for Jackson 2.x as indicated by various artifacts, and we have no plans to change this." |
11 |
|
|
License: ASL 2.0 |
12 |
|
|
URL: http://wiki.fasterxml.com/AaltoHome |
13 |
|
|
Source0: https://github.com/FasterXML/aalto-xml/archive/%{name}-%{version}.tar.gz |
14 |
|
|
|
15 |
|
|
BuildRequires: maven-local |
16 |
|
|
BuildRequires: mvn(com.fasterxml:oss-parent:pom:) |
17 |
|
|
BuildRequires: mvn(junit:junit) |
18 |
|
|
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin) |
19 |
|
|
BuildRequires: mvn(org.codehaus.woodstox:stax2-api) |
20 |
|
|
|
21 |
|
|
BuildArch: noarch |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
The Aalto XML processor is a StAX XML processor implementation. It |
25 |
|
|
is not directly related to other existing mature implementations |
26 |
|
|
(such as Woodstox or Sun Java Streaming XML Parser), although it |
27 |
|
|
did come about as a prototype for evaluating implementation strategies |
28 |
|
|
that differ from those traditionally used for Java-based parsers. |
29 |
|
|
|
30 |
|
|
Two main goals (above and beyond stock StAX/SAX API implementation) are: |
31 |
|
|
|
32 |
|
|
° Ultra-high performance parsing by making the Common Case Fast |
33 |
|
|
(similar to original RISC manifesto). This may mean limiting |
34 |
|
|
functionality, but never compromising correctness. XML 1.0 |
35 |
|
|
compliance is not sacrificed for speed. |
36 |
|
|
|
37 |
|
|
° Allowing non-block, asynchronous parsing: it should be possible to |
38 |
|
|
"feed" more input and incrementally get more XML events out, without |
39 |
|
|
forcing the current thread to block on I/O read operation. |
40 |
|
|
|
41 |
|
|
%package javadoc |
42 |
|
|
Summary: Javadoc for %{name} |
43 |
|
|
|
44 |
|
|
%description javadoc |
45 |
|
|
This package contains javadoc for %{name}. |
46 |
|
|
|
47 |
|
|
%prep |
48 |
|
|
%setup -q -n %{name}-%{name}-%{version} |
49 |
|
|
# Cleanup |
50 |
|
|
find -name "*.class" -print -delete |
51 |
|
|
find -name "*.jar" -print -delete |
52 |
|
|
|
53 |
|
|
sed -i 's/\r//' src/main/resources/META-INF/LICENSE |
54 |
|
|
sed -i 's/\r//' release-notes/asl/* |
55 |
|
|
mv release-notes/asl/ASL2.0 LICENSE |
56 |
|
|
mv release-notes/asl/LICENSE NOTICE |
57 |
|
|
|
58 |
|
|
%mvn_file : %{name} |
59 |
|
|
|
60 |
|
|
%build |
61 |
|
|
|
62 |
|
|
%mvn_build |
63 |
|
|
|
64 |
|
|
%install |
65 |
|
|
%mvn_install |
66 |
|
|
|
67 |
|
|
%files -f .mfiles |
68 |
|
|
%doc README.md release-notes/* |
69 |
|
|
%license LICENSE NOTICE |
70 |
|
|
|
71 |
|
|
%files javadoc -f .mfiles-javadoc |
72 |
|
|
%license LICENSE NOTICE |
73 |
|
|
|