/[packages]/cauldron/aalto-xml/current/SPECS/aalto-xml.spec
ViewVC logotype

Annotation of /cauldron/aalto-xml/current/SPECS/aalto-xml.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1453505 - (hide annotations) (download)
Tue Oct 15 07:03:39 2019 UTC (5 years, 1 month ago) by daviddavid
File size: 2713 byte(s)
- Update to version 1.2.2

1 daviddavid 1337935 Name: aalto-xml
2 daviddavid 1453505 Version: 1.2.2
3 daviddavid 1337937 Release: %mkrel 1
4     Group: Development/Java
5 daviddavid 1337935 Summary: Ultra-high performance non-blocking XML processor (Stax/Stax2, SAX/SAX2)
6     # Source files without license headers https://github.com/FasterXML/aalto-xml/issues/38
7     # See https://github.com/FasterXML/jackson-modules-base/issues/18, from main developer:
8     # "To whoever it concerns: policy of the Jackson project is to only include licensing information as project
9     # level metadata (in repo, pom.xml, artifact within source and binary jars), and not as headers in source files.
10     # Licensing is Apache License 2.0, for Jackson 2.x as indicated by various artifacts, and we have no plans to change this."
11     License: ASL 2.0
12     URL: http://wiki.fasterxml.com/AaltoHome
13     Source0: https://github.com/FasterXML/aalto-xml/archive/%{name}-%{version}.tar.gz
14    
15     BuildRequires: maven-local
16     BuildRequires: mvn(com.fasterxml:oss-parent:pom:)
17 daviddavid 1453505 BuildRequires: mvn(com.fasterxml.woodstox:woodstox-core)
18 daviddavid 1337935 BuildRequires: mvn(junit:junit)
19     BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
20     BuildRequires: mvn(org.codehaus.woodstox:stax2-api)
21    
22     BuildArch: noarch
23    
24     %description
25     The Aalto XML processor is a StAX XML processor implementation. It
26     is not directly related to other existing mature implementations
27     (such as Woodstox or Sun Java Streaming XML Parser), although it
28     did come about as a prototype for evaluating implementation strategies
29     that differ from those traditionally used for Java-based parsers.
30    
31     Two main goals (above and beyond stock StAX/SAX API implementation) are:
32    
33     ° Ultra-high performance parsing by making the Common Case Fast
34     (similar to original RISC manifesto). This may mean limiting
35     functionality, but never compromising correctness. XML 1.0
36     compliance is not sacrificed for speed.
37    
38     ° Allowing non-block, asynchronous parsing: it should be possible to
39     "feed" more input and incrementally get more XML events out, without
40     forcing the current thread to block on I/O read operation.
41    
42     %package javadoc
43     Summary: Javadoc for %{name}
44    
45     %description javadoc
46     This package contains javadoc for %{name}.
47    
48     %prep
49     %setup -q -n %{name}-%{name}-%{version}
50     # Cleanup
51     find -name "*.class" -print -delete
52     find -name "*.jar" -print -delete
53    
54     sed -i 's/\r//' src/main/resources/META-INF/LICENSE
55     sed -i 's/\r//' release-notes/asl/*
56     mv release-notes/asl/ASL2.0 LICENSE
57     mv release-notes/asl/LICENSE NOTICE
58    
59     %mvn_file : %{name}
60    
61 daviddavid 1453505 # Java 9 module support isn't needed
62     %pom_remove_plugin :moditect-maven-plugin
63    
64 daviddavid 1337935 %build
65     %mvn_build
66    
67     %install
68     %mvn_install
69    
70     %files -f .mfiles
71     %doc README.md release-notes/*
72     %license LICENSE NOTICE
73    
74     %files javadoc -f .mfiles-javadoc
75     %license LICENSE NOTICE
76    

  ViewVC Help
Powered by ViewVC 1.1.30