/[packages]/cauldron/aether-ant-tasks/current/SPECS/aether-ant-tasks.spec
ViewVC logotype

Annotation of /cauldron/aether-ant-tasks/current/SPECS/aether-ant-tasks.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 981927 - (hide annotations) (download)
Wed Mar 2 00:10:55 2016 UTC (8 years, 9 months ago) by neoclust
File size: 2803 byte(s)
Second rebuild of the java stack
1 zezinho 913181 %global vertag v20141111
2    
3     Name: aether-ant-tasks
4     Epoch: 1
5     Version: 1.0.1
6 neoclust 981927 Release: %mkrel 5
7 zezinho 913181 Summary: Ant tasks using Aether to resolve, install and deploy artifacts
8 neoclust 972865 Group: Development/Java
9 zezinho 913181 BuildArch: noarch
10    
11     License: EPL
12     URL: http://www.eclipse.org/aether
13     Source0: http://git.eclipse.org/c/aether/aether-ant.git/snapshot/%{name}-%{version}.%{vertag}.tar.bz2
14     Source5: ant-classpath
15    
16     Patch0001: 0001-Add-support-for-XMvn-workspace-reader.patch
17     # Forwarded upstream: http://bugs.eclipse.org/470696
18     Patch0002: 0002-Update-to-Maven-3.2.3.patch
19    
20     BuildRequires: maven-local
21     BuildRequires: mvn(junit:junit)
22     BuildRequires: mvn(org.apache.ant:ant)
23     BuildRequires: mvn(org.apache.ant:ant-launcher)
24     BuildRequires: mvn(org.apache.ant:ant-testutil)
25     BuildRequires: mvn(org.apache.maven:maven-aether-provider) >= 3.1.0
26     BuildRequires: mvn(org.apache.maven:maven-settings-builder)
27     BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
28     BuildRequires: mvn(org.codehaus.plexus:plexus-interpolation)
29     BuildRequires: mvn(org.eclipse.aether:aether-api)
30     BuildRequires: mvn(org.eclipse.aether:aether-connector-basic)
31     BuildRequires: mvn(org.eclipse.aether:aether-impl)
32     BuildRequires: mvn(org.eclipse.aether:aether-test-util)
33     BuildRequires: mvn(org.eclipse.aether:aether-transport-classpath)
34     BuildRequires: mvn(org.eclipse.aether:aether-transport-file)
35     BuildRequires: mvn(org.eclipse.aether:aether-transport-http)
36     BuildRequires: mvn(org.eclipse.aether:aether-util)
37     BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
38     BuildRequires: mvn(org.hamcrest:hamcrest-core)
39     BuildRequires: mvn(org.hamcrest:hamcrest-library)
40    
41     Requires: ant
42    
43     %description
44     The Aether Ant Tasks enable build scripts for Apache Ant 1.7+ to use Eclipse
45     Aether to resolve dependencies and install and deploy locally built artifacts.
46    
47     %package javadoc
48     Summary: Javadocs for %{name}
49     Group: Documentation
50    
51     %description javadoc
52     This package contains the API documentation for %{name}.
53    
54     %prep
55     %setup -q -n %{name}-%{version}.%{vertag}
56     %patch0001 -p1
57     %patch0002 -p1
58    
59     # Use junit since junit-dep is obselete and equivilent to junit since 4.11
60     sed -i -e 's@junit-dep@junit@g' pom.xml
61    
62     %pom_remove_plugin ":maven-shade-plugin"
63     %pom_remove_plugin ":maven-enforcer-plugin"
64    
65     %build
66     # Some tests require internet connectivity, so ignore failures
67     %mvn_build -- -Dmaven.test.failure.ignore=true
68    
69     %install
70     %mvn_install
71    
72     install -d -m 755 %{buildroot}/%{_sysconfdir}/ant.d
73     install -p -m 644 %{SOURCE5} %{buildroot}/%{_sysconfdir}/ant.d/%{name}
74    
75     %files -f .mfiles
76     %config(noreplace) %{_sysconfdir}/ant.d/%{name}
77     %doc README.md
78     %doc epl-v10.html notice.html
79    
80     %files javadoc -f .mfiles-javadoc
81     %doc epl-v10.html notice.html
82    
83 neoclust 972865

  ViewVC Help
Powered by ViewVC 1.1.30