/[packages]/cauldron/afflib/current/SPECS/afflib.spec
ViewVC logotype

Contents of /cauldron/afflib/current/SPECS/afflib.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 202755 - (show annotations) (download)
Sat Jan 28 22:26:15 2012 UTC (12 years, 2 months ago) by malo
File size: 4117 byte(s)
imported package afflib
1 %define major 0
2 %define libname %mklibname afflib %{major}
3 %define develname %mklibname -d afflib
4
5 Summary: A set of programs for creating and manipulating AFF files
6 Name: afflib
7 Version: 3.5.5
8 Release: %mkrel 2
9 Group: System/Libraries
10 License: BSD
11 URL: http://www.afflib.org/
12 Source0: http://www.afflib.org/downloads/%{name}-%{version}.tar.gz
13 Patch1: afflib-3.4.1-pyver.patch
14 BuildRequires: curl-devel
15 # GPLv2 FOSS incompatible with BSD with advertising
16 #BuildRequires: fuse-devel
17 BuildRequires: libewf-devel
18 BuildRequires: lzma-devel
19 BuildRequires: libexpat-devel
20 BuildRequires: libtermcap-devel
21 BuildRequires: ncurses-devel
22 BuildRequires: openssl-devel
23 BuildRequires: python-devel
24 # GPLv2 FOSS incompatible with BSD with advertising
25 #BuildRequires: readline-devel
26 BuildRequires: zlib-devel
27 BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
29 %description
30 AFFLIB is an open source library developed by Simson Garfinkel and Basis
31 Technology that implements the AFF standard. AFFLIB is distributed under
32 4-clause Berkeley License and may be freely incorporated into both Open
33 Source and Proprietary software.
34
35 In addition to the library, AFFLIB also comes with the AFF Tools, a set of
36 programs for creating and manipulating AFF files.
37
38 %package -n %{libname}
39 Summary: A shared library that implements the AFF standard
40 Group: System/Libraries
41
42 %description -n %{libname}
43 AFFLIB is an open source library developed by Simson Garfinkel and Basis
44 Technology that implements the AFF standard. AFFLIB is distributed under
45 4-clause Berkeley License and may be freely incorporated into both Open
46 Source and Proprietary software.
47
48 This package contains a shared library that implements the AFF standard.
49
50 %package -n %{develname}
51 Summary: Static library and header files for the afflib library
52 Group: Development/C
53 Provides: %{name}-devel = %{version}
54 Requires: %{libname} = %{version}
55
56 %description -n %{develname}
57 AFFLIB is an open source library developed by Simson Garfinkel and Basis
58 Technology that implements the AFF standard. AFFLIB is distributed under
59 4-clause Berkeley License and may be freely incorporated into both Open
60 Source and Proprietary software.
61
62 This package contains the static afflib library and its header files.
63
64 %prep
65 %setup -q
66 %patch1 -p1 -b .pyver
67
68 #fix spurious permissions with lzma443
69 find lzma443 -type f -exec chmod 0644 {} ';'
70 chmod 0644 lib/base64.{h,cpp}
71
72 %build
73 #TODO fix format not a string literal
74 %define Werror_cflags %nil
75
76 export CFLAGS="%{optflags} -fPIC"
77
78 %configure2_5x \
79 --disable-static \
80 --enable-shared \
81 --enable-wide-character-type \
82 --enable-libewf=yes \
83 --enable-s3=yes \
84 --enable-fuse=no \
85 --enable-python=yes \
86 --enable-qemu=no \
87 --with-curl=%{_prefix}
88
89 # Remove rpath from libtool
90 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
91 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
92
93 # clean unused-direct-shlib-dependencies
94 sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
95
96 %make
97
98 %install
99 rm -rf %{buildroot}
100
101 %makeinstall_std
102
103 # install headers as well
104 install -d %{buildroot}%{_includedir}/afflib
105 install -m0644 lib/*.h %{buildroot}%{_includedir}/afflib/
106
107 %if %mdkversion < 200900
108 %post -n %{libname} -p /sbin/ldconfig
109 %endif
110
111 %if %mdkversion < 200900
112 %postun -n %{libname} -p /sbin/ldconfig
113 %endif
114
115 %clean
116 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
117
118 %files
119 %defattr(-,root,root)
120 %{_bindir}/afcat
121 %{_bindir}/afcompare
122 %{_bindir}/afconvert
123 %{_bindir}/afcopy
124 %{_bindir}/afcrypto
125 %{_bindir}/afdiskprint
126 %{_bindir}/affix
127 %{_bindir}/affuse
128 %{_bindir}/afinfo
129 %{_bindir}/afrecover
130 %{_bindir}/afsegment
131 %{_bindir}/afsign
132 %{_bindir}/afstats
133 %{_bindir}/aftest
134 %{_bindir}/afverify
135 %{_bindir}/afxml
136 %{_bindir}/s3
137 %{_mandir}/man1/afcat.1*
138 %{py_platsitedir}/pyaff.so
139
140 %files -n %{libname}
141 %defattr(-,root,root)
142 %doc AUTHORS BUGLIST.txt COPYING ChangeLog NEWS README* doc/*
143 %{_libdir}/*.so.%{major}*
144
145 %files -n %{develname}
146 %defattr(-,root,root)
147 %dir %{_includedir}/afflib
148 %{_includedir}/afflib/*.h
149 %{_libdir}/*.so
150 %{_libdir}/*.la
151 %{py_platsitedir}/*.la
152 %{_libdir}/pkgconfig/*.pc
153
154

  ViewVC Help
Powered by ViewVC 1.1.30