1 |
%define name aiksaurus |
2 |
%define version 1.2.1 |
3 |
%define release %mkrel 7 |
4 |
|
5 |
%define api_version 1.2 |
6 |
%define lib_major 0 |
7 |
%define lib_name %mklibname %{name} %{api_version} %{lib_major} |
8 |
%define develname %mklibname -d %name |
9 |
%define lib_namegtk %mklibname %{name}gtk %{api_version} %{lib_major} |
10 |
%define gtkdevelname %mklibname -d %{name}gtk |
11 |
|
12 |
|
13 |
Summary: An English-language thesaurus library |
14 |
Name: %{name} |
15 |
Version: %{version} |
16 |
Release: %{release} |
17 |
License: GPLv2+ |
18 |
Group: Office |
19 |
URL: http://sourceforge.net/projects/aiksaurus/ |
20 |
Source: %{name}-%{version}.tar.bz2 |
21 |
Patch0: aiksaurus-1.2.1-gcc43.patch |
22 |
Patch1: %{name}-1.2.1-fix-str-fmt.patch |
23 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
24 |
BuildRequires: gtk2-devel |
25 |
BuildRequires: autoconf automake |
26 |
BuildRequires: gnome-common |
27 |
Requires: %{name}-data |
28 |
Provides: Aiksaurus |
29 |
Obsoletes: Aiksaurus |
30 |
|
31 |
%description |
32 |
Aiksaurus is an English-language thesaurus library that can be |
33 |
embedded in word processors, email composers, and other authoring |
34 |
software to provide thesaurus capabilities. |
35 |
This package contains a basic command line thesaurus program. |
36 |
|
37 |
Install Aiksaurus if you want to have a thesaurus available on |
38 |
your computer. |
39 |
|
40 |
%package -n %name-data |
41 |
Summary: An English-language thesaurus library |
42 |
Group: Office |
43 |
Provides: Aiksaurus-data |
44 |
Obsoletes: Aiksaurus-data |
45 |
|
46 |
%description -n %name-data |
47 |
Aiksaurus is an English-language thesaurus library that can be |
48 |
embedded in word processors, email composers, and other authoring |
49 |
software to provide thesaurus capabilities. |
50 |
This package contains the datafiles. |
51 |
|
52 |
%package -n %lib_name |
53 |
Summary: An English-language thesaurus library |
54 |
Group: System/Libraries |
55 |
Requires: %{name}-data |
56 |
Provides: libAiksaurus0 |
57 |
Obsoletes: libAiksaurus0 |
58 |
Obsoletes: %mklibname %{name}- 1.2 0 |
59 |
|
60 |
%description -n %lib_name |
61 |
Aiksaurus is an English-language thesaurus library that can be |
62 |
embedded in word processors, email composers, and other authoring |
63 |
software to provide thesaurus capabilities. |
64 |
This package contains these libraries. |
65 |
|
66 |
Install Aiksaurus if you want to have a thesaurus available on |
67 |
your computer. |
68 |
|
69 |
%package -n %develname |
70 |
Summary: Libraries and include files for Aiksuarus |
71 |
Group: Development/C |
72 |
Requires: %{lib_name} = %{version}-%{release} |
73 |
Provides: aiksaurus-devel = %{version}-%{release} |
74 |
Provides: aiksaurus-%{api_version}-devel = %{version}-%{release} |
75 |
Obsoletes: %{mklibname %{name}- 1.2 0}-devel |
76 |
|
77 |
%description -n %develname |
78 |
Aiksaurus is an English-language thesaurus library that can be |
79 |
embedded in word processors, email composers, and other authoring |
80 |
software to provide thesaurus capabilities. |
81 |
This package contains the libraries and includes files necessary to develop |
82 |
applications with Aiksaurus. |
83 |
|
84 |
|
85 |
%package -n %{name}gtk |
86 |
Summary: A GTK+ thesaurus application |
87 |
Group: Office |
88 |
|
89 |
%description -n %{name}gtk |
90 |
Aiksaurusgtk is a GTK+ interface to the Aiksaurus library. |
91 |
It provides an attractive thesaurus interface, and can be embedded |
92 |
in GTK+ projects, notably AbiWord. |
93 |
This package provides the standalone GTK+ interface. |
94 |
|
95 |
%package -n %{lib_namegtk} |
96 |
Summary: Libraries for aiksaurusgtk |
97 |
Group: System/Libraries |
98 |
Provides: AiksaurusGTK |
99 |
Obsoletes: AiksaurusGTK |
100 |
Obsoletes: %mklibname %{name}gtk- 1.2 0 |
101 |
|
102 |
%description -n %{lib_namegtk} |
103 |
Aiksaurusgtk is a GTK+ interface to the Aiksaurus library. |
104 |
It provides an attractive thesaurus interface, and can be embedded |
105 |
in GTK+ projects, notably AbiWord. |
106 |
This package provides the library files for aiksaurusgtk. |
107 |
|
108 |
|
109 |
%package -n %gtkdevelname |
110 |
Summary: A GTK+ thesaurus library |
111 |
Group: Development/C |
112 |
Requires: %{lib_namegtk} = %{version}-%{release} |
113 |
Provides: aiksaurusgtk-devel = %{version}-%{release} |
114 |
Provides: aiksaurusgtk-%{api_version}-devel = %{version}-%{release} |
115 |
Obsoletes: %{mklibname %{name}gtk- 1.2 0}-devel |
116 |
|
117 |
%description -n %{gtkdevelname} |
118 |
This package contains the libraries and includes files necessary to develop |
119 |
applications with Aiksaurusgtk. |
120 |
|
121 |
|
122 |
%prep |
123 |
%setup -q -n %{name}-%{version} |
124 |
%patch0 -p1 |
125 |
%patch1 -p1 -b .strfmt |
126 |
|
127 |
%build |
128 |
%configure2_5x |
129 |
%make |
130 |
|
131 |
%install |
132 |
rm -rf $RPM_BUILD_ROOT |
133 |
%makeinstall_std |
134 |
|
135 |
%if %mdkversion < 200900 |
136 |
%post -n %lib_name -p /sbin/ldconfig |
137 |
%endif |
138 |
%if %mdkversion < 200900 |
139 |
%post -n %lib_namegtk -p /sbin/ldconfig |
140 |
%endif |
141 |
|
142 |
%if %mdkversion < 200900 |
143 |
%postun -n %lib_name -p /sbin/ldconfig |
144 |
%endif |
145 |
%if %mdkversion < 200900 |
146 |
%postun -n %lib_namegtk -p /sbin/ldconfig |
147 |
%endif |
148 |
|
149 |
%clean |
150 |
rm -rf $RPM_BUILD_ROOT |
151 |
|
152 |
%files |
153 |
%defattr(-, root, root) |
154 |
%doc ChangeLog README COPYING AUTHORS |
155 |
%{_bindir}/aiksaurus |
156 |
%{_bindir}/caiksaurus |
157 |
|
158 |
%files -n %name-data |
159 |
%defattr(-, root, root) |
160 |
%dir %{_datadir}/aiksaurus |
161 |
%{_datadir}/aiksaurus/*.dat |
162 |
|
163 |
%files -n %lib_name |
164 |
%defattr(-, root, root) |
165 |
%{_libdir}/libAiksaurus-*.so.* |
166 |
|
167 |
%files -n %develname |
168 |
%defattr(-, root, root) |
169 |
%{_libdir}/libAiksaurus.so |
170 |
%{_libdir}/libAiksaurus.*a |
171 |
%{_libdir}/pkgconfig/aiksaurus-1.0.pc |
172 |
%dir %{_includedir}/Aiksaurus |
173 |
%{_includedir}/Aiksaurus/Aiksaurus.h |
174 |
%{_includedir}/Aiksaurus/AiksaurusC.h |
175 |
|
176 |
|
177 |
%files -n %{name}gtk |
178 |
%defattr(-, root, root) |
179 |
%{_bindir}/gaiksaurus |
180 |
|
181 |
%files -n %{lib_namegtk} |
182 |
%defattr(-, root, root) |
183 |
%{_libdir}/libAiksaurusGTK-*.so.* |
184 |
|
185 |
%files -n %gtkdevelname |
186 |
%defattr(-, root, root) |
187 |
%{_libdir}/libAiksaurusGTK.*a |
188 |
%{_libdir}/libAiksaurusGTK.so |
189 |
%{_libdir}/pkgconfig/gaiksaurus-1.0.pc |
190 |
%{_includedir}/Aiksaurus/AiksaurusGTK*.h |
191 |
|
192 |
|
193 |
|
194 |
|