1 |
%global __python /usr/bin/python2 |
2 |
Summary: A web based terminal |
3 |
Name: ajaxterm |
4 |
Version: 0.10 |
5 |
Release: %mkrel 9 |
6 |
|
7 |
# LGPL for the bundled js part |
8 |
License: Public Domain and GPLv2 and LGPLv2 |
9 |
Group: System/Servers |
10 |
URL: http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm |
11 |
Source: http://antony.lesuisse.org/qweb/files/Ajaxterm-%{version}.tar.bz2 |
12 |
Source1: %{name}.init |
13 |
Source2: %{name}.sysconfig |
14 |
Patch1: %{name}-ff36.patch |
15 |
Patch2: ajaxterm-0.10-CVE-2009-1629.patch |
16 |
Requires(preun): rpm-helper |
17 |
Requires(post): rpm-helper |
18 |
Requires: python |
19 |
BuildRequires: python |
20 |
BuildArch: noarch |
21 |
Recommends: apache-mod_proxy |
22 |
|
23 |
%description |
24 |
Ajaxterm is a web based terminal. It was inspired by and works almost |
25 |
exactly like https://anyterm.org/ except it's much easier to install. |
26 |
|
27 |
Ajaxterm is written in Python (and some AJAX JavaScript for the client side) |
28 |
and depends only on Python 2.3 or better. |
29 |
|
30 |
%prep |
31 |
%setup -q -n Ajaxterm-%{version} |
32 |
%patch1 -p2 |
33 |
%patch2 -p1 |
34 |
|
35 |
%build |
36 |
sed -i 's!/usr/bin/env python!/usr/bin/python2!' configure ajaxterm.py |
37 |
|
38 |
./configure --prefix=%{buildroot}/%{_prefix}/ |
39 |
perl -pi -e 's/.*ajaxterm.initd.*//' Makefile |
40 |
perl -pi -e 's|bin/python2.3|bin/python|' qweb.py |
41 |
|
42 |
%install |
43 |
make install |
44 |
|
45 |
mkdir -p %{buildroot}/%{_initrddir}/ |
46 |
mkdir -p %{buildroot}/%{_sysconfdir}/sysconfig |
47 |
|
48 |
cp %SOURCE1 %{buildroot}/%_initrddir/%{name} |
49 |
cp %SOURCE2 %{buildroot}/%{_sysconfdir}/sysconfig/%{name} |
50 |
|
51 |
chmod 755 %{buildroot}/%{_initrddir}/%{name} |
52 |
perl -pi -e 's|%{buildroot}/||g' %{buildroot}/%{_bindir}/ajaxterm |
53 |
|
54 |
%files |
55 |
%defattr(-, root, root, 0755) |
56 |
%doc README.txt |
57 |
%{_bindir}/* |
58 |
%{_datadir}/%{name}/ |
59 |
%{_mandir}/man1/* |
60 |
%config(noreplace) %{_initrddir}/%{name} |
61 |
%config(noreplace) %{_sysconfdir}/sysconfig/%{name} |
62 |
|
63 |
%post |
64 |
%_post_service %{name} |
65 |
|
66 |
%preun |
67 |
%_preun_service %{name} |