/[packages]/cauldron/alienarena/current/SPECS/alienarena.spec
ViewVC logotype

Annotation of /cauldron/alienarena/current/SPECS/alienarena.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 92847 - (hide annotations) (download)
Thu Apr 28 05:01:42 2011 UTC (13 years ago) by wally
File size: 4296 byte(s)
- fix desktop file name
- use configure2_5x and makeinstall_std macros

1 ahmad 65168 Summary: Multiplayer retro sci-fi deathmatch game
2 tv 64808 Name: alienarena
3     Version: 7.50
4 wally 92847 Release: %mkrel 4
5 tv 64808 License: GPLv2+
6     Group: Games/Arcade
7     # Subversion: https://svn.icculus.org/alienarena/trunk/?sortby=date
8     # Upstream seems too inept to provide a simple source only tarball, so we use svn.
9     # svn export svn://svn.icculus.org/alienarena/tags/7.50/ alienarena-7.50/
10     # These windows files are useless to us.
11     # rm -rf alienarena-7.50/*.exe alienarena-7.50/*.dll alienarena-7.50/Tools/aaradiant.exe
12     # These bundled zips are also pretty useless.
13     # rm -rf alienarena-7.50/lib_zipfiles/
14     # arena/ botinfo/ data1/ live in the alienarena-data package
15     # mkdir alienarena-data-20101216
16     # mv alienarena-7.50/arena/ alienarena-7.50/botinfo/ alienarena-7.50/data1/ alienarena-data-20101216/
17     # rm -f alienarena-data-20101216/{arena,data1}/game.so
18     # This data tarball is used for the alienarena-data package
19     # tar -cvJf alienarena-data-20101216.tar.xz alienarena-data-20101216
20     # This source tarball is used for the alienarena package
21     # tar -cvjf alienarena-7.50.tar.bz2 alienarena-7.50
22     Source0: alienarena-%{version}.tar.bz2
23     Source1: alienarena.desktop
24     Source2: GPL.acebot.txt
25     Source3: alienarena.png
26     Patch3: alienarena-7.45-no-qglBlitFramebufferEXT.patch
27     Patch4: alienarena-7.50-nodata.patch
28     # Ragdolls: added a NaN check which seems to solve the ODE assertion error problem
29     # http://svn.icculus.org/alienarena?view=rev&revision=2286
30     Patch5: alienarena-7.50-NAN.patch
31     URL: http://red.planetarena.org/
32     BuildRequires: X11-devel, libxext-devel, libxxf86dga-devel, libxxf86vm-devel, libjpeg-devel
33 tv 64890 BuildRequires: GL-devel, libmesaglu-devel, curl-devel, libpng-devel
34 tv 64808 BuildRequires: libvorbis-devel, openal-soft-devel, ode-devel, freetype-devel
35     BuildRequires: desktop-file-utils
36     Requires: alienarena-data = 20101216
37     Requires: desktop-file-utils >= 0.9, glxinfo
38 ahmad 65168 Requires: openal%{?_isa}
39 tv 64808
40     %description
41     Alien Arena 2011 is an online deathmatch game with over 30 levels, seven modes
42     of play, loads of mutators, built-in bots, multiple player characters and weapons
43     (with alt-fire modes).
44    
45    
46     %package server
47 ahmad 65168 Group: Games/Arcade
48     Summary: Dedicated server for alienarena, the FPS game
49     Requires: alienarena-data = 20101216
50 tv 64808
51    
52     %description server
53     Alien Arena 2011 is an online deathmatch game with over 30 levels, seven modes
54     of play, loads of mutators, built-in bots, multiple player characters and weapons
55     (with alt-fire modes).
56    
57     This is the dedicated server.
58    
59    
60     %prep
61     %setup -q
62    
63     %patch3 -p1 -b .no-qglBlitFramebufferEXT
64     %patch4 -p1 -b .nodata
65     %patch5 -p1 -b .NAN
66    
67     # Copy license clarification for acebot
68     cp -p %{SOURCE2} .
69    
70     # clean up prebuilt binary files
71     [[ -e crx ]] && rm crded crx crx.sdl {arena,data1}/game.so
72    
73     # clean up end-line encoding
74     [[ -e docs/README.txt ]] && %{__sed} -i 's/\r//' docs/README.txt
75    
76     # So, AlienArena now "uses" openal by dlopening the library, which is hardcoded to
77     # "libopenal.so". That file only lives in openal-devel, so we need to adjust the hardcoding.
78     LIBOPENAL=`ls %{_libdir}/libopenal.so.? | cut -d "/" -f 4`
79     sed -i "s|\"libopenal.so\"|\"$LIBOPENAL\"|g" source/unix/qal_unix.c
80    
81     %build
82     export PTHREAD_LIBS="-lpthread"
83     export PTHREAD_CFLAGS="-pthread"
84 wally 92847 %configure2_5x
85     %make
86 tv 64808
87     # make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" PREFIX="%{_prefix}" \
88     # WITH_DATADIR=yes WITH_LIBDIR=yes WITH_CURRENTDIR=no \
89     # DATADIR=%{_datadir}/%{name} LIBDIR="%{_libdir}/%{name}" OPTIMIZED_CFLAGS=no
90    
91    
92     %install
93 ahmad 65168 rm -fr %{buildroot}
94 wally 92847 %makeinstall_std
95 tv 64808
96     %{__mkdir_p} %{buildroot}%{_datadir}/applications
97 wally 92847 desktop-file-install --vendor "%{_real_vendor}" \
98 tv 64808 --dir %{buildroot}%{_datadir}/applications \
99     %{SOURCE1}
100    
101     mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
102     install -m 644 %{SOURCE3} %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
103    
104     # Fedora's little opengl checker
105     ln -s opengl-game-wrapper.sh %{buildroot}/%{_bindir}/%{name}-wrapper
106     ln -s crx %{buildroot}/%{_bindir}/%{name}
107     ln -s crx-ded %{buildroot}/%{_bindir}/%{name}-server
108    
109 ahmad 65168 %clean
110     rm -fr %{buildroot}
111 tv 64808
112     %files
113     %defattr(-,root,root,-)
114     %doc GPL.acebot.txt
115     %{_bindir}/crx
116     %{_bindir}/%{name}
117     %{_bindir}/%{name}-wrapper
118     %{_datadir}/applications/*.desktop
119     %{_datadir}/icons/hicolor/32x32/apps/%{name}.png
120     %{_defaultdocdir}/%{name}/
121    
122     %files server
123     %defattr(-,root,root,-)
124     %{_bindir}/crx-ded
125     %{_bindir}/%{name}-server

  ViewVC Help
Powered by ViewVC 1.1.30