/[packages]/cauldron/alienarena/current/SPECS/alienarena.spec
ViewVC logotype

Contents of /cauldron/alienarena/current/SPECS/alienarena.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 95342 - (show annotations) (download)
Fri May 6 06:42:00 2011 UTC (12 years, 11 months ago) by tv
File size: 4239 byte(s)
- new release
- drop patch5 (merged upstream)
- build without xf86dga
- build with system ode library
1 Summary: Multiplayer retro sci-fi deathmatch game
2 Name: alienarena
3 Version: 7.51
4 Release: %mkrel 1
5 License: GPLv2+
6 Group: Games/Arcade
7 # Subversion: https://svn.icculus.org/alienarena/trunk/?sortby=date
8 # Upstream seems too inept to provide a simple source only tarball, so we use svn.
9 # svn export svn://svn.icculus.org/alienarena/tags/7.51/ alienarena-7.51/
10 # These windows files are useless to us.
11 # rm -rf alienarena-7.51/*.exe alienarena-7.51/*.dll alienarena-7.51/Tools/aaradiant.exe
12 # These bundled zips are also pretty useless.
13 # rm -rf alienarena-7.51/lib_zipfiles/
14 # We don't want the bundled ode code.
15 # rm -rf alienarena-7.51/source/unix/ode/
16 # arena/ botinfo/ data1/ live in the alienarena-data package
17 # mkdir alienarena-data-20110323
18 # mv alienarena-7.51/arena/ alienarena-7.51/botinfo/ alienarena-7.51/data1/ alienarena-data-20110323/
19 # rm -f alienarena-data-20110323/{arena,data1}/game.so
20 # This data tarball is used for the alienarena-data package
21 # tar -cvJf alienarena-data-20110323.tar.xz alienarena-data-20101216
22 # This source tarball is used for the alienarena package
23 # tar -cvjf alienarena-7.51.tar.bz2 alienarena-7.51
24 Source0: alienarena-%{version}.tar.bz2
25 Source1: alienarena.desktop
26 Source2: GPL.acebot.txt
27 Source3: alienarena.png
28 Patch3: alienarena-7.45-no-qglBlitFramebufferEXT.patch
29 Patch4: alienarena-7.51-nodata.patch
30 # Ragdolls: added a NaN check which seems to solve the ODE assertion error problem
31 # http://svn.icculus.org/alienarena?view=rev&revision=2286
32 URL: http://red.planetarena.org/
33 BuildRequires: libxext-devel
34 BuildRequires: libxxf86vm-devel
35 BuildRequires: libjpeg-devel
36 BuildRequires: GL-devel
37 BuildRequires: libmesaglu-devel
38 BuildRequires: curl-devel
39 BuildRequires: libpng-devel
40 BuildRequires: libvorbis-devel
41 BuildRequires: openal-soft-devel
42 BuildRequires: ode-devel
43 BuildRequires: freetype2-devel
44 BuildRequires: desktop-file-utils
45 Requires: alienarena-data = 20110323
46 Requires: desktop-file-utils >= 0.9, glxinfo
47 Requires: openal%{?_isa}
48
49 %description
50 Alien Arena 2011 is an online deathmatch game with over 30 levels, seven modes
51 of play, loads of mutators, built-in bots, multiple player characters and weapons
52 (with alt-fire modes).
53
54
55 %package server
56 Group: Games/Arcade
57 Summary: Dedicated server for alienarena, the FPS game
58 Requires: alienarena-data = 20110323
59
60
61 %description server
62 Alien Arena 2011 is an online deathmatch game with over 30 levels, seven modes
63 of play, loads of mutators, built-in bots, multiple player characters and weapons
64 (with alt-fire modes).
65
66 This is the dedicated server.
67
68
69 %prep
70 %setup -q
71
72 %patch3 -p1 -b .no-qglBlitFramebufferEXT
73 %patch4 -p1 -b .nodata
74
75 # Copy license clarification for acebot
76 cp -p %{SOURCE2} .
77
78 # clean up prebuilt binary files
79 [[ -e crx ]] && rm crded crx crx.sdl {arena,data1}/game.so
80
81 # clean up end-line encoding
82 [[ -e docs/README.txt ]] && %{__sed} -i 's/\r//' docs/README.txt
83
84 # So, AlienArena now "uses" openal by dlopening the library, which is hardcoded to
85 # "libopenal.so". That file only lives in openal-devel, so we need to adjust the hardcoding.
86 LIBOPENAL=`ls %{_libdir}/libopenal.so.? | cut -d "/" -f 4`
87 sed -i "s|\"libopenal.so\"|\"$LIBOPENAL\"|g" source/unix/qal_unix.c
88
89 %build
90 export PTHREAD_LIBS="-lpthread"
91 export PTHREAD_CFLAGS="-pthread"
92 %configure2_5x --with-system-libode --without-xf86dga
93 %make
94
95 %install
96 rm -fr %{buildroot}
97 %makeinstall_std
98
99 %{__mkdir_p} %{buildroot}%{_datadir}/applications
100 desktop-file-install --vendor "%{_real_vendor}" \
101 --dir %{buildroot}%{_datadir}/applications \
102 %{SOURCE1}
103
104 mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
105 install -m 644 %{SOURCE3} %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
106
107 # Fedora's little opengl checker
108 ln -s opengl-game-wrapper.sh %{buildroot}/%{_bindir}/%{name}-wrapper
109 ln -s crx %{buildroot}/%{_bindir}/%{name}
110 ln -s crx-ded %{buildroot}/%{_bindir}/%{name}-server
111
112 %clean
113 rm -fr %{buildroot}
114
115 %files
116 %defattr(-,root,root,-)
117 %doc GPL.acebot.txt
118 %{_bindir}/crx
119 %{_bindir}/%{name}
120 %{_bindir}/%{name}-wrapper
121 %{_datadir}/applications/*.desktop
122 %{_datadir}/icons/hicolor/32x32/apps/%{name}.png
123 %{_iconsdir}/alienarena.png
124
125 %files server
126 %defattr(-,root,root,-)
127 %{_bindir}/crx-ded
128 %{_bindir}/%{name}-server

  ViewVC Help
Powered by ViewVC 1.1.30