/[packages]/cauldron/anjuta/current/SPECS/anjuta.spec
ViewVC logotype

Contents of /cauldron/anjuta/current/SPECS/anjuta.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 81105 - (show annotations) (download)
Wed Apr 6 06:38:53 2011 UTC (13 years ago) by tv
File size: 5833 byte(s)
rebuild for new vala
1 %define major 0
2 %define libname %mklibname %{name} %major
3 %define libnamedev %mklibname %{name} -d
4 %define _requires_exceptions perl.GBF..Make.
5
6 Summary: Integrated development environment for C and C++ (Linux)
7 Name: anjuta
8 Version: 2.32.1.1
9 Release: %mkrel 4
10 License: GPLv2+
11 Group: Development/Other
12 URL: http://anjuta.sourceforge.net/
13 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/anjuta/%{name}-%{version}.tar.bz2
14 Patch0: anjuta-2.31.6.0-format-strings.patch
15 Patch1: anjuta-2.29.4.0-fix-linking.patch
16
17 BuildRequires: gtk+2-devel >= 2.4.0
18 BuildRequires: libORBit2-devel >= 2.6
19 BuildRequires: libxml2-devel >= 2.4.23
20 BuildRequires: pango-devel >= 1.8
21 BuildRequires: gda4.0-devel
22 BuildRequires: libgdl-devel >= 2.27.3
23 BuildRequires: libxslt-devel
24 BuildRequires: unique-devel
25 BuildRequires: devhelp-devel >= 2.31.6
26 BuildRequires: vte-devel >= 0.9.0
27 BuildRequires: autogen-devel
28 BuildRequires: autogen
29 BuildRequires: gtksourceview-devel
30 BuildRequires: gnome-common
31 BuildRequires: intltool
32 BuildRequires: subversion-devel >= 1.0.2
33 BuildRequires: apr-util-devel >= 0.9.4
34 BuildRequires: binutils-devel
35 BuildRequires: pcre-devel
36 BuildRequires: gtk-doc >= 1.0
37 BuildRequires: gnome-doc-utils >= 0.4.2
38 BuildRequires: apr-devel >= 1.2.2
39 BuildRequires: gd-devel
40 BuildRequires: graphviz-devel >= 2.22
41 BuildRequires: scrollkeeper
42 BuildRequires: howl-devel
43 BuildRequires: glade3-devel >= 1:3.7.1
44 BuildRequires: vala-devel >= 0.9.4
45 BuildRequires: glib2-devel >= 2.25.15
46 BuildRequires: imagemagick
47 # needed for AM_GCONF_SOURCE2 macro in configure script
48 BuildRequires: libGConf2-devel
49
50 Requires: autogen
51 Requires: python-rope
52 Suggests: libglademm-devel
53 Suggests: glade3
54
55 # package was called anjuta2 in Mdv due to anjuta-1.x packages in <= 2008.1
56 Provides: %{name}2 = %{version}-%{release}
57
58 %description
59 Anjuta DevStudio is a versatile Integrated Development Environment (IDE)
60 on GNOME Desktop Environment and features a number of advanced
61 programming facilities. These include project management, application and
62 class wizards, an on-board interactive debugger, powerful source editor,
63 syntax highlighting, intellisense autocompletions, symbol navigation,
64 version controls, integrated GUI designing and other tools.
65
66 Anjuta 2.x is the next generation Anjuta development studio with extensible
67 plugin architecture. The new architecture allows writing independent
68 plugins that could interact with existing plugins. Most of the older
69 features have been already ported to the new architecture and are working.
70
71 %package -n %{libname}
72 Summary: Anjuta 2 libraries
73 Group: System/Libraries
74
75 %description -n %{libname}
76 Anjuta 2 libraries
77
78 %package -n %{libnamedev}
79 Summary: Anjuta 2 devel files
80 Group: Development/Other
81 Requires: %{libname} = %{version}-%{release}
82 Provides: %{name}-devel = %{version}-%{release}
83
84 %description -n %{libnamedev}
85 Anjuta 2 devel files
86
87 %prep
88 %setup -q
89 %apply_patches
90
91 %build
92 autoreconf -fi
93 %configure2_5x \
94 --disable-static \
95 --enable-plugin-sourceview \
96 --enable-introspection=no
97 %make
98
99 %install
100 rm -rf %{buildroot}
101 %makeinstall_std
102
103 desktop-file-install --vendor="" \
104 --remove-key='Encoding' \
105 --add-category="IDE" \
106 --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/*
107
108 %find_lang %{name} --with-gnome
109 %find_lang %{name}-build-tutorial --with-gnome
110 cat %{name}-build-tutorial.lang > anjuta.lang
111
112 # remove unneeded and conflictive files
113 rm -f %{buildroot}%{_libdir}/libanjuta*.la \
114 %{buildroot}%{_libdir}/libanjuta*.a \
115 %{buildroot}%{_datadir}/mime/XMLnamespaces \
116 %{buildroot}%{_datadir}/mime/aliases \
117 %{buildroot}%{_datadir}/mime/globs \
118 %{buildroot}%{_datadir}/mime/magic \
119 %{buildroot}%{_datadir}/mime/subclasses
120 rm -rf %{buildroot}/%{_docdir}
121
122 %clean
123 rm -rf %{buildroot}
124
125 %define schemas anjuta-build-basic-autotools-plugin anjuta-cvs-plugin anjuta-document-manager anjuta-editor-sourceview anjuta-language-cpp-java anjuta-message-manager-plugin anjuta-terminal-plugin anjuta-debug-manager anjuta-symbol-db file-manager preferences python-plugin-properties
126
127 # neccessary because uninstall of schemas is not done by filetriggers
128 %preun
129 %preun_uninstall_gconf_schemas %{schemas}
130
131 %files -f %{name}.lang
132 %defattr(-,root,root)
133 %{_sysconfdir}/gconf/schemas/anjuta-build-basic-autotools-plugin.schemas
134 %{_sysconfdir}/gconf/schemas/anjuta-cvs-plugin.schemas
135 %{_sysconfdir}/gconf/schemas/anjuta-document-manager.schemas
136 %{_sysconfdir}/gconf/schemas/anjuta-debug-manager.schemas
137 %{_sysconfdir}/gconf/schemas/anjuta-editor-sourceview.schemas
138 %{_sysconfdir}/gconf/schemas/anjuta-language-cpp-java.schemas
139 %{_sysconfdir}/gconf/schemas/anjuta-message-manager-plugin.schemas
140 %{_sysconfdir}/gconf/schemas/anjuta-symbol-db.schemas
141 %{_sysconfdir}/gconf/schemas/anjuta-terminal-plugin.schemas
142 %{_sysconfdir}/gconf/schemas/file-manager.schemas
143 %{_sysconfdir}/gconf/schemas/preferences.schemas
144 %{_sysconfdir}/gconf/schemas/python-plugin-properties.schemas
145 %{_bindir}/*
146 %{_libdir}/glade3/modules/*
147 %{_libdir}/anjuta
148 %{_datadir}/anjuta
149 %{_datadir}/glade3/catalogs/*.xml
150 %{_datadir}/applications/*.desktop
151 %{_datadir}/gtk-doc/html/libanjuta*
152 %{_datadir}/icons/gnome/*/mimetypes/*
153 %{_datadir}/locale/*/LC_MESSAGES/anjuta.mo
154 %{_mandir}/man1/anjuta.1*
155 %{_mandir}/man1/anjuta-launcher.1*
156 %{_datadir}/mime/packages/anjuta.xml
157 %{_datadir}/pixmaps/anjuta
158 %{_datadir}/icons/hicolor/*/apps/*
159 %{_datadir}/omf/anjuta-manual/*.omf
160 %{_datadir}/gnome/help/anjuta-manual/
161 %{_datadir}/gnome/help/anjuta-faqs/
162
163
164 %files -n %libname
165 %defattr(-,root,root)
166 %_libdir/*.so.%{major}*
167
168 %files -n %libnamedev
169 %defattr(-,root,root)
170 %_libdir/*.so
171 %_includedir/libanjuta-1.0
172 %_libdir/pkgconfig/*.pc
173

  ViewVC Help
Powered by ViewVC 1.1.30