1 |
matteo |
189320 |
%define git 33b232a |
2 |
|
|
|
3 |
|
|
Name: antico |
4 |
|
|
Version: 0.2 |
5 |
matteo |
189452 |
Release: %mkrel -c git 1 |
6 |
matteo |
189320 |
Summary: Antico Desktop/Window Manager |
7 |
|
|
License: GPLv2 |
8 |
|
|
Url: http://www.giuseppecigala.it/Antico.html |
9 |
|
|
#Source0: https://github.com/antico/antico/tarball/master |
10 |
|
|
Source: %{name}-%{name}-%{git}.tar.gz |
11 |
|
|
Group: Graphical desktop/Other |
12 |
|
|
|
13 |
|
|
BuildRequires: qt4-devel |
14 |
|
|
|
15 |
|
|
Requires: desktop-common-data |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
Antico is a Qt4/X11 Desktop/Window Manager. |
19 |
|
|
The goal is to create a Window/Desktop manager simple and fast. |
20 |
|
|
All parameters must be configured from few files, |
21 |
|
|
avoiding unnecessary complications, following the K.I.S.S. philosophy. |
22 |
|
|
The whole project is be based only on Qt4 libraries, |
23 |
|
|
without any other external dependencies. |
24 |
|
|
|
25 |
|
|
%prep |
26 |
|
|
%setup -q -n %{name}-%{name}-%{git} |
27 |
|
|
|
28 |
|
|
# patch to make antico more modular |
29 |
|
|
find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/antico.cfg"|QDir::homePath() + "/.antico.cfg"|g' {} \; |
30 |
|
|
find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/theme|QDir::rootPath() + "usr/share/antico/theme|g' {} \; |
31 |
|
|
find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/language|QDir::rootPath() + "usr/share/antico/language|g' {} \; |
32 |
|
|
|
33 |
|
|
%build |
34 |
|
|
%{qmake_qt4} |
35 |
matteo |
189420 |
# workaround to allow compilation on mga2 (why?) |
36 |
matteo |
189320 |
%make SUBLIBS="-lXext -lX11" |
37 |
|
|
|
38 |
|
|
%install |
39 |
|
|
%__rm -fr %{buildroot} |
40 |
|
|
|
41 |
|
|
%__install -D -d -m 755 %{buildroot}%{_bindir} |
42 |
|
|
%__install -D -m 755 %{name} %{buildroot}%{_bindir}/%{name} |
43 |
|
|
%__install -D -d -m 755 %{buildroot}%{_datadir}/%{name} |
44 |
|
|
%__cp -R theme %{buildroot}%{_datadir}/%{name}/ |
45 |
|
|
# ----------- patch wmsession.d ---------------------------- |
46 |
|
|
%__install -D -d -m 755 %{buildroot}%{_sysconfdir}/X11/wmsession.d |
47 |
|
|
|
48 |
|
|
file=%{name}-kdm.desktop |
49 |
|
|
name="$(sed -n 's,^Name=,,p' "$file")" |
50 |
|
|
comment="$(sed -n 's,^Comment=,,p' "$file")" |
51 |
|
|
tryexec="$(sed -n 's,^TryExec=,,p' "$file")" |
52 |
|
|
exec="$(sed -n 's,^Exec=,,p' "$file")" |
53 |
|
|
[ -n "$name" ] && [ -n "$comment" ] && [ -n "$exec" ] || exit 1 |
54 |
|
|
|
55 |
|
|
# EXEC needs to be absolute for chksession |
56 |
|
|
case $tryexec in |
57 |
|
|
*/*) ;; |
58 |
|
|
*) tryexec=%{_bindir}/$tryexec;; |
59 |
|
|
esac |
60 |
|
|
|
61 |
|
|
outfile=%{buildroot}%{_sysconfdir}/X11/wmsession.d/14$(basename $file .desktop) |
62 |
|
|
|
63 |
|
|
echo "NAME=$name" > $outfile |
64 |
|
|
[ -n "$tryexec" ] && echo "EXEC=$tryexec" >> $outfile |
65 |
|
|
echo "DESC=$comment" >> $outfile |
66 |
|
|
echo "SCRIPT:" >> $outfile |
67 |
|
|
echo "exec %{_bindir}/$exec" >> $outfile |
68 |
|
|
# --------- end patch ------------------------------------------ |
69 |
|
|
|
70 |
|
|
%__install -D -d -m 755 %{buildroot}%{_datadir}/%{name} |
71 |
|
|
%__cp -R language %{buildroot}%{_datadir}/%{name}/ |
72 |
|
|
|
73 |
|
|
%__chmod -R 755 %{buildroot}%{_datadir}/%{name}/theme |
74 |
|
|
%__chmod -R 755 %{buildroot}%{_datadir}/%{name}/language |
75 |
|
|
|
76 |
|
|
%clean |
77 |
|
|
%__rm -fr %{buildroot} |
78 |
|
|
|
79 |
|
|
%files |
80 |
|
|
%defattr(-,root,root,-) |
81 |
matteo |
189420 |
%doc CHANGELOG COPYING README |
82 |
matteo |
189320 |
%{_bindir}/antico |
83 |
|
|
%{_sysconfdir}/X11/wmsession.d |
84 |
|
|
%{_datadir}/%{name} |