/[packages]/cauldron/antico/current/SPECS/antico.spec
ViewVC logotype

Annotation of /cauldron/antico/current/SPECS/antico.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 191611 - (hide annotations) (download)
Thu Jan 5 15:10:45 2012 UTC (12 years, 3 months ago) by matteo
File size: 3014 byte(s)
- new sources
- switched antico launcher icon with mageia icon

1 matteo 191611 #define git 33b232a
2     %define git 74aa84c
3 matteo 189320
4     Name: antico
5     Version: 0.2
6 matteo 191611 Release: %mkrel -c git 2
7 matteo 189320 Summary: Antico Desktop/Window Manager
8     License: GPLv2
9     Url: http://www.giuseppecigala.it/Antico.html
10     #Source0: https://github.com/antico/antico/tarball/master
11 matteo 191611 Source: pasmatt-%{name}-%{git}.zip
12     #Source: %{name}-%{name}-%{git}.tar.gz
13     Patch0: %{name}-mageia_icon.patch
14 matteo 189320 Group: Graphical desktop/Other
15    
16     BuildRequires: qt4-devel
17    
18     Requires: desktop-common-data
19    
20     %description
21     Antico is a Qt4/X11 Desktop/Window Manager.
22     The goal is to create a Window/Desktop manager simple and fast.
23     All parameters must be configured from few files,
24     avoiding unnecessary complications, following the K.I.S.S. philosophy.
25     The whole project is be based only on Qt4 libraries,
26     without any other external dependencies.
27    
28     %prep
29 matteo 191611 %setup -q -n pasmatt-%{name}-%{git}
30     %apply_patches
31 matteo 189320
32     # patch to make antico more modular
33 matteo 191611 # fixed upstream (pasmatt fork on github)
34     #find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/antico.cfg"|QDir::homePath() + "/.antico.cfg"|g' {} \;
35     #find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/theme|QDir::rootPath() + "usr/share/antico/theme|g' {} \;
36     #find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/language|QDir::rootPath() + "usr/share/antico/language|g' {} \;
37 matteo 189320
38     %build
39     %{qmake_qt4}
40 matteo 191611 # FIXED - workaround to allow compilation on mga2 (why?)
41     #%make SUBLIBS="-lXext -lX11"
42     %make
43 matteo 189320
44     %install
45     %__rm -fr %{buildroot}
46    
47     %__install -D -d -m 755 %{buildroot}%{_bindir}
48     %__install -D -m 755 %{name} %{buildroot}%{_bindir}/%{name}
49     %__install -D -d -m 755 %{buildroot}%{_datadir}/%{name}
50     %__cp -R theme %{buildroot}%{_datadir}/%{name}/
51     # ----------- patch wmsession.d ----------------------------
52     %__install -D -d -m 755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
53    
54     file=%{name}-kdm.desktop
55     name="$(sed -n 's,^Name=,,p' "$file")"
56     comment="$(sed -n 's,^Comment=,,p' "$file")"
57     tryexec="$(sed -n 's,^TryExec=,,p' "$file")"
58     exec="$(sed -n 's,^Exec=,,p' "$file")"
59     [ -n "$name" ] && [ -n "$comment" ] && [ -n "$exec" ] || exit 1
60    
61     # EXEC needs to be absolute for chksession
62     case $tryexec in
63     */*) ;;
64     *) tryexec=%{_bindir}/$tryexec;;
65     esac
66    
67     outfile=%{buildroot}%{_sysconfdir}/X11/wmsession.d/14$(basename $file .desktop)
68    
69     echo "NAME=$name" > $outfile
70     [ -n "$tryexec" ] && echo "EXEC=$tryexec" >> $outfile
71     echo "DESC=$comment" >> $outfile
72     echo "SCRIPT:" >> $outfile
73     echo "exec %{_bindir}/$exec" >> $outfile
74     # --------- end patch ------------------------------------------
75    
76     %__install -D -d -m 755 %{buildroot}%{_datadir}/%{name}
77     %__cp -R language %{buildroot}%{_datadir}/%{name}/
78    
79     %__chmod -R 755 %{buildroot}%{_datadir}/%{name}/theme
80     %__chmod -R 755 %{buildroot}%{_datadir}/%{name}/language
81    
82     %clean
83     %__rm -fr %{buildroot}
84    
85     %files
86     %defattr(-,root,root,-)
87 matteo 189420 %doc CHANGELOG COPYING README
88 matteo 189320 %{_bindir}/antico
89     %{_sysconfdir}/X11/wmsession.d
90     %{_datadir}/%{name}

  ViewVC Help
Powered by ViewVC 1.1.30