/[packages]/cauldron/antico/current/SPECS/antico.spec
ViewVC logotype

Contents of /cauldron/antico/current/SPECS/antico.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 196812 - (show annotations) (download)
Mon Jan 16 11:18:03 2012 UTC (12 years, 3 months ago) by matteo
File size: 2174 byte(s)
- fixed post error due to not existing group
1 %define git a5bcc1d
2
3 Name: antico
4 Version: 0.2
5 Release: %mkrel -c git 5
6 Summary: Antico Desktop/Window Manager
7 License: GPLv2
8 Url: https://github.com/pasmatt/%{name}
9 Source: pasmatt-%{name}-%{git}.zip
10 Source1: 14%{name}
11 Patch0: %{name}-mageia_icon.patch
12 Patch1: %{name}-%{name}cpp-mageia_theme.patch
13 Group: Graphical desktop/Other
14
15 BuildRequires: qt4-devel
16
17 Requires: desktop-common-data
18 Requires: mageia-theme-Default
19
20 %description
21 Antico is a Qt4/X11 Desktop/Window Manager.
22 The goal is to create a Window/Desktop manager simple and fast.
23 All parameters must be configured from few files,
24 avoiding unnecessary complications, following the K.I.S.S. philosophy.
25 The whole project is be based only on Qt4 libraries,
26 without any other external dependencies.
27
28 %prep
29 %setup -q -n pasmatt-%{name}-%{git}
30 %apply_patches
31
32 %build
33 %{qmake_qt4}
34 %make
35
36 %install
37 rm -fr %{buildroot}
38
39 install -D -d -m 755 %{buildroot}%{_bindir}
40 install -D -m 755 %{name} %{buildroot}%{_bindir}/%{name}
41 install -D -d -m 755 %{buildroot}%{_datadir}/%{name}
42 install -D -d -m 755 %{buildroot}%{_sysconfdir}/skel/.%{name}
43 cp -R theme %{buildroot}%{_sysconfdir}/skel/.%{name}/
44 cp -R language %{buildroot}%{_datadir}/%{name}/
45
46 install -D -d -m 755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
47 install -D -m 755 %SOURCE1 %{buildroot}%{_sysconfdir}/X11/wmsession.d/
48
49 chmod -R 755 %{buildroot}%{_sysconfdir}/skel/.%{name}/theme
50 chmod -R 755 %{buildroot}%{_datadir}/%{name}/language
51
52 %files
53 %defattr(-,root,root,-)
54 %doc CHANGELOG COPYING README
55 %{_bindir}/antico
56 %{_sysconfdir}/X11/wmsession.d
57 %{_sysconfdir}/skel/.%{name}
58 %{_datadir}/%{name}
59
60 %post
61 # copy theme directory into already existing user home directories
62 for i in `cat /etc/passwd|grep "/home"|awk -F':' '{print $1":"$6}'`;
63 do
64 homepath=`echo "${i}" | awk -F':' '{print $2}'`
65 cp -R %{_sysconfdir}/skel/.antico "${homepath}/"
66 user=`echo "${i}" | awk -F':' '{print $1}'`
67 chown -R $user "${homepath}/.antico"
68 cat /etc/group | grep $user 2>&1 >/dev/null
69 if [ $? -eq 0 ]; then
70 chgrp -R $user "${homepath}/.antico"
71 else
72 cat /etc/group | grep live 2>&1 >/dev/null
73 if [ $? -eq 0 ]; then
74 chgrp -R live "${homepath}/.antico"
75 fi
76 fi
77 done

  ViewVC Help
Powered by ViewVC 1.1.30