/[packages]/cauldron/antico/current/SPECS/antico.spec
ViewVC logotype

Contents of /cauldron/antico/current/SPECS/antico.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 189320 - (show annotations) (download)
Sat Dec 31 16:42:56 2011 UTC (12 years, 3 months ago) by matteo
File size: 2775 byte(s)
imported package antico
1 %define git 33b232a
2
3 Name: antico
4 Version: 0.2
5 Release: %mkrel 1
6 Summary: Antico Desktop/Window Manager
7 License: GPLv2
8 Url: http://www.giuseppecigala.it/Antico.html
9 #Source0: https://github.com/antico/antico/tarball/master
10 Source: %{name}-%{name}-%{git}.tar.gz
11 Group: Graphical desktop/Other
12
13 BuildRequires: qt4-devel
14
15 Requires: desktop-common-data
16
17 %description
18 Antico is a Qt4/X11 Desktop/Window Manager.
19 The goal is to create a Window/Desktop manager simple and fast.
20 All parameters must be configured from few files,
21 avoiding unnecessary complications, following the K.I.S.S. philosophy.
22 The whole project is be based only on Qt4 libraries,
23 without any other external dependencies.
24
25 %prep
26 %setup -q -n %{name}-%{name}-%{git}
27
28 # patch to make antico more modular
29 find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/antico.cfg"|QDir::homePath() + "/.antico.cfg"|g' {} \;
30 find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/theme|QDir::rootPath() + "usr/share/antico/theme|g' {} \;
31 find . -name "*.cpp" -type f -exec sed -i -e 's|QCoreApplication::applicationDirPath()[[:space:]]+[[:space:]]"/language|QDir::rootPath() + "usr/share/antico/language|g' {} \;
32
33 %build
34 %{qmake_qt4}
35 %make SUBLIBS="-lXext -lX11"
36
37 %install
38 %__rm -fr %{buildroot}
39
40 %__install -D -d -m 755 %{buildroot}%{_bindir}
41 %__install -D -m 755 %{name} %{buildroot}%{_bindir}/%{name}
42 %__install -D -d -m 755 %{buildroot}%{_datadir}/%{name}
43 %__cp -R theme %{buildroot}%{_datadir}/%{name}/
44 # ----------- patch wmsession.d ----------------------------
45 %__install -D -d -m 755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
46
47 file=%{name}-kdm.desktop
48 name="$(sed -n 's,^Name=,,p' "$file")"
49 comment="$(sed -n 's,^Comment=,,p' "$file")"
50 tryexec="$(sed -n 's,^TryExec=,,p' "$file")"
51 exec="$(sed -n 's,^Exec=,,p' "$file")"
52 [ -n "$name" ] && [ -n "$comment" ] && [ -n "$exec" ] || exit 1
53
54 # EXEC needs to be absolute for chksession
55 case $tryexec in
56 */*) ;;
57 *) tryexec=%{_bindir}/$tryexec;;
58 esac
59
60 outfile=%{buildroot}%{_sysconfdir}/X11/wmsession.d/14$(basename $file .desktop)
61
62 echo "NAME=$name" > $outfile
63 [ -n "$tryexec" ] && echo "EXEC=$tryexec" >> $outfile
64 echo "DESC=$comment" >> $outfile
65 echo "SCRIPT:" >> $outfile
66 echo "exec %{_bindir}/$exec" >> $outfile
67 # --------- end patch ------------------------------------------
68
69 %__install -D -d -m 755 %{buildroot}%{_datadir}/%{name}
70 %__cp -R language %{buildroot}%{_datadir}/%{name}/
71
72 %__chmod -R 755 %{buildroot}%{_datadir}/%{name}/theme
73 %__chmod -R 755 %{buildroot}%{_datadir}/%{name}/language
74
75 %clean
76 %__rm -fr %{buildroot}
77
78 %files
79 %defattr(-,root,root,-)
80 %doc CHANGELOG
81 %{_bindir}/antico
82 %{_sysconfdir}/X11/wmsession.d
83 %{_datadir}/%{name}

  ViewVC Help
Powered by ViewVC 1.1.30