1 |
colin |
568388 |
# (cg) Needed for the rpath stuff below. See other comments |
2 |
|
|
%define _provides_exceptions devel(.* |
3 |
|
|
%define _requires_exceptions devel(.* |
4 |
|
|
|
5 |
eandry |
54985 |
Summary: KDE interface for PackageKit |
6 |
fwang |
153921 |
Name: apper |
7 |
fwang |
660743 |
Version: 0.9.0 |
8 |
fwang |
617483 |
Release: %mkrel 1 |
9 |
eandry |
54985 |
License: GPLv2+ |
10 |
malo |
390332 |
Group: System/Packaging |
11 |
fwang |
617483 |
Source0: http://download.kde.org/stable/apper/%{version}/src/%{name}-%{version}.tar.xz |
12 |
neoclust |
583859 |
Patch0: apper-0.8.1-disable-autoload.patch |
13 |
fwang |
153921 |
URL: http://www.opendesktop.org/content/show.php/Apper?content=84745 |
14 |
eandry |
54985 |
BuildRequires: kdelibs4-devel |
15 |
juancho |
211534 |
BuildRequires: kdebase4-workspace-devel |
16 |
eandry |
54985 |
BuildRequires: qt4-qtdbus |
17 |
fwang |
660743 |
BuildRequires: packagekit-qt-devel >= 0.9.0 |
18 |
eandry |
54985 |
BuildRequires: desktop-file-utils |
19 |
fwang |
323941 |
Requires: packagekit >= 0.8.5 |
20 |
fwang |
153922 |
Provides: packagekit-gui |
21 |
|
|
Obsoletes: kpackagekit |
22 |
|
|
Obsoletes: kpackagekit-common |
23 |
eandry |
54985 |
|
24 |
|
|
%description |
25 |
|
|
KDE interface for PackageKit. |
26 |
|
|
|
27 |
fwang |
153922 |
%files -f %name.lang |
28 |
eandry |
54985 |
%{_kde_bindir}/* |
29 |
fwang |
153922 |
%{_kde_libdir}/kde4/*.so |
30 |
colin |
568388 |
%{_kde_libdir}/lib%{name}.so |
31 |
fwang |
460912 |
%{_kde_libdir}/apper/lib%{name}.so |
32 |
fwang |
460920 |
%{_kde_libdir}/kde4/imports/org/kde/apper |
33 |
|
|
%{_kde_libdir}/kde4/libexec/apper-pk-session |
34 |
fwang |
153922 |
%{_kde_appsdir}/* |
35 |
eandry |
54985 |
%{_kde_datadir}/applications/kde4/*.desktop |
36 |
|
|
%{_kde_services}/*.desktop |
37 |
fwang |
153923 |
%{_kde_services}/kded/*.desktop |
38 |
fwang |
153922 |
%{_datadir}/dbus-1/services/*.service |
39 |
fwang |
617489 |
%{_datadir}/appdata/apper.appdata.xml |
40 |
fwang |
460830 |
%{_kde_mandir}/man1/* |
41 |
eandry |
54985 |
|
42 |
|
|
#-------------------------------------------------------------------- |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup -q -n %name-%version |
46 |
colin |
568388 |
# (cg) Our own rpath stripping seems to disagree with stuff here. |
47 |
|
|
find -name CMakeLists.txt -exec sed -i 's/set_target_properties.*INSTALL_RPATH.*//' {} \; |
48 |
neoclust |
583859 |
%apply_patches |
49 |
eandry |
54985 |
|
50 |
|
|
%build |
51 |
|
|
%cmake_kde4 |
52 |
|
|
%make |
53 |
|
|
|
54 |
|
|
%install |
55 |
|
|
%makeinstall_std -C build |
56 |
|
|
|
57 |
colin |
568388 |
# (cg) this seems to work around it not being able to find the library but |
58 |
|
|
# I suspect a better fix is to work out why the rpath stuff is not working |
59 |
|
|
# or being stripped out. |
60 |
|
|
ln -s apper/libapper.so %{buildroot}%{_libdir}/ |
61 |
|
|
|
62 |
eandry |
54985 |
desktop-file-install --vendor='' \ |
63 |
|
|
--dir %buildroot%_kde_datadir/applications/kde4 \ |
64 |
|
|
--remove-category='System' \ |
65 |
|
|
--add-category='Settings' \ |
66 |
|
|
--remove-mime-type='application/x-deb' \ |
67 |
|
|
%buildroot%_kde_datadir/applications/kde4/*.desktop |
68 |
|
|
|
69 |
fwang |
460920 |
%find_lang %name --all-name |
70 |
eandry |
54985 |
|
71 |
|
|
# hack around gnome-packagekit conflict |
72 |
colin |
568388 |
# (cg) Note that this is a rubbish hack: While the files names may no longer |
73 |
|
|
# conflict they are still trying to bus-activate the same service. This can |
74 |
|
|
# never work properly when you have both installed anyway, so it's probably |
75 |
|
|
# better to have the packages conflict IMO. |
76 |
eandry |
54988 |
mv %{buildroot}%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service \ |
77 |
colin |
568388 |
%{buildroot}%{_datadir}/dbus-1/services/kde-org.freedesktop.PackageKit.service |