1 |
%define lib_major 1 |
2 |
%define lib_name %mklibname %{name} %{lib_major} |
3 |
%define dev_name %mklibname %{name} -d |
4 |
|
5 |
Summary: Utility for managing filesystem extended attributes |
6 |
Name: attr |
7 |
Version: 2.4.47 |
8 |
Release: %mkrel 5 |
9 |
Source0: http://git.savannah.gnu.org/cgit/attr.git/snapshot/%{name}-%{version}.tar.gz |
10 |
License: GPLv2 |
11 |
Group: System/Kernel and hardware |
12 |
URL: http://savannah.nongnu.org/projects/attr |
13 |
|
14 |
%description |
15 |
A set of tools for manipulating extended attributes on filesystem |
16 |
objects, in particular getfattr(1) and setfattr(1). |
17 |
An attr(1) command is also provided which is largely compatible |
18 |
with the SGI IRIX tool of the same name. |
19 |
|
20 |
%package -n %{lib_name} |
21 |
Summary: Main library for libattr |
22 |
Group: System/Libraries |
23 |
License: LGPLv2.1 |
24 |
Requires(pre): filesystem >= 2.1.9-18 |
25 |
|
26 |
%description -n %{lib_name} |
27 |
This package contains the library needed to run programs dynamically |
28 |
linked with libattr. |
29 |
|
30 |
%package -n %{dev_name} |
31 |
Summary: Extended attribute static libraries and headers |
32 |
Group: Development/C |
33 |
License: LGPLv2.1 |
34 |
Requires(pre): filesystem >= 2.1.9-18 |
35 |
Requires: %{lib_name} = %{version}-%{release} |
36 |
Provides: lib%{name}-devel = %{version}-%{release} |
37 |
Provides: %{name}-devel = %{version}-%{release} |
38 |
Obsoletes: %{_lib}attr1-devel < 2.4.47-2 |
39 |
|
40 |
%description -n %{dev_name} |
41 |
This package contains the libraries and header files needed to |
42 |
develop programs which make use of extended attributes. |
43 |
For Linux programs, the documented system call API is the |
44 |
recommended interface, but an SGI IRIX compatibility interface |
45 |
is also provided. |
46 |
|
47 |
Currently only ext2, ext3, JFS and XFS support extended attributes. |
48 |
The SGI IRIX compatibility API built above the Linux system calls is |
49 |
used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8). |
50 |
|
51 |
You should install libattr-devel if you want to develop programs |
52 |
which make use of extended attributes. If you install libattr-devel |
53 |
then you'll also want to install attr. |
54 |
|
55 |
%prep |
56 |
%setup -q |
57 |
|
58 |
%build |
59 |
libtoolize -c -i -f |
60 |
cp include/install-sh . |
61 |
aclocal -I m4 |
62 |
autoconf |
63 |
|
64 |
%configure2_5x \ |
65 |
--disable-static |
66 |
%make |
67 |
|
68 |
%install |
69 |
make install DESTDIR=%{buildroot} |
70 |
make install-dev DESTDIR=%{buildroot} |
71 |
make install-lib DESTDIR=%{buildroot} |
72 |
|
73 |
# fix conflict with man-pages-1.56 |
74 |
rm -fr %{buildroot}{%_mandir/man2,%_datadir/doc} |
75 |
|
76 |
# Remove unpackaged symlinks |
77 |
find %{buildroot} -name "*.la" -delete |
78 |
|
79 |
%find_lang %{name} |
80 |
|
81 |
%files -f %{name}.lang |
82 |
%doc doc/CHANGES.gz README |
83 |
%{_bindir}/* |
84 |
%{_mandir}/man1/* |
85 |
|
86 |
%files -n %{lib_name} |
87 |
%{_libdir}/lib%{name}.so.%{lib_major} |
88 |
%{_libdir}/lib%{name}.so.%{lib_major}.* |
89 |
|
90 |
%files -n %{dev_name} |
91 |
%doc doc/CHANGES.gz README |
92 |
%{_libdir}/lib%{name}.so |
93 |
%{_mandir}/man3/* |
94 |
%{_mandir}/man5/* |
95 |
%{_includedir}/%{name}/ |