/[packages]/cauldron/automake/current/SPECS/automake.spec
ViewVC logotype

Contents of /cauldron/automake/current/SPECS/automake.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 346672 - (show annotations) (download)
Fri Jan 11 12:48:59 2013 UTC (12 years, 3 months ago) by umeabot
File size: 2770 byte(s)
Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
1 %define amversion 1.13
2 %define _requires_exceptions perl(Automake::.*)
3 %define _provides_exceptions perl(Automake::.*)
4
5 %define docheck 0
6 %{?_without_check: %global docheck 0}
7
8 Summary: A GNU tool for automatically creating Makefiles
9 Name: automake
10 Version: 1.13.1
11 Release: %mkrel 2
12 License: GPLv2+
13 Group: Development/Other
14 Source0: http://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz
15 URL: http://www.gnu.org/software/automake/
16 BuildArch: noarch
17
18 Requires: autoconf
19 BuildRequires: autoconf
20 BuildRequires: texinfo
21 Conflicts: automake1.5
22 Provides: automake1.9 = %{version}-%{release}
23 Obsoletes: automake1.9
24 Provides: automake1.8 = %{version}-%{release}
25 Obsoletes: automake1.8
26 Requires(post): info-install
27 Requires(preun): info-install
28 Requires(post): update-alternatives
29 Requires(preun): update-alternatives
30
31 # tests need these
32 %if %docheck
33 BuildRequires: bison
34 BuildRequires: flex
35 BuildRequires: tetex-latex
36 BuildRequires: emacs
37 BuildRequires: dejagnu
38 BuildRequires: gcc-java
39 BuildRequires: python
40 %endif
41
42 %description
43 Automake is a tool for automatically generating Makefiles compliant with
44 the GNU Coding Standards.
45
46 You should install Automake if you are developing software and would like
47 to use its capabilities of automatically generating GNU standard
48 Makefiles. If you install Automake, you will also need to install GNU's
49 Autoconf package.
50
51 %prep
52 %setup -q -n automake-%{version}
53
54 %build
55 %configure2_5x --build=%{_host}
56 %make
57
58 %check
59 %if %docheck
60 # (Abel) reqd2.test tries to make sure automake won't work if ltmain.sh
61 # is not present. But automake behavior changed, now it can handle missing
62 # libtool file as well, so this test is bogus.
63 sed -e 's!t/reqd2.sh!!g' Makefile
64 make check # VERBOSE=1
65 %endif
66
67 %install
68 rm -rf %{buildroot}
69 %makeinstall_std
70
71 # provide -1.8 symlinks
72 ln -s automake-%{amversion} %{buildroot}%{_bindir}/automake-1.8
73 ln -s aclocal-%{amversion} %{buildroot}%{_bindir}/aclocal-1.8
74
75 # provide -1.9 symlinks
76 ln -s automake-%{amversion} %{buildroot}%{_bindir}/automake-1.9
77 ln -s aclocal-%{amversion} %{buildroot}%{_bindir}/aclocal-1.9
78
79 rm -f %{buildroot}/%{_infodir}/*
80 install -m 644 doc/%{name}.info* %{buildroot}/%{_infodir}/
81
82 mkdir -p %{buildroot}%{_datadir}/aclocal
83
84 %pre
85 if [ "$1" = 1 ]; then
86 update-alternatives --remove automake %{_bindir}/automake-1.8
87 update-alternatives --remove automake %{_bindir}/automake-1.9
88 fi
89
90 %post
91 %_install_info %name.info
92
93 %preun
94 %_remove_install_info %name.info
95
96 %files
97 %doc AUTHORS ChangeLog NEWS README THANKS
98 %{_bindir}/automake
99 %{_bindir}/aclocal
100 %{_bindir}/automake-%{amversion}
101 %{_bindir}/aclocal-%{amversion}
102 %{_bindir}/automake-1.8
103 %{_bindir}/aclocal-1.8
104 %{_bindir}/automake-1.9
105 %{_bindir}/aclocal-1.9
106 %{_datadir}/automake*
107 %{_infodir}/automake*
108 %{_datadir}/aclocal*
109 %{_mandir}/man1/*

  ViewVC Help
Powered by ViewVC 1.1.30