1 |
%define rname autoscan-network |
2 |
|
3 |
Summary: Utility for network exploration (Samba,Nessus client) |
4 |
Name: autoscan |
5 |
Version: 1.50 |
6 |
Release: %mkrel 17 |
7 |
License: GPLv2+ |
8 |
Group: Networking/Other |
9 |
URL: http://autoscan-network.com/ |
10 |
Source0: http://autoscan.fr/download_files/autoscan-network-%{version}.tar.gz |
11 |
Source1: autoscan-network.init |
12 |
# this .xml file is missing in the tarball, and the GUI doesn't load without it |
13 |
# mdv bug #58012 |
14 |
Source2: Finger_Printing.xml |
15 |
Patch0: autoscan-1.41-x86_64-build-fix.patch |
16 |
Patch1: autoscan-1.50-fix-str-fmt.patch |
17 |
Patch2: autoscan-network-1.50-mandriva-build-options.patch |
18 |
Patch3: autoscan-network-1.50-fix-build-issue.patch |
19 |
Patch4: autoscan-network-1.50-fix-arm-build.patch |
20 |
Patch5: autoscan-network-1.50-aarch64.patch |
21 |
BuildRequires: pkgconfig(libgnomeui-2.0) |
22 |
BuildRequires: pkgconfig(libxml-2.0) |
23 |
BuildRequires: pkgconfig(openssl) |
24 |
BuildRequires: pkgconfig(ao) |
25 |
BuildRequires: pkgconfig(vorbis) |
26 |
BuildRequires: net-snmp-devel |
27 |
BuildRequires: libtool |
28 |
BuildRequires: elfutils-devel |
29 |
BuildRequires: gtk+2-devel |
30 |
BuildRequires: pkgconfig(gtk-vnc-1.0) |
31 |
BuildRequires: pkgconfig(gnome-keyring-1) |
32 |
BuildRequires: gnome-vfs2-devel |
33 |
BuildRequires: glib2-devel |
34 |
BuildRequires: pkgconfig(vte) |
35 |
BuildRequires: desktop-file-utils |
36 |
BuildRequires: pkgconfig(libcurl) |
37 |
BuildRequires: pcap-devel |
38 |
Requires: webclient |
39 |
Requires: %{name}-agent |
40 |
|
41 |
%description |
42 |
AutoScan is an application designed to explore and to manage your network. |
43 |
Entire subnets can be scanned simultaneously without human intervention. |
44 |
It features OS detection, automatic network discovery, a port scanner, |
45 |
and the ability to save the network state. |
46 |
|
47 |
%package agent |
48 |
Summary: AutoScan daemon |
49 |
Group: Networking/Other |
50 |
Provides: %{name} = %{version}-%{release} |
51 |
|
52 |
%description agent |
53 |
Scans network in the background |
54 |
|
55 |
%prep |
56 |
%setup -q -n %{rname}-%{version} |
57 |
%patch0 -p0 |
58 |
%patch1 -p0 |
59 |
%patch2 -p1 |
60 |
%patch3 -p1 |
61 |
%patch4 -p1 |
62 |
%patch5 -p1 |
63 |
|
64 |
install -m 644 %{SOURCE2} usr/share/apps/autoscan-network |
65 |
|
66 |
%build |
67 |
./configure --distrib-mandriva |
68 |
%make OPTIONS_COMPILE="%optflags %ldflags" |
69 |
|
70 |
%install |
71 |
# Daemon install |
72 |
install -d %{buildroot}%{_sbindir}/ |
73 |
install -d %{buildroot}%{_initrddir}/ |
74 |
install -m755 bin/autoscan-network-daemon %{buildroot}%{_sbindir}/ |
75 |
install -m755 %{SOURCE1} %{buildroot}%{_initrddir}/autoscan-network |
76 |
|
77 |
# Gui install |
78 |
install -d %{buildroot}%{_datadir}/apps/%{rname} |
79 |
install -d %{buildroot}%{_datadir}/pixmaps/%{rname} |
80 |
install -d %{buildroot}%{_datadir}/sounds/%{rname} |
81 |
install -d %{buildroot}%{_bindir} |
82 |
install -d %{buildroot}%{_iconsdir} |
83 |
install -d %{buildroot}%{_datadir}/applications/ |
84 |
|
85 |
install -m755 bin/autoscan-network %{buildroot}%{_bindir}/ |
86 |
|
87 |
desktop-file-install --vendor="" \ |
88 |
--remove-category="Application" \ |
89 |
--remove-key='Encoding' --remove-key='MultipleArgs' \ |
90 |
--dir %{buildroot}%{_datadir}/applications usr/share/applications/*.desktop |
91 |
|
92 |
install -m644 usr/share/icons/autoscan-network.png %{buildroot}%{_iconsdir} |
93 |
cp -r usr/share/pixmaps/autoscan-network/* %{buildroot}%{_datadir}/pixmaps/%{rname}/ |
94 |
|
95 |
install -m644 usr/share/apps/autoscan-network/* %buildroot%_datadir/apps/%{rname} |
96 |
install -m 644 usr/share/sounds/autoscan-network/* %{buildroot}%{_datadir}/sounds/%{rname}/ |
97 |
|
98 |
%preun |
99 |
%preun_uninstall_gconf_schemas %{name} |
100 |
|
101 |
%post agent |
102 |
%_post_service %{name}-network |
103 |
|
104 |
%postun agent |
105 |
%_preun_service %{name}-network |
106 |
|
107 |
%files |
108 |
%defattr(755,root,root) |
109 |
%doc AUTHORS |
110 |
%{_bindir}/* |
111 |
%{_datadir}/apps/%{rname} |
112 |
%{_datadir}/pixmaps/%{rname} |
113 |
%{_iconsdir}/* |
114 |
%{_datadir}/sounds/%{rname}/* |
115 |
%{_datadir}/applications/*.desktop |
116 |
|
117 |
%files agent |
118 |
%defattr(755,root,root) |
119 |
%{_sbindir}/* |
120 |
%{_initrddir}/* |
121 |
|
122 |
|