/[packages]/cauldron/avahi/current/SPECS/avahi.spec
ViewVC logotype

Contents of /cauldron/avahi/current/SPECS/avahi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2028914 - (show annotations) (download)
Mon Jan 8 09:37:22 2024 UTC (3 months, 2 weeks ago) by ns80
File size: 21401 byte(s)
- add patches from Ubuntu for CVE-2023-38469, CVE-2023-3847[0-3] (mga#32363)

1 %define gir_major 0.6
2 %define gir_name %mklibname %{name}-gir %{gir_major}
3 %define gir_core_name %mklibname %{name}core-gir %{gir_major}
4
5 %define event_major 1
6 %define event_name %{name}-libevent
7 %define lib_event_name %mklibname %{event_name} %{event_major}
8 %define develnameevent %mklibname -d %event_name
9
10 %define client_major 3
11 %define client_name %{name}-client
12 %define lib_client_name %mklibname %{client_name} %{client_major}
13 %define develnameclient %mklibname -d %client_name
14
15 %define common_major 3
16 %define common_name %{name}-common
17 %define lib_common_name %mklibname %{common_name} %{common_major}
18 %define develnamecommon %mklibname -d %common_name
19
20 # If avahi_core_major changes, make sure to update avahi-gir-fixup.patch
21 %define core_major 7
22 %define core_name %{name}-core
23 %define lib_core_name %mklibname %{core_name} %{core_major}
24 %define develnamecore %mklibname -d %core_name
25
26 %define dns_sd_major 1
27 %define dns_sd_name %{name}-compat-libdns_sd
28 %define lib_dns_sd_name %mklibname %{dns_sd_name} %{dns_sd_major}
29 %define develnamedns_sd %mklibname -d %dns_sd_name
30
31 %define glib_major 1
32 %define glib_name %{name}-glib
33 %define lib_glib_name %mklibname %{glib_name} %{glib_major}
34 %define develnameglib %mklibname -d %glib_name
35
36 %define gobject_major 0
37 %define gobject_name %{name}-gobject
38 %define lib_gobject_name %mklibname %{gobject_name} %{gobject_major}
39 %define develnamegobject %mklibname -d %gobject_name
40
41 %define howl_major 0
42 %define howl_name %{name}-compat-howl
43 %define lib_howl_name %mklibname %{howl_name} %{howl_major}
44 %define develnamehowl %mklibname -d %howl_name
45
46 %define qt5_major 1
47 %define qt5_name %{name}-qt5
48 %define lib_qt5_name %mklibname %{qt5_name}_ %{qt5_major}
49 %define develnameqt5 %mklibname -d %qt5_name
50
51 %define gtk3_major 0
52 %define gtk3_name %{name}-ui-gtk3
53 %define lib_gtk3_name %mklibname %{gtk3_name}_ %{gtk3_major}
54 %define develnamegtk3 %mklibname -d %gtk3_name
55
56 %define ui_major 0
57 %define ui_name %{name}-ui
58 %define lib_ui_name %mklibname %{ui_name} %{ui_major}
59 %define develnameui %mklibname -d %ui_name
60
61 %bcond_with bootstrap
62
63 %if %{without bootstrap}
64 %ifarch %arm %mips
65 %bcond_with mono
66 %else
67 %bcond_without mono
68 %endif
69 %bcond_without qt5
70 %bcond_without gtk3
71 %endif
72 %bcond_with python2
73
74 Name: avahi
75 Version: 0.8
76 Release: %mkrel 11
77 Summary: Avahi service discovery (mDNS/DNS-SD) suite
78 License: LGPLv2+
79 Group: System/Servers
80 Url: https://avahi.org/
81 Source0: https://github.com/lathiat/avahi/releases/download/v%{version}/%{name}-%{version}.tar.gz
82 Source1: avahi-hostname.sh
83 Patch0: avahi-0.6.31-automake-subdir-objects.patch
84 ## upstream patches
85 Patch6: 0006-avahi-dnsconfd.service-Drop-Also-avahi-daemon.socket.patch
86 Patch7: 0007-man-add-missing-bshell.1-symlink.patch
87 Patch8: 0008-Ship-avahi-discover-1-bssh-1-and-bvnc-1-also-for-GTK.patch
88 Patch9: 0009-fix-requires-in-pc-file.patch
89 Patch10: 0010-fix-bytestring-decoding-for-proper-display.patch
90 Patch11: 0011-avahi_dns_packet_consume_uint32-fix-potential-undefi.patch
91 Patch12: CVE-2021-3468.patch
92 Patch13: CVE-2021-3502.patch
93 Patch14: 0017-Emit-error-if-requested-service-is-not-found.patch
94 Patch15: CVE-2023-38469-1.patch
95 Patch16: CVE-2023-38469-2.patch
96 Patch17: CVE-2023-38470-1.patch
97 Patch18: CVE-2023-38470-2.patch
98 Patch19: CVE-2023-38471-1.patch
99 Patch20: CVE-2023-38471-2.patch
100 Patch21: CVE-2023-38472.patch
101 Patch22: CVE-2023-38473.patch
102 BuildRequires: xmltoman
103 BuildRequires: pkgconfig(libdaemon)
104 BuildRequires: pkgconfig(dbus-1)
105 BuildRequires: pkgconfig(libevent)
106 BuildRequires: pkgconfig(expat) >= 2.0.1
107 BuildRequires: libgdbm-devel
108 BuildRequires: pkgconfig(libglade-2.0)
109 %if %{with python2}
110 BuildRequires: pygtk2.0
111 BuildRequires: python2-dbus
112 %endif
113 BuildRequires: pkgconfig(libcap)
114 #needed by autoreconf
115 BuildRequires: intltool
116 %if %{with qt5}
117 BuildRequires: pkgconfig(Qt5Gui)
118 BuildRequires: pkgconfig(Qt5Widgets)
119 %endif
120 %if %{with gtk3}
121 BuildRequires: pkgconfig(gtk+-3.0)
122 %endif
123 BuildRequires: systemd-units
124 BuildRequires: pkgconfig(libsystemd)
125 BuildRequires: pkgconfig(gobject-introspection-1.0)
126 Requires(post): rpm-helper >= 0.24.8-1
127 Requires(preun):rpm-helper >= 0.24.8-1
128 Requires(post): dbus
129 Requires(preun):dbus
130 Recommends: nss_mdns
131
132 %if ! %{with python2}
133 Obsoletes: avahi-python < %{version}-%{release}
134 %endif
135
136 %description
137 Avahi is a system which facilitates service discovery on a local
138 network -- this means that you can plug your laptop or computer into a
139 network and instantly be able to view other people who you can chat
140 with, find printers to print to or find files being shared. This kind
141 of technology is already found in MacOS X (branded 'Rendezvous',
142 'Bonjour' and sometimes 'ZeroConf') and is very convenient.
143
144 %package dnsconfd
145 Group: System/Servers
146 Summary: Avahi DNS configuration server
147 Requires: %{name} = %{version}
148 Requires(post): rpm-helper >= 0.24.8-1
149 Requires(preun): rpm-helper >= 0.24.8-1
150 Conflicts: avahi < 0.6.31-3
151
152 %description dnsconfd
153 avahi-dnsconfd is a small daemon which may be used to configure
154 conventional DNS servers using mDNS in a DHCP-like fashion.
155 Especially useful on IPv6.
156
157 %package x11
158 Group: System/Servers
159 Summary: Graphical tools for Avahi
160 Requires: %{name} = %{version}
161
162 %description x11
163 Graphical tools for Avahi.
164 It includes avahi-discover-standalone.
165
166 %if %{with python2}
167 %package python
168 Group: System/Libraries
169 Summary: Python bindings and utilities for Avahi
170 BuildRequires: pkgconfig(pygobject-3.0)
171 Requires: pygtk2.0-libglade
172 Requires: python2-twisted-core
173 Requires: python2-twisted-web
174 Requires: python2-dbus
175 Requires: avahi
176 Requires: %{name}-x11
177
178 %description python
179 Python bindings and utilities for Avahi.
180 It includes avahi-bookmarks and avahi-discover.
181 %endif
182
183 %if %{with mono}
184 %package sharp
185 Group: System/Libraries
186 Summary: Mono bindings for Avahi
187 BuildRequires: pkgconfig(mono)
188 BuildRequires: pkgconfig(monodoc)
189 BuildRequires: mono-tools
190 #gw this is needed by mono-find-requires:
191 # BuildRequires: pkgconfig(avahi-ui)
192 Requires: %lib_client_name = %version
193 Requires: %lib_common_name = %version
194 Requires: %lib_glib_name = %version
195
196 %description sharp
197 Mono bindings for Avahi.
198
199 %package sharp-doc
200 Summary: Development documentation for avahi-sharp
201 Group: Development/Other
202 Requires(post): mono-tools >= 1.1.9
203 Requires(postun): mono-tools >= 1.1.9
204
205 %description sharp-doc
206 This package contains the API documentation for the avahi-sharp in
207 Monodoc format.
208 %endif
209
210 %package -n %{lib_client_name}
211 Group: System/Libraries
212 Summary: Library for avahi-client
213 # (eatdirt) see mga#13542
214 #Requires: #{name} >= #{version}
215
216 %description -n %{lib_client_name}
217 Library for avahi-client.
218
219 %package -n %develnameclient
220 Group: Development/C
221 Summary: Devel library for avahi-client
222 Provides: %{client_name}-devel = %{version}-%{release}
223 Provides: lib%{client_name}-devel = %{version}-%{release}
224 Requires: %{lib_client_name} = %{version}
225
226 %description -n %develnameclient
227 Devel library for avahi-client.
228
229 %package -n %{lib_event_name}
230 Group: System/Libraries
231 Summary: Library for avahi-event
232 # (eatdirt) see mga#13542
233 #Requires: #{name} >= #{version}
234
235 %description -n %{lib_event_name}
236 Library for avahi-event.
237
238 %package -n %develnameevent
239 Group: Development/C
240 Summary: Devel library for avahi-event
241 Provides: %{event_name}-devel = %{version}-%{release}
242 Provides: lib%{event_name}-devel = %{version}-%{release}
243 Requires: %{lib_event_name} = %{version}
244
245 %description -n %develnameevent
246 Devel library for avahi-event.
247
248 %package -n %{lib_common_name}
249 Group: System/Libraries
250 Summary: Library for avahi-common
251
252 %description -n %{lib_common_name}
253 Library for avahi-common.
254
255 %package -n %develnamecommon
256 Group: Development/C
257 Summary: Devel library for avahi-common
258 Provides: %{common_name}-devel = %{version}-%{release}
259 Provides: lib%{common_name}-devel = %{version}-%{release}
260 Requires: %{lib_common_name} = %{version}
261
262 %description -n %develnamecommon
263 Devel library for avahi-common.
264
265 %package -n %{lib_core_name}
266 Group: System/Libraries
267 Summary: Library for avahi-core
268
269 %description -n %{lib_core_name}
270 Library for avahi-core.
271
272 %package -n %develnamecore
273 Group: Development/C
274 Summary: Devel library for avahi-core
275 Provides: %{core_name}-devel = %{version}-%{release}
276 Provides: lib%{core_name}-devel = %{version}-%{release}
277 Requires: %{lib_core_name} = %{version}
278 Requires: %{gir_core_name} = %{version}
279
280 %description -n %develnamecore
281 Devel library for avahi-core.
282
283 %package -n %{lib_dns_sd_name}
284 Group: System/Libraries
285 Summary: Avahi compatibility library for libdns_sd
286
287 %description -n %{lib_dns_sd_name}
288 Avahi compatibility library for libdns_sd
289
290 %package -n %develnamedns_sd
291 Group: Development/C
292 Summary: Avahi devel compatibility library for libdns_sd
293 Provides: %{dns_sd_name}-devel = %{version}-%{release}
294 Provides: lib%{dns_sd_name}-devel = %{version}-%{release}
295 Requires: %{lib_dns_sd_name} = %{version}
296
297 %description -n %develnamedns_sd
298 Avahi devel compatibility library for libdns_sd.
299
300 %package -n %{lib_glib_name}
301 Group: System/Libraries
302 Summary: Library for avahi-glib
303
304 %description -n %{lib_glib_name}
305 Library for avahi-glib.
306
307 %package -n %develnameglib
308 Group: Development/C
309 Summary: Devel library for avahi-glib
310 Provides: %{glib_name}-devel = %{version}-%{release}
311 Provides: lib%{glib_name}-devel = %{version}-%{release}
312 Requires: %{lib_glib_name} = %{version}
313
314 %description -n %develnameglib
315 Devel library for avahi-glib.
316
317 %package -n %{lib_gobject_name}
318 Group: System/Libraries
319 Summary: Library for avahi-gobject
320
321 %description -n %{lib_gobject_name}
322 Library for avahi-gobject.
323
324 %package -n %develnamegobject
325 Group: Development/C
326 Summary: Devel library for avahi-gobject
327 Provides: %{gobject_name}-devel = %{version}-%{release}
328 Provides: lib%{gobject_name}-devel = %{version}-%{release}
329 Requires: %{lib_gobject_name} = %{version}
330 Requires: %{gir_name} = %{version}
331
332 %description -n %develnamegobject
333 Devel library for avahi-gobject.
334
335 %package -n %{lib_howl_name}
336 Group: System/Libraries
337 Summary: Avahi compatibility library for howl
338
339 %description -n %{lib_howl_name}
340 Avahi compatibility library for howl.
341
342 %package -n %develnamehowl
343 Group: Development/C
344 Summary: Avahi devel compatibility library for libdns_sd for howl
345 Provides: %{howl_name}-devel = %{version}-%{release}
346 Provides: lib%{howl_name}-devel = %{version}-%{release}
347 Provides: howl-devel = %{version}-%{release}
348 Provides: libhowl-devel = %{version}-%{release}
349 Requires: %{lib_howl_name} = %{version}
350
351 %description -n %develnamehowl
352 Avahi devel compatibility library for libdns_sd for howl.
353
354 %if %{with qt5}
355 %package -n %{lib_qt5_name}
356 Group: System/Libraries
357 Summary: Library for avahi-qt5
358
359 %description -n %{lib_qt5_name}
360 Library for avahi-qt5.
361
362 %package -n %develnameqt5
363 Group: Development/C
364 Summary: Devel library for avahi-qt5
365 Provides: %{qt5_name}-devel = %{version}-%{release}
366 Provides: lib%{qt5_name}-devel = %{version}-%{release}
367 Requires: %{lib_qt5_name} = %{version}
368
369 %description -n %develnameqt5
370 Devel library for avahi-qt5.
371 %endif
372
373 %if %{with gtk3}
374 %package -n %{lib_gtk3_name}
375 Group: System/Libraries
376 Summary: Library for avahi-gtk3
377
378 %description -n %{lib_gtk3_name}
379 Library for avahi-gtk3.
380
381 %package -n %develnamegtk3
382 Group: Development/C
383 Summary: Devel library for avahi-gtk3
384 Provides: %{gtk3_name}-devel = %{version}-%{release}
385 Provides: lib%{gtk3_name}-devel = %{version}-%{release}
386 Requires: %{lib_gtk3_name} = %{version}
387
388 %description -n %develnamegtk3
389 Devel library for avahi-gtk3.
390 %endif
391
392 %package -n %{gir_core_name}
393 Summary: GObject Introspection interface description for AvahiCore
394 Group: System/Libraries
395 Requires: %{lib_core_name} = %{version}-%{release}
396
397 %description -n %{gir_core_name}
398 GObject Introspection interface description for AvahiCore.
399
400 %package -n %{gir_name}
401 Summary: GObject Introspection interface description for Avahi
402 Group: System/Libraries
403 Requires: %{lib_gobject_name} = %{version}-%{release}
404
405 %description -n %{gir_name}
406 GObject Introspection interface description for Avahi.
407
408 %prep
409 %setup -q
410 %autopatch -p1
411 cp %{SOURCE1} avahi-hostname.sh
412
413 %build
414 autoreconf -vfi
415 export PKG_CONFIG_PATH=/usr/lib/qt5/%{_lib}/pkgconfig
416 %configure \
417 --disable-static \
418 %if %{without mono}
419 --disable-mono \
420 %endif
421 %if %{without qt5}
422 --disable-qt5 \
423 %endif
424 %if ! %{with python2}
425 --disable-python \
426 %endif
427 --localstatedir=%{_var} \
428 --with-avahi-priv-access-group="avahi" \
429 --enable-compat-libdns_sd \
430 --enable-compat-howl \
431 --enable-introspection=yes \
432 %if %{without gtk3}
433 --disable-gtk3 \
434 %endif
435 --disable-qt3
436
437 %make_build
438
439 %install
440 %make_install
441
442 ln -s avahi-compat-howl.pc %buildroot%_libdir/pkgconfig/howl.pc
443 ln -s avahi-compat-libdns_sd.pc %buildroot%_libdir/pkgconfig/libdns_sd.pc
444
445 %if "%_lib" != "lib" && 0%{?with_mono:1}
446 mkdir -p %buildroot%_prefix/lib
447 mv %buildroot%_libdir/mono %buildroot%_prefix/lib
448 perl -pi -e "s/%_lib/lib/" %buildroot%_libdir/pkgconfig/avahi-{,ui-}sharp.pc
449 %endif
450
451 # install hostname.d hook
452 mkdir -p %{buildroot}/%{_sysconfdir}/sysconfig/network-scripts/hostname.d/
453 install -m755 avahi-hostname.sh %{buildroot}/%{_sysconfdir}/sysconfig/network-scripts/hostname.d/avahi
454
455 %find_lang avahi
456
457 #we don't want these
458 find %{buildroot} -name "*.la" -delete
459
460 # remove example
461 # see : https://bugs.mageia.org/show_bug.cgi?id=3419
462 rm -f %{buildroot}%{_sysconfdir}/avahi/services/sftp-ssh.service
463
464 mkdir -p %{buildroot}%{_localstatedir}/avahi
465
466 rm -f %{buildroot}%{_initrddir}/%{name}-daemon
467 rm -f %{buildroot}%{_initrddir}/%{name}-dnsconfd
468
469 %pre
470 %_pre_useradd %{name} %{_var}/run/%{name}-daemon /bin/false
471 %_pre_useradd %{name}-autoipd %{_var}/lib/%{name}-autoipd /bin/false
472 # Correct home directories if users already exists (mga#10004)
473 if [ "`grep -E '^%{name}:' < /etc/passwd | cut -f6 -d:`" = %{_var}/avahi ]; then
474 %{_sbindir}/usermod -d %{_var}/run/%{name}-daemon %{name}
475 fi
476 if [ "`grep -E '^%{name}-autoipd:' < /etc/passwd | cut -f6 -d:`" = %{_var}/avahi ]; then
477 %{_sbindir}/usermod -d %{_var}/lib/%{name}-autoipd %{name}-autoipd
478 fi
479
480 %postun
481 # Note postun_userdel is a dummy script. It does not do anything!
482 %_postun_userdel %{name}
483 %_postun_userdel %{name}-autoipd
484
485 %post
486 %_post_service %{name}-daemon
487
488 %preun
489 %_preun_service %{name}-daemon
490
491 %post dnsconfd
492 %_post_service %{name}-dnsconfd
493
494 %preun dnsconfd
495 %_preun_service %{name}-dnsconfd
496
497 %if %{with mono}
498 %post sharp-doc
499 %_bindir/monodoc --make-index > /dev/null
500
501 %postun sharp-doc
502 if [ "$1" = "0" -a -x %_bindir/monodoc ]; then %_bindir/monodoc --make-index > /dev/null
503 fi
504 %endif
505
506 %files -f avahi.lang
507 %dir %{_sysconfdir}/%{name}/
508 %dir %{_sysconfdir}/%{name}/services/
509 %config(noreplace) %{_sysconfdir}/%{name}/hosts
510 %config(noreplace) %{_sysconfdir}/%{name}/%{name}-daemon.conf
511 %config(noreplace) %{_sysconfdir}/%{name}/avahi-autoipd.action
512 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/%{name}-dbus.conf
513 %config(noreplace) %{_sysconfdir}/%{name}/services/ssh.service
514 %attr(0755,avahi,avahi) %dir %{_localstatedir}/avahi
515 %{_sysconfdir}/sysconfig/network-scripts/hostname.d/avahi
516 %{_bindir}/%{name}-browse
517 %{_bindir}/%{name}-browse-domains
518 %{_bindir}/%{name}-publish
519 %{_bindir}/%{name}-publish-address
520 %{_bindir}/%{name}-publish-service
521 %{_bindir}/%{name}-resolve
522 %{_bindir}/%{name}-resolve-address
523 %{_bindir}/%{name}-resolve-host-name
524 %{_bindir}/%{name}-set-host-name
525 %{_sbindir}/%{name}-daemon
526 %{_sbindir}/avahi-autoipd
527 %{_datadir}/%{name}/%{name}-service.dtd
528 %{_datadir}/dbus-1/interfaces/*.xml
529 #%%{_datadir}/%%{name}/introspection/AddressResolver.introspect
530 #%%{_datadir}/%%{name}/introspection/DomainBrowser.introspect
531 #%%{_datadir}/%%{name}/introspection/EntryGroup.introspect
532 #%%{_datadir}/%%{name}/introspection/HostNameResolver.introspect
533 #%%{_datadir}/%%{name}/introspection/RecordBrowser.introspect
534 #%%{_datadir}/%%{name}/introspection/Server.introspect
535 #%%{_datadir}/%%{name}/introspection/ServiceBrowser.introspect
536 #%%{_datadir}/%%{name}/introspection/ServiceResolver.introspect
537 #%%{_datadir}/%%{name}/introspection/ServiceTypeBrowser.introspect
538 #%%{_datadir}/%%{name}/service-types
539 %{_mandir}/man1/%{name}-browse-domains.1*
540 %{_mandir}/man1/%{name}-browse.1*
541 %{_mandir}/man1/%{name}-publish.1*
542 %{_mandir}/man1/%{name}-publish-address.1*
543 %{_mandir}/man1/%{name}-publish-service.1*
544 %{_mandir}/man1/%{name}-resolve.1*
545 %{_mandir}/man1/%{name}-resolve-address.1*
546 %{_mandir}/man1/%{name}-resolve-host-name.1*
547 %{_mandir}/man1/%{name}-set-host-name.1*
548 %{_mandir}/man5/%{name}-daemon.conf.5*
549 %{_mandir}/man5/%{name}.hosts.5*
550 %{_mandir}/man5/%{name}.service.5*
551 %{_mandir}/man8/%{name}-daemon.8*
552 %{_mandir}/man8/avahi-autoipd*
553 %dir %{_datadir}/%{name}
554 %{_unitdir}/avahi-daemon.service
555 %{_unitdir}/avahi-daemon.socket
556 %{_datadir}/dbus-1/system-services/org.freedesktop.Avahi.service
557 %if %{with python2}
558 %{_libdir}/avahi/service-types.db
559 %endif
560
561 %files dnsconfd
562 %{_sysconfdir}/%{name}/%{name}-dnsconfd.action
563 %{_sbindir}/%{name}-dnsconfd
564 %{_mandir}/man8/%{name}-dnsconfd.8*
565 %{_mandir}/man8/%{name}-dnsconfd.action.8*
566 %{_unitdir}/avahi-dnsconfd.service
567
568 %files x11
569 %{_bindir}/%{name}-discover-standalone
570 %{_bindir}/bshell
571 %{_bindir}/bssh
572 %{_bindir}/bvnc
573 %{_datadir}/applications/bssh.desktop
574 %{_datadir}/applications/bvnc.desktop
575 %{_datadir}/%{name}/interfaces/%{name}-discover.ui
576 %{_mandir}/man1/bshell.1*
577 %{_mandir}/man1/bssh.1*
578 %{_mandir}/man1/bvnc.1*
579
580 %if %{with python2}
581 %files python
582 %{_bindir}/%{name}-bookmarks
583 %{_bindir}/%{name}-discover
584 %{_datadir}/applications/%{name}-discover.desktop
585 %{python2_sitelib}/%{name}/
586 %{python2_sitelib}/avahi_discover/
587 %{_mandir}/man1/%{name}-discover.1*
588 %{_mandir}/man1/%{name}-bookmarks.1*
589 %endif
590
591 %if %{with mono}
592 %files sharp
593 %{_prefix}/lib/mono/%{name}-sharp/%{name}-sharp.dll
594 %{_prefix}/lib/mono/gac/%{name}-sharp/
595 %{_libdir}/pkgconfig/%{name}-sharp.pc
596 %{_libdir}/pkgconfig/%{name}-ui-sharp.pc
597
598 %files sharp-doc
599 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.source
600 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.tree
601 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.zip
602 %endif
603
604 %files -n %{lib_client_name}
605 %{_libdir}/lib%{name}-client.so.%{client_major}{,.*}
606
607 %files -n %{lib_event_name}
608 %{_libdir}/lib%{name}-libevent.so.%{event_major}{,.*}
609
610 %files -n %{lib_common_name}
611 %{_libdir}/lib%{name}-common.so.%{common_major}{,.*}
612
613 %files -n %{lib_core_name}
614 %{_libdir}/lib%{name}-core.so.%{core_major}{,.*}
615
616 %files -n %{lib_dns_sd_name}
617 %{_libdir}/libdns_sd.so.%{dns_sd_major}{,.*}
618
619 %files -n %{lib_glib_name}
620 %{_libdir}/lib%{name}-glib.so.%{glib_major}{,.*}
621
622 %files -n %{lib_gobject_name}
623 %{_libdir}/lib%{name}-gobject.so.%{gobject_major}{,.*}
624
625 %files -n %{lib_howl_name}
626 %{_libdir}/libhowl.so.%{howl_major}{,.*}
627
628 %if %{with qt5}
629 %files -n %{lib_qt5_name}
630 %{_libdir}/lib%{name}-qt5.so.%{qt5_major}{,.*}
631 %endif
632
633 %if %{with gtk3}
634 %files -n %{lib_gtk3_name}
635 %{_libdir}/lib%{name}-ui-gtk3.so.%{gtk3_major}{,.*}
636 %endif
637
638 %files -n %develnameclient
639 %{_includedir}/%{name}-client
640 %{_libdir}/lib%{name}-client.so
641 %{_libdir}/pkgconfig/%{name}-client.pc
642
643 %files -n %develnameevent
644 %{_includedir}/%{name}-libevent
645 %{_libdir}/lib%{name}-libevent.so
646 %{_libdir}/pkgconfig/%{name}-libevent.pc
647
648 %files -n %develnamecommon
649 %{_includedir}/%{name}-common
650 %{_libdir}/lib%{name}-common.so
651
652 %files -n %develnamecore
653 %{_includedir}/%{name}-core
654 %{_libdir}/lib%{name}-core.so
655 %{_libdir}/pkgconfig/%{name}-core.pc
656 %{_datadir}/gir-1.0/AvahiCore-%{gir_major}.gir
657
658 %files -n %develnamedns_sd
659 %{_includedir}/%{name}-compat-libdns_sd
660 %{_libdir}/libdns_sd.so
661 %{_libdir}/pkgconfig/%{name}-compat-libdns_sd.pc
662 %{_libdir}/pkgconfig/libdns_sd.pc
663
664 %files -n %develnameglib
665 %{_includedir}/%{name}-glib
666 %{_libdir}/lib%{name}-glib.so
667 %{_libdir}/pkgconfig/%{name}-glib.pc
668
669 %files -n %develnamegobject
670 %{_includedir}/%{name}-gobject
671 %{_libdir}/lib%{name}-gobject.so
672 %{_libdir}/pkgconfig/%{name}-gobject.pc
673 %{_datadir}/gir-1.0/Avahi-%{gir_major}.gir
674
675 %files -n %develnamehowl
676 %{_includedir}/%{name}-compat-howl
677 %{_libdir}/libhowl.so
678 %{_libdir}/pkgconfig/%{name}-compat-howl.pc
679 %{_libdir}/pkgconfig/howl.pc
680
681 %if %{with qt5}
682 %files -n %develnameqt5
683 %{_includedir}/%{name}-qt5
684 %{_libdir}/lib%{name}-qt5.so
685 %{_libdir}/pkgconfig/%{name}-qt5.pc
686 %endif
687
688 %if %{with gtk3}
689 %files -n %develnamegtk3
690 %{_includedir}/%{name}-ui/
691 %{_libdir}/libavahi-ui-gtk3.so
692 %{_libdir}/pkgconfig/avahi-ui-gtk3.pc
693 %endif
694
695 %files -n %gir_name
696 %{_libdir}/girepository-1.0/Avahi-%{gir_major}.typelib
697
698 %files -n %gir_core_name
699 %{_libdir}/girepository-1.0/AvahiCore-%{gir_major}.typelib

  ViewVC Help
Powered by ViewVC 1.1.30