/[packages]/cauldron/avahi/current/SPECS/avahi.spec
ViewVC logotype

Contents of /cauldron/avahi/current/SPECS/avahi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 18041 - (show annotations) (download)
Fri Jan 14 22:20:32 2011 UTC (13 years, 3 months ago) by dmorgan
File size: 18445 byte(s)
Bump release
1 %define name avahi
2 %define version 0.6.28
3
4 %define release %mkrel 2
5
6 %define client_name %{name}-client
7 %define common_name %{name}-common
8 %define core_name %{name}-core
9 %define dns_sd_name %{name}-compat-libdns_sd
10 %define glib_name %{name}-glib
11 %define gobject_name %name-gobject
12 %define howl_name %{name}-compat-howl
13 %define qt4_name %{name}-qt4
14 %define ui_name %{name}-ui
15
16 %define dns_sd_old_name mDNSResponder
17 %define howl_old_name howl
18
19 %define client_major 3
20 %define common_major 3
21 %define core_major 7
22 %define dns_sd_major 1
23 %define glib_major 1
24 %define gobject_major 0
25 %define howl_major 0
26 %define qt4_major 1
27 %define qt3_major 1
28 %define ui_major 0
29
30 %define lib_client_name %mklibname %{client_name} %{client_major}
31 %define develnameclient %mklibname -d %client_name
32 %define lib_common_name %mklibname %{common_name} %{common_major}
33 %define develnamecommon %mklibname -d %common_name
34 %define lib_core_name %mklibname %{core_name} %{core_major}
35 %define develnamecore %mklibname -d %core_name
36 %define lib_dns_sd_name %mklibname %{dns_sd_name} %{dns_sd_major}
37 %define develnamedns_sd %mklibname -d %dns_sd_name
38 %define lib_glib_name %mklibname %{glib_name} %{glib_major}
39 %define develnameglib %mklibname -d %glib_name
40 %define lib_gobject_name %mklibname %{gobject_name} %{gobject_major}
41 %define develnamegobject %mklibname -d %gobject_name
42 %define lib_howl_name %mklibname %{howl_name} %{howl_major}
43 %define develnamehowl %mklibname -d %howl_name
44 %define lib_qt4_name %mklibname %{qt4_name}_ %{qt4_major}
45 %define develnameqt4 %mklibname -d %qt4_name
46 %define lib_ui_name %mklibname %{ui_name} %{qt3_major}
47 %define develnameui %mklibname -d %ui_name
48
49 %define lib_dns_sd_old_name %mklibname %{dns_sd_old_name} 1
50 %define lib_howl_old_name %mklibname %{howl_old_name} 0
51 %define lib_howl_fake_EVR 1.0.0-7mdk
52
53 %define build_mono 1
54 %{?_with_mono: %{expand: %%global build_mono 1}}
55 %{?_without_mono: %{expand: %%global build_mono 0}}
56
57 %ifarch %arm %mips
58 %define build_mono 0
59 %endif
60
61 %define build_qt4 1
62 %{?_with_qt4: %{expand: %%global build_qt4 1}}
63 %{?_without_qt4: %{expand: %%global build_qt4 0}}
64
65 %define build_bootstrap 0
66 %{?_with_bootstrap: %{expand: %%global build_bootstrap 1}}
67 %if %{build_bootstrap}
68 %define build_mono 0
69 %define build_qt4 0
70 %endif
71
72 Summary: Avahi service discovery (mDNS/DNS-SD) suite
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 Source0: http://avahi.org/download/%{name}-%{version}.tar.gz
77 Source1: avahi-hostname.sh
78 #Patch0: avahi-0.6.25-fix-chroot.patch
79 License: LGPLv2+
80 Group: System/Servers
81 Url: http://avahi.org/
82 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
83 BuildRequires: daemon-devel
84 BuildRequires: dbus-devel
85 BuildRequires: dbus-python
86 BuildRequires: libexpat-devel >= 2.0.1
87 BuildRequires: libgdbm-devel
88 BuildRequires: libglade2.0-devel
89 BuildRequires: pygtk2.0
90 BuildRequires: libcap-devel
91 %if %build_qt4
92 BuildRequires: qt4-devel
93 %endif
94 #needed by autoreconf
95 BuildRequires: intltool
96 Requires(pre): rpm-helper
97 Requires(postun): rpm-helper
98 Requires(post): rpm-helper
99 Requires(preun): rpm-helper
100 Requires(post): dbus
101 Requires(preun): dbus
102 Obsoletes: howl
103 Provides: howl
104 Obsoletes: tmdns
105 Provides: tmdns
106 Obsoletes: mDNSResponder
107 Provides: mDNSResponder
108 Suggests: nss_mdns
109
110 %description
111 Avahi is a system which facilitates service discovery on a local
112 network -- this means that you can plug your laptop or computer into a
113 network and instantly be able to view other people who you can chat
114 with, find printers to print to or find files being shared. This kind
115 of technology is already found in MacOS X (branded 'Rendezvous',
116 'Bonjour' and sometimes 'ZeroConf') and is very convenient.
117
118 %package dnsconfd
119 Group: System/Servers
120 Summary: Avahi DNS configuration server
121 Requires: %{name} = %{version}
122 Requires(post): rpm-helper
123 Requires(preun): rpm-helper
124 %description dnsconfd
125 avahi-dnsconfd is a small daemon which may be used to configure
126 conventional DNS servers using mDNS in a DHCP-like fashion.
127 Especially useful on IPv6.
128
129 %package x11
130 Group: System/Servers
131 Summary: Graphical tools for Avahi
132 Requires: %{name} = %{version}
133 %description x11
134 Graphical tools for Avahi.
135 It includes avahi-discover-standalone.
136
137 %package python
138 Group: System/Libraries
139 Summary: Python bindings and utilities for Avahi
140 Requires: pygtk2.0-libglade python-twisted-core
141 Requires: python-twisted-web dbus-python avahi
142 Requires: %{name}-x11
143 %description python
144 Python bindings and utilities for Avahi.
145 It includes avahi-bookmarks and avahi-discover.
146
147 %if %build_mono
148 %package sharp
149 Group: System/Libraries
150 Summary: Mono bindings for Avahi
151 BuildRequires: mono-devel mono-tools
152 #gw this is needed by mono-find-requires:
153 BuildRequires: avahi-ui-devel
154 Requires: %lib_client_name = %version
155 Requires: %lib_common_name = %version
156 Requires: %lib_glib_name = %version
157
158 %description sharp
159 Mono bindings for Avahi.
160
161 %package sharp-doc
162 Summary: Development documentation for avahi-sharp
163 Group: Development/Other
164 Requires(post): mono-tools >= 1.1.9
165 Requires(postun): mono-tools >= 1.1.9
166
167 %description sharp-doc
168 This package contains the API documentation for the avahi-sharp in
169 Monodoc format.
170 %endif
171
172 %package -n %{lib_client_name}
173 Group: System/Libraries
174 Summary: Library for avahi-client
175 Requires: %{name} >= %{version}
176 %description -n %{lib_client_name}
177 Library for avahi-client.
178
179 %package -n %develnameclient
180 Group: Development/C
181 Summary: Devel library for avahi-client
182 Provides: %{client_name}-devel = %{version}-%{release}
183 Provides: lib%{client_name}-devel = %{version}-%{release}
184 Requires: %{lib_client_name} = %{version}
185 Obsoletes: %mklibname -d %client_name 3
186
187 %description -n %develnameclient
188 Devel library for avahi-client.
189
190 %package -n %{lib_common_name}
191 Group: System/Libraries
192 Summary: Library for avahi-common
193 %description -n %{lib_common_name}
194 Library for avahi-common.
195
196 %package -n %develnamecommon
197 Group: Development/C
198 Summary: Devel library for avahi-common
199 Provides: %{common_name}-devel = %{version}-%{release}
200 Provides: lib%{common_name}-devel = %{version}-%{release}
201 Requires: %{lib_common_name} = %{version}
202 Obsoletes: %mklibname -d %common_name 3
203
204 %description -n %develnamecommon
205 Devel library for avahi-common.
206
207 %package -n %{lib_core_name}
208 Group: System/Libraries
209 Summary: Library for avahi-core
210 %description -n %{lib_core_name}
211 Library for avahi-core.
212
213 %package -n %develnamecore
214 Group: Development/C
215 Summary: Devel library for avahi-core
216 Provides: %{core_name}-devel = %{version}-%{release}
217 Provides: lib%{core_name}-devel = %{version}-%{release}
218 Requires: %{lib_core_name} = %{version}
219 Obsoletes: %mklibname -d %core_name 5
220
221 %description -n %develnamecore
222 Devel library for avahi-core.
223
224 %package -n %{lib_dns_sd_name}
225 Group: System/Libraries
226 Summary: Avahi compatibility library for libdns_sd
227 Obsoletes: %{lib_dns_sd_old_name}
228 Provides: %{lib_dns_sd_old_name}
229 %description -n %{lib_dns_sd_name}
230 Avahi compatibility library for libdns_sd
231
232 %package -n %develnamedns_sd
233 Group: Development/C
234 Summary: Avahi devel compatibility library for libdns_sd
235 Provides: %{dns_sd_name}-devel = %{version}-%{release}
236 Provides: lib%{dns_sd_name}-devel = %{version}-%{release}
237 Requires: %{lib_dns_sd_name} = %{version}
238 Obsoletes: %{lib_dns_sd_old_name}-devel
239 Provides: %{lib_dns_sd_old_name}-devel
240 Provides: %{dns_sd_old_name}-devel = %{version}-%{release}
241 Provides: lib%{dns_sd_old_name}-devel = %{version}-%{release}
242 Obsoletes: %mklibname -d %dns_sd_name 1
243
244 %description -n %develnamedns_sd
245 Avahi devel compatibility library for libdns_sd.
246
247 %package -n %{lib_glib_name}
248 Group: System/Libraries
249 Summary: Library for avahi-glib
250 %description -n %{lib_glib_name}
251 Library for avahi-glib.
252
253 %package -n %develnameglib
254 Group: Development/C
255 Summary: Devel library for avahi-glib
256 Provides: %{glib_name}-devel = %{version}-%{release}
257 Provides: lib%{glib_name}-devel = %{version}-%{release}
258 Requires: %{lib_glib_name} = %{version}
259 Obsoletes: %mklibname -d %glib_name 1
260
261 %description -n %develnameglib
262 Devel library for avahi-glib.
263
264 %package -n %{lib_gobject_name}
265 Group: System/Libraries
266 Summary: Library for avahi-gobject
267 %description -n %{lib_gobject_name}
268 Library for avahi-gobject.
269
270 %package -n %develnamegobject
271 Group: Development/C
272 Summary: Devel library for avahi-gobject
273 Provides: %{gobject_name}-devel = %{version}-%{release}
274 Provides: lib%{gobject_name}-devel = %{version}-%{release}
275 Requires: %{lib_gobject_name} = %{version}
276
277 %description -n %develnamegobject
278 Devel library for avahi-gobject.
279
280 %package -n %{lib_howl_name}
281 Group: System/Libraries
282 Summary: Avahi compatibility library for howl
283 Obsoletes: %{lib_howl_old_name}
284 Provides: %{lib_howl_old_name} = %{lib_howl_fake_EVR}
285 %description -n %{lib_howl_name}
286 Avahi compatibility library for howl.
287
288 %package -n %develnamehowl
289 Group: Development/C
290 Summary: Avahi devel compatibility library for libdns_sd for howl
291 Provides: %{howl_name}-devel = %{version}-%{release}
292 Provides: lib%{howl_name}-devel = %{version}-%{release}
293 Requires: %{lib_howl_name} = %{version}
294 Obsoletes: %{lib_howl_old_name}-devel
295 Provides: %{lib_howl_old_name}-devel = %{lib_howl_fake_EVR}
296 Provides: %{howl_old_name}-devel = %{version}-%{release}
297 Provides: lib%{howl_old_name}-devel = %{version}-%{release}
298 Obsoletes: %mklibname -d %howl_name 0
299
300
301 %description -n %develnamehowl
302 Avahi devel compatibility library for libdns_sd for howl.
303
304 %if %build_qt4
305 %package -n %{lib_qt4_name}
306 Group: System/Libraries
307 Summary: Library for avahi-qt4
308 %description -n %{lib_qt4_name}
309 Library for avahi-qt4.
310
311 %package -n %develnameqt4
312 Group: Development/C
313 Summary: Devel library for avahi-qt4
314 Provides: %{qt4_name}-devel = %{version}-%{release}
315 Provides: lib%{qt4_name}-devel = %{version}-%{release}
316 Requires: %{lib_qt4_name} = %{version}
317 Obsoletes: %mklibname -d %{qt4_name}_ 1
318
319 %description -n %develnameqt4
320 Devel library for avahi-qt4.
321 %endif
322
323 %package -n %{lib_ui_name}
324 Group: System/Libraries
325 Summary: Library for avahi-ui
326 %description -n %{lib_ui_name}
327 Library for avahi-ui.
328
329 %package -n %develnameui
330 Group: Development/C
331 Summary: Devel library for avahi-ui
332 Provides: %{ui_name}-devel = %{version}-%{release}
333 Provides: lib%{ui_name}-devel = %{version}-%{release}
334 Requires: %{lib_ui_name} = %{version}
335 Obsoletes: %mklibname -d %{ui_name} 1
336
337 %description -n %develnameui
338 Devel library for avahi-ui.
339
340 %prep
341 %setup -q
342 #%patch0 -p1 -b fix-chroot
343 cp %{SOURCE1} avahi-hostname.sh
344
345 %build
346 export PKG_CONFIG_PATH=/usr/lib/qt4/%{_lib}/pkgconfig
347 %configure2_5x \
348 %if !%build_mono
349 --disable-mono \
350 %endif
351 %if !%build_qt4
352 --disable-qt4 \
353 %endif
354 --localstatedir=%{_var} \
355 --with-avahi-priv-access-group="avahi" \
356 --enable-compat-libdns_sd \
357 --enable-compat-howl \
358 --enable-introspection=no \
359 --disable-gtk3 \
360 --disable-qt3
361
362 %make
363
364 %install
365 rm -rf %{buildroot}
366 %makeinstall_std
367 rm -f %{buildroot}/%{_sysconfdir}/%{name}/services/ssh.service
368 ln -s avahi-compat-howl.pc %buildroot%_libdir/pkgconfig/howl.pc
369 %if "%_lib" != "lib" && %build_mono
370 mkdir -p %buildroot%_prefix/lib
371 mv %buildroot%_libdir/mono %buildroot%_prefix/lib
372 perl -pi -e "s/%_lib/lib/" %buildroot%_libdir/pkgconfig/avahi-{,ui-}sharp.pc
373 %endif
374
375 # install hostname.d hook
376 mkdir -p %{buildroot}/%{_sysconfdir}/sysconfig/network-scripts/hostname.d/
377 install -m755 avahi-hostname.sh %{buildroot}/%{_sysconfdir}/sysconfig/network-scripts/hostname.d/avahi
378
379 %find_lang avahi
380
381 %clean
382 rm -rf %{buildroot}
383
384 %pre
385 %_pre_useradd %{name} %{_var}/%{name} /bin/false
386 %_pre_useradd %{name}-autoipd %{_var}/%{name} /bin/false
387
388 %postun
389 %_postun_userdel %{name}
390 %_postun_userdel %{name}-autoipd
391
392 %post
393 %_post_service %{name}-daemon
394
395 %preun
396 %_preun_service %{name}-daemon
397
398 %post dnsconfd
399 %_post_service %{name}-dnsconfd
400
401 %preun dnsconfd
402 %_preun_service %{name}-dnsconfd
403
404 %if %build_mono
405 %post sharp-doc
406 %_bindir/monodoc --make-index > /dev/null
407 %postun sharp-doc
408 if [ "$1" = "0" -a -x %_bindir/monodoc ]; then %_bindir/monodoc --make-index > /dev/null
409 fi
410 %endif
411
412 %files -f avahi.lang
413 %defattr(-,root,root)
414 %dir %{_sysconfdir}/%{name}/
415 %dir %{_sysconfdir}/%{name}/services/
416 %config(noreplace) %{_sysconfdir}/%{name}/hosts
417 %config(noreplace) %{_sysconfdir}/%{name}/%{name}-daemon.conf
418 %config(noreplace) %{_sysconfdir}/%{name}/avahi-autoipd.action
419 %config(noreplace) %{_sysconfdir}/%{name}/services/sftp-ssh.service
420 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/%{name}-dbus.conf
421 %{_initrddir}/%{name}-daemon
422 %{_sysconfdir}/sysconfig/network-scripts/hostname.d/avahi
423 %{_bindir}/%{name}-browse
424 %{_bindir}/%{name}-browse-domains
425 %{_bindir}/%{name}-publish
426 %{_bindir}/%{name}-publish-address
427 %{_bindir}/%{name}-publish-service
428 %{_bindir}/%{name}-resolve
429 %{_bindir}/%{name}-resolve-address
430 %{_bindir}/%{name}-resolve-host-name
431 %{_bindir}/%{name}-set-host-name
432 %{_sbindir}/%{name}-daemon
433 %{_sbindir}/avahi-autoipd
434 %{_datadir}/%{name}/%{name}-service.dtd
435 %{_datadir}/dbus-1/interfaces/*.xml
436 #%{_datadir}/%{name}/introspection/AddressResolver.introspect
437 #%{_datadir}/%{name}/introspection/DomainBrowser.introspect
438 #%{_datadir}/%{name}/introspection/EntryGroup.introspect
439 #%{_datadir}/%{name}/introspection/HostNameResolver.introspect
440 #%{_datadir}/%{name}/introspection/RecordBrowser.introspect
441 #%{_datadir}/%{name}/introspection/Server.introspect
442 #%{_datadir}/%{name}/introspection/ServiceBrowser.introspect
443 #%{_datadir}/%{name}/introspection/ServiceResolver.introspect
444 #%{_datadir}/%{name}/introspection/ServiceTypeBrowser.introspect
445 %{_datadir}/%{name}/service-types
446 %{_mandir}/man1/%{name}-browse-domains.1*
447 %{_mandir}/man1/%{name}-browse.1*
448 %{_mandir}/man1/%{name}-publish.1*
449 %{_mandir}/man1/%{name}-publish-address.1*
450 %{_mandir}/man1/%{name}-publish-service.1*
451 %{_mandir}/man1/%{name}-resolve.1*
452 %{_mandir}/man1/%{name}-resolve-address.1*
453 %{_mandir}/man1/%{name}-resolve-host-name.1*
454 %{_mandir}/man1/%{name}-set-host-name.1*
455 %{_mandir}/man5/%{name}-daemon.conf.5*
456 %{_mandir}/man5/%{name}.hosts.5*
457 %{_mandir}/man5/%{name}.service.5*
458 %{_mandir}/man8/%{name}-daemon.8*
459 %{_mandir}/man8/avahi-autoipd*
460 %dir %_libdir/avahi
461 %_libdir/avahi/service-types.db
462
463 %files dnsconfd
464 %defattr(-,root,root)
465 %{_sysconfdir}/%{name}/%{name}-dnsconfd.action
466 %{_initrddir}/%{name}-dnsconfd
467 %{_sbindir}/%{name}-dnsconfd
468 %{_mandir}/man8/%{name}-dnsconfd.8*
469 %{_mandir}/man8/%{name}-dnsconfd.action.8*
470
471 %files x11
472 %defattr(-,root,root)
473 %{_bindir}/%{name}-discover-standalone
474 %{_bindir}/bshell
475 %{_bindir}/bssh
476 %{_bindir}/bvnc
477 %{_datadir}/applications/bssh.desktop
478 %{_datadir}/applications/bvnc.desktop
479 %{_mandir}/man1/bssh.1*
480 %{_mandir}/man1/bvnc.1*
481 %{_datadir}/applications/%{name}-discover.desktop
482 %{_datadir}/%{name}/interfaces/%{name}-discover.ui
483
484 %files python
485 %defattr(-,root,root)
486 %{_bindir}/%{name}-bookmarks
487 %{_bindir}/%{name}-discover
488 %{py_puresitedir}/%{name}/*.py*
489 %{py_puresitedir}/avahi_discover/
490 %{_mandir}/man1/%{name}-discover.1*
491 %{_mandir}/man1/%{name}-bookmarks.1*
492
493 %if %build_mono
494 %files sharp
495 %defattr(-,root,root)
496 %{_prefix}/lib/mono/%{name}-sharp/%{name}-sharp.dll
497 %{_prefix}/lib/mono/gac/%{name}-sharp/
498 %{_libdir}/pkgconfig/%{name}-sharp.pc
499 %{_prefix}/lib/mono/%{name}-ui-sharp/%{name}-ui-sharp.dll
500 %{_prefix}/lib/mono/gac/%{name}-ui-sharp/
501 %{_libdir}/pkgconfig/%{name}-ui-sharp.pc
502
503 %files sharp-doc
504 %defattr(-,root,root)
505 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.source
506 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.tree
507 %{_usr}/lib/monodoc/sources/%{name}-sharp-docs.zip
508 %{_usr}/lib/monodoc/sources/%{name}-ui-sharp-docs.source
509 %{_usr}/lib/monodoc/sources/%{name}-ui-sharp-docs.tree
510 %{_usr}/lib/monodoc/sources/%{name}-ui-sharp-docs.zip
511 %endif
512
513 %files -n %{lib_client_name}
514 %defattr(-,root,root)
515 %{_libdir}/lib%{name}-client.so.%{client_major}*
516
517 %files -n %{lib_common_name}
518 %defattr(-,root,root)
519 %{_libdir}/lib%{name}-common.so.%{common_major}*
520
521 %files -n %{lib_core_name}
522 %defattr(-,root,root)
523 %{_libdir}/lib%{name}-core.so.%{core_major}*
524
525 %files -n %{lib_dns_sd_name}
526 %defattr(-,root,root)
527 %{_libdir}/libdns_sd.so.%{dns_sd_major}*
528
529 %files -n %{lib_glib_name}
530 %defattr(-,root,root)
531 %{_libdir}/lib%{name}-glib.so.%{glib_major}*
532
533 %files -n %{lib_gobject_name}
534 %defattr(-,root,root)
535 %{_libdir}/lib%{name}-gobject.so.%{gobject_major}*
536
537 %files -n %{lib_howl_name}
538 %defattr(-,root,root)
539 %{_libdir}/libhowl.so.%{howl_major}*
540
541 %if %build_qt4
542 %files -n %{lib_qt4_name}
543 %defattr(-,root,root)
544 %{_libdir}/lib%{name}-qt4.so.%{qt4_major}*
545 %endif
546
547 %files -n %{lib_ui_name}
548 %defattr(-,root,root)
549 %{_libdir}/lib%{name}-ui.so.%{ui_major}*
550
551 %files -n %develnameclient
552 %defattr(-,root,root)
553 %{_includedir}/%{name}-client
554 %{_libdir}/lib%{name}-client.a
555 %attr(644,root,root) %{_libdir}/lib%{name}-client.la
556 %{_libdir}/lib%{name}-client.so
557 %{_libdir}/pkgconfig/%{name}-client.pc
558
559 %files -n %develnamecommon
560 %defattr(-,root,root)
561 %{_includedir}/%{name}-common
562 %{_libdir}/lib%{name}-common.a
563 %attr(644,root,root) %{_libdir}/lib%{name}-common.la
564 %{_libdir}/lib%{name}-common.so
565
566 %files -n %develnamecore
567 %defattr(-,root,root)
568 %{_includedir}/%{name}-core
569 %{_libdir}/lib%{name}-core.a
570 %attr(644,root,root) %{_libdir}/lib%{name}-core.la
571 %{_libdir}/lib%{name}-core.so
572 %{_libdir}/pkgconfig/%{name}-core.pc
573
574 %files -n %develnamedns_sd
575 %defattr(-,root,root)
576 %{_includedir}/%{name}-compat-libdns_sd
577 %{_libdir}/libdns_sd.a
578 %attr(644,root,root) %{_libdir}/libdns_sd.la
579 %{_libdir}/libdns_sd.so
580 %{_libdir}/pkgconfig/%{name}-compat-libdns_sd.pc
581
582 %files -n %develnameglib
583 %defattr(-,root,root)
584 %{_includedir}/%{name}-glib
585 %{_libdir}/lib%{name}-glib.a
586 %attr(644,root,root) %{_libdir}/lib%{name}-glib.la
587 %{_libdir}/lib%{name}-glib.so
588 %{_libdir}/pkgconfig/%{name}-glib.pc
589
590 %files -n %develnamegobject
591 %defattr(-,root,root)
592 %{_includedir}/%{name}-gobject
593 %{_libdir}/lib%{name}-gobject.a
594 %attr(644,root,root) %{_libdir}/lib%{name}-gobject.la
595 %{_libdir}/lib%{name}-gobject.so
596 %{_libdir}/pkgconfig/%{name}-gobject.pc
597
598
599 %files -n %develnamehowl
600 %defattr(-,root,root)
601 %{_includedir}/%{name}-compat-howl
602 %{_libdir}/libhowl.a
603 %attr(644,root,root) %{_libdir}/libhowl.la
604 %{_libdir}/libhowl.so
605 %{_libdir}/pkgconfig/%{name}-compat-howl.pc
606 %{_libdir}/pkgconfig/howl.pc
607
608 %if %build_qt4
609 %files -n %develnameqt4
610 %defattr(-,root,root)
611 %{_includedir}/%{name}-qt4
612 %{_libdir}/lib%{name}-qt4.a
613 %attr(644,root,root) %{_libdir}/lib%{name}-qt4.la
614 %{_libdir}/lib%{name}-qt4.so
615 %{_libdir}/pkgconfig/%{name}-qt4.pc
616 %endif
617
618 %files -n %develnameui
619 %defattr(-,root,root)
620 %{_includedir}/%{name}-ui
621 %{_libdir}/lib%{name}-ui.a
622 %attr(644,root,root) %{_libdir}/lib%{name}-ui.la
623 %{_libdir}/lib%{name}-ui.so
624 %{_libdir}/pkgconfig/%{name}-ui.pc
625
626

  ViewVC Help
Powered by ViewVC 1.1.30