/[packages]/cauldron/axc/current/SPECS/axc.spec
ViewVC logotype

Annotation of /cauldron/axc/current/SPECS/axc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1957905 - (hide annotations) (download)
Wed May 24 17:35:58 2023 UTC (20 months, 2 weeks ago) by daviddavid
File size: 2392 byte(s)
initial package axc (needed for purple-lurch)

1 daviddavid 1957905 %define major 0
2     %define libname %mklibname %{name} %{major}
3     %define develname %mklibname %{name} -d
4    
5     Name: axc
6     Version: 0.3.7
7     Release: %mkrel 1
8     License: GPL-3.0-or-later
9     Group: System/Libraries
10     Summary: Client library for libsignal-protocol-c
11     URL: https://github.com/gkdr/axc
12     Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
13     Patch1: 0001-Add-CMake-build-system.patch
14    
15     BuildRequires: cmake
16     BuildRequires: pkgconfig(cmocka)
17     BuildRequires: pkgconfig(glib-2.0)
18     BuildRequires: pkgconfig(libgcrypt)
19     BuildRequires: pkgconfig(libsignal-protocol-c)
20     BuildRequires: pkgconfig(sqlite3)
21    
22     %description
23     Client library for libsignal-protocol-c, implementing the
24     needed database and crypto interfaces using SQLite and gcrypt.
25     Initially, the libsignal-protocol-c project was named
26     libaxolotl, hence the name axc.
27    
28     Additionally it provides utility functions for common use
29     cases like encrypting and decrypting, ultimately making direct
30     use of libsignal-protocol-c unnecessary.
31    
32     #------------------------------------------------
33    
34     %package -n %{libname}
35     Summary: Client library for libsignal-protocol-c
36     Group: System/Libraries
37    
38     %description -n %{libname}
39     Client library for libsignal-protocol-c, implementing the
40     needed database and crypto interfaces using SQLite and gcrypt.
41     Initially, the libsignal-protocol-c project was named
42     libaxolotl, hence the name axc.
43    
44     Additionally it provides utility functions for common use
45     cases like encrypting and decrypting, ultimately making direct
46     use of libsignal-protocol-c unnecessary.
47    
48     #------------------------------------------------
49    
50     %package -n %{develname}
51     Summary: Development package for %{name}
52     Group: Development/C++
53     Requires: %{libname} = %{version}-%{release}
54     Provides: %{name}-devel = %{version}-%{release}
55     Provides: lib%{name}-devel = %{version}-%{release}
56    
57     %description -n %{develname}
58     Header files for development with %{name}.
59    
60     #------------------------------------------------
61    
62     %prep
63     %autosetup -p1
64    
65     %build
66     %cmake \
67     -DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON \
68     -DAXC_INSTALL:BOOL=ON \
69     -DAXC_WITH_PTHREADS:BOOL=ON \
70     -DAXC_WITH_TESTS:BOOL=ON
71     %cmake_build
72    
73     %install
74     %cmake_install
75    
76     %files -n %{libname}
77     %license LICENSE
78     %doc CHANGELOG.md README.md
79     %{_libdir}/lib%{name}.so.%{major}{,.*}
80    
81     %files -n %{develname}
82     %doc CHANGELOG.md README.md
83     %{_includedir}/%{name}/
84     %{_libdir}/lib%{name}.so
85     %{_libdir}/pkgconfig/lib%{name}.pc

  ViewVC Help
Powered by ViewVC 1.1.30