1 |
alien |
108311 |
# This is a single package containing the beid-middleware, including the |
2 |
|
|
# libraries as well as the firefox plugin used to register the libraries |
3 |
|
|
# with firefox. This enables the use of Belgian eID, for signing and |
4 |
|
|
# authentication for websites such as http://taxonweb.be . I put this all |
5 |
|
|
# in one package, because this is always used together, and nothing else |
6 |
|
|
# requires these files. This new version supersedes the old beid packages. |
7 |
alien |
462772 |
|
8 |
|
|
%define realname eid-mw |
9 |
|
|
%define relsuffix 1253_tcm227-178475 |
10 |
|
|
|
11 |
alien |
105896 |
Name: beid-middleware |
12 |
|
|
Summary: Application to read information from the Belgian e-ID card |
13 |
alien |
462772 |
Version: 4.0.4 |
14 |
|
|
Release: %mkrel 1 |
15 |
alien |
105896 |
# The original parts are under the "eID Toolkit Software License", |
16 |
|
|
# which by my reading is BSD-like; it's basically the BSD in stronger |
17 |
|
|
# legal language with some added gumph about liability etc. It also |
18 |
|
|
# contains bits of OpenSC (which is LGPLv2+) and OpenSSL (which is |
19 |
|
|
# BSD). - AdamW 2008/09 |
20 |
|
|
# Looking at the unofficial link ( http://code.google.com/p/eid-mw ) and |
21 |
|
|
# at the license file inside the svn tree, it seems that it's now released |
22 |
|
|
# as LGPLv3 - alien 2011 |
23 |
|
|
License: LGPLv3 |
24 |
malo |
302582 |
Group: Security |
25 |
alien |
105896 |
URL: http://eid.belgium.be/ |
26 |
alien |
462772 |
Source0: http://eid.belgium.be/nl/binaries/%{realname}-%{version}-%{relsuffix}.tgz |
27 |
alien |
462787 |
# patch 0, 1 and 2 are made by myself - alien 2013 |
28 |
alien |
105896 |
Patch0: beid-middleware-4.0.0.r929_fix_compile.patch |
29 |
alien |
462772 |
Patch1: beid-middleware-4.0.0.r929_fix_compile_dos.patch |
30 |
|
|
Patch2: beid-middleware-4.0.0.r929_fix_library_versioning.patch |
31 |
alien |
105896 |
BuildRequires: gtk2-devel |
32 |
|
|
BuildRequires: xerces-c-devel |
33 |
|
|
BuildRequires: pcsc-lite-devel |
34 |
|
|
BuildRequires: java |
35 |
|
|
BuildRequires: swig |
36 |
|
|
BuildRequires: subversion |
37 |
alien |
462787 |
BuildRequires: zip |
38 |
alien |
105896 |
Requires: pcsc-lite |
39 |
|
|
Obsoletes: beid < 4.0.0 |
40 |
alien |
112561 |
Obsoletes: %{_lib}beid2 < 4.0.0 |
41 |
|
|
Obsoletes: %{_lib}beidcomm0 < 4.0.0 |
42 |
|
|
Obsoletes: %{_lib}beidcommon0 < 4.0.0 |
43 |
|
|
Obsoletes: %{_lib}beidgui1 < 4.0.0 |
44 |
|
|
Obsoletes: %{_lib}beidlibopensc2 < 4.0.0 |
45 |
|
|
Obsoletes: %{_lib}beidpcsclite2 < 4.0.0 |
46 |
|
|
Obsoletes: %{_lib}beidpkcs11_2 < 4.0.0 |
47 |
alien |
462772 |
# Suggesting the goverment supplied readers device drivers. |
48 |
alien |
108311 |
Suggests: acr38u |
49 |
alien |
462772 |
Suggests: ccid |
50 |
alien |
105896 |
|
51 |
|
|
%description |
52 |
|
|
This application allows the user to read out any information from a |
53 |
|
|
Belgian electronic ID card, by using libbeid and libbeidlibopensc to |
54 |
|
|
read the data from the card and parse it. Both identity information |
55 |
|
|
and information about the stored cryptographic keys can be read in a |
56 |
|
|
user-friendly manner, and can easily be printed out or stored for |
57 |
|
|
later review. |
58 |
|
|
|
59 |
|
|
The application verifies the signature of the identity information, |
60 |
|
|
checks whether it was signed by a government-issued key, and |
61 |
|
|
optionally checks the certificate against the government's Certificate |
62 |
|
|
Revocation List (CRL) and/or by using the Online Certificate Status |
63 |
|
|
Protocol (OCSP) against the government's servers. |
64 |
|
|
|
65 |
|
|
%prep |
66 |
alien |
462772 |
%setup -q -n %{realname}-%{version} |
67 |
alien |
105896 |
%apply_patches |
68 |
|
|
|
69 |
|
|
%build |
70 |
alien |
462772 |
mkdir xpi/m4 |
71 |
alien |
105896 |
autoreconf -i |
72 |
|
|
%configure2_5x |
73 |
|
|
%make |
74 |
|
|
%make xpipackage |
75 |
|
|
|
76 |
|
|
%install |
77 |
|
|
rm -rf %{buildroot} |
78 |
|
|
%makeinstall_std |
79 |
alien |
107927 |
# remove static libraries |
80 |
|
|
rm -f %{buildroot}%{_libdir}/*.{la,a} |
81 |
alien |
108311 |
# remove development libraries |
82 |
|
|
rm -f %{buildroot}%{_libdir}/libbeid*.so |
83 |
alien |
462787 |
# remove contents of the xpi |
84 |
|
|
rm -rf %{buildroot}%{_datarootdir}/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be |
85 |
|
|
# install the xpi itself |
86 |
|
|
install -D -m 755 xpi/src/belgiumeid.xpi %{buildroot}%{_datarootdir}/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be.xpi |
87 |
alien |
105896 |
|
88 |
|
|
%clean |
89 |
|
|
rm -rf %{buildroot} |
90 |
|
|
|
91 |
alien |
108311 |
%files |
92 |
alien |
105896 |
%defattr(-, root, root, 0755) |
93 |
alien |
107927 |
%{_libdir}/libbeid* |
94 |
alien |
105896 |
%{_libdir}/*cardplugin* |
95 |
alien |
462772 |
%{_libexecdir}/beid-* |
96 |
alien |
462787 |
%{_datarootdir}/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be.xpi |