1 |
blino |
1502 |
Summary: A Tk toolkit extension, including widgets, geometry managers, etc |
2 |
|
|
Name: blt |
3 |
|
|
Version: 2.4z |
4 |
blino |
1504 |
Release: %mkrel 23 |
5 |
blino |
1502 |
License: MIT |
6 |
|
|
Group: System/Libraries |
7 |
|
|
URL: http://www.sourceforge.net/projects/blt/ |
8 |
|
|
Source0: BLT%{version}.tar.bz2 |
9 |
|
|
Patch0: blt2.4z-patch-2.patch |
10 |
|
|
Patch1: blt2.4z-configure.in-disable-rpath.patch |
11 |
|
|
Patch2: blt2.4z-libdir.patch |
12 |
|
|
Patch3: blt2.4z-mkdir_p.patch |
13 |
|
|
Patch4: blt2.4z-64bit-fixes.patch |
14 |
|
|
Patch5: blt-2.4z-tcl8.5-fix.patch |
15 |
|
|
# Loosens the version checking, or else it will fail when built against |
16 |
|
|
# any Tcl/Tk with a minor version (8.5.1, 8.5.2, 8.5.3) - braindead test |
17 |
|
|
# AdamW 2008/07 |
18 |
|
|
Patch6: blt-2.4z-exact.patch |
19 |
|
|
# Part fix, part kludge for Tcl 8.6 (interp->result, TIP #330) - AdamW |
20 |
|
|
# 2008/12 |
21 |
|
|
Patch7: blt-2.4z-tcl86.patch |
22 |
|
|
# Fix a use of /usr/local/bin - AdamW 2008/12 |
23 |
|
|
Patch8: blt-2.4z-local.patch |
24 |
|
|
BuildRequires: X11-devel |
25 |
|
|
BuildRequires: tk-devel |
26 |
|
|
BuildRequires: tcl-devel |
27 |
|
|
BuildRequires: autoconf2.1 |
28 |
|
|
Obsoletes: %{name}-scripts < %{version}-%{release} |
29 |
|
|
Obsoletes: %{mklibname blt 2} |
30 |
|
|
Obsoletes: %{mklibname blt 2 -d} |
31 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
32 |
|
|
|
33 |
|
|
%description |
34 |
|
|
BLT is an extension to the Tk toolkit. BLT's most useful feature is the |
35 |
|
|
provision of more widgets for Tk, but it also provides more geometry managers |
36 |
|
|
and miscellaneous other commands. Note that you won't need to do any patching |
37 |
|
|
of the Tcl or Tk source files to use BLT, but you will need to have Tcl/Tk |
38 |
|
|
installed in order to use BLT. |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup -q -n %{name}%{version} |
42 |
|
|
sed -i -e 's,local/,,g' demos/scripts/page.tcl |
43 |
|
|
%patch0 -p1 |
44 |
|
|
%patch1 -p1 -b .rpath |
45 |
|
|
%patch2 -p1 -b .libdir |
46 |
|
|
%patch3 -p1 -b .mkdir_p |
47 |
|
|
%patch4 -p1 -b .64bit-fixes |
48 |
|
|
%patch5 -p1 |
49 |
|
|
%patch6 -p1 -b .exact |
50 |
|
|
%patch7 -p1 -b .tcl86 |
51 |
|
|
#patch8 -p1 |
52 |
|
|
autoconf-2.13 |
53 |
|
|
|
54 |
|
|
%build |
55 |
|
|
%configure --libdir=%{tcl_sitearch} |
56 |
|
|
make |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -rf %{buildroot} |
60 |
|
|
make prefix=%{buildroot}%{_prefix} bindir=%{buildroot}%{_bindir} libdir=%{buildroot}%{tcl_sitearch} mandir=%{buildroot}%{_mandir} install |
61 |
|
|
|
62 |
|
|
ln -sf bltwish24 %{buildroot}%{_bindir}/bltwish |
63 |
|
|
ln -sf bltsh24 %{buildroot}%{_bindir}/bltsh |
64 |
|
|
|
65 |
blino |
1504 |
# Dadou - Don't put in %%_libdir things which should be in %%_docdir |
66 |
blino |
1502 |
rm -fr %{buildroot}%{tcl_sitearch}/blt2.4/NEWS |
67 |
|
|
rm -fr %{buildroot}%{tcl_sitearch}/blt2.4/PROBLEMS |
68 |
|
|
rm -fr %{buildroot}%{tcl_sitearch}/blt2.4/README |
69 |
|
|
rm -fr %{buildroot}%{tcl_sitearch}/blt2.4/demos |
70 |
|
|
|
71 |
blino |
1504 |
# Dadou - Prevent conflicts with other packages |
72 |
blino |
1502 |
for i in bitmap graph tabset tree watch; do |
73 |
|
|
mv %{buildroot}%{_mandir}/mann/$i{,-blt}.n |
74 |
|
|
done |
75 |
|
|
|
76 |
|
|
# need to be available as a shared lib as well as a tcl module |
77 |
|
|
ln -s %{tcl_sitearch}/libBLT24.so %{buildroot}%{_libdir}/libBLT24.so |
78 |
|
|
ln -s %{tcl_sitearch}/libBLTlite24.so %{buildroot}%{_libdir}/libBLTlite24.so |
79 |
|
|
|
80 |
|
|
# development crap, we don't have anything that builds against this |
81 |
|
|
# at present |
82 |
|
|
rm -rf %{buildroot}%{_includedir} |
83 |
|
|
rm -f %{buildroot}%{_libdir}/*.a |
84 |
|
|
rm -f %{buildroot}%{tcl_sitearch}/*.a |
85 |
|
|
|
86 |
|
|
%clean |
87 |
|
|
rm -fr %{buildroot} |
88 |
|
|
|
89 |
|
|
%files |
90 |
|
|
%defattr(-,root,root,-) |
91 |
|
|
%doc MANIFEST NEWS PROBLEMS README |
92 |
|
|
%doc examples/ |
93 |
|
|
%doc html/ |
94 |
|
|
%doc demos/ |
95 |
|
|
%{_bindir}/* |
96 |
|
|
%{_mandir}/mann/* |
97 |
|
|
%{_mandir}/man3/* |
98 |
|
|
%{tcl_sitearch}/*.so |
99 |
|
|
%{tcl_sitearch}/%{name}2.4 |
100 |
|
|
%{_libdir}/*.so |
101 |
|
|
|
102 |
|
|
|
103 |
|
|
|