1 |
Summary: A Tk toolkit extension, including widgets, geometry managers, etc |
2 |
Name: blt |
3 |
Version: 2.5 |
4 |
Release: %mkrel 18 |
5 |
License: MIT |
6 |
Group: System/Libraries |
7 |
URL: http://pdqi.com/w/pw/pdqi/Wize/Blt |
8 |
Source0: http://pdqi.com/w/Download/blt-src-2.5.tar.gz |
9 |
Patch0: blt-2.5-mga-cplusplus.patch |
10 |
# (tv) Tcl/Tk 8.6 fixes from FC, adapted for blt-2.5: |
11 |
Patch1: blt2.4z-tcl8.6.patch |
12 |
Patch2: blt2.4z-tk8.6.patch |
13 |
Patch3: blt-2.5-mga-errorLine.patch |
14 |
Patch4: blt-autoconf.patch |
15 |
Patch5: blt-rpath.patch |
16 |
BuildRequires: pkgconfig(x11) |
17 |
BuildRequires: pkgconfig(tk) |
18 |
BuildRequires: pkgconfig(tcl) |
19 |
|
20 |
%description |
21 |
BLT is an extension to the Tk toolkit. BLT's most useful feature is the |
22 |
provision of more widgets for Tk, but it also provides more geometry managers |
23 |
and miscellaneous other commands. Note that you won't need to do any patching |
24 |
of the Tcl or Tk source files to use BLT, but you will need to have Tcl/Tk |
25 |
installed in order to use BLT. |
26 |
|
27 |
%package -n blt-devel |
28 |
Summary: Tk toolkit extension |
29 |
Group: System/Libraries |
30 |
Requires: blt = %{version} |
31 |
|
32 |
%description -n blt-devel |
33 |
Development files for BLT |
34 |
|
35 |
%prep |
36 |
%setup -q -n %{name}%{version} |
37 |
%autopatch -p1 |
38 |
|
39 |
sed -i -e 's,local/,,g' demos/scripts/page.tcl |
40 |
|
41 |
%build |
42 |
autoreconf -vfi |
43 |
%configure --libdir=%{tcl_sitearch} \ |
44 |
--with-tcl=%{_libdir} |
45 |
make LDFLAGS="%{ldflags}" |
46 |
|
47 |
%install |
48 |
%{__mkdir_p} %{buildroot}%{_libdir} |
49 |
%{__mkdir_p} %{buildroot}%{_mandir} |
50 |
|
51 |
make prefix=%{buildroot}%{_prefix} \ |
52 |
exec_prefix=%{buildroot}%{_prefix} \ |
53 |
bindir=%{buildroot}%{_bindir} \ |
54 |
libdir=%{buildroot}%{tcl_sitearch} \ |
55 |
includedir=%{buildroot}%{_includedir} \ |
56 |
mandir=%{buildroot}%{_mandir} \ |
57 |
scriptdir=%{buildroot}%{tcl_sitearch}/blt%{version} \ |
58 |
install |
59 |
|
60 |
ln -sf bltwish25 %{buildroot}%{_bindir}/bltwish |
61 |
ln -sf bltsh25 %{buildroot}%{_bindir}/bltsh |
62 |
|
63 |
# Dadou - Don't put in %%_libdir things which should be in %%_docdir |
64 |
rm -fr %{buildroot}%{tcl_sitearch}/blt2.5/NEWS |
65 |
rm -fr %{buildroot}%{tcl_sitearch}/blt2.5/PROBLEMS |
66 |
rm -fr %{buildroot}%{tcl_sitearch}/blt2.5/README |
67 |
rm -fr %{buildroot}%{tcl_sitearch}/blt2.5/demos |
68 |
|
69 |
# Dadou - Prevent conflicts with other packages |
70 |
for i in bitmap graph tabset tree watch; do |
71 |
mv %{buildroot}%{_mandir}/mann/$i{,-blt}.n |
72 |
done |
73 |
|
74 |
# need to be available as a shared lib as well as a tcl module |
75 |
ln -s %{tcl_sitearch}/libBLT25.so %{buildroot}%{_libdir}/libBLT25.so |
76 |
ln -s %{tcl_sitearch}/libBLTlite25.so %{buildroot}%{_libdir}/libBLTlite25.so |
77 |
|
78 |
# development crap, we don't have anything that builds against this |
79 |
# at present |
80 |
rm -f %{buildroot}%{_libdir}/*.a |
81 |
rm -f %{buildroot}%{tcl_sitearch}/*.a |
82 |
|
83 |
sed -i -e 's!%{buildroot}!!g' %{buildroot}%{tcl_sitearch}/blt%{version}/pkgIndex.tcl |
84 |
|
85 |
%files |
86 |
%doc MANIFEST NEWS PROBLEMS README |
87 |
%doc examples/ |
88 |
%doc html/ |
89 |
%doc demos/ |
90 |
%{_bindir}/* |
91 |
%{_mandir}/mann/* |
92 |
%{_mandir}/man3/* |
93 |
%{tcl_sitearch}/*.so |
94 |
%{tcl_sitearch}/%{name}2.5 |
95 |
%{_libdir}/*.so |
96 |
|
97 |
%files -n blt-devel |
98 |
%{_includedir}/*.h |