/[packages]/cauldron/bogofilter/current/SPECS/bogofilter.spec
ViewVC logotype

Contents of /cauldron/bogofilter/current/SPECS/bogofilter.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1928028 - (show annotations) (download)
Fri Dec 30 09:24:10 2022 UTC (15 months, 3 weeks ago) by daviddavid
File size: 2757 byte(s)
- rebuild for gsl 2.7.1 on arrmv7

1 %global __requires_exclude perl
2
3 Summary: Fast anti-spam filtering by Bayesian statistical analysis
4 Name: bogofilter
5 Version: 1.2.5
6 Release: %mkrel 4
7 License: GPLv2+
8 Group: Networking/Mail
9 URL: https://bogofilter.sourceforge.net/
10 Source0: https://prdownloads.sourceforge.net/bogofilter/%{name}-%{version}.tar.xz
11 BuildRequires: db-devel
12 BuildRequires: pkgconfig(gsl)
13 BuildRequires: valgrind
14 BuildRequires: flex
15 BuildRequires: openjade
16
17 %description
18 Bogofilter is a Bayesian spam filter. In its normal mode of
19 operation, it takes an email message or other text on standard
20 input, does a statistical check against lists of "good" and
21 "bad" words, and returns a status code indicating whether or not
22 the message is spam. Bogofilter is designed with fast algorithms
23 (including Berkeley DB system), coded directly in C, and tuned for
24 speed, so it can be used for production by sites that process a
25 lot of mail.
26
27 %prep
28 %setup -q
29
30 %build
31
32 %configure \
33 --disable-rpath \
34 --disable-transactions \
35 --with-database=db \
36 --disable-dependency-tracking \
37 --without-included-gsl
38
39 %make_build
40
41 %ifnarch armv7hl
42 # Some strange test failures that would need to be investigated but don't seem fatal
43 # 3/54 Failed:
44 #./outputs/dump.load-2.out ./checks.23370.20160529T004141/dump.load-2.txt differ: char 87, line 3
45 #FAIL: t.dump.load
46 #want: "7.2 6.20030303 10.20030304", have: "1.2 6.20030303 10.20030304"
47 #FAIL: t.nonascii.replace
48 #./outputs/bulkmode.out ./checks.24400.20160529T004148/bulk-double-2.out differ: char 80, line 3
49 #FAIL: t.bulkmode
50 %check
51 make DESTDIR="%{buildroot}" check
52 %endif
53
54 %install
55 %make_install
56
57 mv %{buildroot}%{_sysconfdir}/bogofilter.cf.example %{buildroot}%{_sysconfdir}/bogofilter.cf
58
59 # trio is embedded and has different AUTHORS, CHANGES, README
60 mkdir -p %{buildroot}%{_datadir}/doc/%{name}/trio
61 cp trio/CHANGES %{buildroot}%{_datadir}/doc/%{name}/trio/CHANGES
62 cp trio/AUTHORS %{buildroot}%{_datadir}/doc/%{name}/trio/AUTHORS
63 cp trio/README %{buildroot}%{_datadir}/doc/%{name}/trio/README
64
65 ##include contrib, some may find it useful
66 for d in contrib ; do
67 install -d %{buildroot}%{_datadir}/%{name}/$d
68 files=$(find "$d" -maxdepth 1 -type f -print)
69 for f in $files ; do
70 case $f in
71 *.c|*.o|*.obj|*/Makefile*) continue ;;
72 *.1)
73 cp -p $f %{buildroot}%{_mandir}/man1 ;;
74 *)
75 cp -p $f %{buildroot}%{_datadir}/%{name}/$d ;;
76 esac
77 done
78 done
79
80 %files
81 %doc AUTHORS GETTING.STARTED Doxyfile NEWS
82 %doc README* OBITUARY TODO RELEASE.NOTES*
83 %doc bogofilter.cf.example
84 %doc doc/README* doc/bogofilter-SA*
85 %doc doc/integrating-* doc/*.html doc/*.xml
86 %doc contrib/README*
87 %doc %{_datadir}/doc/%{name}/trio
88 %config(noreplace) %{_sysconfdir}/bogofilter.cf
89 %{_bindir}/*
90 %{_datadir}/bogofilter
91 %{_mandir}/man1/*

  ViewVC Help
Powered by ViewVC 1.1.30