/[packages]/cauldron/cairo/current/SPECS/cairo.spec
ViewVC logotype

Contents of /cauldron/cairo/current/SPECS/cairo.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 16608 - (show annotations) (download)
Thu Jan 13 21:57:17 2011 UTC (13 years, 3 months ago) by blino
File size: 6198 byte(s)
remove old macros

1 %define release %mkrel 2
2
3 %define lib_major 2
4 %define libname %mklibname cairo %{lib_major}
5 %define libnamedev %mklibname -d cairo
6 %define libnamestaticdev %mklibname -s -d cairo
7
8 %define pixman_version 0.17.6
9
10 #gw check coverage fails in 1.9.4
11 %define enable_test 0
12 %define stable 1
13 %define build_plf 0
14 %define build_doc 1
15
16 %{?_with_plf: %{expand: %%global build_plf 1}}
17 %if %build_plf
18 %define distsuffix plf
19 %endif
20
21
22 Summary: Cairo - multi-platform 2D graphics library
23 Name: cairo
24 Version: 1.10.2
25 Release: %release
26 License: BSD
27 Group: System/Libraries
28 %if %stable
29 Source0: http://cairographics.org/releases/%name-%version.tar.gz
30 Source1: http://cairographics.org/releases/%name-%version.tar.gz.sha1
31 %else
32 Source0: http://cairographics.org/snapshots/%name-%version.tar.gz
33 Source1: http://cairographics.org/snapshots/%name-%version.tar.gz.sha1
34 %endif
35 # gw patches to handle LCD subpixel hinting
36 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
37 Patch4: cairo-04_lcd_filter.dpatch
38 # http://bugs.freedesktop.org/show_bug.cgi?id=11838
39 # http://bugs.freedesktop.org/show_bug.cgi?id=13335
40 # https://bugs.launchpad.net/ubuntu/+source/cairo/+bug/209256
41 # http://forums.fedoraforum.org/showthread.php?p=1094309#post1094309
42 Patch5: cairo-respect-fontconfig.patch
43
44 URL: http://cairographics.org/
45 BuildRequires: freetype2-devel >= 2.1.10
46 BuildRequires: libxext-devel
47 BuildRequires: libx11-devel
48 BuildRequires: libxrender-devel
49 BuildRequires: libfontconfig-devel
50 BuildRequires: glib2-devel
51 %if %enable_test
52 # needed by tests
53 BuildRequires: fonts-ttf-bitstream-vera
54 # only needed for pdf tests
55 #BuildRequires: libpango-devel >= 1.13.0
56 # gw for svg tests
57 BuildRequires: librsvg-devel
58 # gw for ps testing
59 BuildRequires: libspectre-devel
60 # gw for pdf testing
61 BuildRequires: libpoppler-glib-devel
62 %endif
63 BuildRequires: x11-server-xvfb
64 BuildRequires: pixman-devel >= %{pixman_version}
65
66 BuildRequires: libpng-devel
67 %if %build_doc
68 BuildRequires: gtk-doc
69 %endif
70 BuildRoot: %_tmppath/%name-%version-root
71
72 %description
73 Cairo provides anti-aliased vector-based rendering for X. Paths
74 consist of line segments and cubic splines and can be rendered at any
75 width with various join and cap styles. All colors may be specified
76 with optional translucence (opacity/alpha) and combined using the
77 extended Porter/Duff compositing algebra as found in the X Render
78 Extension.
79
80 Cairo exports a stateful rendering API similar in spirit to the path
81 construction, text, and painting operators of PostScript, (with the
82 significant addition of translucence in the imaging model). When
83 complete, the API is intended to support the complete imaging model of
84 PDF 1.4.
85
86 Cairo relies on the Xc library for backend rendering. Xc provides an
87 abstract interface for rendering to multiple target types. As of this
88 writing, Xc allows Cairo to target X drawables as well as generic
89 image buffers. Future backends such as PostScript, PDF, and perhaps
90 OpenGL are currently being planned.
91 %if %{build_plf}
92
93 This package is in PLF because this build has LCD subpixel hinting enabled
94 which are covered by software patents.
95 %endif
96
97 %package -n %{libname}
98 Summary: Cairo - multi-platform 2D graphics library
99 Group: System/Libraries
100 Provides: cairo = %{version}-%{release}
101 Requires: freetype2 >= 2.1.10
102 Requires: %{_lib}pixman-1_0 >= %{pixman_version}
103
104 %description -n %{libname}
105 Cairo provides anti-aliased vector-based rendering for X. Paths
106 consist of line segments and cubic splines and can be rendered at any
107 width with various join and cap styles. All colors may be specified
108 with optional translucence (opacity/alpha) and combined using the
109 extended Porter/Duff compositing algebra as found in the X Render
110 Extension.
111
112 Cairo exports a stateful rendering API similar in spirit to the path
113 construction, text, and painting operators of PostScript, (with the
114 significant addition of translucence in the imaging model). When
115 complete, the API is intended to support the complete imaging model of
116 PDF 1.4.
117
118 Cairo relies on the Xc library for backend rendering. Xc provides an
119 abstract interface for rendering to multiple target types. As of this
120 writing, Xc allows Cairo to target X drawables as well as generic
121 image buffers. Future backends such as PostScript, PDF, and perhaps
122 OpenGL are currently being planned.
123 %if %{build_plf}
124
125 This package is in PLF because this build has LCD subpixel hinting enabled
126 which are covered by software patents.
127 %endif
128
129 %package -n %{libnamedev}
130 Summary: Development files for Cairo library
131 Group: Development/C
132 Requires: %{libname} = %version
133 Provides: %{name}-devel = %version-%release
134 Provides: lib%{name}-devel = %version-%release
135 Obsoletes: %mklibname -d cairo 2
136 Conflicts: %{_lib}cairo1-devel
137
138 %description -n %{libnamedev}
139 Development files for Cairo library.
140
141 %package -n %{libnamestaticdev}
142 Summary: Static Cairo library
143 Group: Development/C
144 Requires: %{libnamedev} = %version
145 Provides: lib%name-static-devel = %version
146 Obsoletes: %mklibname -s -d cairo 2
147
148 %description -n %{libnamestaticdev}
149 Static Cairo library.
150
151
152 %prep
153 %setup -q
154 %if %build_plf
155 %patch4 -p1
156 %patch5 -p1
157 %endif
158
159 #autoreconf -fi
160
161 %build
162 export PTHREAD_LIBS=-lpthread
163 %configure2_5x \
164 %if %build_doc
165 --enable-gtk-doc \
166 %endif
167 --enable-pdf --enable-ps --disable-xcb
168 %make
169
170 %check
171 %if %{enable_test}
172 XDISPLAY=$(i=1; while [ -f /tmp/.X$i-lock ]; do i=$(($i+1)); done; echo $i)
173 %{_bindir}/Xvfb -screen 0 1600x1200x24 :$XDISPLAY &
174 export DISPLAY=:$XDISPLAY
175 make check
176 kill $(cat /tmp/.X$XDISPLAY-lock)
177 %endif
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %makeinstall_std
183 rm -f %buildroot%_libdir/cairo/*.a
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files -n %{libname}
189 %defattr(644,root,root,755)
190 %doc AUTHORS COPYING NEWS README
191 %_libdir/libcairo.so.%{lib_major}*
192 %_libdir/libcairo-gobject.so.%{lib_major}*
193 %_libdir/libcairo-script-interpreter.so.%{lib_major}*
194
195 %files -n %{libnamedev}
196 %defattr(644,root,root,755)
197 %doc RELEASING BIBLIOGRAPHY BUGS ChangeLog
198 %attr(755,root,root) %_bindir/cairo-trace
199 %_libdir/cairo/
200 %_libdir/lib*.so
201 %attr(644,root,root) %_libdir/lib*.la
202 %_includedir/*
203 %_libdir/pkgconfig/*.pc
204 %_datadir/gtk-doc/html/cairo/
205
206 %files -n %{libnamestaticdev}
207 %defattr(644,root,root,755)
208 %_libdir/lib*.a
209
210
211
212

  ViewVC Help
Powered by ViewVC 1.1.30