/[packages]/cauldron/cantor/current/SPECS/cantor.spec
ViewVC logotype

Contents of /cauldron/cantor/current/SPECS/cantor.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 269646 - (show annotations) (download)
Thu Jul 12 02:29:23 2012 UTC (12 years, 3 months ago) by fwang
File size: 4304 byte(s)
new version 4.8.97
1 %define rel 1
2
3 Name: cantor
4 Summary: KDE Interface for doing Mathematics and Scientific Computing
5 Version: 4.8.97
6 Release: %mkrel %{rel}
7 Group: Sciences/Mathematics
8 License: GPLv2
9 URL: http://www.kde.org/applications/education/cantor/
10 Source: ftp://ftp.kde.org/pub/kde/unstable/%version/src/%{name}-%version.tar.xz
11
12 # Branch patches 100->200
13
14 # Trunk patches 200->300
15
16 # Mageia patches 500->600
17
18 Patch500: kdeedu-4.6.90-cantor-rpath.patch
19
20 BuildRequires: kdelibs4-devel >= 2:%{version}
21 BuildRequires: pkgconfig(libR)
22 BuildRequires: pkgconfig(libspectre)
23 BuildRequires: pkgconfig(libqalculate)
24 BuildRequires: analitza-devel
25 Suggests: cantor-handbook
26
27 %description
28 Cantor is a KDE Application aimed to provide a nice interface
29 for doing Mathematics and Scientific Computing. It doesn't implement
30 its own Computation Logic, but instead is built around different
31 Backends.
32
33 %files
34 %_kde_bindir/cantor
35 %_kde_bindir/cantor_rserver
36 %_kde_libdir/kde4/cantor_advancedplotassistant.so
37 %_kde_libdir/kde4/cantor_creatematrixassistant.so
38 %_kde_libdir/kde4/cantor_differentiateassistant.so
39 %_kde_libdir/kde4/cantor_eigenvaluesassistant.so
40 %_kde_libdir/kde4/cantor_eigenvectorsassistant.so
41 %_kde_libdir/kde4/cantor_helppanelplugin.so
42 %_kde_libdir/kde4/cantor_integrateassistant.so
43 %_kde_libdir/kde4/cantor_invertmatrixassistant.so
44 %_kde_libdir/kde4/cantor_kalgebrabackend.so
45 %_kde_libdir/kde4/cantor_maximabackend.so
46 %_kde_libdir/kde4/cantor_nullbackend.so
47 %_kde_libdir/kde4/cantor_octavebackend.so
48 %_kde_libdir/kde4/cantor_plot2dassistant.so
49 %_kde_libdir/kde4/cantor_plot3dassistant.so
50 %_kde_libdir/kde4/cantor_qalculatebackend.so
51 %_kde_libdir/kde4/cantor_qalculateplotassistant.so
52 %_kde_libdir/kde4/cantor_rbackend.so
53 %_kde_libdir/kde4/cantor_runscriptassistant.so
54 %_kde_libdir/kde4/cantor_sagebackend.so
55 %_kde_libdir/kde4/cantor_scilabbackend.so
56 %_kde_libdir/kde4/cantor_solveassistant.so
57 %_kde_libdir/kde4/cantor_variablemanagerplugin.so
58 %_kde_libdir/kde4/libcantorpart.so
59 %_kde_libdir/libcantor_config.so
60 %_kde_datadir/applications/kde4/cantor.desktop
61 %_kde_appsdir/cantor
62 %_kde_iconsdir/*/*/apps/cantor.*
63 %_kde_iconsdir/*/*/apps/maximabackend.png
64 %_kde_iconsdir/*/*/apps/octavebackend.png
65 %_kde_iconsdir/*/*/apps/rbackend.png
66 %_kde_iconsdir/*/*/apps/sagebackend.png
67 %_kde_iconsdir/hicolor/*/apps/qalculatebackend.png
68 %_kde_iconsdir/hicolor/*/apps/scilabbackend.png
69 %_kde_configdir/cantor*.knsrc
70 %_kde_datadir/config.kcfg/cantor.kcfg
71 %_kde_datadir/config.kcfg/cantor_libs.kcfg
72 %_kde_datadir/config.kcfg/octavebackend.kcfg
73 %_kde_datadir/config.kcfg/maximabackend.kcfg
74 %_kde_datadir/config.kcfg/qalculatebackend.kcfg
75 %_kde_datadir/config.kcfg/rserver.kcfg
76 %_kde_datadir/config.kcfg/sagebackend.kcfg
77 %_kde_datadir/config.kcfg/scilabbackend.kcfg
78 %_kde_services/cantor
79 %_kde_servicetypes/cantor_assistant.desktop
80 %_kde_servicetypes/cantor_backend.desktop
81 %_kde_servicetypes/cantor_panelplugin.desktop
82
83 #------------------------------------------------------------------------------
84
85 %package handbook
86 Summary: Cantor Handbook
87 Conflicts: cantor < 4.7.1
88 BuildArch: noarch
89 Group: Books/Other
90
91 %description handbook
92 This package provides cantor handbook
93
94 %files handbook
95 %doc README TODO
96 %docdir %_kde_docdir/HTML/
97 %_kde_docdir/HTML/en/cantor
98
99 #------------------------------------------------------------------------------
100
101 %define cantorlibs_major 0
102 %define libcantorlibs %mklibname cantorlibs %{cantorlibs_major}
103
104 %package -n %libcantorlibs
105 Summary: Runtime library for cantor
106 Group: System/Libraries
107
108 %description -n %libcantorlibs
109 Runtime library for cantor
110
111 %files -n %libcantorlibs
112 # FIXME : Fix lib major
113 %_kde_libdir/libcantorlibs.so.%{cantorlibs_major}*
114 %_kde_libdir/libcantorlibs.so.1
115
116 #------------------------------------------------------------------------------
117
118 %package devel
119 Summary: Devel stuff for %{name}
120 Group: Development/KDE and Qt
121 Requires: %libcantorlibs = %version-%release
122 Conflicts: kdeedu4-devel < 4.6.90
123
124 %description devel
125 Files needed to build applications based on %{name}.
126
127 %files devel
128 %_kde_libdir/libcantorlibs.so
129 %_kde_includedir/%{name}
130
131 #------------------------------------------------------------------------------
132
133 %prep
134 %setup -q
135 %apply_patches
136
137 %build
138 export LD=/usr/bin/ld.gold
139 %cmake_kde4 -DKDE4_ENABLE_FINAL=OFF
140 %make
141
142 %install
143 rm -fr %buildroot
144 %makeinstall_std -C build

  ViewVC Help
Powered by ViewVC 1.1.30