1 |
akien |
1059579 |
Name: cave9 |
2 |
|
|
Version: 0.4.1 |
3 |
|
|
Release: %mkrel 1 |
4 |
|
|
Summary: A cave exploration game featuring unique controls based on gravity |
5 |
|
|
Group: Games/Arcade |
6 |
|
|
License: LGPLv3 and CC-BY-SA and CC-BY and Public Domain |
7 |
|
|
URL: http://code.google.com/p/cave9 |
8 |
|
|
# Repacked from https://github.com/bart9h/cave9 with data (e6896eb) |
9 |
|
|
Source0: %{name}-%{version}.tar.xz |
10 |
|
|
#Source0: https://github.com/bart9h/cave9/archive/%{version}/%{name}-%{version}.tar.gz |
11 |
|
|
Patch0: 0001-Data-paths-support-games-FHS-dir.patch |
12 |
|
|
|
13 |
|
|
BuildRequires: pkgconfig(sdl) |
14 |
|
|
BuildRequires: pkgconfig(SDL_image) |
15 |
|
|
BuildRequires: pkgconfig(SDL_net) |
16 |
|
|
BuildRequires: pkgconfig(SDL_ttf) |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
Cave 9 is 3D cave exploration game based on the SF-cave game. |
20 |
|
|
You control a jet that maneuvers through a series of caves and the objective |
21 |
|
|
of the game is to avoid colliding with the cave walls. |
22 |
|
|
|
23 |
|
|
%prep |
24 |
|
|
%autosetup -p1 |
25 |
|
|
|
26 |
|
|
%build |
27 |
|
|
%setup_compile_flags |
28 |
|
|
export CFLAGS="%{optflags} -Wno-error=unused-result" |
29 |
|
|
%make_build |
30 |
|
|
|
31 |
|
|
%install |
32 |
|
|
install -D -m755 cave9 %{buildroot}%{_gamesbindir}/%{name} |
33 |
|
|
|
34 |
|
|
install -d %{buildroot}%{_gamesdatadir}/%{name} |
35 |
|
|
cp -a data/* %{buildroot}%{_gamesdatadir}/%{name}/ |
36 |
|
|
|
37 |
|
|
install -d %{buildroot}%{_datadir}/applications |
38 |
|
|
cat << EOF > %{buildroot}%{_datadir}/applications/%{name}.desktop |
39 |
|
|
[Desktop Entry] |
40 |
|
|
Name=Cave 9 |
41 |
|
|
GenericName=3D gravity game |
42 |
|
|
Comment=3D gravity cave exploration game |
43 |
|
|
Exec=%{name} |
44 |
|
|
Icon=%{name} |
45 |
|
|
Type=Application |
46 |
|
|
Categories=Game;ArcadeGame; |
47 |
|
|
EOF |
48 |
|
|
|
49 |
|
|
install -D -m644 data/icon.png %{buildroot}%{_datadir}/icons/%{name}.png |
50 |
|
|
|
51 |
|
|
# Taken from Fedora's package |
52 |
|
|
install -d %{buildroot}%{_datadir}/appdata |
53 |
|
|
cat << EOF > %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml |
54 |
|
|
<?xml version="1.0" encoding="UTF-8"?> |
55 |
|
|
<!-- Copyright 2014 Ravi Srinivasan <ravishankar.srinivasan@gmail.com> --> |
56 |
|
|
<application> |
57 |
|
|
<id type="desktop">cave9.desktop</id> |
58 |
|
|
<metadata_license>CC0-1.0</metadata_license> |
59 |
|
|
<summary>A cave exploration game featuring unique controls based on gravity</summary> |
60 |
|
|
<description> |
61 |
|
|
<p> |
62 |
|
|
cave9 is 3D cave exploration game based on the SF-cave game. |
63 |
|
|
You control a jet that maneuvers through a series of caves and the objective |
64 |
|
|
of the game is to avoid colliding with the cave walls. |
65 |
|
|
</p> |
66 |
|
|
</description> |
67 |
|
|
<url type="homepage">http://code.google.com/p/cave9</url> |
68 |
|
|
<!-- Broken URL |
69 |
|
|
<screenshots> |
70 |
|
|
<screenshot type="default">http://cave9.googlecode.com/files/cave9-small.jpg</screenshot> |
71 |
|
|
</screenshots> |
72 |
|
|
--> |
73 |
|
|
</application> |
74 |
|
|
EOF |
75 |
|
|
|
76 |
|
|
%files |
77 |
|
|
%doc AUTHORS.txt README.txt |
78 |
|
|
%{_datadir}/appdata/%{name}.appdata.xml |
79 |
|
|
%{_datadir}/applications/%{name}.desktop |
80 |
|
|
%{_datadir}/icons/%{name}.png |
81 |
|
|
%{_gamesbindir}/%{name} |
82 |
|
|
%{_gamesdatadir}/%{name}/ |