/[packages]/cauldron/cave9/current/SPECS/cave9.spec
ViewVC logotype

Annotation of /cauldron/cave9/current/SPECS/cave9.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1159793 - (hide annotations) (download)
Mon Sep 25 18:49:09 2017 UTC (7 years ago) by cjw
File size: 2718 byte(s)
- patch1: fix build with gcc 7

1 akien 1059579 Name: cave9
2     Version: 0.4.1
3 cjw 1159793 Release: %mkrel 2
4 akien 1059579 Summary: A cave exploration game featuring unique controls based on gravity
5     Group: Games/Arcade
6     License: LGPLv3 and CC-BY-SA and CC-BY and Public Domain
7     URL: http://code.google.com/p/cave9
8     # Repacked from https://github.com/bart9h/cave9 with data (e6896eb)
9     Source0: %{name}-%{version}.tar.xz
10     #Source0: https://github.com/bart9h/cave9/archive/%{version}/%{name}-%{version}.tar.gz
11     Patch0: 0001-Data-paths-support-games-FHS-dir.patch
12 cjw 1159793 Patch1: cave9-0.4.1-gcc7.patch
13 akien 1059579
14     BuildRequires: pkgconfig(sdl)
15     BuildRequires: pkgconfig(SDL_image)
16     BuildRequires: pkgconfig(SDL_net)
17     BuildRequires: pkgconfig(SDL_ttf)
18    
19     %description
20     Cave 9 is 3D cave exploration game based on the SF-cave game.
21     You control a jet that maneuvers through a series of caves and the objective
22     of the game is to avoid colliding with the cave walls.
23    
24     %prep
25     %autosetup -p1
26    
27     %build
28     %setup_compile_flags
29     export CFLAGS="%{optflags} -Wno-error=unused-result"
30     %make_build
31    
32     %install
33     install -D -m755 cave9 %{buildroot}%{_gamesbindir}/%{name}
34    
35     install -d %{buildroot}%{_gamesdatadir}/%{name}
36     cp -a data/* %{buildroot}%{_gamesdatadir}/%{name}/
37    
38     install -d %{buildroot}%{_datadir}/applications
39     cat << EOF > %{buildroot}%{_datadir}/applications/%{name}.desktop
40     [Desktop Entry]
41     Name=Cave 9
42     GenericName=3D gravity game
43     Comment=3D gravity cave exploration game
44     Exec=%{name}
45     Icon=%{name}
46     Type=Application
47     Categories=Game;ArcadeGame;
48     EOF
49    
50     install -D -m644 data/icon.png %{buildroot}%{_datadir}/icons/%{name}.png
51    
52     # Taken from Fedora's package
53     install -d %{buildroot}%{_datadir}/appdata
54     cat << EOF > %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
55     <?xml version="1.0" encoding="UTF-8"?>
56     <!-- Copyright 2014 Ravi Srinivasan <ravishankar.srinivasan@gmail.com> -->
57     <application>
58     <id type="desktop">cave9.desktop</id>
59     <metadata_license>CC0-1.0</metadata_license>
60     <summary>A cave exploration game featuring unique controls based on gravity</summary>
61     <description>
62     <p>
63     cave9 is 3D cave exploration game based on the SF-cave game.
64     You control a jet that maneuvers through a series of caves and the objective
65     of the game is to avoid colliding with the cave walls.
66     </p>
67     </description>
68     <url type="homepage">http://code.google.com/p/cave9</url>
69     <!-- Broken URL
70     <screenshots>
71     <screenshot type="default">http://cave9.googlecode.com/files/cave9-small.jpg</screenshot>
72     </screenshots>
73     -->
74     </application>
75     EOF
76    
77     %files
78     %doc AUTHORS.txt README.txt
79     %{_datadir}/appdata/%{name}.appdata.xml
80     %{_datadir}/applications/%{name}.desktop
81     %{_datadir}/icons/%{name}.png
82     %{_gamesbindir}/%{name}
83     %{_gamesdatadir}/%{name}/

  ViewVC Help
Powered by ViewVC 1.1.30