1 |
akien |
1059579 |
Name: cave9 |
2 |
|
|
Version: 0.4.1 |
3 |
umeabot |
1511346 |
Release: %mkrel 4 |
4 |
akien |
1059579 |
Summary: A cave exploration game featuring unique controls based on gravity |
5 |
|
|
Group: Games/Arcade |
6 |
|
|
License: LGPLv3 and CC-BY-SA and CC-BY and Public Domain |
7 |
|
|
URL: http://code.google.com/p/cave9 |
8 |
|
|
# Repacked from https://github.com/bart9h/cave9 with data (e6896eb) |
9 |
|
|
Source0: %{name}-%{version}.tar.xz |
10 |
|
|
#Source0: https://github.com/bart9h/cave9/archive/%{version}/%{name}-%{version}.tar.gz |
11 |
|
|
Patch0: 0001-Data-paths-support-games-FHS-dir.patch |
12 |
cjw |
1159793 |
Patch1: cave9-0.4.1-gcc7.patch |
13 |
akien |
1059579 |
|
14 |
|
|
BuildRequires: pkgconfig(sdl) |
15 |
|
|
BuildRequires: pkgconfig(SDL_image) |
16 |
|
|
BuildRequires: pkgconfig(SDL_net) |
17 |
|
|
BuildRequires: pkgconfig(SDL_ttf) |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
Cave 9 is 3D cave exploration game based on the SF-cave game. |
21 |
|
|
You control a jet that maneuvers through a series of caves and the objective |
22 |
|
|
of the game is to avoid colliding with the cave walls. |
23 |
|
|
|
24 |
|
|
%prep |
25 |
|
|
%autosetup -p1 |
26 |
|
|
|
27 |
daviddavid |
1296320 |
sed -i src/GNUmakefile -e "s/-Wall -Werror -ggdb//" |
28 |
|
|
|
29 |
akien |
1059579 |
%build |
30 |
wally |
1474261 |
%set_build_flags |
31 |
akien |
1059579 |
export CFLAGS="%{optflags} -Wno-error=unused-result" |
32 |
|
|
%make_build |
33 |
|
|
|
34 |
|
|
%install |
35 |
|
|
install -D -m755 cave9 %{buildroot}%{_gamesbindir}/%{name} |
36 |
|
|
|
37 |
|
|
install -d %{buildroot}%{_gamesdatadir}/%{name} |
38 |
|
|
cp -a data/* %{buildroot}%{_gamesdatadir}/%{name}/ |
39 |
|
|
|
40 |
|
|
install -d %{buildroot}%{_datadir}/applications |
41 |
|
|
cat << EOF > %{buildroot}%{_datadir}/applications/%{name}.desktop |
42 |
|
|
[Desktop Entry] |
43 |
|
|
Name=Cave 9 |
44 |
|
|
GenericName=3D gravity game |
45 |
|
|
Comment=3D gravity cave exploration game |
46 |
|
|
Exec=%{name} |
47 |
|
|
Icon=%{name} |
48 |
|
|
Type=Application |
49 |
|
|
Categories=Game;ArcadeGame; |
50 |
|
|
EOF |
51 |
|
|
|
52 |
|
|
install -D -m644 data/icon.png %{buildroot}%{_datadir}/icons/%{name}.png |
53 |
|
|
|
54 |
|
|
# Taken from Fedora's package |
55 |
|
|
install -d %{buildroot}%{_datadir}/appdata |
56 |
|
|
cat << EOF > %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml |
57 |
|
|
<?xml version="1.0" encoding="UTF-8"?> |
58 |
|
|
<!-- Copyright 2014 Ravi Srinivasan <ravishankar.srinivasan@gmail.com> --> |
59 |
|
|
<application> |
60 |
|
|
<id type="desktop">cave9.desktop</id> |
61 |
|
|
<metadata_license>CC0-1.0</metadata_license> |
62 |
|
|
<summary>A cave exploration game featuring unique controls based on gravity</summary> |
63 |
|
|
<description> |
64 |
|
|
<p> |
65 |
|
|
cave9 is 3D cave exploration game based on the SF-cave game. |
66 |
|
|
You control a jet that maneuvers through a series of caves and the objective |
67 |
|
|
of the game is to avoid colliding with the cave walls. |
68 |
|
|
</p> |
69 |
|
|
</description> |
70 |
|
|
<url type="homepage">http://code.google.com/p/cave9</url> |
71 |
|
|
<!-- Broken URL |
72 |
|
|
<screenshots> |
73 |
|
|
<screenshot type="default">http://cave9.googlecode.com/files/cave9-small.jpg</screenshot> |
74 |
|
|
</screenshots> |
75 |
|
|
--> |
76 |
|
|
</application> |
77 |
|
|
EOF |
78 |
|
|
|
79 |
|
|
%files |
80 |
|
|
%doc AUTHORS.txt README.txt |
81 |
|
|
%{_datadir}/appdata/%{name}.appdata.xml |
82 |
|
|
%{_datadir}/applications/%{name}.desktop |
83 |
|
|
%{_datadir}/icons/%{name}.png |
84 |
|
|
%{_gamesbindir}/%{name} |
85 |
|
|
%{_gamesdatadir}/%{name}/ |